Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 Overlay (Part 6)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 26, 27, 28  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Wed Jun 25, 2008 10:07 pm    Post subject: Reply with quote

If it's a reprodeucable error, recompile KDE for backtraces (debug use flags and no "-fomit-frame-pointer" and the like), install drkonqui and report a bug containing a backtrace.
Back to top
View user's profile Send private message
Lepaca Kliffoth
l33t
l33t


Joined: 28 Apr 2004
Posts: 737
Location: Florence, Italy

PostPosted: Thu Jun 26, 2008 2:47 am    Post subject: Reply with quote

Ok. Nothing I can do by myself?
_________________
It isn't enough to win - everyone else must lose, and you also have to rub it in their face (maybe chop off an arm too for good measure).
Animebox!
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Thu Jun 26, 2008 11:26 am    Post subject: Reply with quote

I've got difficulties installing kde-scm*
When it tries to install kdelibs, it stops complaining about missing phonon libreries and headers. If I try to compile phonon, it complains about missing kde4-config (that I think it's provided by kdelibs?). What can I do?
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Jun 26, 2008 2:14 pm    Post subject: Reply with quote

cerebro84 wrote:
I've got difficulties installing kde-scm*
When it tries to install kdelibs, it stops complaining about missing phonon libreries and headers. If I try to compile phonon, it complains about missing kde4-config (that I think it's provided by kdelibs?). What can I do?

Build logs, please.
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Thu Jun 26, 2008 2:21 pm    Post subject: Reply with quote

Berniyh wrote:
Build logs, please.


For kdelibs:
Code:
sunnydale ~ # paludis -i phonon --log-level silent
Building target list...
Building dependency list...

These packages will be installed:

* kde-base/kdelibs::kde4-experimental :kde-svn [S scm]
    3dnow+ acl alsa (-altivec)+ bindist bzip2+ -debug -doc fam -htmlhandbook+ jpeg2k kerberos mmx+ nls+ openexr opengl+ semantic-desktop+ spell sse+ sse2+ ssl+ -test+ -zeroconf+
* kde-base/kdepimlibs::kde4-experimental :kde-svn [N scm]
    "Common library for KDE PIM apps."
    -debug -htmlhandbook ldap sasl -test
* kde-base/phonon::kde4-experimental :kde-svn [N scm] <target>
    "KDE multimedia API"
    -debug xcb

Total: 3 packages (2 new, 1 in new slot)

Use flags:

* 3dnow:           Adds support for 3dnow multimedia processor instructions
* altivec:         Adds support for optimizations for G4 and G5/ppc970 processors
* bzip2:           Use the bzlib compression library
* debug:           Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
* htmlhandbook:    Enable HTML handbooks generation
* ldap:            Adds LDAP support (Lightweight Directory Access Protocol)
* mmx:             Adds support for optimizations for Pentium MMX and Athlon class processors
* nls:             Adds Native Language Support (using gettext - GNU locale utilities)
* opengl:          Adds support for OpenGL (3D graphics)
* sasl:            Adds support for the Simple Authentication and Security Layer
* semantic-desktop: Semantic desktop allows for storage of digital information and its metadata to allow the user to express his personal mental models, making all information become intuitively accessible.
* sse:             fast floating point optimization for PentiumIII+ class chips
* sse2:            faster floating point optimization for SSE2 capable chips
* ssl:             Adds support for Secure Socket Layer connections
* test:            Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in make.conf/package.use anymore
* xcb:             Support the X C-language Binding, a replacement for Xlib
* zeroconf:        Support for DNS Service Discovery (DNS-SD)

(1 of 3) Installing kde-base/kdelibs-scm:kde-svn::kde4-experimental

>>> Running ebuild phase killold as root:root...
>>> Starting builtin_killold
>>> Done builtin_killold
>>> Completed ebuild phase killold
>>> Running ebuild phases init saveenv as root:root...
>>> Starting builtin_init
>>> Done builtin_init
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases init saveenv
>>> Running ebuild phases loadenv setup saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_setup

 * WARNING! This is an experimental ebuild of the kdelibs KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!

>>> Done pkg_setup
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases loadenv setup saveenv
>>> Running ebuild phases loadenv unpack compile saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting src_unpack
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdelibs
U    cmake/modules/KDE4Macros.cmake
U    kinit/CMakeLists.txt
U    kdecore/network/ktcpsocket.cpp
Updated to revision 824688.
 *    working copy: /usr/portage/distfiles/svn-src/KDE/kdelibs/kdelibs

 * Applying kdelibs-scm-X11-optional.patch ...                           [ ok ]
 * Applying kdelibs-scm-alsa-optional.patch ...                          [ ok ]
>>> Done src_unpack
>>> Starting src_compile
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2-snapshot-20080623 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Building kdelibs...
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Phonon includes NOT found!
-- Phonon library NOT found!
CMake Error at cmake/modules/FindPhonon.cmake:49 (message):
  Phonon library or includes NOT found!
Call Stack (most recent call first):
  cmake/modules/FindKDE4Internal.cmake:1097 (find_package)
  CMakeLists.txt:27 (find_package)


-- Configuring done

!!! ERROR in kde-base/kdelibs-scm:
!!! In cmake-utils_src_configureout at line 1052
!!! Cmake failed

!!! Call stack:
!!!    * cmake-utils_src_configureout (/var/tmp/paludis/kde-base-kdelibs-scm/temp/loadsaveenv:1052)
!!!    * kde4-base_src_configure (/var/tmp/paludis/kde-base-kdelibs-scm/temp/loadsaveenv:3048)
!!!    * kde4-base_src_compile (/var/tmp/paludis/kde-base-kdelibs-scm/temp/loadsaveenv:3028)
!!!    * src_compile (/var/tmp/paludis/kde-base-kdelibs-scm/temp/loadsaveenv:3937)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 29300 exit with error
die trap: exiting with error.

Install error:
  * In program paludis (--log-level silent --show-reasons none --dl-downgrade as-needed --continue-on-failure if-satisfied) -i phonon --log-level silent:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'kde-base/kdelibs-scm:kde-svn::kde4-experimental':
  * Install error: Install failed for 'kde-base/kdelibs-scm:kde-svn::kde4-experimental'



(2 of 3, 1 failed) Skipping kde-base/kdepimlibs-scm:kde-svn::kde4-experimental (unsatisfied 'kde-base/kdelibs:kde-svn')


(3 of 3, 1 skipped, 1 failed) Skipping kde-base/phonon-scm:kde-svn::kde4-experimental (unsatisfied 'kde-base/kdelibs:kde-svn')


Summary of failures:

* kde-base/kdelibs-scm:kde-svn::kde4-experimental: failure
* kde-base/kdepimlibs-scm:kde-svn::kde4-experimental: skipped (dependency 'kde-base/kdelibs:kde-svn' unsatisfied)
* kde-base/phonon-scm:kde-svn::kde4-experimental: skipped (dependency 'kde-base/kdelibs:kde-svn' unsatisfied)

Total: 3 packages, 0 successes, 2 skipped, 1 failure, 0 unreached

Resume command: paludis --log-level silent --install --add-to-world-spec 'kde-base/phonon' --continue-on-failure if-satisfied --serialised 0.25 'package;=kde-base/kdelibs-scm:kde-svn::kde4-experimental;installed;has_all_deps;P' 'package;=kde-base/kdepimlibs-scm:kde-svn::kde4-experimental;installed;has_all_deps;P' 'package;=kde-base/phonon-scm:kde-svn::kde4-experimental;installed;has_all_deps;P'

 * You have 3 unread news items (use 'eselect news' to read)

 * Searching for configuration files requiring action...
 * No configuration file updates required
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Thu Jun 26, 2008 2:24 pm    Post subject: Reply with quote

For Phonon:

Code:
sunnydale ~ # paludis --log-level silent --install --add-to-world-spec 'kde-base/phonon' --continue-on-failure if-satisfied --serialised 0.25 'package;=kde-base/phonon-scm:kde-svn::kde4-experimental;installed;has_all_deps;P'
Building target list...
Building dependency list...

These packages will be installed:

* kde-base/phonon::kde4-experimental :kde-svn [N scm]
    "KDE multimedia API"
    -debug xcb

Total: 1 package (1 new)

Use flags:

* debug:           Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
* xcb:             Support the X C-language Binding, a replacement for Xlib

(1 of 1) Installing kde-base/phonon-scm:kde-svn::kde4-experimental

>>> Running ebuild phase killold as root:root...
>>> Starting builtin_killold
>>> Done builtin_killold
>>> Completed ebuild phase killold
>>> Running ebuild phases init saveenv as root:root...
>>> Starting builtin_init
>>> Done builtin_init
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases init saveenv
>>> Running ebuild phases loadenv setup saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting pkg_setup
>>> Done pkg_setup
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases loadenv setup saveenv
>>> Running ebuild phases loadenv unpack compile saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting src_unpack
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdebase
U    apps/nsplugins/HOWTO.DEBUG
U    apps/lib/konq/CMakeLists.txt
U    workspace/ksysguard/gui/WorkSheet.cc
U    workspace/plasma/applets/digital-clock/clock.cpp

Fetching external item into 'workspace/kwin/clients/oxygen/lib'
Updated external to revision 824689.


Fetching external item into 'workspace/kwin/clients/ozone/lib'
Updated external to revision 824689.

Updated to revision 824689.
 *    working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

 * Exporting parts of working copy to /var/tmp/paludis/kde-base-phonon-scm/work/phonon
>>> Done src_unpack
>>> Starting src_compile
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/i686-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/i686-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake/Modules/FindKDE4.cmake:35 (MESSAGE):
  ERROR: Could not find KDE4 kde4-config
Call Stack (most recent call first):
  CMakeLists.txt:7 (find_package)


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.6)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring done

!!! ERROR in kde-base/phonon-scm:
!!! In cmake-utils_src_configureout at line 1116
!!! Cmake failed

!!! Call stack:
!!!    * cmake-utils_src_configureout (/var/tmp/paludis/kde-base-phonon-scm/temp/loadsaveenv:1116)
!!!    * kde4-base_src_configure (/var/tmp/paludis/kde-base-phonon-scm/temp/loadsaveenv:3119)
!!!    * kde4-meta_src_configure (/var/tmp/paludis/kde-base-phonon-scm/temp/loadsaveenv:3366)
!!!    * kde4-meta_src_compile (/var/tmp/paludis/kde-base-phonon-scm/temp/loadsaveenv:3360)
!!!    * src_compile (/var/tmp/paludis/kde-base-phonon-scm/temp/loadsaveenv:4264)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 30220 exit with error
die trap: exiting with error.

Install error:
  * In program paludis (--log-level silent --show-reasons none --dl-downgrade as-needed --continue-on-failure if-satisfied) --log-level silent --install --add-to-world-spec kde-base/phonon --continue-on-failure if-satisfied --serialised 0.25 package;=kde-base/phonon-scm:kde-svn::kde4-experimental;installed;has_all_deps;P:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'kde-base/phonon-scm:kde-svn::kde4-experimental':
  * Install error: Install failed for 'kde-base/phonon-scm:kde-svn::kde4-experimental'



Summary of failures:

* kde-base/phonon-scm:kde-svn::kde4-experimental: failure

Total: 1 package, 0 successes, 0 skipped, 1 failure, 0 unreached

Resume command: paludis --log-level silent --install --add-to-world-spec 'kde-base/phonon' --continue-on-failure if-satisfied --serialised 0.25 'package;=kde-base/phonon-scm:kde-svn::kde4-experimental;installed;has_all_deps;P'

 * You have 3 unread news items (use 'eselect news' to read)

 * Searching for configuration files requiring action...
 * No configuration file updates required
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Jun 26, 2008 4:03 pm    Post subject: Reply with quote

Eeeeeh, you should *really* sync the overlay and *read* the news it provides. :)
(eselect news list)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Thu Jun 26, 2008 8:17 pm    Post subject: Reply with quote

Hello,
paludis needs >=net-misc/networkmanager-0.7, but I do not find it?

Thanks
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Jun 26, 2008 8:49 pm    Post subject: Reply with quote

Finswimmer wrote:
Hello,
paludis needs >=net-misc/networkmanager-0.7, but I do not find it?

Thanks
Tobi


https://forums.gentoo.org/viewtopic-p-5131286.html#5131286

doesn't exist ? :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri Jun 27, 2008 12:24 am    Post subject: Reply with quote

kernelOfTruth wrote:
Finswimmer wrote:
Hello,
paludis needs >=net-misc/networkmanager-0.7, but I do not find it?

Thanks
Tobi


https://forums.gentoo.org/viewtopic-p-5131286.html#5131286

doesn't exist ? :idea:

Yep and I explained everything about it already, so please read the rest of it. :)
Back to top
View user's profile Send private message
Strayer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2003
Posts: 75
Location: Germany

PostPosted: Fri Jun 27, 2008 11:21 am    Post subject: Reply with quote

I currently try to build kdebase-scm... but I encounter an error while building kde-base/kdeartwork-iconthemes-scm.

Error:
>>> Starting src_unpack
* subversion check out start -->
* repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdeartwork
svn: No such revision 825076

What the hell...? :/


Edit: Nevermind - works now :)
Back to top
View user's profile Send private message
Dagger
Retired Dev
Retired Dev


Joined: 11 Jun 2003
Posts: 765
Location: UK

PostPosted: Fri Jun 27, 2008 11:55 am    Post subject: Reply with quote

Strayer wrote:
I currently try to build kdebase-scm... but I encounter an error while building kde-base/kdeartwork-iconthemes-scm.

Error:
>>> Starting src_unpack
* subversion check out start -->
* repository: svn://anonsvn.kde.org/home/kde/trunk/KDE/kdeartwork
svn: No such revision 825076

What the hell...? :/


Edit: Nevermind - works now :)


yeah with errors like this, it _should_ work on the second try. If it won't deleting /var/paludis/repositories/gentoo/distfiles/svn-src/KDE/_offending_trunk_ should sort it.
_________________
95% of all computer errors occur between chair and keyboard (TM)
Join the FSF as an Associate Member!
Post under CC license.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Jun 27, 2008 2:31 pm    Post subject: Reply with quote

Just sync'd, and "paludis -ip1 genkdesvn-all --dl-reinstall-targets always" bails out with:
Code:
DepList additional requirements not met error:
  * In program paludis -ip1 genkdesvn-all --dl-reinstall-targets always:
  * When performing install action from command line:                   
  * When executing install task:                                       
  * When building dependency list:
  * When adding NamedSetDepSpec 'kde-devel-scm':
  * When adding NamedSetDepSpec 'kde-scm':
  * When adding NamedSetDepSpec 'kdebase-scm':
  * When adding PackageDepSpec 'kde-base/nsplugins:kde-svn':
  * When adding package 'kde-base/nsplugins-scm:kde-svn::kde4-experimental':
  * When adding build dependencies as pre dependencies:
  * When adding PackageDepSpec 'x11-libs/qt-core[glib]':
  * Error searching for 'x11-libs/qt-core[glib]': additional requirements are not met

Additional requirements are as follows:
    * Flag 'glib' enabled

This error usually indicates that one of the packages you are trying to
install requires that another package be built with particular USE flags
enabled or disabled. You may be able to work around this restriction by
adjusting your use.conf.
I'm not sure if this means the glib flag IS enabled, and needs to be disabled for qt-core, or vice-versa? To me, the message seems ambiguos. Or is it something else?

Have use flags changed somewhere in the overlay, do I need to add glib to qt-core and rebuild all of qt-split before genkdesvn-all, or exactly what? Same thing happens with "paludis -ip1 kde-scm --dl-reinstall-targets always."

I notice my paludis use.conf flags and what emerge --info reports are not exactly in sync- is that a problem, and should I fix it up and rebuild everything (system, world) with paludis? My info: Paludis use.conf flags:
Code:
# Globally enabled use flags:           
*/* X xv xcomposite xvid qt gtk gtk2 qt3 qt4 qt3support kde opengl imlib motif libwww glibc-omitfp gnome sse mmx mmxext 3dnow 3dnowext alsa dbus hal kdehiddenvisibilty midi mplayer jack jack-tmpfs jackmidi jpeg ladspa lash ldap libsamplerate mad mikmod mp3 mpeg musicbrainz caps cairo cdparanoia cdr dssi dvd dvdr dvdread emovix flac oss pdf png portaudio ogg quicktime sdl sndfile soundtouch svg tiff vcd vorbis vst win32codecs xml

# Globally disabled use flags:                                                 
*/* -semantic-desktop -arts -oss -ipv6 -emboss -kerberos -apache -apache2 -ldap

*/* -doc nls -apache2
*/* LINGUAS: -* en
*/* INPUT_DEVICES: -* keyboard mouse evdev
*/* VIDEO_CARDS: -* ati vesa vga fbdev
# */* LINGUAS: en
# */* INPUT_DEVICES: keyboard mouse evdev
# */* VIDEO_CARDS: ati vesa vga fbdev
# app-editors/vim -nls
app-office/akonadi -mysql
app-cdr/k3b ffmpeg

# And some wildcarding
kde-base/*              opengl -semantic-desktop

x11-libs/qt accessibility dbus opengl qt3support zlib sqlite3
x11-libs/qt-core qt3support ssl
x11-libs/qt-gui accessibility dbus mng qt3support tiff xinerama
x11-libs/qt-opengl qt3support
x11-libs/qt-phonon dbus
x11-libs/qt-qt3support accessibility
x11-libs/qt-sql qt3support postgres odbc sqlite
My emerge --info use flags:
Code:
USE="3dnow 3dnowext X acl acpi alsa berkdb cairo caps cdr cli cpudetection cracklib crypt cups dbus dri dssi dvd dvdr dvdread eds encode esd evo fam firefox flac fortran gdbm gif gpm gstreamer gtk gtk2 hal iconv isdnlog jack jack-tmpfs jackmidi jpeg kde kdehiddenvisibility kerberos ladspa lash ldap libsamplerate mad midi mikmod mmx mmxext mp3 mpeg mudflap musicbrainz ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png portaudio pppd python qt-copy qt3 qt3support qt4 quicktime readline reflection sdl session silverxp sndfile soundtouch spell spl sse ssl svg tcpd tiff truetype unicode vorbis vst win32codecs x86 xml xorg xv zlib"

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Jun 27, 2008 2:33 pm    Post subject: Reply with quote

wrc1944, recompile qt-core and qt-gui with USE="glib"
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Jun 27, 2008 2:37 pm    Post subject: Reply with quote

Hmmm. I added glib to qt-core in /etc/paludis/use.conf, and now I get this error:
Code:
Error searching for 'x11-libs/qt-gui[glib]': additional requirements are not met

Additional requirements are as follows:
    * Flag 'glib' enabled
Does this mean I now need to rebuild all of qt-split with the glib use flag first before kde, because of changes in the overlay?

EDIT: Thanks gimpel- just missed your post before posting my second one- will do. :)
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental


Last edited by wrc1944 on Fri Jun 27, 2008 2:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 156

PostPosted: Fri Jun 27, 2008 2:41 pm    Post subject: Reply with quote

wrc1944 wrote:
Hmmm. I added glib to qt-core in /etc/paludis/use.conf, and now I get this error:
Code:
Error searching for 'x11-libs/qt-gui[glib]': additional requirements are not met

Additional requirements are as follows:
    * Flag 'glib' enabled
Does this mean I now need to rebuild all of qt-split with the glib use flag first before kde, because of changes in the overlay?

If I understand you correctly, you added to use flag to use.conf but didn't rebuild qt-core and qt-gui as gimpel suggested you. If so, rebuilding them should solve your problems.
_________________
Stefano
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Jun 27, 2008 2:51 pm    Post subject: Reply with quote

Thanks much, guys. :) Will do Wow- "paludis -ip1 x11-libs/qt-core x11-libs/qt-gui" wants to install 25 packages- guess that comes from not updating world first. :oops:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Fri Jun 27, 2008 3:30 pm    Post subject: Reply with quote

Berniyh wrote:
Eeeeeh, you should *really* sync the overlay and *read* the news it provides. :)
(eselect news list)


Oh, looks like for some reason the sync URL disappeared and the repository didn't update for quite a long time. Now phonon compiled and kdelibs is 43%. I had do set -networkmanager use flag in solid to let paludis work cause I didn't understand if there is another workaround like another repository or an ebuild, however I don't think to need it.
Thank you very much for your help!
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Jun 27, 2008 6:06 pm    Post subject: Reply with quote

I did the rebuilds above with glib, and then got this on automoc, about the 7th or 8th package of 110 or so in my genkdesvn-all command. Tried again, but same result. Any ideas as to what's wrong, and why it suddenly refuses the connection? Is anonsvn just down right now, or could my subversion app be messed up?

EDIT:
Just so I'll know that's the problem, is anyone else currently unable to connect to anonsvn?
Code:
>>> Done builtin_loadenv
>>> Starting src_unpack
 * subversion update start -->
 *      repository: svn://anonsvn.kde.org/home/kde/trunk/kdesupport/automoc
svn: Can't connect to host 'anonsvn.kde.org': Connection refused

!!! ERROR in kde-base/automoc-scm:
!!! In subversion_fetch at line 3659
!!! subversion: can't update /usr/portage/distfiles/svn-src/automoc/automoc from svn://anonsvn.kde.org/home/kde/trunk/kdesupport/automoc.

!!! Call stack:
!!!    * subversion_fetch (/var/tmp/paludis/kde-base-automoc-scm/temp/loadsaveenv:3659)
!!!    * subversion_src_unpack (/var/tmp/paludis/kde-base-automoc-scm/temp/loadsaveenv:3692)
!!!    * src_unpack (/var/tmp/paludis/kde-base-automoc-scm/temp/loadsaveenv:3452)
!!!    * ebuild_f_unpack (/usr/libexec/paludis/0/src_unpack.bash:42)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 11600 exit with error
die trap: exiting with error.

Install error:
  * In program paludis -i1 genkdesvn-all --dl-reinstall-targets always:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'kde-base/automoc-scm:0::kde4-experimental':
  * Install error: Install failed for 'kde-base/automoc-scm:0::kde4-experimental'

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri Jun 27, 2008 8:08 pm    Post subject: Reply with quote

Stefano Crocco wrote:
wrc1944 wrote:
Hmmm. I added glib to qt-core in /etc/paludis/use.conf, and now I get this error:
Code:
Error searching for 'x11-libs/qt-gui[glib]': additional requirements are not met

Additional requirements are as follows:
    * Flag 'glib' enabled
Does this mean I now need to rebuild all of qt-split with the glib use flag first before kde, because of changes in the overlay?

If I understand you correctly, you added to use flag to use.conf but didn't rebuild qt-core and qt-gui as gimpel suggested you. If so, rebuilding them should solve your problems.

It pulls them in automatically, if you set the requirement in use.conf.
He just missed qt-gui. ;)
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Fri Jun 27, 2008 8:10 pm    Post subject: Reply with quote

cerebro84 wrote:
Berniyh wrote:
Eeeeeh, you should *really* sync the overlay and *read* the news it provides. :)
(eselect news list)


Oh, looks like for some reason the sync URL disappeared and the repository didn't update for quite a long time. Now phonon compiled and kdelibs is 43%. I had do set -networkmanager use flag in solid to let paludis work cause I didn't understand if there is another workaround like another repository or an ebuild, however I don't think to need it.
Thank you very much for your help!

No, you currently have to set -networkmanager, see the previous page(s).
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Jun 27, 2008 8:50 pm    Post subject: Reply with quote

Why not just remove that useless useflag (uselessflag, lol) for now? Saves time and energy for both, users and you as maintainer.

Just wondering..
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Jun 27, 2008 8:55 pm    Post subject: Reply with quote

Again, I keep getting the same anonsvn Connection refused error. Can someone please post about this? Either a confirmation of yes I too can't connect, or I can connect would tell me if anonsvn is up or down. I'm starting to think my svn system is broken. Everything regarding internet works fine, except anonsvn.

I just finished a paludis -i world fine, so my connection for non-svn is good. Could anything in today's paludis --sync have messed up svn- I don't see how, but if others can connect, it must be something on my system or ISP.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Jun 27, 2008 8:59 pm    Post subject: Reply with quote

wrc1944 wrote:
Again, I keep getting the same anonsvn Connection refused error. Can someone please post about this? Either a confirmation of yes I too can't connect, or I can connect would tell me if anonsvn is up or down. I'm starting to think my svn system is broken. Everything regarding internet works fine, except anonsvn.

I just finished a paludis -i world fine, so my connection for non-svn is good. Could anything in today's paludis --sync have messed up svn- I don't see how, but if others can connect, it must be something on my system or ISP.

Works fine here.

The anonsvn rotation mirror leads to kde.codeyard.cs.ru.nl (131.174.31.25) here. So that guy works.
You can set that in /etc/hosts like described earlier in this thread or the previous one already.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
cerebro84
n00b
n00b


Joined: 20 Aug 2005
Posts: 64

PostPosted: Fri Jun 27, 2008 9:14 pm    Post subject: Reply with quote

wrc1944 wrote:
Again, I keep getting the same anonsvn Connection refused error. Can someone please post about this?


Fine here
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 26, 27, 28  Next
Page 18 of 28

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum