Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 Overlay (Part 6)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 26, 27, 28  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Jul 05, 2008 4:42 pm    Post subject: Reply with quote

Next exciting question:

I've been running kde-svn for long enough that I feel I can remove 3.5 without much loss. What's the easiest way to remove it?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Sat Jul 05, 2008 4:49 pm    Post subject: Reply with quote

loftwyr wrote:
Next exciting question:

I've been running kde-svn for long enough that I feel I can remove 3.5 without much loss. What's the easiest way to remove it?

Depends on what you want to remove.

If you want to remove everything, you could run:
Code:
paludis -u --with-dependencies kde-base/kdelibs:3.5


The problem with that is, that you might have a few programs that depend on kdelibs, that you might want to keep.
(sim in my case, for example, or konvi.)
In that case, I would remove the -meta ebuild or the set, that you have in your world file to keep the kde stuff, and run --uninstall-unused (with care, of course).
If you added single programs to your world file, you might have to remove them, too.

Alternatively, you can use the sets, that we provide.
Code:
paludis -u kdebase-35x

That would uninstall everything from kdebase in the slot :3.5.
Note, that you have to use either --with-dependencies or --permit-unsafe-uninstalls there, because paludis doesn't reorder the packages when uninstalling stuff atm.
There is a set for everything that has a -meta ebuild, for :3.5.
Code:
kde-35x
kdeaccessibility-35x
kdeaddons-35x
kdeadmin-35x
kdeartwork-35x
kdebase-35x
kdebindings-35x
kde-devel-35x
kdeedu-35x
kdegames-35x
kdegraphics-35x
kde-mono-35x
kdemultimedia-35x
kdenetwork-35x
kdepim-35x
kdesdk-35x
kdetoys-35x
kdeutils-35x
kdewebdev-35x
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Jul 05, 2008 6:09 pm    Post subject: Reply with quote

Okay, so I've managed to remove all of 3.5. I tried the methods above but the only one that seemed to only remove kde-35 was -up kde-libs and that was too much (openoffice uses kde-libs)

So I used eix to find them all and then manually created the paludis command.

So now that I have them all out and am rebuilding things to stop arts use, when I -ip world, it wants to reinstall kpilot and all it's dependencies (kontact, etc.) without telling me why (no dependency listed). I'm not sure if I should post it here or on the Paludis trac so I thought I'd try here first.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Smoothhound
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 149

PostPosted: Mon Jul 07, 2008 7:07 am    Post subject: Reply with quote

I can't figure out how to mask a single package from kde4-experimental. I want to mask the strigi-scm package because of this bug, however all of syntactical contortions I have devised don't seem to work...
Code:
=app-misc/strigi-scm
=app-misc/strigi-0.5.10

>=app-misc/strigi-0.5.10

app-misc/strigi::kde4-experimental

app-misc/strigi-scm

And a few more variations on the above, what's the obvious syntax that I can't land upon? :)
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Mon Jul 07, 2008 2:13 pm    Post subject: Reply with quote

Smoothhound wrote:
I can't figure out how to mask a single package from kde4-experimental. I want to mask the strigi-scm package because of this bug, however all of syntactical contortions I have devised don't seem to work...
Code:
=app-misc/strigi-scm
=app-misc/strigi-0.5.10

>=app-misc/strigi-0.5.10

app-misc/strigi::kde4-experimental

app-misc/strigi-scm

And a few more variations on the above, what's the obvious syntax that I can't land upon? :)

All of them should work, except the last one, but only, if you don't unmask it at the same time.
Back to top
View user's profile Send private message
Smoothhound
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 149

PostPosted: Mon Jul 07, 2008 2:33 pm    Post subject: Reply with quote

Berniyh wrote:
Smoothhound wrote:
I can't figure out how to mask a single package from kde4-experimental. I want to mask the strigi-scm package because of this bug, however all of syntactical contortions I have devised don't seem to work...
Code:
=app-misc/strigi-scm
=app-misc/strigi-0.5.10

>=app-misc/strigi-0.5.10

app-misc/strigi::kde4-experimental

app-misc/strigi-scm

And a few more variations on the above, what's the obvious syntax that I can't land upon? :)

All of them should work, except the last one, but only, if you don't unmask it at the same time.


Ah, of course! :oops: It took me a little while to work out where it had been specifically unmasked - part of the kde-deps-scm set

Thanks
Back to top
View user's profile Send private message
2dimm
n00b
n00b


Joined: 10 Jun 2005
Posts: 52
Location: Brussels, Belgium

PostPosted: Tue Jul 08, 2008 12:42 pm    Post subject: Re: Cursor themes Reply with quote

KejPi wrote:
I have found out that there are some Oxygen cursor themes in kdebase/workspace/cursors directory in my working copy but I haven't found which ebuild installs them. Is there eny ebuild which installs them? Currently I can see just one cursor theme (Classical KDE) in system settings and there are not even those I have in my system.


I found that startkde had been modified at line 131 to include a path for xcursors - adding '/usr/share/cursors/xorg-x11' solved the missing cursor themes.

If there is a build for the Oxygen cursors I failed to find it. I copied kde-wallpapers to my local portage: rename to kde-cursors & change kmmodule name accordingly. (I also had to copy kde4-functions.eclass to my local eclass directory & edit to add kde-base/kdebase kde-base/kde-cursors to the kde derivation map)
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 156

PostPosted: Tue Jul 08, 2008 2:14 pm    Post subject: Re: Cursor themes Reply with quote

2dimm wrote:
KejPi wrote:
I have found out that there are some Oxygen cursor themes in kdebase/workspace/cursors directory in my working copy but I haven't found which ebuild installs them. Is there eny ebuild which installs them? Currently I can see just one cursor theme (Classical KDE) in system settings and there are not even those I have in my system.


I found that startkde had been modified at line 131 to include a path for xcursors - adding '/usr/share/cursors/xorg-x11' solved the missing cursor themes.

If there is a build for the Oxygen cursors I failed to find it. I copied kde-wallpapers to my local portage: rename to kde-cursors & change kmmodule name accordingly. (I also had to copy kde4-functions.eclass to my local eclass directory & edit to add kde-base/kdebase kde-base/kde-cursors to the kde derivation map)


The ebuild for the oxygen cursors is called kdebase-cursors. If you don't have it, I think you need to sync the overlay.
_________________
Stefano
Back to top
View user's profile Send private message
2dimm
n00b
n00b


Joined: 10 Jun 2005
Posts: 52
Location: Brussels, Belgium

PostPosted: Tue Jul 08, 2008 2:25 pm    Post subject: Re: Cursor themes Reply with quote

Stefano Crocco wrote:
The ebuild for the oxygen cursors is called kdebase-cursors. If you don't have it, I think you need to sync the overlay.


many thanks - i'd failed to notice it was failing to sync - sorted!
Back to top
View user's profile Send private message
math_roc
n00b
n00b


Joined: 07 Jan 2006
Posts: 65

PostPosted: Wed Jul 09, 2008 9:37 am    Post subject: Reply with quote

I can't compile kde-base/plasma-workspace-scm anymore
here is the output of paludis

Quote:
....
[ 76%] Generating screensaver_interface.cpp, screensaver_interface.h
[ 76%] Generating ui_shellOptions.h
Generating sessionrunner.moc
Generating shellrunner.moc
Linking CXX shared library ../../lib/libkdeinit4_plasma.so
CMakeFiles/kdeinit_plasma-qgv.dir/desktopcorona.o: In function `DesktopCorona::loadDefaultLayout()':
desktopcorona.cpp:(.text+0x720): undefined reference to `Plasma::Corona::addContainmentDelayed(QString const&, QList<QVariant> const&)'
desktopcorona.cpp:(.text+0x952): undefined reference to `Plasma::Corona::addContainmentDelayed(QString const&, QList<QVariant> const&)'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkdeinit4_plasma.so] Error 1
make[1]: *** [plasma/plasma/CMakeFiles/kdeinit_plasma-qgv.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 77%] Generating screensaver_interface.moc
Scanning dependencies of target krunner_shell
Scanning dependencies of target krunner_sessions
[ 78%] Building CXX object plasma/runners/shell/CMakeFiles/krunner_shell.dir/shellrunner.o
[ 78%] Building CXX object plasma/runners/shell/CMakeFiles/krunner_shell.dir/krunner_shell_automoc.o
[ 78%] Building CXX object plasma/runners/sessions/CMakeFiles/krunner_sessions.dir/sessionrunner.o
[ 78%] Building CXX object plasma/runners/sessions/CMakeFiles/krunner_sessions.dir/screensaver_interface.o
Linking CXX shared module ../../../lib/krunner_shell.so
[ 79%] Building CXX object plasma/runners/sessions/CMakeFiles/krunner_sessions.dir/krunner_sessions_automoc.o
[ 79%] Built target krunner_shell
Linking CXX shared module ../../../lib/krunner_sessions.so
[ 79%] Built target krunner_sessions
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/plasma-workspace-scm:
!!! In cmake-utils_src_make at line 1174
!!! Make failed!

!!! Call stack:
!!! * cmake-utils_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:1174)
!!! * kde4-base_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3166)
!!! * kde4-meta_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3451)
!!! * kde4-meta_src_compile (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3402)
!!! * src_compile (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:4370)
!!! * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!! * ebuild_main (/usr/libexec/paludis/ebuild.bash:463)
!!! * main (/usr/libexec/paludis/ebuild.bash:478)

diefunc: making ebuild PID 31135 exit with error
die trap: exiting with error.

Install error:
* In program paludis (--dl-reinstall if-use-changed --dl-reinstall-scm weekly --dl-new-slots as-needed --log-level silent) --install everything:
* When performing install action from command line:
* When executing install task:
* When installing 'kde-base/plasma-workspace-scm:kde-svn::kde4-experimental':
* Install error: Install failed for 'kde-base/plasma-workspace-scm:kde-svn::kde4-experimental'
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Wed Jul 09, 2008 11:09 am    Post subject: Reply with quote

Did you recompile libplasma first?
Back to top
View user's profile Send private message
math_roc
n00b
n00b


Joined: 07 Jan 2006
Posts: 65

PostPosted: Wed Jul 09, 2008 1:12 pm    Post subject: Reply with quote

I did:
Quote:
mathieu@localhost /var/paludis/repositories/local/media-video/mms $ qlop -l|grep libplasma|tail -n 1
Mon Jul 7 03:00:44 2008 >>> kde-base/libplasma-scm:kde-svn::kde4-experimental (7 of 10)


I'm trying to recompile it once again, and the result is: plasma-workspace compile fine!!
guess changes appends between the two upgrades ^^

thx
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Jul 10, 2008 12:54 am    Post subject: Reply with quote

I don't know how many people noticed, but trunk is now KDE 4.2, if you want 4.1, then switch to branches instead of trunk.

The RC1 was tagged today, but I don't see any documentation on the site for it yet, not even in svn for the site. Ah well. There should be lots of fixes in the RC1. :)

Cheers all.

Oh, I am less pissy at Gentoo now that I switch to Paludis, but I am wanting to switch to Exherbo Linux sometime soon-ish when I have the time to play around. Quite frankly, I like the philosophy much better and it looks like it will kick ass when it's gets going. :D
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Jul 10, 2008 1:11 am    Post subject: Reply with quote

How do we switch the svn ebuilds to the 4.1 branch?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Jul 10, 2008 2:46 am    Post subject: Reply with quote

loftwyr wrote:
How do we switch the svn ebuilds to the 4.1 branch?
Unsupported: read though /your/overlay/dir/kde/eclass/kde4svn.eclass file and find the lines that have ESVN_REPO_URI in them and change trunk/KDE to branches/KDE/4.1 for the ESVN_REPO_URI under kdebase-*, kde*, and kdelibs*. Not supported be the makers of the overlay. However, you get the 4.1 branch instead of 4.2, which is too experimental for me.

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
orgoz
n00b
n00b


Joined: 15 Nov 2006
Posts: 48

PostPosted: Thu Jul 10, 2008 12:20 pm    Post subject: Reply with quote

Hi,

I am using Qt44dev overlay to compile KDE4 but since few days i have an error trying to fetch qt*-4.4.2_pre20080701.


Code:

Fetch error:
  * In program paludis -i world:
  * When performing install action from command line:
  * When executing install task:
  * When fetching 'x11-libs/qt-core-4.4.2_pre20080701:4::qt44dev':
  * Fetch error: Fetch of 'x11-libs/qt-core-4.4.2_pre20080701:4::qt44dev' failed

  * File 'qt-x11-opensource-src-4.4.2-snapshot-20080701.tar.gz': failed automatic fetching


After verifying on the trolltech ftp (ftp://ftp.trolltech.com/qt/snapshots/), there is no snapshot for this day...

Do I have a configuration problem or do I have to be more patient to see that fixed ?

Thanks
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Jul 10, 2008 1:10 pm    Post subject: Reply with quote

You can use QT 4.4.0 that is in the portage tree. It would be more stable than snapshot releases. Is there a particular reason you want to use the snapshots?

Or, you can bump an ebuild to a current release. Just change the date part of the name of the ebuild then redigest.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
orgoz
n00b
n00b


Joined: 15 Nov 2006
Posts: 48

PostPosted: Thu Jul 10, 2008 1:19 pm    Post subject: Reply with quote

Ok thanks, I used this overlay when QT4 was not in portage tree. I will delete this overlay and try with QT 4.4.0.

Thank you for your help.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Thu Jul 10, 2008 1:33 pm    Post subject: Reply with quote

I've been away from my Paludis genkdesvn box for a few days (installed the portage kdesvn just to check it out on another box). Back now, and I just tried to sync and keep getting this. Nothing here on it- read all recent posts since I was gone. Is the server just down, or is something wrong with my setup- maybe update world first? I'm just a few days behind a current world, so that seems unlikely.
Code:
gentoo-audio rob # paludis --sync kde4-experimental
Sync kde4-experimental                             
sync kde4-experimental> Updating 72cdd41..55346c4 
sync kde4-experimental> sets/genkdesvn-extras.conf: needs update
sync kde4-experimental> sets/kdebase-scm.conf: needs update     
sync kde4-experimental> error: Entry 'sets/genkdesvn-extras.conf' not uptodate. Cannot merge.

Sync error:
  * In program paludis --sync kde4-experimental:
  * When performing sync action from command line:
  * When executing sync task:
  * When syncing repository 'kde4-experimental':
  * When syncing repository 'kde4-experimental':
  * sync of '/var/paludis/repositories/kde4-experimental' from 'git://www2.mailstation.de/git/genkde4svn.git' failed

Sync kde4-experimental failed

* Regenerating cache for installable repositories...
Regenerating cache for virtuals...
Regenerating cache for gentoo...
Regenerating cache for kde4-experimental...
Regenerating cache for paludis-overlay...
 * Done regenerating cache for installable repositories

 * Cleaning write cache for ebuild format repositories...
 * Done cleaning write cache for ebuild format repositories
In this case, are we supposed to somehow exclude or edit the item mentioned in the error above (Entry 'sets/genkdesvn-extras.conf' not uptodate)?

EDIT: Hmmm. Solved it, I think. Previously, I had commented out digicam in the genkdesvn-extras set, and nepomuk in the kdebase set. When I uncommented them, and tried to sync again, it worked. Either that, or the server just happened to come back online (not likely, I guess :wink: )

I'm wondering why would just having two items commented out in sets suddenly cause a repo sync failure, when it didn't do so before? I can understand it might cause another package not to compile for dep reasons, but the repo sync problem is a mystery.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Jul 10, 2008 3:37 pm    Post subject: Reply with quote

orgoz wrote:
Ok thanks, I used this overlay when QT4 was not in portage tree. I will delete this overlay and try with QT 4.4.0.

Thank you for your help.
You don't need to remove the overlay. Just remove the unmasking you did for QT, then you should get the Gentoo ones, though, I think you need ~ARCH keyword unmask 4.4.0. The ebuilds in the overlay are under a different keyword/mask.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
Berniyh
l33t
l33t


Joined: 07 Jun 2006
Posts: 677

PostPosted: Thu Jul 10, 2008 7:55 pm    Post subject: Reply with quote

wrc1944 wrote:
I've been away from my Paludis genkdesvn box for a few days (installed the portage kdesvn just to check it out on another box). Back now, and I just tried to sync and keep getting this. Nothing here on it- read all recent posts since I was gone. Is the server just down, or is something wrong with my setup- maybe update world first? I'm just a few days behind a current world, so that seems unlikely.
Code:
gentoo-audio rob # paludis --sync kde4-experimental
Sync kde4-experimental                             
sync kde4-experimental> Updating 72cdd41..55346c4 
sync kde4-experimental> sets/genkdesvn-extras.conf: needs update
sync kde4-experimental> sets/kdebase-scm.conf: needs update     
sync kde4-experimental> error: Entry 'sets/genkdesvn-extras.conf' not uptodate. Cannot merge.

Sync error:
  * In program paludis --sync kde4-experimental:
  * When performing sync action from command line:
  * When executing sync task:
  * When syncing repository 'kde4-experimental':
  * When syncing repository 'kde4-experimental':
  * sync of '/var/paludis/repositories/kde4-experimental' from 'git://www2.mailstation.de/git/genkde4svn.git' failed

Sync kde4-experimental failed

* Regenerating cache for installable repositories...
Regenerating cache for virtuals...
Regenerating cache for gentoo...
Regenerating cache for kde4-experimental...
Regenerating cache for paludis-overlay...
 * Done regenerating cache for installable repositories

 * Cleaning write cache for ebuild format repositories...
 * Done cleaning write cache for ebuild format repositories
In this case, are we supposed to somehow exclude or edit the item mentioned in the error above (Entry 'sets/genkdesvn-extras.conf' not uptodate)?

EDIT: Hmmm. Solved it, I think. Previously, I had commented out digicam in the genkdesvn-extras set, and nepomuk in the kdebase set. When I uncommented them, and tried to sync again, it worked. Either that, or the server just happened to come back online (not likely, I guess :wink: )

I'm wondering why would just having two items commented out in sets suddenly cause a repo sync failure, when it didn't do so before? I can understand it might cause another package not to compile for dep reasons, but the repo sync problem is a mystery.

That is a git thing.
If you modify files locally and try to merge, it will fail, if you didn't commit.
The best solution if you want to use modified sets, is to create a copy and put that in /etc/paludis/sets.
Maybe you want to rename it to, to prevent confusion, but if the name is the same, the set in /etc/paludis/sets overrides the overlay's one.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Thu Jul 10, 2008 8:29 pm    Post subject: Reply with quote

Berniyh wrote:
Quote:
The best solution if you want to use modified sets, is to create a copy and put that in /etc/paludis/sets.
Maybe you want to rename it to, to prevent confusion, but if the name is the same, the set in /etc/paludis/sets overrides the overlay's one.
As we discussed earlier, I followed your recommendation and didn't use sets in /etc/paludis. Nepomuk and digikam kept failing, so many weeks ago I finally just commented them out in the overlay sets files since there were only two. I wanted to keep it simple, and not have to deal with sets over-rides at that time. Besides, at that time nepomuk-sever kept using 99% of the cpu, making kdesvn unusable.

However, as mentioned above, apparently commenting out packages in the overlay sets now prevents syncing of the overlay. After uncommenting them in order to sync, nepomuck of course showed up in "genkdesvn all" list, but now fails because it can't find itself, whicb seems weird. In other words, it won't install because it can't find itself already installed?? :roll:

Or is it only the "tests not found" that's causing it to fail? This comes after configure runs on paludis -ip1 kde-base-nepomuk
Code:
-----------------------------------------------------------------------------               
-- The following OPTIONAL packages could NOT be located on your system.                     
-- Consider installing them to enable more features from this software.                     
+ Nepomuk: Nepomuk Libraries <kdelibs>                                                       
Required to build Nepomuk.                                                                   
-----------------------------------------------------------------------------               
-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/paludis/kde-base-nepomuk-scm/work/nepomuk_build
make -j2                                                                                     
 * >>> Test phase [test]: kde-base/nepomuk-scm                                               
make -j2 -j1 test                                                                           
Running tests...                                                                             
Start processing tests                                                                                 
Test project /var/tmp/paludis/kde-base-nepomuk-scm/work/nepomuk_build                                   
No tests were found!!!                                                                                 
>>> Done src_test                                                                                       
>>> Starting builtin_saveenv                                                                           
>>> Done builtin_saveenv                                                                               
>>> Completed ebuild phases loadenv test saveenv                                                       
>>> Running ebuild phases loadenv install saveenv as root:root...                                       
>>> Starting builtin_loadenv                                                                           
>>> Done builtin_loadenv                                                                               
>>> Starting src_install                                                                               
make -j2 install DESTDIR=/var/tmp/paludis/kde-base-nepomuk-scm/image/                                   
make: *** No rule to make target `install'.  Stop.                                                     

!!! ERROR in kde-base/nepomuk-scm:
!!! In cmake-utils_src_install at line 1153
!!! Make install failed                   

!!! Call stack:
!!!    * cmake-utils_src_install (/var/tmp/paludis/kde-base-nepomuk-scm/temp/loadsaveenv:1153)
!!!    * kde4-meta_src_install (/var/tmp/paludis/kde-base-nepomuk-scm/temp/loadsaveenv:3523) 
!!!    * src_install (/var/tmp/paludis/kde-base-nepomuk-scm/temp/loadsaveenv:4384)           
!!!    * ebuild_f_install (/usr/libexec/paludis/0/src_install.bash:46)                       
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)                                   
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)                                         

diefunc: making ebuild PID 14292 exit with error
die trap: exiting with error.                   

Install error:
  * In program paludis -i1 genkdesvn-all --dl-reinstall-targets always:
  * When performing install action from command line:                 
  * When executing install task:                                       
  * When installing 'kde-base/nepomuk-scm:kde-svn::kde4-experimental':
  * Install error: Install failed for 'kde-base/nepomuk-scm:kde-svn::kde4-experimental'

Summary of failures:
* kde-base/nepomuk-scm:kde-svn::kde4-experimental: failure

Total: 122 packages, 96 successes, 0 skipped, 1 failure, 25 unreached
I did notice during my genkdesvn update today many packages wanted nepokuk as an optional package for more features. If I can get nepomuk installed with --checks none, I guess I'll need another complete rebuild. :roll:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 968

PostPosted: Thu Jul 10, 2008 9:20 pm    Post subject: Reply with quote

@wrc1944: did you try to rm -r /path/to/distfiles/svn-src to remove all the downloaded source code from the svn server? I find this clears up a lot of bugs ... well it did when I used portage in the past. There must be a more elegant Paludis way of doing that. :)
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
hvengel
Guru
Guru


Joined: 19 Sep 2004
Posts: 515

PostPosted: Thu Jul 10, 2008 11:13 pm    Post subject: Reply with quote

Qt designer fails with:

$ designer
makekdewidgets(15812)/kdecore (KLocale) KLocalePrivate::initEncoding: Defaulting to ISO 8859-1 encoding.
QMetaProperty::read: Unable to handle unregistered datatype 'QList<QChar>' for property 'KCharSelect::displayedChars'
QMetaProperty::read: Unable to handle unregistered datatype 'QList<QColor>' for property 'KColorCombo::colors'
Error while reparenting!
QMetaProperty::read: Unable to handle unregistered datatype 'KUrl' for property 'KUrlRequester::url'
QMetaProperty::read: Unable to handle unregistered datatype 'KFile::Modes' for property 'KUrlRequester::mode'
QMetaProperty::read: Unable to handle unregistered datatype 'KUrl' for property 'KUrlRequester::url'
QMetaProperty::read: Unable to handle unregistered datatype 'KFile::Modes' for property 'KUrlRequester::mode'
QMetaProperty::read: Unable to handle unregistered datatype 'QList<QChar>' for property 'KCharSelect::displayedChars'
QMetaProperty::read: Unable to handle unregistered datatype 'QList<QColor>' for property 'KColorCombo::colors'
Error while reparenting!
designer: symbol lookup error: /usr/kde/svn/lib64/kde4/plugins/designer/kdewidgets.so: undefined symbol: _ZN13KFontComboBoxC1EP7QWidget

Anyone have any idea what is going on with this and how to fix it?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Fri Jul 11, 2008 12:15 am    Post subject: Reply with quote

Stifflerstealth wrote:
Code:
@wrc1944: did you try to rm -r /path/to/distfiles/svn-src to remove all the downloaded source code from the svn server? I find this clears up a lot of bugs ... well it did when I used portage in the past. There must be a more elegant Paludis way of doing that. :)
Oops- forgot to do that. I too find that's a good idea after not updating for a week or more.
Another strange problem:
After today's genkdesvn all update (all went fine except nepomuk), while updating world three different times I've gotten a KDE Daemon crash dialog box. It doesn't seem to affect anything fuctioning- the update process, firefox, etc. I just close it and things seem normal. Any ideas?
Quote:
A Fatal Error Occurred
The application KDE Daemon (kded4) crashed and caused the signal 11 (SIGSEGV).
Please help us improve the software you use by filing a report at http://bugs.kde.org. Useful details include how to reproduce the error, documents that were loaded, etc.
Details:
Application: KDE Daemon (kded4), signal SIGSEGV

Thread 1 (Thread 0xa6661700 (LWP 3007)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0xa69dcb80 in nanosleep () from /lib/libc.so.6
#2 0xa69dc9bf in sleep () from /lib/libc.so.6
#3 0xa7b4576c in KCrash::startDrKonqi () from /usr/kde/svn/lib/libkdeui.so.5
#4 0xafdd5f40 in ?? ()
#5 0xafdd8118 in ?? ()
#6 0x00000003 in ?? ()
#7 0xa6cb4ff4 in ?? () from /usr/lib/libX11.so.6
#8 0x00000ec1 in ?? ()
#9 0x7273752f in ?? ()
#10 0x65646b2f in ?? ()
#11 0x6e76732f in ?? ()
#12 0x62696c2f in ?? ()
#13 0x65646b2f in ?? ()
#14 0x696c2f34 in ?? ()
#15 0x65786562 in ?? ()
#16 0x72642f63 in ?? ()
#17 0x716e6f6b in ?? ()
#18 0x642d0069 in ?? ()
#19 0x6c707369 in ?? ()
#20 0x3a007961 in ?? ()
#21 0x00302e30 in ?? ()
#22 0x70612d2d in ?? ()
#23 0x6d616e70 in ?? ()
#24 0x646b0065 in ?? ()
#25 0x00346465 in ?? ()
#26 0x69732d2d in ?? ()
#27 0x6c616e67 in ?? ()
#28 0x00313100 in ?? ()
#29 0x69702d2d in ?? ()
#30 0x30330064 in ?? ()
#31 0x2d003730 in ?? ()
#32 0x7070612d in ?? ()
#33 0x73726576 in ?? ()
#34 0x006e6f69 in ?? ()
#35 0x3a644924 in ?? ()
#36 0x65646b20 in ?? ()
#37 0x70632e64 in ?? ()
#38 0x32382070 in ?? ()
#39 0x33313135 in ?? ()
#40 0x30303220 in ?? ()
#41 0x36302d38 in ?? ()
#42 0x2037322d in ?? ()
#43 0x333a3331 in ?? ()
#44 0x36343a30 in ?? ()
#45 0x6664205a in ?? ()
#46 0x65727561 in ?? ()
#47 0x2d002420 in ?? ()
#48 0x6f72702d in ?? ()
#49 0x6d617267 in ?? ()
#50 0x656d616e in ?? ()
#51 0x45444b00 in ?? ()
#52 0x65614420 in ?? ()
#53 0x006e6f6d in ?? ()
#54 0x75622d2d in ?? ()
#55 0x64646167 in ?? ()
#56 0x73736572 in ?? ()
#57 0x62757300 in ?? ()
#58 0x4074696d in ?? ()
#59 0x73677562 in ?? ()
#60 0x65646b2e in ?? ()
#61 0x67726f2e in ?? ()
#62 0x732d2d00 in ?? ()
#63 0x74726174 in ?? ()
#64 0x64697075 in ?? ()
#65 0x00003000 in ?? ()
#66 0x00000000 in ?? ()

_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 19, 20, 21 ... 26, 27, 28  Next
Page 20 of 28

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum