Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE4 Overlay (Part 6)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 21, 22, 23 ... 26, 27, 28  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ezln
n00b
n00b


Joined: 23 May 2008
Posts: 14

PostPosted: Sat Jul 19, 2008 6:26 pm    Post subject: Reply with quote

Ola to all. I have a big problem with upgrade. I have read the news with eselect and i have gived paludis -i1 kde-base/kdeplasma-addons, after i have discard the blocks and uninstall kdeplasmoids. But i obtain a failure with pixman-0.11.8:

http://rafb.net/p/uEJCel94.html

seem to be a problem with ebuild of pixman. I have an Intel Core2 Duo with sse, sse2 and ssse3 enabled as use-flags.

Thanks for the help if somebody can help me. I'm blocked now.
_________________
hasta la victoria siempre, subcomandante Marcos
Back to top
View user's profile Send private message
ezln
n00b
n00b


Joined: 23 May 2008
Posts: 14

PostPosted: Sun Jul 20, 2008 12:41 pm    Post subject: Reply with quote

Hallo.

Now i have solved with pixman, but i obtain a failure with paludis -i kde-base/kdeplasma-addons:

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build
make -j3
[ 1%] [ 2%] Generating ui_config.h
Generating ui_clockConfig.h
Generating calculator.moc
Generating dict.moc
Generating binaryclock.moc
Scanning dependencies of target plasma_applet_binaryclock
Scanning dependencies of target plasma_applet_calculator
Scanning dependencies of target plasma_applet_dict
[ 3%] [ 4%] Building CXX object applets/dict/CMakeFiles/plasma_applet_dict.dir/dict.o
[ 5%] Building CXX object applets/calculator/CMakeFiles/plasma_applet_calculator.dir/calculator.o
Building CXX object applets/binary-clock/CMakeFiles/plasma_applet_binaryclock.dir/binaryclock.o
[ 6%] Building CXX object applets/dict/CMakeFiles/plasma_applet_dict.dir/plasma_applet_dict_automoc.o
Linking CXX shared module ../../lib/plasma_applet_dict.so
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/calculator/calculator.cpp: In member function 'virtual void CalculatorApplet::init()':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/calculator/calculator.cpp:80: warning: converting to 'int' from 'double'
[ 6%] [ 8%] Building CXX object applets/calculator/CMakeFiles/plasma_applet_calculator.dir/plasma_applet_calculator_automoc.o
Built target plasma_applet_dict
Generating comic.moc
In file included from /var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:21:
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:26:25: error: clockapplet.h: No such file or directory
Linking CXX shared module ../../lib/plasma_applet_calculator.so
[ 8%] Built target plasma_applet_calculator
[ 9%] Generating ui_fileWatcherConfig.h
Generating fileWatcherConfig.moc
Generating fileWatcher.moc
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:38: error: expected class-name before '{' token
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:49: error: expected unqualified-id before '&' token
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:49: error: expected ',' or '...' before '&' token
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:49: error: ISO C++ forbids declaration of 'parameter' with no type
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:38: warning: 'class BinaryClock' has virtual functions but non-virtual destructor
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In constructor 'BinaryClock::BinaryClock(QObject*, const QVariantList&)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:31: error: class 'BinaryClock' does not have any field named 'ClockApplet'
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:39: error: 'setHasConfigurationInterface' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:40: error: 'resize' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::init()':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:45: error: 'config' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:54: error: 'localTimezone' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:54: error: 'setCurrentTimezone' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:56: error: 'connect' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::constraintsEvent(Plasma::Constraints)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:87: error: 'getContentsMargins' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:91: error: 'formFactor' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:92: error: 'contentsRect' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:92: error: 'setMaximumHeight' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:95: error: 'contentsRect' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:95: error: 'setMaximumWidth' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:98: error: 'contentsRect' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:98: error: 'resize' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::connectToEngine()':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:105: error: 'dataEngine' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:108: error: 'currentTimezone' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:110: error: 'currentTimezone' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: At global scope:
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:114: error: prototype for 'void BinaryClock::dataUpdated(const QString&, const QHash<QString, QVariant>&)' does not match any in class 'BinaryClock'
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:49: error: candidate is: void BinaryClock::dataUpdated(const QString&, int)
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::dataUpdated(const QString&, const QHash<QString, QVariant>&)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:128: error: 'update' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::createClockConfigurationInterface(KConfigDialog*)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:136: error: 'icon' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:146: error: 'config' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::clockConfigAccepted()':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:154: error: 'config' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:187: error: 'dataEngine' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:187: error: 'currentTimezone' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:193: error: 'update' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:194: error: 'configNeedsSaving' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::changeEngineTimezone(const QString&, const QString&)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:199: error: 'dataEngine' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:203: error: no matching function for call to 'Plasma::DataEngine::connectSource(const QString&, BinaryClock* const, int)'
/usr/kde/svn/include/KDE/Plasma/../../plasma/dataengine.h:136: note: candidates are: void Plasma::DataEngine::connectSource(const QString&, QObject*, uint, Plasma::IntervalAlignment) const
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:205: error: no matching function for call to 'Plasma::DataEngine::connectSource(const QString&, BinaryClock* const, int, Plasma::IntervalAlignment)'
/usr/kde/svn/include/KDE/Plasma/../../plasma/dataengine.h:136: note: candidates are: void Plasma::DataEngine::connectSource(const QString&, QObject*, uint, Plasma::IntervalAlignment) const
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp: In member function 'void BinaryClock::updateColors()':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:211: error: 'config' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.cpp:233: error: 'update' was not declared in this scope
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/binary-clock/binaryclock.moc: At global scope:
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/binary-clock/binaryclock.moc:44: error: 'ClockApplet' has not been declared
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/binary-clock/binaryclock.moc: In member function 'virtual void* BinaryClock::qt_metacast(const char*)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/binary-clock/binaryclock.moc:58: error: 'ClockApplet' has not been declared
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/binary-clock/binaryclock.moc: In member function 'virtual int BinaryClock::qt_metacall(QMetaObject::Call, int, void**)':
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/binary-clock/binaryclock.moc:63: error: 'ClockApplet' has not been declared
/usr/kde/svn/include/kpluginfactory.h: In static member function 'static QObject* KPluginFactory::createInstance(QWidget*, QObject*, const QVariantList&) [with impl = BinaryClock, ParentType = QObject]':
/usr/kde/svn/include/kpluginfactory.h:479: instantiated from 'QObject* (* KPluginFactory::InheritanceChecker<impl>::createInstanceFunction(...))(QWidget*, QObject*, const QVariantList&) [with impl = BinaryClock]'
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/binary-clock/binaryclock.h:83: instantiated from here
/usr/kde/svn/include/kpluginfactory.h:461: error: cannot convert 'BinaryClock*' to 'QObject*' in return
make[2]: *** [applets/binary-clock/CMakeFiles/plasma_applet_binaryclock.dir/binaryclock.o] Error 1
make[1]: *** [applets/binary-clock/CMakeFiles/plasma_applet_binaryclock.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Scanning dependencies of target plasma_applet_comic
[ 10%] Building CXX object applets/comic/CMakeFiles/plasma_applet_comic.dir/comic.o
[ 11%] Building CXX object applets/comic/CMakeFiles/plasma_applet_comic.dir/configwidget.o
[ 12%] Building CXX object applets/comic/CMakeFiles/plasma_applet_comic.dir/plasma_applet_comic_automoc.o
Scanning dependencies of target plasma_applet_fileWatcher
Linking CXX shared module ../../lib/plasma_applet_comic.so
[ 12%] Built target plasma_applet_comic
[ 13%] Building CXX object applets/fileWatcher/CMakeFiles/plasma_applet_fileWatcher.dir/fileWatcher.o
[ 15%] Building CXX object applets/fileWatcher/CMakeFiles/plasma_applet_fileWatcher.dir/fileWatcherConfig.o
[ 16%] Building CXX object applets/fileWatcher/CMakeFiles/plasma_applet_fileWatcher.dir/plasma_applet_fileWatcher_automoc.o
Linking CXX shared module ../../lib/plasma_applet_fileWatcher.so
[ 16%] Built target plasma_applet_fileWatcher
make: *** [all] Error 2

!!! ERROR in kde-base/kdeplasma-addons-scm:
!!! In cmake-utils_src_make at line 1084
!!! Make failed!

!!! Call stack:
!!! * cmake-utils_src_make (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:1084)
!!! * kde4-base_src_make (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:3069)
!!! * kde4-base_src_compile (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:3038)
!!! * src_compile (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:3911)
!!! * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!! * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!! * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 31324 exit with error
die trap: exiting with error.

Install error:
* In program paludis -i1 kde-base/kdeplasma-addons:
* When performing install action from command line:
* When executing install task:
* When installing 'kde-base/kdeplasma-addons-scm:kde-svn::kde4-experimental':
* Install error: Install failed for 'kde-base/kdeplasma-addons-scm:kde-svn::kde4-experimental'


Some tips from somebody? Thanks in advance. I think this time the situation is critic... :( I wanna upgrade all genkdesvn, but if i have problems only with kdeplasma-addons....i don't now when i complete all the upgrade..... :(

Sorry for my english, i'm italian.
_________________
hasta la victoria siempre, subcomandante Marcos
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Sun Jul 20, 2008 1:25 pm    Post subject: Reply with quote

With pixman-0.11.6 it is possible to build but not install :-(

Code:
Linking CXX shared module CMakeFiles/CMakeRelink.dir/krunner_converterrunner.so
Install the project...
-- Install configuration: "Release"
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_dict.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-dict-default.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_binaryclock.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-applet-binaryclock.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_calculator.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-applet-calculator.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_comic.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-comic-default.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_fileWatcher.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-fileWatcher-default.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_fifteenPuzzle.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-applet-fifteenPuzzle.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/icons/hicolor/scalable/apps/./fifteenpuzzle.svgz
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_frame.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-frame-default.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/apps/desktoptheme/default/widgets/picture-frame-default.svgz
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_fuzzy_clock.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-clock-fuzzy.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_kolourpicker.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-kolourpicker-default.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_konqprofiles.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-applet-konqprofiles.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_konsoleprofiles.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-applet-konsoleprofiles.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_luna.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-applet-luna.desktop
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/apps/desktoptheme/default/widgets/luna.svgz
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/lib/kde4/plasma_applet_notes.so
-- Installing /var/tmp/paludis/kde-base-kdeplasma-addons-scm/image/usr/kde/svn/share/kde4/services/plasma-notes-default.desktop
CMake Error: Error in cmake code at
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/notes/cmake_install.cmake:37:
FILE INSTALL cannot find file "/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/notes/notes.svgz" to install.
Current CMake stack:
[3]     /var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/notes/cmake_install.cmake
[2]     /var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/cmake_install.cmake
[1]     /var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/cmake_install.cmake
make: *** [install] Error 255
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/kdeplasma-addons-scm:
!!! In cmake-utils_src_install at line 1076
!!! Make install failed

!!! Call stack:
!!!    * cmake-utils_src_install (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:1076)
!!!    * kde4-base_src_install (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:3119)
!!!    * src_install (/var/tmp/paludis/kde-base-kdeplasma-addons-scm/temp/loadsaveenv:4037)
!!!    * ebuild_f_install (/usr/libexec/paludis/0/src_install.bash:46)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:463)
!!!    * main (/usr/libexec/paludis/ebuild.bash:478)

diefunc: making ebuild PID 17775 exit with error
die trap: exiting with error.

Install error:
  * In program /usr/bin/paludis (--checks none --show-reasons summary --show-use-descriptions changed --dl-downgrade warning --dl-installed-deps-pre pre-or-post --log-level warning --dl-upgrade always --resume-command-template /root/.paludis-resume-XXXXXX) -i1 kdeplasma-addons:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'kde-base/kdeplasma-addons-scm:kde-svn::kde4-experimental':
  * Install error: Install failed for 'kde-base/kdeplasma-addons-scm:kde-svn::kde4-experimental'

_________________
hidentity.org
Back to top
View user's profile Send private message
ezln
n00b
n00b


Joined: 23 May 2008
Posts: 14

PostPosted: Sun Jul 20, 2008 2:53 pm    Post subject: Reply with quote

Hallo.

I have installed pixman 0.10.0, i simply put away pixman from keywords.conf....only so the prog compile. In other case i obtain the error i have posted before.
But with the stable version of pixman don't compile kdeplasma-addons, you say? Only the version 0.11.8 is good...but, imho, have a problem with ebuild or is a bug...i don't now.. :(
_________________
hasta la victoria siempre, subcomandante Marcos
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sun Jul 20, 2008 5:01 pm    Post subject: Reply with quote

KejPi wrote:
...
Code:
...
CMake Error: Error in cmake code at
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/notes/cmake_install.cmake:37:
FILE INSTALL cannot find file "/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/notes/notes.svgz" to install.
...


I wonder what this all has to do with pixman..
Code:
└» paludis -q pixman|grep installed
    installed:               0.11.8* {:0}
...and no problems compiling.

But I also get this error. Welcome to SVN! :)

Also commit 835295 broke libplasma, ksysguard an others - for now I manually undid that one by editing /usr/kde/svn/share/apps/cmake/modules/KDE4Macros.cmake
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
KejPi
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2004
Posts: 122
Location: Prague, Czech republic

PostPosted: Mon Jul 21, 2008 7:25 am    Post subject: Reply with quote

gimpel wrote:
KejPi wrote:
...
Code:
...
CMake Error: Error in cmake code at
/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons_build/applets/notes/cmake_install.cmake:37:
FILE INSTALL cannot find file "/var/tmp/paludis/kde-base-kdeplasma-addons-scm/work/kdeplasma-addons-scm/applets/notes/notes.svgz" to install.
...


I wonder what this all has to do with pixman..


No, this has nothing to do with pixman.
I can compile it with 0.10.0 and 0.11.6 without any problem. I fixed somehow it by changing makefile in SVN working copy (at least it is possible to install it)
_________________
hidentity.org
Back to top
View user's profile Send private message
hvengel
Guru
Guru


Joined: 19 Sep 2004
Posts: 515

PostPosted: Mon Jul 28, 2008 7:29 pm    Post subject: Reply with quote

Earlier I asked about Qt Designer failing to start when running KDE svn. Today I played around with it and found that there is apparently something wrong with /usr/kde/svn/lib64/kde4/plugins/designer/kdewidgets.so and /usr/kde/svn/lib64/kde4/plugins/designer/ksysguardwidgets.so (missing symbols). I backed up these files and copied the same files over to the svn directories from my KDE 4.0.5 installation (designer works there). Designer now starts and the KDE widgets show up and appear to be functional (I tried using the KSysGuardProcessList widget and it was functional). So there is either an error in the code that is used to build these widget plug in libraries or there is something wrong with how these are being built. I don't know which.

Has anyone here ever been able to run Qt designer 4.x with KDE svn without resorting to the kind of hack I used?
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jul 28, 2008 8:54 pm    Post subject: Reply with quote

I'm trying to update webkit-kpart and it's failing as follows:
Code:

-- Could not find OPTIONAL package Eigen                                                                                             
CMake Error: find_package could not find module FindGIO.cmake or a configuration file for package GIO.                               
Adjust CMAKE_MODULE_PATH to find FindGIO.cmake or set GIO_DIR to the directory containing a CMake configuration file for GIO.  The file will have one of the following names:                                                                                               
  GIOConfig.cmake                                                                                                                     
  gio-config.cmake                                                                                                                   

-- Found GLIB2: /usr/lib64/libglib-2.0.so


I've deleted the entire svn-src dir and re-checked it out.

the FindGIO.cmake file is there and gio-2.0 exists on my system. is there anything I can do to fix this?
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jul 28, 2008 8:57 pm    Post subject: Reply with quote

Next failure: korn is failing due to a missing make install function?

Code:

-- Configuring done
-- Generating done
-- Build files have been written to: /mnt/windows/tmp/paludis/kde-base-korn-scm/work/korn_build
make -j5                                                                                       
[  0%] Helper target for XML stuff. The Kontact plugin, KOrganizer and others depend on it.   
[100%] Built target kmail_xml                                                                                                         
 * >>> Test phase [test]: kde-base/korn-scm                                                                                           
make -j5 -j1 test                                                                                                                     
Running tests...                                                                                                                     
Start processing tests                                                                                                               
Test project /mnt/windows/tmp/paludis/kde-base-korn-scm/work/korn_build                                                               
No tests were found!!!                                                                                                               
>>> Done src_test                                                                                                                     
>>> Starting builtin_saveenv                                                                                                         
>>> Done builtin_saveenv                                                                                                             
>>> Completed ebuild phases loadenv test saveenv                                                                                     
>>> Running ebuild phases loadenv install saveenv as root:root...                                                                     
>>> Starting builtin_loadenv                                                                                                         
>>> Done builtin_loadenv                                                                                                             
>>> Starting src_install                                                                                                             
make -j5 install DESTDIR=/mnt/windows/tmp/paludis/kde-base-korn-scm/image/                                                           
make: *** No rule to make target `install'.  Stop.                                                                                   
/usr/libexec/paludis/utils/emake: emake returned error 2                                                                             

!!! ERROR in kde-base/korn-scm:
!!! In cmake-utils_src_install at line 1188
!!! Make install failed                   

_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Mon Jul 28, 2008 9:03 pm    Post subject: Reply with quote

Hmmm... a few things are failing: nepomuk-kde. The first error is:

Parsing ontology file "/mnt/windows/tmp/paludis/kde-misc-nepomuk-kde-scm/work/nepomuk-kde/nepomuk-kde/libnfo/nfo.rdfs" failed.

It then blows up all over the place.

the log of the build is here:

http://www.dpmr.ca/gentoo/nepomuk.log
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
trikolon
Apprentice
Apprentice


Joined: 04 Dec 2004
Posts: 297
Location: Erlangen

PostPosted: Wed Jul 30, 2008 3:37 pm    Post subject: Reply with quote

does anybody know how i can use my printer under kde 4.1.0? under 3.5 it worked with kdeprint, but that does not exists in 4.1??

edit: only okular is unable to print. it always prints pdfs. acroread or kate are printing as they should... any ideas?
Back to top
View user's profile Send private message
skibbi
Apprentice
Apprentice


Joined: 13 Apr 2004
Posts: 202
Location: Rostock - Germany

PostPosted: Thu Jul 31, 2008 8:03 am    Post subject: HowTo install KDE 4.1 final? Reply with quote

Hi,
I just did everything to use the kdesvn overlay ( I did everything that was mentioned in the repository's README) but now I want to install KDE 4.1 final and I have no idea what to do. I'm not familar with paludis and the required dependencies for KDE 4.1. It would be nice if someone could help me.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Thu Jul 31, 2008 8:06 am    Post subject: Reply with quote

trikolon wrote:
does anybody know how i can use my printer under kde 4.1.0? under 3.5 it worked with kdeprint, but that does not exists in 4.1??

edit: only okular is unable to print. it always prints pdfs. acroread or kate are printing as they should... any ideas?


use cups to configure printer.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
trikolon
Apprentice
Apprentice


Joined: 04 Dec 2004
Posts: 297
Location: Erlangen

PostPosted: Thu Jul 31, 2008 9:01 am    Post subject: Reply with quote

Quote:
trikolon hat Folgendes geschrieben:
does anybody know how i can use my printer under kde 4.1.0? under 3.5 it worked with kdeprint, but that does not exists in 4.1??

edit: only okular is unable to print. it always prints pdfs. acroread or kate are printing as they should... any ideas?


use cups to configure printer.


the printer is already configured with cups and i can use it with acroread or kate. in okular the printer is displayed but i cannot print with it. it only prints a pdf document.
Back to top
View user's profile Send private message
lucianolev
n00b
n00b


Joined: 19 Sep 2006
Posts: 31

PostPosted: Fri Aug 01, 2008 3:54 am    Post subject: Reply with quote

That's a known bug which is very annoying for me: http://bugs.kde.org/show_bug.cgi?id=162793

It seems to be fixed, let's hope that it's included in qt 4.4.1
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3234
Location: Gainesville, Florida

PostPosted: Fri Aug 01, 2008 8:00 pm    Post subject: Reply with quote

I'm on my Arch partition today, and they just went to qt-4.4.1 in their testing repo, so I dropped qt-copy, and am presently over half-way finished with a complete kdesvn rebuild against the Arch qt-4.4.1. So far no problems. (I use the kdesvn-build tool, and .kdesvn-buildrc script).

Anyway, I was wondering if/when we will need to go to qt-4.4.1 over here on Gentoo? I run a Paludis install, and a different portage install of kdesvn on another partition, both identical Gentoo ~x86. Haven't seen any posts on the forum about qt-4.4.1 yet, but if the Arch install finishes up my kdesvn rebuild OK, I'll want to go to 4.4.1 and rebuild on my Gentoo boxes ASAP.

UPDATE: For informational purposes, I can confirm that on Arch Linux the following kdesvn modules (r840697 and greater) build fine with cmake-2.6.0, gcc-4.3.1, glibc-2.8, and the new qt-4.4.1.

kdesupport
kdelibs
kdepimlibs
kdebase
kdemultimedia
kdeartwork
kdegames
kdenetwork
kdeadmin
kdepim
kdeutils
kdegraphics
kdeedu
extragear/graphics
extragear/base
kdeplasma-addons

extragear/multimedia (k3b) failed at 88%
Code:
/home/wrc/kdesvn/extragear/multimedia/k3b/libk3bdevice/k3bmsf.h:112: warning: ‘kndbgstream’ is deprecated (declared at /home/wrc/kde/include/kdebug.h:212)
[ 88%] Building CXX object k3b/src/CMakeFiles/k3b_bin.dir/k3b_bin_automoc.o
Linking CXX executable k3b
[ 88%] Built target k3b_bin
make: *** [all] Error 2

I only was building k3b from this module, so maybe I should have done the entire module (or at least libkdemultimedia), and possibly avoided this error.
(EDIT: Sorry. :oops: I mixed up kdemultimedia and extragear/multimedia. libkdemultimedia is not in with k3b in extragear/multimedia.)

All the other modules were full builds, and everything in each individual module built fine. Reboot was fine, and it's running great so far.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.1.12-gentoo USE=experimental
Back to top
View user's profile Send private message
notHerbert
Advocate
Advocate


Joined: 11 Mar 2008
Posts: 2228
Location: 45N 73W

PostPosted: Sun Aug 03, 2008 3:32 am    Post subject: Reply with quote

Did anybody else get these blocks in kdesvn-portage? I'm not quite sure how to proceed.
Code:

...
...
[ebuild  NS   ] kde-base/kdebase-meta-4.1.0 [3.5.9] 0 kB [1]
[blocks B     ] x11-libs/qt-core (is blocking x11-libs/qt-4.3.5)
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 (is blocking x11-libs/qt-script-4.4.0, x11-libs/qt-dbus-4.4.0, x11-libs/qt-sql-4.4.0, x11-libs/qt-gui-4.4.0, x11-libs/qt-qt3support-4.4.0, x11-libs/qt-svg-4.4.0, x11-libs/qt-test-4.4.0, x11-libs/qt-opengl-4.4.0, x11-libs/qt-core-4.4.0, x11-libs/qt-webkit-4.4.0)

Total: 87 packages (54 new, 33 in new slots), Size of downloads: 257,004 kB
Conflict: 2 blocks (2 unsatisfied)


EDIT: If I do 'emerge -uDNpv --with-bdeps=y @world @system' the blocks are gone.
Back to top
View user's profile Send private message
den_RDC
Apprentice
Apprentice


Joined: 25 Aug 2002
Posts: 166
Location: beercountry, Belgium;)

PostPosted: Sun Aug 03, 2008 12:11 pm    Post subject: Reply with quote

Some problem as the poster above - For the record - no version of QT4 is actually installed on this system
Code:

[ebuild  N    ]     x11-libs/qt-core-4.4.0  USE="doc qt3support ssl -debug -glib -pch" 0 kB
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 (is blocking x11-libs/qt-script-4.4.0, x11-libs/qt-dbus-4.4.0, x11-libs/qt-sql-4.4.0, x11-libs/qt-gui-4.4.0, x11-libs/qt-qt3support-4.4.0, x11-libs/qt-svg-4.4.0, x11-libs/qt-test-4.4.0, x11-libs/qt-opengl-4.4.0, x11-libs/qt-core-4.4.0, x11-libs/qt-webkit-4.4.0)
[blocks B     ] x11-libs/qt-core (is blocking x11-libs/qt-4.3.3)

_________________
Fan of the "Survivor Warriors of the Evil Empire of Bloody Destruction and Bloody Darkness"
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Sun Aug 03, 2008 4:50 pm    Post subject: Reply with quote

den_RDC wrote:
Some problem as the poster above - For the record - no version of QT4 is actually installed on this system
Code:

[ebuild  N    ]     x11-libs/qt-core-4.4.0  USE="doc qt3support ssl -debug -glib -pch" 0 kB
[blocks B     ] <=x11-libs/qt-4.4.0_alpha:4 (is blocking x11-libs/qt-script-4.4.0, x11-libs/qt-dbus-4.4.0, x11-libs/qt-sql-4.4.0, x11-libs/qt-gui-4.4.0, x11-libs/qt-qt3support-4.4.0, x11-libs/qt-svg-4.4.0, x11-libs/qt-test-4.4.0, x11-libs/qt-opengl-4.4.0, x11-libs/qt-core-4.4.0, x11-libs/qt-webkit-4.4.0)
[blocks B     ] x11-libs/qt-core (is blocking x11-libs/qt-4.3.3)


well, qt4.4 is slotted while 4.3.x is not slotted and is monolithic. so before installing qt 4.4 you'll need to either force the install and then uninstall qt4.3 or to uninstall qt4.3 and the install qt4.4. it's your choice on what approach to take. i personally have chosen the 2nd one since i had some hours of free time not in front of the pc and since i'm compiling into ram. so for me it went quite fast, but it might take some time if you use standard compiling method and a single core cpu.
Back to top
View user's profile Send private message
arghnoname
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 84
Location: Washington, DC

PostPosted: Fri Aug 08, 2008 3:50 am    Post subject: Reply with quote

The other issue you have to watch for is there are a few packages that require qt 4.3 and will attempt to pull them in. Doing the same emerge with the -t option allowed me to figure out what they were. Taking off the qt4 use flag on those packages or removing them fixed the issue. I didn't happen to need that functionality in those few packages. I put them in a temp file in my package.use directory.

In my case:

Code:

app-text/poppler-bindings -qt4
dev-python/qscintilla-python -qt4
Back to top
View user's profile Send private message
binro
l33t
l33t


Joined: 06 May 2005
Posts: 627
Location: Bangkok, Thailand

PostPosted: Fri Aug 08, 2008 6:57 am    Post subject: Reply with quote

I have just started installing 4.1 and am going through the process of removing the blocks. I am currently getting:

    [blocks B ] media-libs/libkipi (is blocking kde-base/libkipi-4.1.0)

Apparently digikam needs media-libs/libkipi, so if I upgrade will digikam stop working on the 3.5 system? I want to be able to full-back.

TIA
_________________
"Ship me somewheres east of Suez, where the best is like the worst,
Where there ain't no Ten Commandments an' a man can raise a thirst"
from "Mandalay" by Rudyard Kipling
Back to top
View user's profile Send private message
pigeon768
l33t
l33t


Joined: 02 Jan 2006
Posts: 675

PostPosted: Tue Aug 12, 2008 11:14 am    Post subject: Reply with quote

phonon-xine fails.
Code:
[  4%] Generating moc_effect.cpp
Building CXX object phonon/kcm/CMakeFiles/phonon_devicepreference_update.dir/phonon_devicepreference_update_automoc.o
[  6%] Generating xinestream.moc
Building CXX object phonon/kcm/CMakeFiles/phonon_devicepreference_update.dir/devicepreference_update.o
Generating abstractaudiooutput.moc
Generating videodataoutput.moc
/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine/phonon/xine/videodataoutput.h:44: Error: Undefined interface
automoc4: process for /var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/phonon/xine/videodataoutput.moc failed: Unknown error
pid to wait for: 0
Generating moc_nullsink.cpp
Linking CXX executable phonon_devicepreference_update
Generating volumefadereffect.moc
Generating audiodataoutput.moc
[  6%] Built target phonon_devicepreference_update
[  9%] Generating ui_xineoptions.h
Generating videowidget.moc
Generating xineoptions.moc
Scanning dependencies of target kaudiodevicelist
/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine/phonon/xine/videowidget.h:98: Error: Undefined interface
automoc4: process for /var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/phonon/xine/videowidget.moc failed: Unknown error
pid to wait for: 0
Generating mediaobject.moc
[ 11%] Building CXX object phonon/libkaudiodevicelist/CMakeFiles/kaudiodevicelist.dir/audiodevice.o
Generating backend.moc
Generating audiooutput.moc
returning failed..
make[2]: *** [phonon/xine/phonon_xine_automoc.cpp] Error 1
make[1]: *** [phonon/xine/CMakeFiles/phonon_xine.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 13%] Building CXX object phonon/libkaudiodevicelist/CMakeFiles/kaudiodevicelist.dir/audiodeviceenumerator.o
Scanning dependencies of target kcm_phononxine
[ 15%] Building CXX object phonon/xine/kcm/CMakeFiles/kcm_phononxine.dir/xineoptions.o
[ 18%] Building CXX object phonon/libkaudiodevicelist/CMakeFiles/kaudiodevicelist.dir/hardwaredatabase.o
[ 20%] Building CXX object phonon/libkaudiodevicelist/CMakeFiles/kaudiodevicelist.dir/qrc_resources.o
[ 22%] Building CXX object phonon/libkaudiodevicelist/CMakeFiles/kaudiodevicelist.dir/kaudiodevicelist_automoc.o
/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine/phonon/libkaudiodevicelist/hardwaredatabase.cpp: In member function 'void Phonon::HardwareDatabase::HardwareDatabasePrivate::createCache(const QString&, const QString&)':
/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine/phonon/libkaudiodevicelist/hardwaredatabase.cpp:128: warning: unused variable 'opened'
[ 25%] Building CXX object phonon/xine/kcm/CMakeFiles/kcm_phononxine.dir/kcm_phononxine_automoc.o
Linking CXX shared module ../../../lib/kcm_phononxine.so
[ 25%] Built target kcm_phononxine
Linking CXX shared library ../../lib/libkaudiodevicelist.so
[ 25%] Built target kaudiodevicelist
make: *** [all] Error 2
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/phonon-xine-scm:
!!! In cmake-utils_src_make at line 1150
!!! Make failed!
/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeError.log:
Code:
[snip]Determining if files /usr/src/sys/gnu/i386/isa/sound/awe_voice.h exist failed with the following output:
Change Dir: /var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeTmp

Run Build Command:/usr/bin/gmake "cmTryCompileExec/fast"
/usr/bin/gmake -f CMakeFiles/cmTryCompileExec.dir/build.make CMakeFiles/cmTryCompileExec.dir/build
gmake[1]: Entering directory `/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeTmp'
/usr/bin/cmake -E cmake_progress_report /var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeTmp/CMakeFiles 1
Building C object CMakeFiles/cmTryCompileExec.dir/CheckIncludeFiles.c.o
/usr/bin/x86_64-pc-linux-gnu-gcc   -O2 -march=native -fomit-frame-pointer -pipe  -Wno-long-long -std=iso9899:1990 -Wundef -Wcast-align -Werror-implicit-function-declaration -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -Wformat-security -Wmissing-format-attribute -fno-common     -o CMakeFiles/cmTryCompileExec.dir/CheckIncludeFiles.c.o   -c /var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeTmp/CheckIncludeFiles.c
/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeTmp/CheckIncludeFiles.c:2:55: error: /usr/src/sys/gnu/i386/isa/sound/awe_voice.h: No such file or directory
gmake[1]: Leaving directory `/var/tmp/paludis/kde-base-phonon-xine-scm/work/phonon-xine_build/CMakeFiles/CMakeTmp'
gmake[1]: *** [CMakeFiles/cmTryCompileExec.dir/CheckIncludeFiles.c.o] Error 1
gmake: *** [cmTryCompileExec/fast] Error 2

Source:
/* */
#include </usr/src/sys/gnu/i386/isa/sound/awe_voice.h>


int main(){return 0;}
awe_voice.h? o.O
Back to top
View user's profile Send private message
beso_1717
Apprentice
Apprentice


Joined: 19 Jul 2007
Posts: 263

PostPosted: Tue Aug 12, 2008 9:19 pm    Post subject: Reply with quote

arghnoname wrote:
The other issue you have to watch for is there are a few packages that require qt 4.3 and will attempt to pull them in. Doing the same emerge with the -t option allowed me to figure out what they were. Taking off the qt4 use flag on those packages or removing them fixed the issue. I didn't happen to need that functionality in those few packages. I put them in a temp file in my package.use directory.

In my case:

Code:

app-text/poppler-bindings -qt4
dev-python/qscintilla-python -qt4


or just rebuild the packages with --dl-deps-default discard and they will use the new qt version and drop the dep on the old one.
Back to top
View user's profile Send private message
Mr_Grieves
n00b
n00b


Joined: 05 Mar 2007
Posts: 23

PostPosted: Thu Aug 14, 2008 12:16 pm    Post subject: plasma-workspace won't compile Reply with quote

Anyone else having trouble compiling plasma-workspace? I've been waiting for a few days to get past this:

Code:

[ 14%] Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/core/leavemodel.o
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:29:29: error: kdisplaymanager.h: No such file or directory
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp: In constructor 'Kickoff::LeaveModel::LeaveModel(QObject*)':
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:127: error: 'KDisplayManager' was not declared in this scope
make[2]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/core/leavemodel.o] Error 1
make[1]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 15%] Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/core/leavemodel.o
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:29:29: error: kdisplaymanager.h: No such file or directory
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp: In constructor 'Kickoff::LeaveModel::LeaveModel(QObject*)':
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:127: error: 'KDisplayManager' was not declared in this scope[ 15%]
Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/core/models.o
make[2]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/core/leavemodel.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/all] Error 2
make: *** [all] Error 2

!!! ERROR in kde-base/plasma-workspace-scm:
!!! In cmake-utils_src_make at line 1111
!!! Make failed!

!!! Call stack:
!!!    * cmake-utils_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:1111)
!!!    * kde4-base_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3103)
!!!    * kde4-meta_src_make (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3388)
!!!    * kde4-meta_src_compile (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:3339)
!!!    * src_compile (/var/tmp/paludis/kde-base-plasma-workspace-scm/temp/loadsaveenv:4240)
!!!    * ebuild_f_compile (/usr/libexec/paludis/1/src_compile.bash:49)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:460)
!!!    * main (/usr/libexec/paludis/ebuild.bash:479)

diefunc: making ebuild PID 29219 exit with error
die trap: exiting with error.


Is anyone else having this problem, or is it just my system? All I know is that ratpoison is getting old with a dual monitor set up :)
_________________
IRC Mr_Grieves
Back to top
View user's profile Send private message
Stefano Crocco
Apprentice
Apprentice


Joined: 28 Sep 2006
Posts: 156

PostPosted: Thu Aug 14, 2008 12:27 pm    Post subject: Re: plasma-workspace won't compile Reply with quote

Mr_Grieves wrote:
Anyone else having trouble compiling plasma-workspace? I've been waiting for a few days to get past this:

Code:

[ 14%] Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/core/leavemodel.o
/var/tmp/paludis/kde-base-plasma-workspace-scm/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:29:29: error: kdisplaymanager.h: No such file or directory





I had this problem, too. Syncing the overlay should fix it

Stefano
_________________
Stefano
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 21, 22, 23 ... 26, 27, 28  Next
Page 22 of 28

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum