Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Using XMMS properly with SHOUTCAST
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
ChojinDSL
l33t
l33t


Joined: 07 Jul 2003
Posts: 784

PostPosted: Tue Jul 22, 2003 8:49 am    Post subject: Using XMMS properly with SHOUTCAST Reply with quote

Ok, I just figured this out and I think I remember reading a post somewhere about someone who didnt know how to do it so that xmms not only plays shoutcast (.pls) links directly by just clicking on them, but also so that xmms displays which song is being played at the moment via shoutcast stream.

Ok, first of all, open preferences in XMMS, click on the" Audio I/O Plugins" tab and highlight "MPEG Layer 1/2/3"

Then click on configure. In the new window that opens, click on the streaming tab and activate both the "Enable SHOUT/Icecast title Streaming" and "Enable Icecast Metadat UDP Channel".

Ok, once thats done, all you need to do is tell your browser what to do with .pls files.
Since I use Opera, I'll simply tell you how I did it there.
Go to the shoutcast website, www.shoutcast.com and click on one of the "tune in" links, a dialog should pop up asking what to do with the file. Click on "advanced" and then simply select the option "open with other application" in the field there just enter xmms. DO NOT activate the "pass web address directly to application". Then just click on OK or APPLY or whatever and your done.

Now whenever you click on a "tune in" link on the shoutcast page, xmms will automatically load, list all the addressess for the clicked link in the playlist and start playing it.

Just like Winamp under windows.

I havent tried this with any other browser, but my guess is, that you just need to let the browser know what to do with ".pls" links.

Feel free to add procedures for other browsers if the process varies greatly from my description.
Back to top
View user's profile Send private message
pYrania
Retired Dev
Retired Dev


Joined: 27 Oct 2002
Posts: 650
Location: Cologne - Germany

PostPosted: Tue Jul 22, 2003 2:49 pm    Post subject: Reply with quote

The mimetype is audio/x-scpls.
In most browsers (apart of mine 8O) you can specify the applications to load by mimetype.
_________________
Markus Nigbur
Back to top
View user's profile Send private message
ChojinDSL
l33t
l33t


Joined: 07 Jul 2003
Posts: 784

PostPosted: Tue Jul 22, 2003 4:00 pm    Post subject: Reply with quote

Which browser do you use?
Back to top
View user's profile Send private message
pYrania
Retired Dev
Retired Dev


Joined: 27 Oct 2002
Posts: 650
Location: Cologne - Germany

PostPosted: Tue Jul 22, 2003 4:05 pm    Post subject: Reply with quote

This would be MozillaFirebird.
If you click on "Tune In" you get the option to specify the program to run it with and it will automatically save it to its configuration.
_________________
Markus Nigbur
Back to top
View user's profile Send private message
Squinky86
Retired Dev
Retired Dev


Joined: 25 Mar 2003
Posts: 309
Location: Alabama, USA

PostPosted: Tue Jul 22, 2003 4:57 pm    Post subject: Reply with quote

Ah, thank you! I never noticed that option to display the song name.
Now, back to my classical music...
_________________
Me
Back to top
View user's profile Send private message
theplatypus
n00b
n00b


Joined: 03 Sep 2002
Posts: 44

PostPosted: Sun Jul 27, 2003 1:03 pm    Post subject: Reply with quote

Works great, thanks for the tip
Back to top
View user's profile Send private message
Black
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2002
Posts: 124
Location: Province of Quebec, Canada

PostPosted: Sun Jul 27, 2003 2:58 pm    Post subject: Reply with quote

Hmmfff... Konqueror doesn't seem to play nice on that one. I click on the link, it asks me if I want to open it using XMMS, where I say yes. XMMS opens, but then asks me which file to open.

I guess it's because Konqueror sends the URL to XMMS. Any help here?
Back to top
View user's profile Send private message
equilibrium
Apprentice
Apprentice


Joined: 29 Jun 2003
Posts: 213
Location: UK

PostPosted: Fri Aug 01, 2003 3:05 pm    Post subject: Reply with quote

nice :)

but to get MozillaFirebird to run the file with xmms I had to type "/usr/bin/xmms" as typing "xmms" didn't work :D
_________________
kernel 4.15.17-1-equk | i3wm | github
Back to top
View user's profile Send private message
cdunham
Apprentice
Apprentice


Joined: 06 Jun 2003
Posts: 211
Location: Rhode Island

PostPosted: Sun Aug 03, 2003 5:24 pm    Post subject: Reply with quote

Black wrote:
Hmmfff... Konqueror doesn't seem to play nice on that one. I click on the link, it asks me if I want to open it using XMMS, where I say yes. XMMS opens, but then asks me which file to open.

I guess it's because Konqueror sends the URL to XMMS. Any help here?


I'm not sure where it came from, but I have a nice "xmms-enqueue.desktop" that looks like this:

Code:
[Desktop Entry]
Comment=
Encoding=UTF-8
Exec=xmms %F -e
GenericName=Playlist Tool
Icon=xmms
MimeType=audio/x-mp3;audio/x-mod;audio/x-wav;audio/x-mpegurl;audio/x-scpls;Application
Name=Enqueue in XMMS
NoDisplay=true
Path=
ServiceTypes=
SwallowExec=
SwallowTitle=
Terminal=false
TerminalOptions=
Type=Application
X-KDE-StartupNotify=false
X-KDE-SubstituteUID=false
X-KDE-Username=


Works great, lasts a long time...
_________________
This post more meaningful in a scalar context.
Back to top
View user's profile Send private message
cdunham
Apprentice
Apprentice


Joined: 06 Jun 2003
Posts: 211
Location: Rhode Island

PostPosted: Sun Aug 03, 2003 5:27 pm    Post subject: Reply with quote

cdunham wrote:
I'm not sure where it came from, but I have a nice "xmms-enqueue.desktop"...


Code:
/usr/kde/3.1/share/apps/kappfinder/apps/Multimedia/xmms-enqueue.desktop


Perhaps running KAppfinder (under Settings) did it. Cool.
_________________
This post more meaningful in a scalar context.
Back to top
View user's profile Send private message
Balthasar
n00b
n00b


Joined: 25 May 2003
Posts: 62
Location: Florida

PostPosted: Sun Aug 03, 2003 11:25 pm    Post subject: Reply with quote

I just tried specifying the program to open with as /usr/bin/xmms -e
and that gave me an error, is there maybe a way to have the "Tune in" enqueued instead of erasing the playlist ?
_________________
"Trust the computer industry to shorten ‘Year 2000’ to ‘Y2K’. It was this kind of thinking that caused the problem in the first place."

Just because it's common sense, doesn't mean it's common practice. - Will Rogers
Back to top
View user's profile Send private message
cdunham
Apprentice
Apprentice


Joined: 06 Jun 2003
Posts: 211
Location: Rhode Island

PostPosted: Mon Aug 04, 2003 12:07 am    Post subject: Reply with quote

Balthasar wrote:
I just tried specifying the program to open with as /usr/bin/xmms -e
and that gave me an error, is there maybe a way to have the "Tune in" enqueued instead of erasing the playlist ?


You need the %F to pass the file to enqueue. RTFM ;-)
_________________
This post more meaningful in a scalar context.
Back to top
View user's profile Send private message
Black
Tux's lil' helper
Tux's lil' helper


Joined: 10 Dec 2002
Posts: 124
Location: Province of Quebec, Canada

PostPosted: Mon Aug 04, 2003 2:20 am    Post subject: Reply with quote

Well, fixed it with your help! :)

I was about to try adding the "-e" flag, then I realized Konqueror was running "xmms %U", instead of "xmms %F", so I changed it to %F, which did the trick.

%U must send the URL. I couldn't find help on the file associations when I asked.
Back to top
View user's profile Send private message
triad
Apprentice
Apprentice


Joined: 10 Jul 2003
Posts: 234
Location: Dark Side of the Moon

PostPosted: Mon Aug 04, 2003 2:44 am    Post subject: Reply with quote

Great TIP thanks!

Triad
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum