Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
OpenOffice 3
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Zaister
n00b
n00b


Joined: 08 Apr 2004
Posts: 20
Location: Germany

PostPosted: Fri Oct 10, 2008 10:04 am    Post subject: Reply with quote

I was able to compile RC1 originally, but I can't get to build the later RCs. Currently getting this error with RC4:

Code:

1 module(s):
        vcl
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.0.0_rc4/work/ooo/build/ooo300-m9/vcl/util

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from vcl"

rmdir /tmp/18450
make: *** [stamp/build] Error 1
 *
 * ERROR: app-office/openoffice-3.0.0_rc4 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 5385:  Called die
 * The specific snippet of code:
 * make || die "Build failed"
 * The die message:
 * Build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-3.0.0_rc4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-3.0.0_rc4/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.07"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER=""
and of course, the output of emerge --info


Here's the emerge --info output:

Code:

Portage 2.2_rc12 (default/linux/x86/2008.0, gcc-4.3.2, glibc-2.6.1-r0, 2.6.26-gentoo i686)
=================================================================
System uname: Linux-2.6.26-gentoo-i686-Intel-R-_Core-TM-2_CPU_6600_@_2.40GHz-with-glibc2.0
Timestamp of tree: Fri, 10 Oct 2008 07:45:02 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.2-r8
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.3.0-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.6a
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe -fomit-frame-pointer"
DISTDIR="/data/gentoo/distfiles"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FEATURES="ccache distlocks parallel-fetch preserve-libs protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://de-mirror.org/distro/gentoo/ "
LDFLAGS="-Wl,-O1"
LINGUAS="en de"
MAKEOPTS="-j3"
PKGDIR="/data/gentoo/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://mercutio.home/gentoo-portage"
USE="X a52 aac acpi alsa bash-completion berkdb bluetooth bzip2 cairo cli cracklib crypt css cups curl daap dbus dga dri dvd dvdr dvdread encode fam fbcon fbcondecor ffmpeg flac foomaticdb fortran ftp gd gdbm gif glitz gpm hal iconv imagemagick imap ipod isdnlog java joystick jpeg kde ldap lm_sensors logitech-mouse loop-aes mad matroska midi mmap mng mp3 mpeg mplayer mudflap mysql ncurses nls nptl nptlonly nsplugin nvidia offensive ogg openal opengl openmp oracle pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline real reflection rtc rtsp samba sasl scanner sdl session spell spl sqlite ssl subversion svg sysfs tcpd theora tiff tk truetype unicode usb vorbis win32codecs wmp x264 x86 xcomposite xine xinerama xml xorg xulrunner xv xvid yahoo zlib" ALSA_CARDS="ca0106" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" FOO2ZJS_DEVICES="km2430" INPUT_DEVICES="keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en de" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

_________________
Regards,
Stefan.
Back to top
View user's profile Send private message
El_Presidente_Pufferfish
Veteran
Veteran


Joined: 11 Jul 2002
Posts: 1179
Location: Seattle

PostPosted: Fri Oct 10, 2008 5:04 pm    Post subject: Reply with quote

I still can't compile without pam :(
Back to top
View user's profile Send private message
Need4Speed
Guru
Guru


Joined: 06 Jun 2004
Posts: 497

PostPosted: Sat Oct 11, 2008 4:45 pm    Post subject: Reply with quote

It builds fine here without pam:

Code:
gentoo ~ # paludis -q openoffice
* app-office/openoffice         
    gentoo:                  2.4.1 3.0.0_rc4 {:0}
    installed:               3.0.0_rc4* {:0}     
    Description:             OpenOffice.org, a full office productivity suite.
    Homepage:                http://go-oo.org                                 
    Relevant USE flags:      (-binfilter) (cups) (dbus) (-debug) (-eds) (-elibc_FreeBSD) (-gnome) (gstreamer) (gtk) (java) (-kde) (-ldap) (-linguas_af) (-linguas_ar) (-linguas_as_IN) (-linguas_be_BY) (-linguas_bg) (-linguas_bn) (-linguas_br) (-linguas_bs) (-linguas_ca) (-linguas_cs) (-linguas_cy) (-linguas_da) (-linguas_de) (-linguas_dz) (-linguas_el) (linguas_en) (-linguas_en_GB) (linguas_en_US) (-linguas_en_ZA) (-linguas_eo) (-linguas_es) (-linguas_et) (-linguas_fa) (-linguas_fi) (-linguas_fr) (-linguas_ga) (-linguas_gl) (-linguas_gu_IN) (-linguas_he) (-linguas_hi_IN) (-linguas_hr) (-linguas_hu) (-linguas_it) (-linguas_ja) (-linguas_km) (-linguas_ko) (-linguas_ku) (-linguas_lt) (-linguas_lv) (-linguas_mk) (-linguas_ml_IN) (-linguas_mr_IN) (-linguas_nb) (-linguas_ne) (-linguas_nl) (-linguas_nn) (-linguas_nr) (-linguas_ns) (-linguas_or_IN) (-linguas_pa_IN) (-linguas_pl) (-linguas_pt) (-linguas_pt_BR) (-linguas_ru) (-linguas_rw) (-linguas_sh) (-linguas_sk) (-linguas_sl) (-linguas_sr) (-linguas_ss) (-linguas_st) (-linguas_sv) (-linguas_sw_TZ) (-linguas_ta_IN) (-linguas_te_IN) (-linguas_tg) (-linguas_th) (-linguas_ti_ER) (-linguas_tn) (-linguas_tr) (-linguas_ts) (-linguas_uk) (-linguas_ur_IN) (-linguas_ve) (-linguas_vi) (-linguas_xh) (-linguas_zh_CN) (-linguas_zh_TW) (-linguas_zu) (-mono) (-nsplugin) (-odk) (opengl) (-pam)
    License:                 LGPL-2
    Installed time:          Sat Oct 11 04:29:01 2008
    From repositories:       gentoo
    Installed using:         paludis-0.30.1

_________________
2.6.34-rc3 on x86_64 w/ paludis
WM: ratpoison
Term: urxvt, zsh
Browser: uzbl
Email: mutt, offlineimap
IRC: weechat
News: newsbeuter
PDF: apvlv
Back to top
View user's profile Send private message
El_Presidente_Pufferfish
Veteran
Veteran


Joined: 11 Jul 2002
Posts: 1179
Location: Seattle

PostPosted: Sun Oct 12, 2008 3:59 pm    Post subject: Reply with quote

Funny...I still get:
Code:
configure: error: install pam-devel
 *
 * ERROR: app-office/openoffice-3.0.0_rc4 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 5344:  Called die
 * The specific snippet of code:
 * ./configure --with-distro="Gentoo" --with-arch="${ARCH}" --host="${CHOST}" --with-srcdir="${DISTDIR}" --with-lang="${LINGUAS_OOO}" --with-num-cpus="${JOBS}" --without-binsuffix --with-installed-ooo-dirname="openoffice" --with-tag="${MST}" ${GTKFLAG} `use_enable mono` `use_enable kde` `use_enable !debug strip` `use_enable odk` `use_with java` --disable-access --disable-post-install-scripts --with-system-libwpd --mandir=/usr/share/man --libdir=/usr/$(get_libdir) || die "Configuration failed!";
 * The die message:
 * Configuration failed!
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sun Oct 12, 2008 6:22 pm    Post subject: Reply with quote

You could try my local ebuild which pulls in the latest Go-OO source 3.0.0.6:

ebuild: http://rafb.net/p/wUGKyP58.html
needing a modified gentoo-3.0.0.6.diff: http://rafb.net/p/FFiQiQ23.html

Still compiling it myself now, so I can't tell if it works. It should at least resolve the USE="-java" issue failing at module 'stax'.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 412
Location: GA-USA

PostPosted: Thu Oct 16, 2008 12:28 pm    Post subject: Reply with quote

I installed the full openoffice-3.0 from Portage yesterday without error, though it was still hard masked from my sync on 10/14. See:
https://forums.gentoo.org/viewtopic-t-711312-highlight-openoffice.html

Good luck. ymmv
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
Zaister
n00b
n00b


Joined: 08 Apr 2004
Posts: 20
Location: Germany

PostPosted: Thu Oct 16, 2008 12:58 pm    Post subject: Reply with quote

With USE=kde" I still get the same error

Code:

1 module(s):
        vcl 
need(s) to be rebuilt

Reason(s):

ERROR: error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.0.0/work/ooo/build/ooo300-m9/vcl/util                                         

Attention: if you build and deliver the above module(s) you may prolongue your the build issuing command "build --from vcl"                                     

rmdir /tmp/11059
make: *** [stamp/build] Error 1
 *                             
 * ERROR: app-office/openoffice-3.0.0 failed.
 * Call stack:                               
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 5412:  Called die       
 * The specific snippet of code:             
 * make || die "Build failed"               
 * The die message:
 * Build failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-3.0.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-3.0.0/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME="/opt/sun-jdk-1.6.0.07"
JAVACFLAGS="-source 1.5 -target 1.5" COMPILER=""
and of course, the output of emerge --info


This is on KDE 4 with kdelibs 4.1.2-r1 and 3.5.10-r2 installed using these useflags for OOo:

USE="cups dbus java kde* ldap nsplugin opengl pam -binfilter -debug -eds -gnome -gstreamer -gtk -mono -odk -templates"
_________________
Regards,
Stefan.
Back to top
View user's profile Send private message
figueroa
Guru
Guru


Joined: 14 Aug 2005
Posts: 412
Location: GA-USA

PostPosted: Thu Oct 16, 2008 2:35 pm    Post subject: Reply with quote

Zaister, see what happens when you run:

Code:
python-updater -i -p


If it lists packages it would rebuild, let it rebuild them by re-running without the -p.

That may solve the problem. In any case, it should do no harm.
_________________
Andy Figueroa
andy@andyfigueroa.net Working with Unix since 1983.
Back to top
View user's profile Send private message
Zaister
n00b
n00b


Joined: 08 Apr 2004
Posts: 20
Location: Germany

PostPosted: Thu Oct 16, 2008 2:43 pm    Post subject: Reply with quote

figueroa wrote:
Zaister, see what happens when you run:

Code:
python-updater -i -p


If it lists packages it would rebuild, let it rebuild them by re-running without the -p.

That may solve the problem. In any case, it should do no harm.


Thanks for the tip. However, I'm getting only "Couldn't determine any previous Python version(s)." I have only Python 2.5.2-r8 installed, and my last update was September 20 (from -r7), 2.5.1 was replaced in April long ago.
_________________
Regards,
Stefan.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Thu Oct 16, 2008 6:51 pm    Post subject: Reply with quote

VCL is the widgit set. It's being broken as it's finding the kde4 set first and it's not ported to kde4. The build would have to be patched to look for kdelibs-3.5 directly.

I couldnt' get it to build without the kde flag either, and just went with openoffice-bin
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
jonnevers
Veteran
Veteran


Joined: 02 Jan 2003
Posts: 1594
Location: Gentoo64 land

PostPosted: Sat Oct 18, 2008 10:40 pm    Post subject: Reply with quote

compilg OOooooooooo [O_o] 3.0 currently...

felt like sharing:
Code:
Making: ../../../unxlngx6.pro/slo/assclass.obj

OOo, now with even more ass(aliciousness).
Back to top
View user's profile Send private message
gsoe
Apprentice
Apprentice


Joined: 10 Dec 2006
Posts: 289
Location: Denmark

PostPosted: Sat Oct 18, 2008 11:18 pm    Post subject: Reply with quote

assclass.obj !! Ha ha, never noticed that. Compiling as well, even synced twice in two hours as I discovered that Oo3 went stable...

Wonderful feeling using Gentoo and watching it (and in general: Linux) incrementally getting better and more mature. Now I'm looking forward to KDE 3.5.10 and KDE integration in firefox. Does anybody know if we can expect a system where Oo can work with files on samba shares?

BTW, kudos to the devs and the ones testing for having a monster like Oo stable this fast!
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Sat Oct 18, 2008 11:24 pm    Post subject: Reply with quote

gsoe wrote:
assclass.obj !! Ha ha, never noticed that. Compiling as well, even synced twice in two hours as I discovered that Oo3 went stable...

Wonderful feeling using Gentoo and watching it (and in general: Linux) incrementally getting better and more mature. Now I'm looking forward to KDE 3.10 and KDE integration in firefox. Does anybody know if we can expect a system where Oo can work with files on samba shares?


Yeah, I'm sure that name was totally a coincidence...some ooo programmer is probably laughing his asslclass off that he got a source file named 'assclass' into the source :D No complaints, it's free and it's good!

And yes, I was really surprised and happy that ooo3 went stable so quickly....it's a good sign for the disto that the momentum is picking up again...that and the fact that there are so many new users showing up in the forums...all good for Gentoo.
Back to top
View user's profile Send private message
gsoe
Apprentice
Apprentice


Joined: 10 Dec 2006
Posts: 289
Location: Denmark

PostPosted: Sun Oct 19, 2008 1:00 am    Post subject: Reply with quote

This might be more like "Gentoo chat", but whatever...
platojones wrote:
Yeah, I'm sure that name was totally a coincidence...some ooo programmer is probably laughing his asslclass off that he got a source file named 'assclass' into the source
Well, some open source people seem to have a very developed sense of humor. Did you ever notice that in the Microsoft world, when you browse some kind of directions concerning what kind of smartness can be done with the system, you'd always encounter example filenames like "managementbuzzzwords.sth". Well, I remember an open source guy using example filenames like "bigboobs.jpg" in that situation...
Back to top
View user's profile Send private message
baaann
Guru
Guru


Joined: 23 Jan 2006
Posts: 548
Location: uk

PostPosted: Sun Oct 19, 2008 9:14 am    Post subject: Reply with quote

gsoe wrote:


Does anybody know if we can expect a system where Oo can work with files on samba shares?



You can, but you need the gnome USE flag set(unless its changed for 3.0 of course), see this thread

https://forums.gentoo.org/viewtopic-p-4955315-highlight-.html#4955315
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Oct 19, 2008 9:36 am    Post subject: Reply with quote

platojones wrote:

And yes, I was really surprised and happy that ooo3 went stable so quickly....it's a good sign for the disto that the momentum is picking up again...that and the fact that there are so many new users showing up in the forums...all good for Gentoo.


++

yeah, kudos to devs: suka and the others are doing a great job :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
gsoe
Apprentice
Apprentice


Joined: 10 Dec 2006
Posts: 289
Location: Denmark

PostPosted: Sun Oct 19, 2008 10:45 am    Post subject: Reply with quote

baaann wrote:
You can, but you need the gnome USE flag set(unless its changed for 3.0 of course), see this thread
Thanks, I missed that one. In the meantime my Ooo3 compile has finished, and the new version works like a charm with samba shares without the "gnome" USE flag.
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Mon Oct 20, 2008 3:13 pm    Post subject: Reply with quote

my splashscreen is corrupted. the rest works fine.
anybody with the same situation?
Back to top
View user's profile Send private message
alex.blackbit
Advocate
Advocate


Joined: 26 Jul 2005
Posts: 2397

PostPosted: Mon Oct 20, 2008 11:49 pm    Post subject: Reply with quote

here is a screenshot.
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 477
Location: USA

PostPosted: Wed Oct 22, 2008 8:43 am    Post subject: Reply with quote

I just installed OO3 on both Gentoo & Vista. I expected it to render the application faster in Gentoo since I'm using Fluxbox, but it's kinda sluggish everytime I switched between one virtual desktop to another that contained the OO3. It refreshed the page for a split second before displaying the entire application. The problem got worse when I had multiple plot in Calc. I could also see the delay while jumping from one menu to another menu.

When I ran it on Vista, the result is the opposite; it's acting normally.

It's a nice improvement in term of eye-candy, but the performance is lacking, especially while running the program in Gentoo.
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
P0w3r3d
n00b
n00b


Joined: 13 Jan 2005
Posts: 54

PostPosted: Wed Oct 22, 2008 11:39 am    Post subject: Reply with quote

Here I had problems with the USE template, but all works without it
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 6929
Location: Austria

PostPosted: Sat Oct 25, 2008 2:37 pm    Post subject: Reply with quote

I simply can't get openoffice-3.0.0 to compile.

MAKEOPTS="-j1" emerge -va openoffice
USE="cups dbus java* opengl"


Portage 2.2_rc12 (default/linux/amd64/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r0, 2.6.27-ext4-r1 x86_64)

Code:
Making: ../unxlngx6.pro/misc/sblx.flt                                                             
-----------------------------                                                                     
SHL1FILTERFILE not set!                                                                           
-----------------------------                                                                     
dummy file to keep the dependencies for later use.                                                 
------------------------------                                                                     
Making: ../unxlngx6.pro/lib/libsblx.so                                                             
g++ -Wl,-z,combreloc -Wl,-z,defs -Wl,--as-needed -Wl,-Bsymbolic-functions -Wl,--dynamic-list-cpp-new -Wl,--dynamic-list-cpp-typeinfo -Wl,-rpath,'$ORIGIN:$ORIGIN/../ure-link/lib' -shared -L../unxlngx6.pro/lib -L../lib -L/var/tmp/portage/app-office/openoffice-3.0.0/work/ooo/build/ooo300-m9/solenv/unxlngx6/lib -L/var/tmp/portage/app-office/openoffice-3.0.0/work/ooo/build/ooo300-m9/solver/300/unxlngx6.pro/lib -L/var/tmp/portage/app-office/openoffice-3.0.0/work/ooo/build/ooo300-m9/solenv/unxlngx6/lib -L/opt/sun-jdk-1.6.0.07/lib64 -L/opt/sun-jdk-1.6.0.07/jre/lib/amd64 -L/opt/sun-jdk-1.6.0.07/jre/lib/amd64/server -L/opt/sun-jdk-1.6.0.07/jre/lib/amd64/native_threads -L/usr/lib64 ../unxlngx6.pro/slo/sb_dflt_version.o -o ../unxlngx6.pro/lib/libsblx.so ../unxlngx6.pro/slo/basmgr.o ../unxlngx6.pro/slo/basicmanagerrepository.o ../unxlngx6.pro/slo/sb.o ../unxlngx6.pro/slo/sbxmod.o ../unxlngx6.pro/slo/image.o ../unxlngx6.pro/slo/sbintern.o ../unxlngx6.pro/slo/sbunoobj.o ../unxlngx6.pro/slo/propacc.o ../unxlngx6.pro/slo/disas.o ../unxlngx6.pro/slo/errobject.o ../unxlngx6.pro/slo/eventatt.o ../unxlngx6.pro/slo/sbcomp.o ../unxlngx6.pro/slo/dim.o ../unxlngx6.pro/slo/exprtree.o ../unxlngx6.pro/slo/exprnode.o ../unxlngx6.pro/slo/exprgen.o ../unxlngx6.pro/slo/codegen.o ../unxlngx6.pro/slo/io.o ../unxlngx6.pro/slo/loops.o ../unxlngx6.pro/slo/parser.o ../unxlngx6.pro/slo/scanner.o ../unxlngx6.pro/slo/token.o ../unxlngx6.pro/slo/symtbl.o ../unxlngx6.pro/slo/buffer.o ../unxlngx6.pro/slo/namecont.o ../unxlngx6.pro/slo/scriptcont.o ../unxlngx6.pro/slo/dlgcont.o ../unxlngx6.pro/slo/sbmodule.o ../unxlngx6.pro/slo/sbservices.o ../unxlngx6.pro/slo/modsizeexceeded.o ../unxlngx6.pro/slo/basrdll.o ../unxlngx6.pro/slo/inputbox.o ../unxlngx6.pro/slo/runtime.o ../unxlngx6.pro/slo/step0.o ../unxlngx6.pro/slo/step1.o ../unxlngx6.pro/slo/step2.o ../unxlngx6.pro/slo/iosys.o ../unxlngx6.pro/slo/stdobj.o ../unxlngx6.pro/slo/stdobj1.o ../unxlngx6.pro/slo/methods.o ../unxlngx6.pro/slo/methods1.o ../unxlngx6.pro/slo/props.o ../unxlngx6.pro/slo/ddectrl.o ../unxlngx6.pro/slo/dllmgr.o ../unxlngx6.pro/slo/sbxbase.o ../unxlngx6.pro/slo/sbxres.o ../unxlngx6.pro/slo/sbxvalue.o ../unxlngx6.pro/slo/sbxvals.o ../unxlngx6.pro/slo/sbxvar.o ../unxlngx6.pro/slo/sbxarray.o ../unxlngx6.pro/slo/sbxobj.o ../unxlngx6.pro/slo/sbxcoll.o ../unxlngx6.pro/slo/sbxexec.o ../unxlngx6.pro/slo/sbxint.o ../unxlngx6.pro/slo/sbxlng.o ../unxlngx6.pro/slo/sbxsng.o ../unxlngx6.pro/slo/sbxmstrm.o ../unxlngx6.pro/slo/sbxdbl.o ../unxlngx6.pro/slo/sbxcurr.o ../unxlngx6.pro/slo/sbxdate.o ../unxlngx6.pro/slo/sbxstr.o ../unxlngx6.pro/slo/sbxbool.o ../unxlngx6.pro/slo/sbxchar.o ../unxlngx6.pro/slo/sbxbyte.o ../unxlngx6.pro/slo/sbxuint.o ../unxlngx6.pro/slo/sbxulng.o ../unxlngx6.pro/slo/sbxform.o ../unxlngx6.pro/slo/sbxscan.o ../unxlngx6.pro/slo/sbxdec.o -luno_cppu -luno_cppuhelpergcc3 -ltllx -lsvtlx -lsvllx -lvcllx -lvos3gcc3 -luno_sal -lcomphelp4gcc3 -lutllx -lsotlx -lvos3gcc3 -lxcrlx -ldl -lpthread -lm
../unxlngx6.pro/slo/image.o: In function `SbiImage::Load(SvStream&, unsigned int&)':               
image.cxx:(.text+0x968): undefined reference to `PCodeBuffConvertor<unsigned short, unsigned int>::convert()'                                                                                         
image.cxx:(.text+0x970): undefined reference to `PCodeBuffConvertor<unsigned short, unsigned int>::convert()'                                                                                         
../unxlngx6.pro/slo/image.o: In function `SbiImage::Save(SvStream&, unsigned int)':               
image.cxx:(.text+0x107d): undefined reference to `PCodeBuffConvertor<unsigned int, unsigned short>::convert()'                                                                                       
image.cxx:(.text+0x1085): undefined reference to `PCodeBuffConvertor<unsigned int, unsigned short>::convert()'                                                                                       
collect2: ld returned 1 exit status                                                               
dmake:  Error code 1, while making '../unxlngx6.pro/lib/libsblx.so'                               

ERROR: Error 65280 occurred while making /var/tmp/portage/app-office/openoffice-3.0.0/work/ooo/build/ooo300-m9/basic/util                                                                             
rmdir /tmp/11135                                                                                   
make: *** [stamp/build] Error 1                                                                   
 *                                                                                                 
 * ERROR: app-office/openoffice-3.0.0 failed.                                                     
 * Call stack:                                                                                     
 * ebuild.sh, line   49:  Called src_compile                                                       
 * environment, line 5517:  Called die                                                             
 * The specific snippet of code:                                                                   
 * make || die "Build failed"                                                                     
 * The die message:                                                                               
 * Build failed

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
BrummieJim
l33t
l33t


Joined: 22 Jul 2005
Posts: 642

PostPosted: Thu Nov 13, 2008 6:16 pm    Post subject: Reply with quote

Has anyone else noticed that some of the higher maths functions don't work in Calc, i.e. POWER, MOD? SIN and COS work.
Edit
Ahh, realised, they seem to have changed from ; to , to break arguments. Good thing really.
/Edit
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Wed Nov 26, 2008 3:25 pm    Post subject: Reply with quote

I updated to OOo 3.0.0 (source build) today. It runs on par with any *.0.0 release as far as I can tell. I've seen it crash some and I can point out 5 trivial bugs already. But overall it's very decent and worth your compiling time. I was expecting a lot worse. I only expect an extremely stable product when we reach 3.1.1 though. If thats what you want then you should stick to the 2.4 release.
Back to top
View user's profile Send private message
emc
Guru
Guru


Joined: 02 Jul 2004
Posts: 543
Location: Cracow, Poland

PostPosted: Wed Dec 03, 2008 12:14 am    Post subject: Reply with quote

Anybody can take a look, I have problem with hsqldb during Ooo3 installation:

https://forums.gentoo.org/viewtopic-t-716394-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum