Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gnome] Problème de compilation
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Sat May 03, 2008 11:31 am    Post subject: [Gnome] Problème de compilation Reply with quote

Bonjour tout le monde, voilà mon problème


Comme décrit dans le titre, j'ai un problème avec gnome qui refuse de s'installer,
Je me suis renseigné sur le HOWTO http://fr.gentoo-wiki.com/HOWTO_Le_bureau_Gnome#Composants_de_base_de_Gnome
j'ai vu qu'il fallait que je mettre "hal gnome dbus -kde -arts -qu3 -qut4 gtk" dans mes USE et cela est fait, mais j'ai une erreur quand j'écris
"emerge -DuN gnome" idem pour
"rc-update add dbus default
/etc/init.d/dbus start
rc-update add hald default
/etc/init.d/hald start"
Aucun ne marche, et je n'ai pas installé le serveur X11, comment l'installer?(non précisé dans le HOWTO)
Cela provient peut-être de là ces erreurs, à voir


Merci pour vos réponses
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sat May 03, 2008 12:03 pm    Post subject: Reply with quote

Si tu ne fournis pas les erreurs, on ne peut pas t'aider.

Pour installer Xorg : emerge xorg-x11.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Sat May 03, 2008 2:19 pm    Post subject: Reply with quote

Salut,
Oui là il nous faut la boule de cristal ! :lol:
Logiquement xorg-x11 étant une dépendance de gnome la commade emerge gnome a du te l'installer
En revanche ton xorg ne va pas se configurer tout seul et il te faudra suivre les docs officielles relative à ton matos :
http://www.gentoo.org/doc/fr/?catid=desktop
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Sat May 03, 2008 3:10 pm    Post subject: Reply with quote

Oui, désolé,

Là je regarde le lien que m'a donné "gglaboussole", je vais essayer de tout faire comme décrit dans les howto, et si j'ai un problème je reviens pour vous le faire savoir, merci d'être là pour les nouveaux ;)
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Sat May 03, 2008 3:52 pm    Post subject: Reply with quote

tiens, du nouveau

Quand j'ai voulu installé gnome au tout départ, j'avais "udev" qui m'en empêchait, alors je l'ai supprimé ... maintenant je me rend compte que j'aurais pas dû faire ça ... comment me rattraper ? ^^
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Sat May 03, 2008 4:23 pm    Post subject: Reply with quote

non t'aurais du éviter hum...
Ben essaie emerge --oneshot udev
et fait un petit revdep-rebuild -pv pour voir si t'as pas des trucs cassés...ça mange pas de pain (cette commande appartient au paquet gentoolkit à installer absolument si t'as pas....ça fait parti du kit de survie du gentooiste)
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Sat May 03, 2008 4:54 pm    Post subject: Reply with quote

bon, ça ne marche pas, j'ai essayé ensuite avec le CD d'installation, j'ai pas réussi à faire marcher ça donc ... réinstallation complète ... :/


Ca va me prendre encore un moment tiens ... :/ mais bon, jamais 2 sans 3 comme on dit ^^ alors bon, c'est parti pour la troisième installation (je ne me décourage jamais ;))
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Sat May 03, 2008 6:45 pm    Post subject: Reply with quote

eh ben je salut ton courage... tu l'auras mérité comme ça ta gentoo :wink:
Normalement t'as du avoir un méchant warning avant de faire emerge -C udev....
Je pense que ça doit être quand même possible d'éviter la reinstall avec un chroot...mais bon la reinstallation c'est formateur :wink:
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Sat May 03, 2008 8:38 pm    Post subject: Reply with quote

De toutes façons je veux apprendre, alors je serai même partant pour une troisième install s'il le fallait :)

Maintenant je vais m'informer le plus possible pour avoir un serveur gnome fonctionnel, et ensuite à partir de ça j'aurai la base. Je pourrais commencer réellement à apprendre :) Et donc tester, retester, détester (euh ... non) tout un tas de logiciels, d'environnements graphiques peut-être ... :)

*en pleine soif de connaissances*
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Sun May 04, 2008 9:43 am    Post subject: Reply with quote

nouveau

: sys-fs/udev-115-r1 is blocking sys-fs/device-mapper-1.02.24-r1

quand je tente un "emerge gnome"

J'ai les uses qu'il faut et j'ai installé le serveur X
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun May 04, 2008 10:14 am    Post subject: Reply with quote

Dans l'ordre, désinstalle device-mapper, met à jour udev et réinstalle device-mapper si tu en as besoin.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Mon May 05, 2008 10:49 am    Post subject: Reply with quote

en tapant "emerge --unmerge device-mapper" je suis tombé sur une erreur, il ne trouve pas ce programme, une solution?
Back to top
View user's profile Send private message
MasterPrenium
Tux's lil' helper
Tux's lil' helper


Joined: 07 Dec 2006
Posts: 89

PostPosted: Mon May 05, 2008 10:55 am    Post subject: Reply with quote

çà doit etre ta version de udev qui le gène ...

Code:
emerge --nodep udev && emerge --sync && emerge udev && emerge device-mapper


pour info :
Code:
 * RDEPEND
sys-fs/device-mapper-1.02.24-r1: !<sys-fs/udev-115-r1
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Tue May 06, 2008 8:53 pm    Post subject: Reply with quote

Ça à l'air de marcher ... merci ! :)

Là je compile, souhaitez-moi bonne chance >< ^^

Si je ne répond pas c'est que ça marche ... ou pour cause de suicide.
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Tue May 06, 2008 11:31 pm    Post subject: Reply with quote

et voilà une erreur qui est survenue à 2h20 de compilation acharnée :

Quote:
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %list.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %admon.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %linespecific.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %synop.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %para.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %informal.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %formal.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %compound.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %genobj.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %descobj.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:119: parser warning : PEReference: %ndxterm.class; not found
%local.divcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %list.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %admon.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %linespecific.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %synop.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %para.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %informal.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %formal.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %compound.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %genobj.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %descobj.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:129: parser warning : PEReference: %ndxterm.class; not found
%local.refcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:139: parser warning : PEReference: %linespecific.class; not found
%local.indexdivcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:139: parser warning : PEReference: %synop.class; not found
%local.indexdivcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:139: parser warning : PEReference: %para.class; not found
%local.indexdivcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:139: parser warning : PEReference: %informal.class; not found
%local.indexdivcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:139: parser warning : PEReference: %link.char.class; not found
%local.indexdivcomponent.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:145: parser warning : PEReference: %tech.char.class; not found
%local.refname.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %xref.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %gen.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %link.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %tech.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %base.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %docinfo.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %other.char.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:160: parser warning : PEReference: %ndxterm.class; not found
%local.refinline.char.mix;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:208: parser warning : PEReference: %role.attrib; not found
<!ENTITY % set.role.attrib "%role.attrib;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:214: parser warning : PEReference: %ubiq.inclusion; not found
%ubiq.inclusion;>
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:224: parser warning : PEReference: %status.attrib; not found
%status.attrib;
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:225: parser warning : PEReference: %common.attrib; not found
%common.attrib;
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:235: parser warning : PEReference: %role.attrib; not found
<!ENTITY % setinfo.role.attrib "%role.attrib;">
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser warning : PEReference: %info.class; not found
<!ELEMENT setinfo %ho; ((%info.class;)+)
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : ContentDecl : Name or '(' expected
<!ELEMENT setinfo %ho; ((%info.class;)+)
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : expected '>'
<!ELEMENT setinfo %ho; ((%info.class;)+)
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : Content error in the external subset
<!ELEMENT setinfo %ho; ((%info.class;)+)
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser warning : PEReference: %beginpage.exclusion; not found
%beginpage.exclusion;>
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : Content error in the external subset
%beginpage.exclusion;>
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : Content error in the external subset
<!--end of setinfo.element-->]]>
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : Content error in the external subset
<!--end of setinfo.element-->]]>
^
http://www.oasis-open.org/docbook/xml/4.2/dbhierx.mod:239: parser error : Content error in the external subset
<!--end of setinfo.element-->]]>
^
unable to parse uk/gnome-keyring-manager.xml
make[2]: *** [gnome-keyring-manager-uk.omf] Error 1
make[2]: *** Waiting for unfinished jobs....
http://www.oasis-open.org/docbook/xml/4.2/dbpoolx.mod:687: parser warning : PEReference: %notation.class; not found
%local.graphics.attrib;"
^
Entity: line 1: parser error : NmToken expected in ATTLIST enumeration
%graphics.attrib;
^
Entity: line 4:
format () #IMPLIED
^
Entity: line 1: parser error : Content error in the external subset
%graphics.attrib;
^
Entity: line 4:
format () #IMPLIED
^
Entity: line 1: parser error : Content error in the external subset
%graphics.attrib;
^
Entity: line 4:
format () #IMPLIED
^
Entity: line 1: parser error : Content error in the external subset
%graphics.attrib;
^
Entity: line 4:
format () #IMPLIED
^
Entity: line 1: parser error : Content error in the external subset
%graphics.attrib;
^
Entity: line 4:
format () #IMPLIED
^
unable to parse vi/gnome-keyring-manager.xml
make[2]: *** [gnome-keyring-manager-vi.omf] Error 1
make[2]: Leaving directory `/var/tmp/portage/gnome-extra/gnome-keyring-manager-2.20.0/work/gnome-keyring-manager-2.20.0/docs'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gnome-extra/gnome-keyring-manager-2.20.0/work/gnome-keyring-manager-2.20.0'
make: *** [all] Error 2
*
* ERROR: gnome-extra/gnome-keyring-manager-2.20.0 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 611: Called gnome2_src_compile
* environment, line 541: Called die
* The specific snippet of code:
* emake || die "compile failure"
* The die message:
* compile failure
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/gnome-extra/gnome-keyring-manager-2.20.0/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/gnome-extra/gnome-keyring-manager-2.20.0/temp/environment'.
*
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Wed May 07, 2008 8:54 am    Post subject: Reply with quote

Aucun d'entre vous n'a de solutions pour mon problème ? :(
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed May 07, 2008 9:09 am    Post subject: Reply with quote

Pourrais tu nous donner ton emerge --info ?
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Wed May 07, 2008 1:28 pm    Post subject: Reply with quote

Comment fait-on pour mettre ça dans un fichier pour ensuite le mettre sur le forum ? (je sais que dans 2 jours ce sera une évidence pour moi aussi ... mais pour l'instant je ne connais pas le "truc" :))
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Wed May 07, 2008 1:34 pm    Post subject: Reply with quote

kane13 wrote:
Comment fait-on pour mettre ça dans un fichier

Simplement : tacommande > tonfichier.txt
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Wed May 07, 2008 1:58 pm    Post subject: Reply with quote

il y a pas à dire, c'est vraiment bien fait quand même ^^

Quote:
Portage 2.1.4.4 (default-linux/x86/2007.0, gcc-4.1.1, glibc-2.5-r0, 2.6.24-gentoo-r7 i686)
=================================================================
System uname: 2.6.24-gentoo-r7 i686 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Timestamp of tree: Tue, 06 May 2008 20:20:01 +0000
app-shells/bash: 3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python: 2.4.4-r9
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9
sys-apps/sandbox: 1.2.18.1-r2
sys-devel/autoconf: 2.13, 2.61
sys-devel/automake: 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.17-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.ovh.net/gentoo-distfiles/ "
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acl acpi alsa amr audacious audiofile avahi berkdb cdr cdrom cli cracklib crypt cups dbus dhcp divx dri dvb dvbplayer dvd dvdr ffmpeg fortran gdbm gdm gif gnome gpm gstreamer gstreamer08 gtk hal iconv ipv6 isdnlog java jpeg midi mjpeg mp3 mp4 mpeg2 mplayer msn msnextras mudflap ncurses nls nptl nptlonly nvidia ogg opengl openmp oss pam pcre perl png pppd python quicktime readline reflection reiserfs samba session spl sse sse2 ssl stream svg svga tcpd unicode wma x86 xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboad mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Vivement que ça MARCHE ^^
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Wed May 07, 2008 4:29 pm    Post subject: Reply with quote

euh ... quelqu'un ? :(
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed May 07, 2008 4:38 pm    Post subject: Reply with quote

Mets -doc dans tes USE flags. Le USE doc fait que tous les paquets sans exception vont voir leur doc créer est installée. C'est peut-être pas ce que tu veux. Perso quand je veux la doc pour un paquet je passe par /etc/portage/pakage.use mais sinon le -doc en global est de rigueur.

Et vu que ton soucis de compil a l'air d'être pour la doc... :wink:
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Wed May 07, 2008 5:03 pm    Post subject: Reply with quote

Mais dans ce cas il ne faut pas que je recompile quelque chose pour que le nouvel élément de use (-doc) soit pris en compte ? Juste je rajoute ça et tout marche pour le mieux dans le meilleur des mondes ?
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Wed May 07, 2008 5:08 pm    Post subject: Reply with quote

Si tu veux que tes packages déjà installé soit soumis au USE flage -doc nouvellement inséré oui tu peux lancer un emerge -DuN world rapido.
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
kane13
n00b
n00b


Joined: 01 May 2008
Posts: 19

PostPosted: Wed May 07, 2008 7:16 pm    Post subject: Reply with quote

Alors, après le "emerge -DuN world" voici l'erreur que j'ai (parce qu'en fait, j'ai des erreurs à chaque fois que je tape une commande :) )

Quote:
Calculating world dependencies ... done!
[ebuild R ] sys-libs/zlib-1.2.3-r1 USE="(-build%)"
[ebuild U ] sys-devel/gnuconfig-20070724 [20060702]
[ebuild U ] dev-libs/expat-2.0.1 [1.95.8]
[ebuild U ] sys-devel/gcc-config-1.4.0-r4 [1.3.14]
[ebuild U ] app-misc/pax-utils-0.1.17 [0.1.15]
[ebuild U ] dev-libs/gmp-4.2.2 [4.2.1]
[ebuild N ] dev-util/unifdef-1.20
[ebuild U ] sys-libs/timezone-data-2008a [2007c]
[ebuild U ] app-arch/cpio-2.9-r1 [2.6-r5]
[ebuild R ] sys-devel/patch-2.5.9 USE="(-build%)"
[ebuild U ] app-arch/bzip2-1.0.5 [1.0.3-r6]
[ebuild U ] sys-apps/hdparm-8.6 [6.6]
[ebuild U ] sys-kernel/linux-headers-2.6.23-r3 [2.6.17-r2]
[ebuild U ] dev-libs/mpfr-2.3.1 [2.2.0_p16]
[ebuild U ] sys-apps/sysvinit-2.86-r10 [2.86-r8] USE="(-ibm)"
[ebuild U ] net-misc/iputils-20071127 [20060512]
[ebuild U ] sys-libs/cracklib-2.8.12 [2.8.9-r1]
[ebuild U ] sys-apps/file-4.23 [4.20-r1]
[ebuild R ] media-libs/mesa-6.5.2-r1 VIDEO_CARDS="-i810* -mach64* -mga* -r128* -radeon* -s3virge* -savage* -sis* -tdfx* -trident* -via*"
[ebuild U ] sys-apps/man-pages-2.78 [2.42] LINGUAS="-cs% -da% -de% -es% -fr% -it% -ja% -nl% -pl% -ro% -ru% -zh_CN%"
[ebuild U ] sys-devel/binutils-config-1.9-r4 [1.9-r3]
[ebuild U ] sys-devel/gettext-0.17 [0.16.1] USE="acl%* openmp%*"
[ebuild U ] sys-devel/binutils-2.18-r1 [2.16.1-r3]
[ebuild U ] sys-apps/sed-4.1.5-r1 [4.1.5]
[ebuild U ] sys-devel/m4-1.4.11 [1.4.7] USE="-examples%"
[ebuild U ] sys-apps/findutils-4.3.13 [4.3.2-r1]
[ebuild U ] sys-devel/flex-2.5.33-r3 [2.5.33-r1]
[ebuild U ] sys-apps/diffutils-2.8.7-r2 [2.8.7-r1]
[ebuild U ] sys-apps/grep-2.5.1a-r1 [2.5.1-r8] USE="pcre%*"
[ebuild U ] app-arch/gzip-1.3.12-r1 [1.3.5-r10]
[ebuild U ] sys-apps/net-tools-1.60-r13 [1.60-r12]
[ebuild U ] sys-apps/kbd-1.13-r1 [1.12-r8]
[ebuild U ] sys-apps/gawk-3.1.5-r5 [3.1.5-r2]
[ebuild U ] app-arch/tar-1.19-r1 [1.16-r2]
[ebuild NS ] sys-libs/db-4.5.20_p2 USE="java -bootstrap -doc -nocxx -tcl -test"
[ebuild R ] sys-libs/db-4.3.29-r2 USE="java*"
[ebuild U ] sys-devel/bison-2.3 [2.2]
[ebuild U ] dev-lang/perl-5.8.8-r4 [5.8.8-r2]
[ebuild U ] dev-libs/openssl-0.9.8g [0.9.8d] USE="sse2* -gmp% -kerberos%"
[ebuild U ] net-misc/wget-1.11.1 [1.10.2]
[ebuild U ] sys-libs/ncurses-5.6-r2 [5.5-r3] USE="-profile%"
[ebuild U ] sys-apps/texinfo-4.11-r1 [4.8-r5]
[ebuild U ] app-shells/bash-3.2_p33 [3.2_p17-r1]
[ebuild U ] sys-libs/gpm-1.20.1-r6 [1.20.1-r5]
[ebuild U ] app-editors/nano-2.1.1 [2.0.2]
[ebuild U ] sys-apps/less-418 [394]
[ebuild U ] sys-process/procps-3.2.7 [3.2.6]
[ebuild U ] sys-devel/autoconf-2.61-r1 [2.61]
[ebuild U ] sys-libs/readline-5.2_p12-r1 [5.1_p4]
[ebuild U ] app-admin/perl-cleaner-1.05 [1.04.3]
[ebuild U ] sys-apps/which-2.19 [2.16]
[ebuild N ] virtual/pager-0
[ebuild U ] sys-devel/automake-1.10.1 [1.10]
[ebuild N ] sys-devel/bc-1.06-r6 USE="readline -static"
[ebuild U ] sys-devel/libtool-1.5.26 [1.5.22] USE="-vanilla%"
[ebuild U ] sys-libs/com_err-1.40.8 [1.39]
[ebuild U ] sys-libs/pam-0.99.9.0 [0.78-r5] USE="cracklib%* nls%* -audit% -test% -vim-syntax%"
[ebuild R ] x11-base/xorg-server-1.3.0.0-r5 INPUT_DEVICES="-evdev* -keyboard*" VIDEO_CARDS="nvidia* -apm* -ark* -chips* -cirrus* -cyrix* -dummy* -fbdev* -glint* -i128* -i740* -i810* -imstt* -mach64* -mga* -neomagic* -nsc* -nv* -r128* -radeon* -rendition* -s3* -s3virge* -savage* -siliconmotion* -sis* -sisusb* -tdfx* -tga* -trident* -tseng* -v4l* -vesa* -vga* -via* -vmware* -voodoo*"
[ebuild U ] sys-apps/attr-2.4.39 [2.4.32]
[ebuild R ] sys-apps/groff-1.19.2-r1 USE="X*"
[ebuild U ] sys-libs/ss-1.40.8 [1.39]
[ebuild U ] sys-process/psmisc-22.6 [22.2] USE="X*"
[ebuild U ] sys-boot/grub-0.97-r5 [0.97-r4] USE="ncurses%*"
[ebuild U ] sys-apps/acl-2.2.45 [2.2.39-r1]
[ebuild U ] sys-fs/e2fsprogs-1.40.8 [1.39]
[ebuild U ] sys-apps/shadow-4.0.18.2 [4.0.18.1]
[ebuild U ] sys-apps/man-1.6f-r1 [1.6d]
[ebuild U ] sys-apps/busybox-1.8.2 [1.2.2.1] USE="pam%* (-selinux)"
[ebuild U ] net-misc/rsync-2.6.9-r6 [2.6.9-r1]
[ebuild U ] sys-apps/util-linux-2.13.1.1 [2.12r-r5] USE="unicode%* -loop-aes% -old-linux% -slang%"
[ebuild U ] net-misc/openssh-4.7_p1-r6 [4.5_p1-r1] USE="X*"
[ebuild U ] sys-apps/coreutils-6.10-r2 [6.4] USE="-vanilla% -xattr%"
[ebuild U ] app-misc/ca-certificates-20070303-r1 [20061027.2]
[ebuild U ] sys-apps/debianutils-2.28.2 [2.17.4]
[ebuild U ] sys-devel/gcc-4.1.2 [4.1.1-r3] USE="gtk* mudflap* -d% -libffi%"
[ebuild U ] sys-libs/glibc-2.6.1 [2.5] USE="-debug% -gd% -vanilla%"
[ebuild U ] sys-apps/module-init-tools-3.4 [3.2.2-r2] USE="-old-linux%"
[ebuild U ] sys-apps/baselayout-1.12.11.1 [1.12.9]
[blocks B ] sys-apps/mktemp (is blocking sys-apps/coreutils-6.10-r2)
[blocks B ] >=sys-apps/coreutils-6.10 (is blocking sys-apps/mktemp-1.5)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Je vais peut-être tenté malgré ça le "emerge gnome" mais bon ... j'ai un doute, je préférerai régler cet incident avant.
Merci de votre réponse (PS: c'était une erreur que j'ai eu une fois en tentant de faire "emerge gnome" il me semble ... enfin bon, je vous laisse faire)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum