Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] vmware workstation 6.5 text garbled/pango errors
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
alienvenom
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jan 2005
Posts: 123
Location: San Francisco, CA

PostPosted: Thu May 08, 2008 7:33 am    Post subject: [SOLVED] vmware workstation 6.5 text garbled/pango errors Reply with quote

After merging vmware-workstation-6.5.0. from the vmware overlay. I configured it by using the config script, started the vmware service except when I launch vmware I get the following:

Code:
Gtk: GModule initialization check failed: Gtk+ version too old (micro mismatch)
Using log file /tmp/vmware-brian/ui-7169.log
Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Fontconfig warning: no <cachedir> elements found. Check configuration.
Fontconfig warning: adding <cachedir>/var/cache/fontconfig</cachedir>
Fontconfig warning: adding <cachedir>~/.fontconfig</cachedir>
Pango: No builtin or dynamically
loaded modules were found. Pango will not work correctly.
This probably means there was an error in the creation of:
  '/etc/pango/pango.modules'
You should create this file by running pango-querymodules.
Pango: pango_shape called with bad font, expect ugly output
Pango: pango_font_get_glyph_extents called with bad font, expect ugly output
Pango: _pango_cairo_font_install called with bad font, expect ugly output
Pango: pango_font_get_metrics called with bad font, expect ugly output


In addition, the window text is extremely garbled

http://dogtoe.com/files/linux/vmware-workstation-6.5/vmware-workstation-6.5-text-garbled.png

Also, it wont even work without specifying: VMWARE_USE_SHIPPED_GTK=force


Last edited by alienvenom on Thu May 08, 2008 8:00 am; edited 2 times in total
Back to top
View user's profile Send private message
alienvenom
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jan 2005
Posts: 123
Location: San Francisco, CA

PostPosted: Thu May 08, 2008 7:59 am    Post subject: Reply with quote

Fixed it, by doing the following:

1. Added the following to /etc/portage/package.use:
Code:
x11-libs/pango ~x86
x11-libs/gtk+ ~x86
dev-util/gtk-doc-am ~x86


2. emerge -avuDN gtk+ pango

3. Launched vmware. Note, at first it still did not work, but I got the bright idea of removing VMWARE_USE_SHIPPED_GTK=force and it worked fine.

Note: Previous versions of vmware require you to use VMWARE_USE_SHIPPED_GTK=force.
Back to top
View user's profile Send private message
alienvenom
Tux's lil' helper
Tux's lil' helper


Joined: 12 Jan 2005
Posts: 123
Location: San Francisco, CA

PostPosted: Thu May 08, 2008 8:46 am    Post subject: Reply with quote

I also had to re-emerge libsexymm again to get it to work (prevent it from segfaulting when I tried to do anything)...
Back to top
View user's profile Send private message
gauner1986
n00b
n00b


Joined: 22 Feb 2007
Posts: 17

PostPosted: Tue Jun 10, 2008 2:16 pm    Post subject: Reply with quote

Unfortunately that solution (I have tried everything suggested in this thread) doesn't help me. I have the same problem
Code:

Jun 10 16:10:47.220: vmui| Log for VMware Workstation pid=26128 version=e.x.p build=build-91182 option=BETA
Jun 10 16:10:47.230: vmui| LOCALE en_US.UTF-8 -> NULL
Jun 10 16:10:47.327: vmui| Using log file /tmp/vmware-root/ui-26128.log
Jun 10 16:10:47.329: vmui| HAL05LoadHALLibraries: dlopened libhal.so.1.
Jun 10 16:10:47.329: vmui| HAL05LoadHalLibraries: dlopened libdbus-1.so.3.
Jun 10 16:10:47.329: vmui| HAL05LoadGlibLibrary: dlopened libdbus-glib-1.so.2.
Jun 10 16:10:47.452: vmui| HAL05Init: HAL05 Initialized successfully.
Jun 10 16:10:47.579: vmui| UUID: SMBIOS UUID is reported as 'bf 3f 81 dc 39 27 8b 6d-aa 00 00 1b fc 82 09 57'.
Jun 10 16:10:47.610: vmui| HostDeviceInfo_FindHostParallelPorts: /proc/sys/dev/parport could not be explored. Unable to enumerate host parallel ports.
Jun 10 16:10:47.613: vmui| HOSTINFO: Seeing Intel CPU, numCoresPerCPU 2 numThreadsPerCore 1.
Jun 10 16:10:47.613: vmui| HOSTINFO: This machine has 1 physical CPUS, 2 total cores, and 2 logical CPUs.
Jun 10 16:10:47.755: vmui| Using system libcrypto, version 9070DF
Jun 10 16:10:47.803: vmui| Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Jun 10 16:10:47.839: vmui| Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Jun 10 16:10:47.840: vmui| Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Jun 10 16:10:47.847: vmui| Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Jun 10 16:10:47.847: vmui| Unable to load image-loading module: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: @@LIBCONF_DIR@@/lib/gtk-2.0/2.10.0/loaders/libpixbufloader-png.so: cannot open shared object file: No such file or directory
Jun 10 16:10:47.869: vmui| Foundry Init: setting up global state (0 threads)
Jun 10 16:10:47.869: vmui| LOCALE en_US.UTF-8 -> NULL
Jun 10 16:10:47.870: vmui| Foundry Init: version 4, hostType 1, hostName (null), hostPort 0, options 0x203
Jun 10 16:10:47.967: vmui| Pango: No builtin or dynamically
Jun 10 16:10:47.967: vmui| loaded modules were found. Pango will not work correctly.
Jun 10 16:10:47.967: vmui| This probably means there was an error in the creation of:
Jun 10 16:10:47.967: vmui|   '/etc/pango/pango.modules'
Jun 10 16:10:47.967: vmui| You should create this file by running pango-querymodules.
Jun 10 16:10:47.969: vmui| Pango: pango_shape called with bad font, expect ugly output
Jun 10 16:10:47.969: vmui| Pango: pango_font_get_glyph_extents called with bad font, expect ugly output
Jun 10 16:10:48.035: vmui| VmdbVmCfg_HashConfigFile: using input path in place of canonical path
Jun 10 16:10:48.035: vmui| FILE: CreateEntryDirectory creation failure on '/root/vmware/Windows XP Professional/Windows XP Professional.vmx.lck': No such file or directory
Jun 10 16:10:48.036: vmui| Cmd /host2/#_client/util/vm/cmd/##85/op/manageVM/ failed: The configuration file for this virtual machine cannot be found. It might be missing from the virtual machine directory, or the path specified to access this virtual machine might be incorrect.
Jun 10 16:10:48.036: vmui|
Jun 10 16:10:48.036: vmui| Configuration file: /root/vmware/Windows XP Professional/Windows XP Professional.vmx
Jun 10 16:10:48.036: vmui| VMHSCmd Command error: The configuration file for this virtual machine cannot be found. It might be missing from the virtual machine directory, or the path specified to access this virtual machine might be incorrect.
Jun 10 16:10:48.036: vmui|
Jun 10 16:10:48.036: vmui| Configuration file: /root/vmware/Windows XP Professional/Windows XP Professional.vmx
Jun 10 16:10:48.036: vmui| VmdbVmCfg_HashConfigFile: using input path in place of canonical path
Jun 10 16:10:48.036: vmui| FILE: CreateEntryDirectory creation failure on '/home/gauner/vmware/Windows XP Professional/Windows XP Professional.vmx.lck': No such file or directory
Jun 10 16:10:48.037: vmui| Cmd /host2/#_client/util/vm/cmd/##86/op/manageVM/ failed: The configuration file for this virtual machine cannot be found. It might be missing from the virtual machine directory, or the path specified to access this virtual machine might be incorrect.
Jun 10 16:10:48.037: vmui|
Jun 10 16:10:48.037: vmui| Configuration file: /home/gauner/vmware/Windows XP Professional/Windows XP Professional.vmx
Jun 10 16:10:48.037: vmui| VMHSCmd Command error: The configuration file for this virtual machine cannot be found. It might be missing from the virtual machine directory, or the path specified to access this virtual machine might be incorrect.
Jun 10 16:10:48.037: vmui|
Jun 10 16:10:48.037: vmui| Configuration file: /home/gauner/vmware/Windows XP Professional/Windows XP Professional.vmx
Jun 10 16:10:48.137: vmui| Pango: _pango_cairo_font_install called with bad font, expect ugly output
Jun 10 16:10:48.137: vmui| Pango: pango_font_get_metrics called with bad font, expect ugly output


This is my ui-logfile. The output is garbled like in the picture alienvenom posted.

How can i switch off this shipped GTK thing? I don't specify this variable anywhere, therefore i think it's unset. But just to make sure it is...
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Sun Jun 15, 2008 4:44 pm    Post subject: Reply with quote

i solved your problem with
Code:
emerge -e world

after having vmware installed and configured.
i know it is not a quick step...but there is probably a lib or more that should be recompiled.
i get vmware 6.5 functioning doing that.

don't think it is performing...
the debug mode ever active make it extremely slow...i tried to use it but i uninstalled it very soon.


now i'm trying to make vmware 6.0 functioning with vmtools 6.5 but i don't know how to do this.
if you read the documentation of vmware 6.5 it is written that:
Quote:
Support for Direct3D Graphics
To take advantage of the 3‐D capabilities of Workstation, the virtual machine must be
running the version of VMware Tools included with Workstation 6.5 or higher. For
example, you do not need to upgrade a Workstation 6.0 virtual machine to Workstation
6.5, but you do need to upgrade the VMware Tools running inside it. If you move the
virtual machine and want to use the 3‐D capabilities, be sure you have the correct
version of VMware Tools installed.

the good question is: how to do this? :D
Back to top
View user's profile Send private message
gauner1986
n00b
n00b


Joined: 22 Feb 2007
Posts: 17

PostPosted: Tue Jun 17, 2008 1:32 pm    Post subject: Reply with quote

I'm right now emerging world.. (After spending hours on fixing circular dependencies *grrr*).

You can circumvent the debug-mode somehow, even in the 6.5 beta. It's done just by moving the vmware-debug binary somewhere and linking the non-debug library to vmware-debug.
Back to top
View user's profile Send private message
ckx3009
Guru
Guru


Joined: 08 Apr 2008
Posts: 362
Location: Milano, Italy

PostPosted: Wed Jun 18, 2008 9:49 am    Post subject: Reply with quote

uhm i'm going to try your solution..
may be that two heads are better than one and that both me and you will have a good vmware 6.5 XD
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum