Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge world - depgraph creation failed
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Fri May 09, 2008 1:16 am    Post subject: emerge world - depgraph creation failed Reply with quote

Code:
Collective borg # emerge -avuDN world

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

x11-libs/libcompizconfig:0

  ('ebuild', '/', 'x11-libs/libcompizconfig-0.7.4', 'merge') pulled in by
    ('ebuild', '/', 'dev-python/compizconfig-python-0.7.4', 'merge')

  ('installed', '/', 'x11-libs/libcompizconfig-9999', 'nomerge') pulled in by
    ('installed', '/', 'dev-python/compizconfig-python-9999', 'nomerge')

x11-wm/compiz:0

  ('ebuild', '/', 'x11-wm/compiz-0.7.4', 'merge') pulled in by
    ('installed', '/', 'x11-wm/emerald-0.7.4', 'nomerge')

  ('installed', '/', 'x11-wm/compiz-9999', 'nomerge') pulled in by
    ('installed', '/', 'x11-apps/fusion-icon-9999', 'nomerge')
    ('installed', '/', 'x11-plugins/compiz-fusion-plugins-wallpaper-9999', 'nomerge')
    ('installed', '/', 'x11-libs/libcompizconfig-9999', 'nomerge')
    (and 3 more)

dev-python/compizconfig-python:0

  ('ebuild', '/', 'dev-python/compizconfig-python-0.7.4', 'merge') pulled in by
    ('ebuild', '/', 'x11-apps/ccsm-0.7.4', 'merge')

  ('installed', '/', 'dev-python/compizconfig-python-9999', 'nomerge') pulled in by
    ('installed', '/', 'x11-apps/fusion-icon-9999', 'nomerge')

x11-libs/compiz-bcop:0

  ('ebuild', '/', 'x11-libs/compiz-bcop-0.7.4', 'merge') pulled in by
    ('ebuild', '/', 'x11-plugins/compiz-fusion-plugins-main-0.7.4', 'merge')

  ('installed', '/', 'x11-libs/compiz-bcop-9999', 'nomerge') pulled in by
    ('installed', '/', 'x11-plugins/compiz-fusion-plugins-wallpaper-9999', 'nomerge')
    ('installed', '/', 'x11-plugins/compiz-plugins-screensaver-9999', 'nomerge')
    ('installed', '/', 'x11-plugins/compiz-fusion-plugins-unsupported-9999', 'nomerge')


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.


When I add the offending packages to package.mask I get an error saying all ebuilds that can satisfy those packages have been masked.

If anyone has encountered this or has any advice I would be very appreciative.

Thanks. :)
Back to top
View user's profile Send private message
tarpman
Veteran
Veteran


Joined: 04 Nov 2004
Posts: 1083
Location: Victoria, BC, Canada

PostPosted: Fri May 09, 2008 4:31 am    Post subject: Reply with quote

Looks like you have some, but not all, of the ebuilds unmasked in your package.keywords file. Either unmask all of them, or none of them.
_________________
Saving the world, one kilobyte at a time.
Back to top
View user's profile Send private message
bunder
Bodhisattva
Bodhisattva


Joined: 10 Apr 2004
Posts: 5834

PostPosted: Fri May 09, 2008 4:46 am    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
overlay | patches
Neddyseagoon wrote:
The problem with leaving is that you can only do it once and it reduces your influence.
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Fri May 09, 2008 6:12 am    Post subject: Reply with quote

well i have all of this in package.keywords
Quote:
x11-plugins/compiz-plugins-screensaver **
~x11-libs/compiz-bcop-9999 **
~x11-wm/compiz-9999 **
~x11-plugins/compiz-fusion-plugins-main-9999 **
~x11-plugins/compiz-fusion-plugins-extra-9999 **
~x11-plugins/compiz-fusion-plugins-unsupported-9999 **
~x11-libs/libcompizconfig-9999 **
~x11-libs/compizconfig-backend-gconf-9999 **
~x11-apps/ccsm-9999 **
~dev-python/compizconfig-python-9999 **
~x11-apps/fusion-icon-9999 **
~x11-plugins/compiz-fusion-plugins-wallpaper-9999 **
~x11-wm/emerald-9999 **
~x11-libs/compiz-bcop-9999 **
~x11-plugins/compiz-plugins-screensaver-9999 **
~x11-themes/emerald-themes-9999 **


i can't think of anything i might be missing and if i comment them all out i get the same error
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Fri May 09, 2008 9:59 pm    Post subject: Reply with quote

facepalm.jpg

everything was -9999 but x11-wm/compiz-fusion itself, i upgraded that to -9999 and now emerge -avuDN world works fine

thanks tarpman for pointing me in the right direction :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum