Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HWSETUP fails
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 568

PostPosted: Fri May 16, 2008 6:22 am    Post subject: HWSETUP fails Reply with quote

Hi
currently Iam building a gentoo-based livecd for distcc and I also want the livecd-tools to be installed on it. HWsetup fails for some reason.

Code:


>> Source unpacked.
>>> Compiling source in /var/tmp/portage/sys-apps/hwsetup-1.2-r1/work/hwsetup-1.2 ...
i686-pc-linux-gnu-gcc -I/usr/include/kudzu -DBLACKLIST -Wall -fPIC -O2 -march=i686 -pipe -s -lz -o hwsetup hwsetup.c -lkudzu -lpci
hwsetup.c:55: warning: missing braces around initializer
hwsetup.c:55: warning: (near initialization for 'blacklist[0]')
hwsetup.c: In function 'gen_blacklist':
hwsetup.c:80: warning: passing argument 1 of 'strcpy' from incompatible pointer type
hwsetup.c: In function 'load_mod':
hwsetup.c:580: warning: passing argument 1 of 'modcmp' from incompatible pointer type
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../libkudzu.a(ddc.o): In function `ddcProbe':
(.text+0x8c6): undefined reference to `get_edid_supported'
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../libkudzu.a(ddc.o): In function `ddcProbe':
(.text+0x8d3): undefined reference to `get_edid_info'
/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/../../../libkudzu.a(ddc.o): In function `ddcProbe':
(.text+0xb11): undefined reference to `vbe_get_vbe_info'
collect2: ld returned 1 exit status
distcc[28299] ERROR: compile hwsetup.c on localhost failed
make: *** [hwsetup] Error 1
ERROR: sys-apps/hwsetup-1.2-r1 failed.
Call stack:
             ebuild.sh, line   49:  Called src_compile
            environment, line 2348:  Called die
 The specific snippet of code:
     emake LDFLAGS="${LDFLAGS}" OPT="${CFLAGS}" CC="$(tc-getCC)" || die "emake failed"
 The die message:
  emake failed
Back to top
View user's profile Send private message
richard.scott
Veteran
Veteran


Joined: 19 May 2003
Posts: 1497
Location: Oxfordshire, UK

PostPosted: Sun May 18, 2008 8:04 pm    Post subject: Reply with quote

Installing the latest sys-libs/libkudzu-1.2.57.1 resolved this same compile Issue I was having.
Back to top
View user's profile Send private message
Tolstoi
l33t
l33t


Joined: 20 May 2004
Posts: 678

PostPosted: Sat Jul 05, 2008 12:28 pm    Post subject: Reply with quote

Thanks, worked fine here too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum