Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ubigraph, missing libxmlrpc_xmlparse.so.3
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
c00l.wave
Apprentice
Apprentice


Joined: 24 Aug 2003
Posts: 245

PostPosted: Tue May 20, 2008 7:09 pm    Post subject: Ubigraph, missing libxmlrpc_xmlparse.so.3 Reply with quote

I found Ubigraph today and wanted to take a look at it. Unfortunately it consists of a client and a server which are both free but only the client is open source. First I got an error about the missing file libxmlrpc_client.so.3 and emerged dev-libs/xmlrpc-c. Now I'm getting:

Code:
bin/ubigraph_server: error while loading shared libraries: libxmlrpc_xmlparse.so.3: cannot open shared object file: No such file or directory


That does not seem to have been compiled with xmlrpc-c... Any idea how to get that module?
_________________
nohup nice -n -20 cp /dev/urandom /dev/null &
Back to top
View user's profile Send private message
c00l.wave
Apprentice
Apprentice


Joined: 24 Aug 2003
Posts: 245

PostPosted: Fri May 23, 2008 7:03 pm    Post subject: Reply with quote

Okay, now that I've got some time to check on that problem I figured out that the ebuild for dev-libs/xmlrpc-c has --enable-libxml2-backend hardcoded as a parameter to configure. By removing it, xmlrpc-c uses an expat snapshot packaged with the xmlrpc-c source archive. Maybe using it imposes a security risk, but at least it builds the previously missing module. If it's okay to use it it would be better to make this configurable by a USE flag (archivedexpat or simply xmlparse or something like that)?

Next problem to solve is an outdated stable GCC as far as I got the reason for this message right: (in some older posts people report the problem solves by upgrading to 4.2)

Code:
bin/ubigraph_server: /usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by bin/ubigraph_server)


Edit: Seems I'm stuck with that problem: According to several bug reports I won't be able to get my system running with 4.2 atm and I don't like to backup, recompile for 3 days and then restore because everything's broken and all that just for playing with one app... :?
_________________
nohup nice -n -20 cp /dev/urandom /dev/null &
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum