Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1 portage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 27, 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Strayer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2003
Posts: 75
Location: Germany

PostPosted: Fri Sep 19, 2008 9:50 am    Post subject: Reply with quote

I want my KDE 4.2 in german language... but I can only find kde-4 and kde-svn slotted packages for kde-l10n.
Is this a bug or something or are there just no ebuilds for them?
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Fri Sep 19, 2008 12:49 pm    Post subject: Reply with quote

Any way to change the size/color of the Application Launcher in kde-4.1.66? It got shorter so that now I only see 4 favorites and now is fixed at black like the taskbar. :(
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Fri Sep 19, 2008 12:52 pm    Post subject: Reply with quote

oh yes, just move your mouse pointer to the top right edge. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Fri Sep 19, 2008 1:14 pm    Post subject: Reply with quote

Thanks. :oops: To my defense no gripper was drawn like in kde-4.1. But I guess other windows operate this way also..

And that also fixed a color bug for me. For some reason the selected item was getting a gray highlight that was drawn improperly (it covered part of the item above) and the scroll bar also had drawing problems.
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
eusanpe
Tux's lil' helper
Tux's lil' helper


Joined: 06 Sep 2002
Posts: 107

PostPosted: Fri Sep 19, 2008 6:16 pm    Post subject: Reply with quote

Hello All:

Kmenuedit will not compile. Any suggestions?

Thanks,
Tony

Code:


-----------------------------------------------------------
>>> Emerging (53 of 225) kde-base/kmenuedit-9999
 * checking ebuild checksums ;-) ...                                                                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                [ ok ]

 * WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!

>>> Unpacking source...
 * Fetching disabled since 1 hours has not passed since last update.
 * Using existing repository copy at revision 862726.
 *    working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

 * Exporting parts of working copy to /var/tmp/portage/kde-base/kmenuedit-9999/work/kmenuedit
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/kde-base/kmenuedit-9999/work/kmenuedit ...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.1 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /usr/lib64/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/svn/include
-- Found KDE 4.2 library dir: /usr/kde/svn/lib64
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/svn/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Strigi 0.6.0
-- Found Strigi: /usr/lib64/libstreams.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found QImageBlitz: /usr/include/qimageblitz
-- Found ZLIB: /lib64/libz.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found LIBUSB: /lib64/libusb.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found Fontconfig: /usr/lib64/libfontconfig.so
-- Found Freetype: -lfreetype -lz
-- checking for modules 'libggadget-1.0>=0.10.3;libggadget-qt-1.0>=0.10.3'
--   package 'libggadget-1.0>=0.10.3' not found
--   package 'libggadget-qt-1.0>=0.10.3' not found
-- Could NOT find Googlegadgets  (missing:  GOOGLEGADGETS_LIBRARIES GOOGLEGADGETS_INCLUDE_DIRS)
-- Performing Test PAM_MESSAGE_CONST
-- Performing Test PAM_MESSAGE_CONST - Success
-- Found PAM: /lib64/libpam.so;/usr/lib64/libdl.so
-- Looking for getspnam
-- Looking for getspnam - found
-- Looking for crypt in crypt
-- Looking for crypt in crypt - found
-- Looking for include files HAVE_CRYPT_H
-- Looking for include files HAVE_CRYPT_H - found
-- Looking for XkbLockModifiers in X11
-- Looking for XkbLockModifiers in X11 - found
-- Looking for getpassphrase
-- Looking for getpassphrase - not found
-- Looking for vsyslog
-- Looking for vsyslog - found
-- Looking for statvfs
-- Looking for statvfs - found
-- Looking for include files HAVE_LIMITS_H
-- Looking for include files HAVE_LIMITS_H - found
-- Looking for include files HAVE_SYS_TIME_H
-- Looking for include files HAVE_SYS_TIME_H - found
-- Looking for include files HAVE_STDINT_H
-- Looking for include files HAVE_STDINT_H - found
-- Looking for include files HAVE_SYS_VFS_H
-- Looking for include files HAVE_SYS_VFS_H - found
-- Looking for include files HAVE_SYS_STATVFS_H
-- Looking for include files HAVE_SYS_STATVFS_H - found
-- Looking for include files HAVE_SYS_PARAM_H
-- Looking for include files HAVE_SYS_PARAM_H - found
-- Looking for include files HAVE_SYS_MOUNT_H
-- Looking for include files HAVE_SYS_MOUNT_H - found
-- Looking for include files HAVE_SYS_STATFS_H
-- Looking for include files HAVE_SYS_STATFS_H - found
-- Looking for statfs
-- Looking for statfs - found
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of struct ucred
-- Check size of struct ucred - failed
-- Looking for getpeereid
-- Looking for getpeereid - not found
-- checking for module 'xrandr>=1.2'
--   found xrandr, version 1.2.3
--
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ libxss
+ libxext
-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
+ GoogleGadgets: Google Gadgets library <http://code.google.com/p/google-gadgets-for-linux/>
Needed to build plasma scriptengine for google gadgets
-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/kde-base/kmenuedit-9999/work/kmenuedit_build
make[2]: *** No rule to make target `khotkeys/app/org.kde.khotkeys.xml', needed by `kmenuedit/khotkeys_interface.cpp'.  Stop.
make[1]: *** [kmenuedit/CMakeFiles/kdeinit_kmenuedit.dir/all] Error 2
make: *** [all] Error 2
 *
 * ERROR: kde-base/kmenuedit-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3064:  Called kde4overlay-meta_src_compile
 *             environment, line 2344:  Called kde4overlay-meta_src_make
 *             environment, line 2393:  Called kde4overlay-base_src_make
 *             environment, line 2104:  Called cmake-utils_src_make
 *             environment, line  756:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/kde-base:kmenuedit-9999:20080919-175815.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kmenuedit-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'


emerge --info
Code:
Portage 2.2_rc8 (default/linux/amd64/2008.0, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.26-reiser4 x86_64)
=================================================================
System uname: Linux-2.6.26-reiser4-x86_64-Intel-R-_Core-TM-2_CPU_T7600_@_2.33GHz-with-glibc2.2.5
Timestamp of tree: Thu, 18 Sep 2008 14:30:01 +0000
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r7
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5-r1
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/svn/env /usr/kde/svn/share/config /usr/kde/svn/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -O2 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer parallel-fetch preserve-libs sfperms strict unmerge-orphans userfetch userpriv"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/sabayon /usr/local/portage/layman/kdesvn-portage /usr/local/portage/layman/rbu /usr/local/portage/layman/gnome /usr/local/portage/layman/desktop-effects /usr/local/portage /usr/local/portage/kde-misc /usr/local/portage/myoverlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X Xaw3d a52 aac aalib acpi alsa amd64 ao aotuv archive artworkextra audiofile automount avahi bash-completion bittorrent bluetooth bzip2 cairo calendar cddb cdio cdparanoia cdr cdrw cgraph chm cisco cups curl cxx dbus dell dga dhcp dialup disk-partition divx djbfft djvu dmx dri drm dts dv dvd dvdr dvdread encode esd exif expat fam ffmpeg fftw filepicker firefox flac fltk fontconfig foomaticdb ftp gcdmaster gd gdbm ggi gif gimp git glib glitz gmedia gnome gnomecd gphoto2 gpm graphviz gs gstreamer gtk hal hddtemp hfs iconv ieee1394 imagemagick imlib ipod irda jabber java javascript jpeg jpeg2k kde kde4 kontact lame laptop lcms libcaca libnotify libsamplerate lm_sensors lzo mad midi mikmod mmap mmx mmxext mng modplug mono motif mp3 mp3rtp mp4 mpeg mplayer msn multilib nas nautilus ncurses network-cron networkmanager nls nntp nptl nptlonly nsplugin ntp ogg openal openexr opengl openvpn oscar oss paste64 pccts pda pdf plasma png policykit povray ppds python qt3 qt3support qt4 quicktime rar rdesktop readline realmedia rtc samba sdl semantic-desktop slit sndfile sound spell srt sse sse2 sse3 ssl ssse3 subversion svg swat syslog tcl teletext tga theora tiff timidity tk toolbar toolkit-scroll-bars truetype unicode usb v4l v4l2 vcd visualization vnc vorbis wavpack webkit wmf wmp wxwindows x264 xanim xattr xcb xcomposite xft xine xinerama xml xorg xpm xscreensaver xulrunner xv xvid zip zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="dmix adpcm alaw asym copy dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Fri Sep 19, 2008 8:38 pm    Post subject: Reply with quote

noone knows my problem ? phonen doesn't find phonon-xine !? (kde 4.1.66)
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Sep 20, 2008 11:56 am    Post subject: Reply with quote

I do have the same problem yet haven't any solution. Recompiling phonon, phonon-xine and the upgrade to qt-4.4.2 didn't help. I think we'll have to wait for kde-4.1.67...

EDIT: Solution found! :D

Unmask media-sound/phonon-9999 * **, emerge it, be happy. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Nuitari
Apprentice
Apprentice


Joined: 15 May 2005
Posts: 245

PostPosted: Sat Sep 20, 2008 12:14 pm    Post subject: Reply with quote

amarok-1.90 doesn't compile:
http://rafb.net/p/rrujyv68.html

maybe solid error?
_________________
Da un discorso su #gentoo:

[15:10] <flowolf> pino: credo che se dovessi leggere ancora un punto interrogativo ed il tuo nick sulla stessa riga
[15:10] <flowolf> potrei andare fuori di testa
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Sep 20, 2008 1:28 pm    Post subject: Reply with quote

I do have linking problems too with amarok-1.90, k3b, ktorrent,...

However try amarok-1.9999, it builds fine. ;)
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
DaggyStyle
Watchman
Watchman


Joined: 22 Mar 2006
Posts: 5398

PostPosted: Sat Sep 20, 2008 1:47 pm    Post subject: Reply with quote

what's the address of the site which updates on the kde4.1 ebuild creation?
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
Back to top
View user's profile Send private message
bienchen
Apprentice
Apprentice


Joined: 14 Sep 2004
Posts: 261
Location: Hamburg, Germany

PostPosted: Sat Sep 20, 2008 2:28 pm    Post subject: Reply with quote

Hi,

I got a problem installing KDE-4.1. I completely followed this guide:

http://gentoo-wiki.com/HOWTO_KDE4

and on

Quote:
emerge -vat kde-meta:4.1


I get:

Quote:
hese are the packages that would be merged, in reverse order:

Calculating dependencies \
emerge: there are no ebuilds to satisfy "kde-base/kde-meta:4.1".


A little help? No idea where to go from there...

bienchen
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Sep 20, 2008 2:34 pm    Post subject: Reply with quote

Things have changed recently:

kdesvn-portage has dumped all 4.1 ebuilds to concentrate exclusively on the 4.2 branch
KDE-4.1 branch remains in official kde-testing

After some hassle amarok-1.9999 even works, kind of. I'm missing smart playlists though. :(
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bienchen
Apprentice
Apprentice


Joined: 14 Sep 2004
Posts: 261
Location: Hamburg, Germany

PostPosted: Sat Sep 20, 2008 5:15 pm    Post subject: Reply with quote

So what version of KDE should I use? 4.1 or 4.2?

I installed the kde-testing overlay and got

Quote:
* Overlay eclasses override eclasses from PORTDIR:
*
* '/usr/portage/local/layman/kde-testing/eclass/kde4-base.eclass'
* '/usr/portage/local/layman/kde-testing/eclass/kde4-functions.eclass'
* '/usr/portage/local/layman/kde-testing/eclass/kde4-meta.eclass'
*
* It is best to avoid overridding eclasses from PORTDIR because it will
* trigger invalidation of cached ebuild metadata that is distributed with
* the portage tree. If you must override eclasses from PORTDIR then you
* are advised to run `emerge --regen` after each time that you run `emerge
* --sync`. Set PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you
* would like to disable this warning.


on

Quote:
emerge -p kde-meta:4.1


And after this again the message, that the ebuild is not in portage.

greetings,

bienchen
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Sep 20, 2008 5:26 pm    Post subject: Reply with quote

That's because there is no such slot (4.1) in kde-testing. Instead, you might want to use (4):

Code:
emerge -p kde-meta:4


So which version should you use?
4.1 - hassle-free stable branch which is officially being worked on (and supported as soon as it hits portage)
4.2 - development branch with tagged 'stable' versions from SVN. Expect major KDE updates about once a week when a new minor version gets tagged. Most of the time those should emerge fine, but there may be regressions once in a while.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bienchen
Apprentice
Apprentice


Joined: 14 Sep 2004
Posts: 261
Location: Hamburg, Germany

PostPosted: Sat Sep 20, 2008 5:33 pm    Post subject: Reply with quote

And what should I do on the eclass-override?

Trying to get 4.1 working, then...
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sat Sep 20, 2008 6:26 pm    Post subject: Reply with quote

I think we can ignore that for now...
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
bienchen
Apprentice
Apprentice


Joined: 14 Sep 2004
Posts: 261
Location: Hamburg, Germany

PostPosted: Sat Sep 20, 2008 10:16 pm    Post subject: Reply with quote

Is it possible, that there are many dependencies not unmask for KDE 4.1 from the kde-testing overlay?

Like x11-libs/qt-svg:4, for an example?

greetings,

bienchen
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Sep 21, 2008 12:10 pm    Post subject: Reply with quote

qt-4.4* is in official portage, yet masked. Yes, you have to do some things by hand. ;)

I have reworked the KDE4 gentoo-wiki to make the differences between kde-testing and kdesvn-portage visible. It might be of help for you: http://gentoo-wiki.com/KDE4

EDIT: I've switched over to kde-testing myself - it works great.
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Benson
Apprentice
Apprentice


Joined: 23 Feb 2004
Posts: 156
Location: Switzerland

PostPosted: Sun Sep 21, 2008 3:45 pm    Post subject: Reply with quote

genstorm wrote:
I do have the same problem yet haven't any solution. Recompiling phonon, phonon-xine and the upgrade to qt-4.4.2 didn't help. I think we'll have to wait for kde-4.1.67...

EDIT: Solution found! :D

Unmask media-sound/phonon-9999 * **, emerge it, be happy. ;)

Seems like anonsvn.kde.org is down, i get a connection error... hope it`s back soon, because besides phonon everything is workin well (using 4.1.64).
_________________
If it compiles, commit to CVS.
If it links, ship to customer.
If it runs without bugs, ..., nah, never had that case.
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Sun Sep 21, 2008 4:12 pm    Post subject: Reply with quote

To circumvent the problems with anonsvn.kde.org, you have to add the line

Quote:

138.246.255.180 anonsvn.kde.org

in /etc/hosts.
Back to top
View user's profile Send private message
PaulSorensen
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2004
Posts: 80
Location: Chicago, USA

PostPosted: Sun Sep 21, 2008 7:41 pm    Post subject: Reply with quote

I followed the new KDE4 instructions on gentoo-wiki to install kde4 and I get the below. The first time I ran in, it installed 11 packages:


  • kde-base/automoc-0.9.84
  • media-sound/phonon-4.2.0-r1
  • app-office/akonadi-server-1.0.0
  • dev-libs/soprano-2.1
  • kde-base/kdelibs-4.1.1-r2
  • kde-base/kdepimlibs-4.1.1
  • app-misc/strigi-0.5.11
  • kde-base/libkworkspace-4.1.1
  • kde-base/libtaskmanager-4.1.1
  • kde-base/libplasma-4.1.1
  • kde-base/kate-4.1.1


This list is obviously a small subset of the kde4 packages - now when I run emerge -vat @kde-4x, I get this:
Code:

 * Overlay eclasses override eclasses from PORTDIR:
 *
 *   '/usr/local/portage/layman/kde-testing/eclass/kde4-base.eclass'
 *   '/usr/local/portage/layman/kde-testing/eclass/kde4-functions.eclass'
 *   '/usr/local/portage/layman/kde-testing/eclass/kde4-meta.eclass'
 *
 * It is best to avoid overridding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to add FEATURES="metadata-transfer" to /etc/make.conf and to
 * run `emerge --regen` after each time that you run `emerge --sync`. Set
 * PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you would like to
 * disable this warning.
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 4, data @kdeadmin-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 5, data @kdeartwork-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 6, data @kdebase-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 7, data @kdeedu-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 8, data @kdegames-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 9, data @kdegraphics-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 10, data @kdemultimedia-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 11, data @kdenetwork-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 12, data @kdepim-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 13, data @kdetoys-4
/usr/local/portage/layman/kde-testing/sets/kde-4x: Validation failed at line: 14, data @kdeutils-4

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] kde-base/kate-4.1.1  USE="plasma -debug -htmlhandbook -kdeprefix" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage
 [1] /usr/local/portage/layman/kde-testing


Any ideas on what this could be?
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Sun Sep 21, 2008 7:43 pm    Post subject: Reply with quote

hm. ich just installed kdebase-meta and the additional packages i wanted to have (e.g. kopete, amarok... )
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Sep 21, 2008 8:00 pm    Post subject: Reply with quote

@PaulSorensen: It seems you already had some kde-4.1 packages installed? Did you switch from kdesvn-portage?
_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
PaulSorensen
Tux's lil' helper
Tux's lil' helper


Joined: 15 Apr 2004
Posts: 80
Location: Chicago, USA

PostPosted: Sun Sep 21, 2008 8:02 pm    Post subject: Reply with quote

genstorm wrote:
@PaulSorensen: It seems you already had some kde-4.1 packages installed? Did you switch from kdesvn-portage?


Hi genstorm - yes I did, do you think that is causing the problem? I attempted to clean out any of the kdesvn packages that I could find.
Back to top
View user's profile Send private message
asturm
Developer
Developer


Joined: 05 Apr 2007
Posts: 7135
Location: Austria

PostPosted: Sun Sep 21, 2008 10:13 pm    Post subject: Reply with quote

I don't know how those ebuilds work together - someone here posted an alpha guide howto move from kdesvn-portage to kde-testing, but it didn't look too easy. Have you been able to login into a kde4 session without problems?

I made the switch by unmerging all "4.1" slotted packages and finally emerging kdebase-meta:4. Didn't use the set but I get the same validation warnings - maybe that's broken for now.

This should do the trick if you want a clean kde-testing 4.1 environment:
Code:
equery list kde-base/ | grep "(4.1)" | xargs emerge -Cp

_________________
backend.cpp:92:2: warning: #warning TODO - this error message is about as useful as a cooling unit in the arctic
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 27, 28, 29, 30  Next
Page 28 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum