Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1 portage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 16, 17, 18 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cohone
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2006
Posts: 113

PostPosted: Mon Jul 28, 2008 12:08 am    Post subject: Reply with quote

kernelOfTruth wrote:
I just re-compiled digikam from svn and "hit" the following problem:

Quote:
-- digiKam will be compiled without lens auto-correction image editor plugin.
--
-- digiKam will be compiled...
-- ------------------------------------------------
--
-- Warning, you using a bugous GCC version ( 4.3.1)


after that it canceled / error

any idea what part of gcc-4.3.1 is broken / buggy ?

many thanks in advance



Thats just an advice that you're using a "bugous" version of gcc (too obvious :oops: ).

¿do you have an error something like "cmake failed" after GCC message?
¿do you have an error in the ./configure fase about "imlib not found" or something like that.?

if so ive solved the problem some time ago by editing /usr/portage/distfiles/svn-src/KDE/kdemultimedia/kdemultimedia/CMakeLists.txt
and commenting macro_optional_find_package related to imlib.
since i did that i have no troubles compiling digikam-9999 and kipi-plugings-9999
Back to top
View user's profile Send private message
Shamus397
Apprentice
Apprentice


Joined: 03 Apr 2005
Posts: 217
Location: Ur-th

PostPosted: Mon Jul 28, 2008 3:30 am    Post subject: Reply with quote

It's nice (in a sad way) to know that I'm not the only one suffering from poor performance. If it's just a Qt4/XRender problem I'm sure it'll all get sorted out eventually. But in the meantime I don't think I can use KDE 4.1 for a day to day desktop since things like Rosegarden and QSynth don't play nice with it (and of course those work fine in KDE 3.5 :P).

I wish I knew how I could contribute towards fixing stuff like that, but I really don't have the foggiest idea where to begin or who I would talk to. :(

And to whoever posted iotop: THANK YOU THANK YOU THANK YOU
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Mon Jul 28, 2008 8:14 am    Post subject: Reply with quote

I recently wanted to add some custom short cuts to amarok, which worked, but was forgotten after restarting. So I thought it might be a bug in this early amarok version. But now I wanted to assign ctrl+s to "save as" in okular and there the same thing happens. First it works, but after a restart everything is gone.
Do others have the same problem or a solution to it?
Back to top
View user's profile Send private message
ThGravo
n00b
n00b


Joined: 20 Apr 2006
Posts: 24

PostPosted: Mon Jul 28, 2008 8:54 am    Post subject: Can't emerge! Reply with quote

Can't emerge because of:
Code:
# emerge @kde-4.1
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-base/libkmahjongg:4.1".

Changing it in the sets to =kde-base/libkmahjongg-4.1* is a workaround, but makes me run into the next unsatisfied dependency and so on.
Is there another way to fix this? What does the ":" do at all?
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Mon Jul 28, 2008 10:00 am    Post subject: Reply with quote

I ran powertop while using KDE 4.0.99 and I noticed that knotify4 is the main source of CPU wake-ups (roughly 70 per second): is it normal? If so, why is it doing that?
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Mon Jul 28, 2008 12:07 pm    Post subject: Reply with quote

Dusdan wrote:
I ran powertop while using KDE 4.0.99 and I noticed that knotify4 is the main source of CPU wake-ups (roughly 70 per second): is it normal? If so, why is it doing that?
I just realized it is a known bug: forget my post.
http://bugs.kde.org/show_bug.cgi?id=151546
Back to top
View user's profile Send private message
JotaCE
l33t
l33t


Joined: 10 Jul 2007
Posts: 769
Location: SANTIAGO, CHILE!!!

PostPosted: Mon Jul 28, 2008 2:23 pm    Post subject: Reply with quote

i'm try to compile kde-4.1.60 (9999) and this error in krunner

Code:
 localhost jotace # emerge krunner
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) kde-base/krunner-9999 to /
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]

Scanning dependencies of target krunner_lock                                   
Scanning dependencies of target kdeinit_krunner                                 
[ 39%] Building CXX object krunner/lock/plasma/CMakeFiles/plasma-overlay.dir/savercorona.o                                                                     
[ 41%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/lockprocess.o                                                                               
[ 42%] Building CXX object krunner/lock/plasma/CMakeFiles/plasma-overlay.dir/saverview.o                                                                       
[ 44%] Building CXX object krunner/CMakeFiles/kdeinit_krunner.dir/krunnerdialog.o                                                                               
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/krunnerdialog.cpp: In member function 'virtual void KRunnerDialog::paintEvent(QPaintEvent*)':       
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/krunnerdialog.cpp:80: error: no matching function for call to 'Plasma::PanelSvg::paintPanel(QPainter*)'                                                                             
/usr/kde/svn/include/plasma/panelsvg.h:196: note: candidates are: void Plasma::PanelSvg::paintPanel(QPainter*, const QRectF&, const QPointF&)                   
[ 45%] Building CXX object krunner/lock/plasma/CMakeFiles/plasma-overlay.dir/main.o                                                                             
make[2]: *** [krunner/CMakeFiles/kdeinit_krunner.dir/krunnerdialog.o] Error 1   
make[1]: *** [krunner/CMakeFiles/kdeinit_krunner.dir/all] Error 2               
make[1]: *** Waiting for unfinished jobs....                                   
Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/autologout.o       
[ 51%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/main.o     
[ 52%] Building CXX object krunner/lock/plasma/CMakeFiles/plasma-overlay.dir/appadaptor.o                                                                       
[ 54%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/lockprocessadaptor.o                                                                       
[ 55%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/ksmserver_interface.o                                                                       
[ 57%] Building CXX object krunner/lock/plasma/CMakeFiles/plasma-overlay.dir/plasma-overlay_automoc.o                                                           
Linking CXX executable plasma-overlay                                           
[ 57%] Built target plasma-overlay                                             
[ 58%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/kscreensaver_interface.o                                                                   
[ 60%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/kxkb_interface.o                                                                           
[ 61%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/kscreensaversettings.o                                                                     
[ 63%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/krunner_lock_automoc.o                                                                     
Linking CXX executable krunner_lock                                             
[ 63%] Built target krunner_lock                                               
make: *** [all] Error 2                                                         
 *                                                                             
 * ERROR: kde-base/krunner-9999 failed.                                         
 * Call stack:                                                                 
 *               ebuild.sh, line   49:  Called src_compile                     
 *             environment, line 3009:  Called kde4overlay-meta_src_compile     
 *             environment, line 2287:  Called kde4overlay-meta_src_make       
 *             environment, line 2336:  Called kde4overlay-base_src_make       
 *             environment, line 2047:  Called cmake-utils_src_make             
 *             environment, line  736:  Called die                             
 * The specific snippet of code:                                               
 *           emake "$@" || die "Make failed!";                                 
 *  The die message:                                                           
 *   Make failed!                                                               
 *                                                                             
 * If you need support, post the topmost build error, and the call stack if relevant.                                                                           
 * A complete build log is located at '/var/tmp/portage/kde-base/krunner-9999/temp/build.log'.                                                                 
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/krunner-9999/temp/environment'.                                                         
 * This ebuild used the following eclasses from overlays:                       
 *   /usr/portage/local/layman/kdesvn-portage/eclass/kde4svn-meta.eclass       
 *   /usr/portage/local/layman/kdesvn-portage/eclass/kde4svn.eclass             
 *   /usr/portage/local/layman/kdesvn-portage/eclass/kde4overlay-meta.eclass   
 *   /usr/portage/local/layman/kdesvn-portage/eclass/kde4overlay-functions.eclass                                                                               
 *   /usr/portage/local/layman/kdesvn-portage/eclass/kde4overlay-base.eclass   
 *                                                                             


Any idea?
_________________
La derrota no es motivo de vergüenza si el espíritu sigue sin conquistar!
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Mon Jul 28, 2008 9:53 pm    Post subject: Re: Can't emerge! Reply with quote

ThGravo wrote:
Can't emerge because of:
Code:
# emerge @kde-4.1
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-base/libkmahjongg:4.1".

Changing it in the sets to =kde-base/libkmahjongg-4.1* is a workaround, but makes me run into the next unsatisfied dependency and so on.
Is there another way to fix this? What does the ":" do at all?

The :4.1 specifies the slot IIRC. So if a set required qt, then any qt would satisfy that dependency, but if it depended on qt:3 then only the latest version of qt-3.* would be installed on a deep emerge of that package.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Tue Jul 29, 2008 1:49 pm    Post subject: Reply with quote

I've read all the posts on this, and it seemed it was solved weeks ago, but what is the deal with:
Code:
[blocks B     ] media-sound/phonon (is blocking x11-libs/qt-phonon-4.4.0)
[blocks B     ] x11-libs/qt-phonon:4 (is blocking media-sound/phonon-4.2.9999)
I must be missing something obvious, but I can't figure this out.
Last night I synced, rebuilt qt-split (hadn't done so in weeks), and then all of kde-9999, and on reboot plasma crashed immediately with a black screen and crash dialog box, referring to qt.

I assumed I needed a qt rebuild, so I did it, and apparently qt-split pulled in qt-phonon, even thought I had media-sound/phonon installed.
Then today, i needed to uppdate/rebuild again, and got these phonon blocks. It was weird because equery reported I didn't have media-sound/phonon installed, but it was blocking.

Finally I removed qt-phonon, and also commented it out in the qt-split sets file, and got rid of the blocks, and then media-sound.phonon appeared as 2nd on the complete kde-9999 rebuild list. I'm currently at kdelibs (3rd on the 90 package list).

I guess my question is just exactly which phonon packages are we supposed to have- media-sound, qt, or both, and how to avoid this blocking problem when using "equery list kde-base/ | grep 9999 | xargs -n1 -i echo ={} | xargs emerge -vp" ? I still can't figure out what is causing this- the gstreamer or some other USE flag or multimedia package problem?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
piwacet
Guru
Guru


Joined: 30 Dec 2004
Posts: 486

PostPosted: Tue Jul 29, 2008 2:41 pm    Post subject: Reply with quote

Well there it is.

Got released just now according to KDE website.
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Tue Jul 29, 2008 2:48 pm    Post subject: Reply with quote

I just started compiling and when having a look after ~100 packages, I noticed that it compiles and installes 4.1.0 nicely, however 4.0.99 does NOT get unmerged, but some of its files (all?) get overwritten. Is this intended?
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Tue Jul 29, 2008 3:21 pm    Post subject: Reply with quote

Boccaccio wrote:
I just started compiling and when having a look after ~100 packages, I noticed that it compiles and installes 4.1.0 nicely, however 4.0.99 does NOT get unmerged, but some of its files (all?) get overwritten. Is this intended?


This will happen if you installed 4.0.99 before the slot move. In this case I would recommend unmerging 4.0.99 first. If you installed it using sets, it should be just a matter of unmerging the set. If you need any help, come to the #gentoo-kde4-live IRC channel.
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Tue Jul 29, 2008 3:22 pm    Post subject: Reply with quote

Boccaccio wrote:
I just started compiling and when having a look after ~100 packages, I noticed that it compiles and installes 4.1.0 nicely, however 4.0.99 does NOT get unmerged, but some of its files (all?) get overwritten. Is this intended?


Where did you get the ebuilds for KDE 4.1.0 ? I didn't see them in Portage or in the kde4-experimental overlay....
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 282

PostPosted: Tue Jul 29, 2008 3:30 pm    Post subject: Reply with quote

They are in the kdesvn-portage overlay
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 3:32 pm    Post subject: Reply with quote

wrc1944 wrote:

Finally I removed qt-phonon, and also commented it out in the qt-split sets file, and got rid of the blocks, and then media-sound.phonon appeared as 2nd on the complete kde-9999 rebuild list. I'm currently at kdelibs (3rd on the 90 package list).

I guess my question is just exactly which phonon packages are we supposed to have- media-sound, qt, or both, and how to avoid this blocking problem when using "equery list kde-base/ | grep 9999 | xargs -n1 -i echo ={} | xargs emerge -vp" ?

When I installed 2 weeks ago, and reinstalled 1 week ago, I could not have qt-phonon, and had to have
"media-sound/phonon-4.2.9999."

As per a post found somewhere in this thread, I made a soft link or two to solve a problem that may or may not need to be solved anymore.

You say that your list pulls in media-sound, but say nothing about qt. So there is no problem, yes?

also, that equery list will miss the following, you might want to just make a static list / set
=media-sound/phonon-4.2.9999
=app-office/akonadi-server-9999
=dev-libs/soprano-9999


EDIT: jeanfrancis sync overlay?
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
forkboy
Apprentice
Apprentice


Joined: 24 Nov 2004
Posts: 200
Location: Blackpool, UK

PostPosted: Tue Jul 29, 2008 3:40 pm    Post subject: Reply with quote

AllenJB wrote:
This will happen if you installed 4.0.99 before the slot move. In this case I would recommend unmerging 4.0.99 first. If you installed it using sets, it should be just a matter of unmerging the set. If you need any help, come to the #gentoo-kde4-live IRC channel.

I didn't install using sets, how can I unmerge all of 4.0.99?
Back to top
View user's profile Send private message
Benson
Apprentice
Apprentice


Joined: 23 Feb 2004
Posts: 156
Location: Switzerland

PostPosted: Tue Jul 29, 2008 3:50 pm    Post subject: Reply with quote

AllenJB wrote:
This will happen if you installed 4.0.99 before the slot move. In this case I would recommend unmerging 4.0.99 first. If you installed it using sets, it should be just a matter of unmerging the set. If you need any help, come to the #gentoo-kde4-live IRC channel.

When was the slot move? The script slot_move_kde-4.1_4.1.sh is only needed if i have emerged kde-4.0.99 before the slot move, else i can simply update!?

BTW: Where did the yakuake-4.1 ebuild go? Thought i've seen it yesterday...

cheers,
Benson
_________________
If it compiles, commit to CVS.
If it links, ship to customer.
If it runs without bugs, ..., nah, never had that case.
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1285
Location: Ashford, Kent

PostPosted: Tue Jul 29, 2008 3:54 pm    Post subject: Reply with quote

forkboy wrote:
AllenJB wrote:
This will happen if you installed 4.0.99 before the slot move. In this case I would recommend unmerging 4.0.99 first. If you installed it using sets, it should be just a matter of unmerging the set. If you need any help, come to the #gentoo-kde4-live IRC channel.

I didn't install using sets, how can I unmerge all of 4.0.99?


Use a package search utility such as eix. The following is untested, but may work: eix --in-overlay kde4-overlay --and --slot kde-4.1 --and -I

Then use that list for emerge: emerge -Ca `eix --format "<category>/<name>:kde-4.1" -* --in-overlay kde4-overlay --and --slot kde-4.1 --and -I`
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 3:58 pm    Post subject: Reply with quote

@forkboy, I made a list for you if you want: http://rafb.net/p/SqRGJ681.html
you could copy the text to a_file
and then unmerge with
Code:
emerge --ask --unmerge `cat a_file`


made like this:
Code:

cd /usr/portage/local/layman/kdesvn-portage/
find -iname "*4.0.99.ebuild" | sed 's-./-=-' | cut -d'/' -f 1-2 | awk '{print $1 "-4.0.99"}' > 4099_list
emerge --ask --unmerge `4099_list`


edit: AllenJB's way looks interesting, I might have to look into that.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Bloodsurfer
Guru
Guru


Joined: 07 Dec 2005
Posts: 361
Location: Wolfstein, Germany (Rhineland-Palatinate)

PostPosted: Tue Jul 29, 2008 4:09 pm    Post subject: Reply with quote

You can also use
qlist -CIv | grep 4.0.99 | xargs -n1 -i echo ={} | xargs emerge -C

But look over that list (with -p) first before really unmerging!! Could be that there is per chance some other program on your system with version number 4.0.99 ;)
_________________
SiberianSniper: my girlfriend's name ends with .c
Clete2: Uber geek! W00t! I'd rather have it end in .cpp... <insert name>.cpp
Dralnu: ...why not <name>.o? Then she's ready for linking...
SiberianSniper: or <name>.ko, so she's ready for insertion?
Back to top
View user's profile Send private message
forkboy
Apprentice
Apprentice


Joined: 24 Nov 2004
Posts: 200
Location: Blackpool, UK

PostPosted: Tue Jul 29, 2008 4:17 pm    Post subject: Reply with quote

Bloodsurfer I used your method thanks guys
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Tue Jul 29, 2008 4:45 pm    Post subject: Reply with quote

For some reason, I can't get past this: :?
SNIPPED 100's of ldap undefined reference lines, then kdepimlibs fails:

Code:
KLDAP::LdapAttributeProxyModel]+0xc4): undefined reference to `QSortFilterProxyModel::lessThan(QModelIndex const&, QModelIndex const&) const'
CMakeFiles/kldap.dir/ldapattributeproxymodel.o:(.data.rel.ro._ZTIN5KLDAP23LdapAttributeProxyModelE[typeinfo for KLDAP::LdapAttributeProxyModel]+0x8): undefined reference to `typeinfo for QSortFilterProxyModel'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkldap.so.4.2.0] Error 1
make[1]: *** [kldap/CMakeFiles/kldap.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/resourcescheduler.o
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/searchcreatejob.o
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/session.o
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/standardactionmanager.o
/var/tmp/portage/kde-base/kdepimlibs-9999/work/kdepimlibs-9999/akonadi/session.cpp:183: warning: unused parameter 'job'
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/subscriptionjob.o
/var/tmp/portage/kde-base/kdepimlibs-9999/work/kdepimlibs-9999/akonadi/subscriptionjob.cpp: In member function 'void Akonadi::SubscriptionJobPrivate::sendCommand(const QByteArray&, const QList<Akonadi::Collection>&)':
/var/tmp/portage/kde-base/kdepimlibs-9999/work/kdepimlibs-9999/akonadi/subscriptionjob.cpp:36: warning: unused variable 'q'
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/subscriptionchangeproxymodel.o
[ 30%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/subscriptiondialog.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/subscriptionmodel.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/transactionjobs.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/transactionsequence.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/pluginloader.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/notificationmanagerinterface.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/agentmanagerinterface.o
[ 31%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/tracerinterface.o
[ 32%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/resourceadaptor.o
[ 32%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/statusadaptor.o
[ 32%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/controladaptor.o
[ 32%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/akonadi-kde_automoc.o
Linking CXX shared library ../lib/libakonadi-kde.so
[ 32%] Built target akonadi-kde
make: *** [all] Error 2
 * ERROR: kde-base/kdepimlibs-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2611:  Called kde4overlay-base_src_compile
 *             environment, line 1921:  Called kde4overlay-base_src_make
 *             environment, line 1954:  Called cmake-utils_src_make
 *             environment, line  650:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!


Thanks coolsnowmen for the feedback on the phono stuff. :)
EDIT: This happens at the end of an emerge -v @kde-deps-meta, after kdelibs and akonadi-server have been rebuilt. I also installed cyrus-sasl and rebuilt openldap- same error out with kdepimlibs. So, I'm stuck for now- no use building the rest without the dep kdepimlibs first. :? I'm going back to my Paludis partition and try updating kdesvn there, and hopefully kdepimlibs will not fail there, and I can get a clue as to what's wrong on my kdesvn-portage. :roll:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 6:24 pm    Post subject: Reply with quote

@wrc1944, try installing cmake-2.6.0 (needs to be unmasked), making sure everything else in system.stable is up.to.date, "revdep-rebuild -i -p" and then reemerging kdepimlibs-9999
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Tue Jul 29, 2008 6:45 pm    Post subject: Reply with quote

coolsnowmen,
Thanks- I am current ~x86, and did do a revdep- only thing that needed a rebuild was kdepimlibs, which of course kept failing. :roll:
I didn't check to see if cmake was masked (no messages about needing a newer version appeared), so I'm not sure if I have 2.6.0- probably not. Soon as my Paludis kdesvn partition finishes up (or kdepimlibs fails there too), I'll go back to kdesvn-portage and try your cmake suggestion. However, if on this paludis box kdepimlibs compiles OK with cmake-2.4.8, that would seem to indicate cmake is not the problem on the portage box.

UPDATE: Same error on kdepimlibs with cmake-2.4.8 on my paludis box, so maybe it is cmake versioin needs to be 2.6.0. I'll unamsk, and try with that. Anybody else running into this, either with portage kdesvn, or paludis?

If I do a major update cmake version such as this one, does that mean a complete qt-split rebuild before doing the complete kdesvn rebuild?
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental


Last edited by wrc1944 on Tue Jul 29, 2008 7:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 7:47 pm    Post subject: Reply with quote

wrc1944 wrote:
coolsnowmen,
if on this paludis box kdepimlibs compiles OK with cmake-2.4.8, that would seem to indicate cmake is not the problem on the portage box.


I actually did a reference to needing cmake for svn trunk in the cmake configure. I'm not going to go downgrading cmake to find it again, but the internet backs me up.
http://www.kdedevelopers.org/node/3568
"starting August 4th, i.e. Monday in 2 weeks, CMake >= 2.6.0 will be required to build KDE from svn trunk, which will become KDE 4.2 in a few month"
So, as far as I am concerned, if you want to install newer stuff than 4.1, which has already been taged, so svn is newer, then cmake 2.6 will be needed, if it is not already.

Edit: also note that when it comes to linking errors, it would be quite possible for paludis's environment to be different than portages.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 16, 17, 18 ... 28, 29, 30  Next
Page 17 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum