Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1 portage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
NaiL
Apprentice
Apprentice


Joined: 13 Feb 2003
Posts: 228
Location: Spain/BCN

PostPosted: Tue Jul 29, 2008 8:06 pm    Post subject: Reply with quote

How i can install KDE 4.1 (the final release)

I tried the keyword files and unmask from the Documentation directory but it tries to install the SVN version.

I'm using portage 2.1 and i don't want to change to 2.2 by now.

Thanks.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Tue Jul 29, 2008 8:23 pm    Post subject: Reply with quote

coolsnowmen wrote:
Quote:
I actually did a reference to needing cmake for svn trunk in the cmake configure. I'm not going to go downgrading cmake to find it again, but the internet backs me up.
http://www.kdedevelopers.org/node/3568
"starting August 4th, i.e. Monday in 2 weeks, CMake >= 2.6.0 will be required to build KDE from svn trunk, which will become KDE 4.2 in a few month"
So, as far as I am concerned, if you want to install newer stuff than 4.1, which has already been taged, so svn is newer, then cmake 2.6 will be needed, if it is not already.
Thanks for the heads up! :) I guess I can confirm it is indeed needed now. If 2.6.0 was unmasked, I would never have run into this, as a world update should have done it. Anyway, 2.6.0 just let me compile kdepimlibs, so I guess I need to do all of kde again.

What about the deps, and qt-split? I assume the deps for sure, but am not sure about qt. They should mention this right away on both the portage and paludis kdesvn threads, or lots of people will have this trouble.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
neuron
Advocate
Advocate


Joined: 28 May 2002
Posts: 2371

PostPosted: Tue Jul 29, 2008 8:39 pm    Post subject: Reply with quote

all the symlinks for the package set kde 4.1 seems to have gone missing :/
Back to top
View user's profile Send private message
natros
n00b
n00b


Joined: 26 Sep 2003
Posts: 70

PostPosted: Tue Jul 29, 2008 9:06 pm    Post subject: Reply with quote

Does anyone know if gentoo is going to ship 4.1 or they are waiting for a more stable release.

Thanks.
_________________
-=[abit ip35 pro core2quad q6600 (oc 3.0 ghz) 8 gb ram 2x320 raid0 ext4 xfx8800gt 512mb]=-
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 9:19 pm    Post subject: Reply with quote

natros wrote:
Does anyone know if gentoo is going to ship 4.1 or they are waiting for a more stable release. Thanks.

With 4.1 in a usable state (not perfect), and with 4.0 basically for.show.and.testing, I'd be surprised if developers were not working on it now, and if hard [M]asked ebuilds were not in the tree in under 2 weeks.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 9:22 pm    Post subject: Noone had posted it here, so... Reply with quote

Just FYI:

Under the kde 4.1 announcement http://www.kde.org/announcements/4.1/
there is a reference to the known graphics problems: http://techbase.kde.org/User:Lemma/GPU-Performance

Something about knowing that they (kde/nvidia/ati) know of the problem makes me not as annoyed about it.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 427
Location: Graben-Neudorf, Germany

PostPosted: Tue Jul 29, 2008 10:18 pm    Post subject: Reply with quote

natros wrote:
Does anyone know if gentoo is going to ship 4.1 or they are waiting for a more stable release.


Please check the kdesvn-portage overlay:
https://forums.gentoo.org/viewtopic-t-694231-postdays-0-postorder-asc-start-0.html

Best wishes,
Arne
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Tue Jul 29, 2008 10:22 pm    Post subject: Reply with quote

ArneBab wrote:
natros wrote:
Does anyone know if gentoo is going to ship 4.1 or they are waiting for a more stable release.


Please check the kdesvn-portage overlay:
https://forums.gentoo.org/viewtopic-t-694231-postdays-0-postorder-asc-start-0.html

Best wishes,
Arne


I'm confused, did you just link back to this same topic? I think he meant the main gentoo portage tree.
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
natros
n00b
n00b


Joined: 26 Sep 2003
Posts: 70

PostPosted: Tue Jul 29, 2008 10:34 pm    Post subject: Reply with quote

ArneBab wrote:
natros wrote:
Does anyone know if gentoo is going to ship 4.1 or they are waiting for a more stable release.


Please check the kdesvn-portage overlay:
https://forums.gentoo.org/viewtopic-t-694231-postdays-0-postorder-asc-start-0.html

Best wishes,
Arne

Thank you, but I don't want mess with my system. I'll wait for an official stable release.
_________________
-=[abit ip35 pro core2quad q6600 (oc 3.0 ghz) 8 gb ram 2x320 raid0 ext4 xfx8800gt 512mb]=-
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 427
Location: Graben-Neudorf, Germany

PostPosted: Wed Jul 30, 2008 5:53 am    Post subject: Reply with quote

coolsnowmen wrote:
I'm confused, did you just link back to this same topic? I think he meant the main gentoo portage tree.


... uh ... I got the threads muddled up in my heads I think... sorry for that.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Wed Jul 30, 2008 6:24 pm    Post subject: kde-base/nepomuk-9999 failed Reply with quote

Code:
[ 58%] [ 59%] Building CXX object nepomuk/kcm/CMakeFiles/kcm_nepomuk.dir/kcm_nepomuk_automoc.o                               
Building CXX object nepomuk/services/storage/CMakeFiles/nepomukstorage.dir/nepomukstorage_automoc.o                           
Linking CXX shared module ../../lib/kcm_nepomuk.so                                                                           
Linking CXX shared module ../../../lib/nepomukstorage.so                                                                     
[ 59%] Built target nepomukstorage                                                                                           
make[2]: *** No rule to make target `/var/tmp/portage/kde-base/nepomuk-9999/work/nepomuk/nepomuk/interfaces/org.kde.nepomuk.OntologyManager.xml', needed by `nepomuk/services/ontologyloader/ontologymanageradaptor.cpp'.  Stop.                           
make[1]: *** [nepomuk/services/ontologyloader/CMakeFiles/nepomukontologyloader.dir/all] Error 2                               
make[1]: *** Waiting for unfinished jobs....                                                                                 
[ 59%] Built target kcm_nepomuk                                                                                               
make: *** [all] Error 2                                                                                                       
 *                                                                                                                           
 * ERROR: kde-base/nepomuk-9999 failed.                                                                                       
 * Call stack:                                                                                                               
 *               ebuild.sh, line   49:  Called src_compile                                                                   
 *             environment, line 3095:  Called kde4overlay-meta_src_compile                                                   
 *             environment, line 2358:  Called kde4overlay-meta_src_make                                                     
 *             environment, line 2407:  Called kde4overlay-base_src_make                                                     
 *             environment, line 2118:  Called cmake-utils_src_make                                                           
 *             environment, line  770:  Called die                                                                           
 * The specific snippet of code:                                                                                             
 *           emake "$@" || die "Make failed!";                                                                               
 *  The die message:                                                                                                         
 *   Make failed!                                                                                                             
 *
Back to top
View user's profile Send private message
TNorthover
Guru
Guru


Joined: 25 Jan 2004
Posts: 434
Location: Edinburgh, UK

PostPosted: Wed Jul 30, 2008 6:35 pm    Post subject: Reply with quote

Having a bit of a problem with composite on my nvidia card. Doesn't seem to do anything in OpenGL mode, but works (in a limited way, obviously) under XRender. I'm fairly convinced the GL settings are correct because I can play 3d games fine, and haven't changed them since it all worked under 4.0 anyway.

Anyone encountered or heard of this issue before?
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Wed Jul 30, 2008 6:37 pm    Post subject: Reply with quote

TNorthover wrote:
Having a bit of a problem with composite on my nvidia card. Doesn't seem to do anything in OpenGL mode, but works (in a limited way, obviously) under XRender. I'm fairly convinced the GL settings are correct because I can play 3d games fine, and haven't changed them since it all worked under 4.0 anyway.

Anyone encountered or heard of this issue before?


There are a lot of issues with the NVidia proprietary drivers under kde4, you can find out more there :

http://techbase.kde.org/User:Lemma/KDE4-NVIDIA
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Wed Jul 30, 2008 6:48 pm    Post subject: Reply with quote

Code:
-----------------------------------------------------------------------------
-- The following external packages were located on your system.
-- This installation will have the extra features provided by these packages.
+ Soprano
+ Nepomuk
Congratulations! All external packages have been found.
-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/paludis/kde-base-nepomuk-4.1.0/work/nepomuk_build
make -j2
>>> Done src_compile
>>> Starting builtin_saveenv
>>> Done builtin_saveenv
>>> Completed ebuild phases loadenv unpack compile saveenv
>>> Running ebuild phases loadenv install saveenv as root:root...
>>> Starting builtin_loadenv
>>> Done builtin_loadenv
>>> Starting src_install
make -j2 install DESTDIR=/var/tmp/paludis/kde-base-nepomuk-4.1.0/image/
make: *** No rule to make target `install'.  Stop.
/usr/libexec/paludis/utils/emake: emake returned error 2

!!! ERROR in kde-base/nepomuk-4.1.0:
!!! In cmake-utils_src_install at line 1158
!!! Make install failed

!!! Call stack:
!!!    * cmake-utils_src_install (/var/tmp/paludis/kde-base-nepomuk-4.1.0/temp/loadsaveenv:1158)
!!!    * kde4overlay-meta_src_install (/var/tmp/paludis/kde-base-nepomuk-4.1.0/temp/loadsaveenv:3474)
!!!    * src_install (/var/tmp/paludis/kde-base-nepomuk-4.1.0/temp/loadsaveenv:4325)
!!!    * ebuild_f_install (/usr/libexec/paludis/0/src_install.bash:46)
!!!    * ebuild_main (/usr/libexec/paludis/ebuild.bash:463)
!!!    * main (/usr/libexec/paludis/ebuild.bash:478)

diefunc: making ebuild PID 1196 exit with error
die trap: exiting with error.

Install error:
  * In program paludis (--log-level warning --dl-reinstall if-use-changed --dl-reinstall-scm weekly --dl-downgrade warning --dl-blocks accumulate --show-reasons summary --show-use-descriptions changed --resume-command-template /tmp/palTMPXXXXXX --continue-on-failure if-satisfied --debug-build none) -i kde-base/dolphin:
  * When performing install action from command line:
  * When executing install task:
  * When installing 'kde-base/nepomuk-4.1.0:4.1::kde4-overlay':
  * Install error: Install failed for 'kde-base/nepomuk-4.1.0:4.1::kde4-overlay'


Nepomuk is needed for dolphin :cry:
Any idea how to resolve this ?

Thanks :)
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Wed Jul 30, 2008 6:52 pm    Post subject: Reply with quote

Well, it compiled fine for me yesterday... And I have almost the same setup than you (paludis, etc)... Strange 8O. Do someone know if the KDE team changed the nepomuk tarball ?
Back to top
View user's profile Send private message
Loibisch
Tux's lil' helper
Tux's lil' helper


Joined: 03 Jan 2006
Posts: 89

PostPosted: Wed Jul 30, 2008 7:11 pm    Post subject: Reply with quote

coolsnowmen wrote:
With 4.1 in a usable state (not perfect), and with 4.0 basically for.show.and.testing, I'd be surprised if developers were not working on it now, and if hard [M]asked ebuilds were not in the tree in under 2 weeks.

Yeah...welcome to Gentoo, the bleeding-edge distribution...everyone else has their distro-approved binary packages already but I wouldn't be surprised if the two weeks estimate wasn't too far off for Gentoo...
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Wed Jul 30, 2008 7:17 pm    Post subject: Reply with quote

Loibisch wrote:
coolsnowmen wrote:
With 4.1 in a usable state (not perfect), and with 4.0 basically for.show.and.testing, I'd be surprised if developers were not working on it now, and if hard [M]asked ebuilds were not in the tree in under 2 weeks.

Yeah...welcome to Gentoo, the bleeding-edge distribution...everyone else has their distro-approved binary packages already but I wouldn't be surprised if the two weeks estimate wasn't too far off for Gentoo...


Well, Gentoo is a choice... it's much harder to maintain a source-based distro supporting tons of different configurations than building binaries for 2 possible archs (x86 and x86_64).

Gentoo is really bleeding-edge when you use overlays :)
Back to top
View user's profile Send private message
NaiL
Apprentice
Apprentice


Joined: 13 Feb 2003
Posts: 228
Location: Spain/BCN

PostPosted: Wed Jul 30, 2008 7:46 pm    Post subject: Reply with quote

NaiL wrote:
How i can install KDE 4.1 (the final release)

I tried the keyword files and unmask from the Documentation directory but it tries to install the SVN version.

I'm using portage 2.1 and i don't want to change to 2.2 by now.

Thanks.


+1
Back to top
View user's profile Send private message
natros
n00b
n00b


Joined: 26 Sep 2003
Posts: 70

PostPosted: Wed Jul 30, 2008 8:18 pm    Post subject: Reply with quote

jeanfrancis wrote:
TNorthover wrote:
Having a bit of a problem with composite on my nvidia card. Doesn't seem to do anything in OpenGL mode, but works (in a limited way, obviously) under XRender. I'm fairly convinced the GL settings are correct because I can play 3d games fine, and haven't changed them since it all worked under 4.0 anyway.

Anyone encountered or heard of this issue before?


There are a lot of issues with the NVidia proprietary drivers under kde4, you can find out more there :

http://techbase.kde.org/User:Lemma/KDE4-NVIDIA

There is a new driver: 173.14.12
http://www.phoronix.com/scan.php?page=article&item=nvidia_173_14_12&num=1
_________________
-=[abit ip35 pro core2quad q6600 (oc 3.0 ghz) 8 gb ram 2x320 raid0 ext4 xfx8800gt 512mb]=-
Back to top
View user's profile Send private message
Marlo
Veteran
Veteran


Joined: 26 Jul 2003
Posts: 1413

PostPosted: Wed Jul 30, 2008 8:21 pm    Post subject: Reply with quote

@

Cordial owing to the developers for this good work.
Portage and kde4 trunk works very well.

Thanks again.

Ma
_________________
Thank you for your attention, interest and support.
------------------------------------------------------------------
http://radio.garden/
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Wed Jul 30, 2008 9:42 pm    Post subject: Reply with quote

jeanfrancis wrote:
Well, it compiled fine for me yesterday... And I have almost the same setup than you (paludis, etc)... Strange 8O. Do someone know if the KDE team changed the nepomuk tarball ?


Nepomuk is in kdebase-runtime-4.1.0.tar.bz2 tarball. I delete it and download it again... still the same :/
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...


Last edited by CryoGen on Wed Jul 30, 2008 11:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
wyvern
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2003
Posts: 99
Location: Victoria, B.C.

PostPosted: Wed Jul 30, 2008 9:53 pm    Post subject: KDE 4.1 Overlay not working Reply with quote

I followed the instructions for the 'unofficial' overlay from here:

http://gentoo-wiki.com/KDE4

Everything works fine until I get to the point where I have to actually emerge:

tombstone ~ # emerge -vat @kde-4.1

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "=net-voip/tapioca-qt-9999" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-voip/tapioca-qt-9999 (masked by: missing keyword)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


I've currently got ACCEPT_KEYWORDS="~amd64" set in my make.conf. (this is a 64-bit install). Any suggestions?
_________________
---
ex nihilo nihil fit
Back to top
View user's profile Send private message
coolsnowmen
Veteran
Veteran


Joined: 30 Jun 2004
Posts: 1479
Location: No.VA

PostPosted: Wed Jul 30, 2008 10:03 pm    Post subject: Re: KDE 4.1 Overlay not working Reply with quote

wyvern wrote:
..

!!! All ebuilds that could satisfy "=net-voip/tapioca-qt-9999" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-voip/tapioca-qt-9999 (masked by: missing keyword)

I've currently got ACCEPT_KEYWORDS="~amd64" set in my make.conf. (this is a 64-bit install). Any suggestions?

Yeah, you need the "**" keyword for this ebuild (like so many on the page you mentioned to followed)

when in doubt, look at the ebuild:
Quote:
grep KEYWORD /usr/portage/local/layman/kdesvn-portage/net-voip/tapioca-qt/tapioca-qt-9999.ebuild
KEYWORDS=""


EDIT: Looking at that page you reference again, it should have happened.
It says
Quote:
KDE 4.1 Only

Add the keywords for the overlay to your /etc/portage/package.keywords directory with: mkdir /etc/portage/package.keywords/kdesvn; ln -s /usr/local/portage/layman/kdesvn-portage/Documentation/portage/package.keywords/*-4.1.keywords /etc/portage/package.keywords/kdesvn/


and
Code:
package.keywords # grep tapioca *4.1*
kde-4.1.keywords:=net-libs/tapioca-qt-9999 **

/EDIT
_________________
emerge: there are no ebuilds to satisfy "moo"
Back to top
View user's profile Send private message
wyvern
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2003
Posts: 99
Location: Victoria, B.C.

PostPosted: Wed Jul 30, 2008 10:42 pm    Post subject: Re: KDE 4.1 Overlay not working Reply with quote

coolsnowmen wrote:

Yeah, you need the "**" keyword for this ebuild (like so many on the page you mentioned to followed)


That's what I suspected, and what I did, but doing it just yields a different error:

Code:
tombstone ~ # emerge -vat @kde-4.1

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-util/cmake-2.6.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/cmake-2.6.0 (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Marcus D. Hanwell <cryos@gentoo.org> (08 May 2008)
# Masking new version until it has received a little more testing


For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "net-libs/telepathy-qt-9999" [ebuild])


EDIT:

Ah, I see - this is a different problem entirely. Thanks for pointing that out.
_________________
---
ex nihilo nihil fit
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Thu Jul 31, 2008 2:37 am    Post subject: Reply with quote

neuron wrote:
all the symlinks for the package set kde 4.1 seems to have gone missing :/


Any one know if this is planned to be fixed? I mean will the keywords files for 4.1 be put back in the Documentation folder? Or should I try to recreate these?

[EDIT]
The following appears to have worked since I had 4.0.99 installed.

Code:
equery list kde-base/ | grep 4.0.99 | sed s'/-4.0.99//' | xargs -n1 -i echo {}:4.1 > /etc/portage/package.keywords/kde4.1


[/EDIT]
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 17, 18, 19 ... 28, 29, 30  Next
Page 18 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum