Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1 portage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 21, 22, 23 ... 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Aug 08, 2008 1:51 pm    Post subject: Reply with quote

that's not the error, scroll up your compile-log and search for "error" :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
lordcris
Apprentice
Apprentice


Joined: 09 Jul 2002
Posts: 248

PostPosted: Fri Aug 08, 2008 2:37 pm    Post subject: Reply with quote

kernelOfTruth wrote:
that's not the error, scroll up your compile-log and search for "error" :idea:



you are right, sorry.

Code:

var/tmp/portage/app-cdr/k3b-2.0_pre20080805/work/k3b-2.0_pre20080805/plugins/decoder/ffmpeg/k3bffmpegdecoder.cpp:24:28: error: ffmpeg/avcodec.h: No such file or directory
distcc[4395] ERROR: compile /var/tmp/portage/app-cdr/k3b-2.0_pre20080805/work/k3b-2.0_pre20080805/plugins/decoder/ffmpeg/k3bffmpegdecoder.cpp on lordcris failed
make[2]: *** [plugins/decoder/ffmpeg/CMakeFiles/k3bffmpegdecoder.dir/k3bffmpegdecoder.o] Error 1
make[1]: *** [plugins/decoder/ffmpeg/CMakeFiles/k3bffmpegdecoder.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 46%] [ 46%] Building CXX object plugins/d



EDIT

ok,
i emerged k3b with USE=-ffmpeg
and it compiled ok.
thanks
Back to top
View user's profile Send private message
Cleus
Apprentice
Apprentice


Joined: 21 Aug 2004
Posts: 157

PostPosted: Sat Aug 09, 2008 1:28 am    Post subject: Reply with quote

Svn bug?

Code:
* Exporting parts of working copy to /tmp/portage/kde-base/ktnef-9999/work/ktnef
rsync: link_stat "/data/distfiles/svn-src/KDE/kdepim/kdepim/ktnef" failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at main.c(1040) [sender=3.0.3]
 * ERROR: kde-base/ktnef-9999 failed.
Back to top
View user's profile Send private message
sab
n00b
n00b


Joined: 20 Feb 2007
Posts: 12
Location: London

PostPosted: Sun Aug 10, 2008 6:59 am    Post subject: Reply with quote

Could someone tell me what version is kdesvn-portage. I have started compiling it, but it looks to be 4.2.
Which overlay should I use if I want 4.1?
I guess a 4.1 wiki page will be awsome. There is one mixed with the rest of kde versions and not very useful.

Thanks
Sab
_________________
" Have you ever noticed that at trade shows Microsoft is always the one giving
away stress balls?"
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 276

PostPosted: Sun Aug 10, 2008 8:51 am    Post subject: Reply with quote

When using KDE 3.5 I used xbindkeys to map my multimedia laptop buttons to work together with amarok and kmix nicely using dcop. Now in KDE 4.1 dcop is replaced by dbus and I must admit I have no clue how this works. Using google to find some help also didn't give me anything useful.

So here are the things I used to do in KDE 3.5:
Quote:

#Volume up
"dcop kmix Mixer0 increaseVolume 1"
c:176

#Volume down"
"dcop kmix Mixer0 decreaseVolume 1"
c:174

"dcop amarok player playPause"
c:162

"dcop amarok player stop"
c:164

"dcop amarok player prev"
c:144

"dcop amarok player next"
c:153

Could anybody help me to get this working with dbus?
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Sun Aug 10, 2008 9:32 am    Post subject: Reply with quote

yngwin wrote:
Add an entry for text/xml to systemsettings > advanced > file associations


I have the same problem. However, there is no option for file associations in systemsettings. What package am I am missing?
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Sun Aug 10, 2008 9:33 am    Post subject: Reply with quote

And also, if someone could solve this problem of mine:

Code:

http://forums.gentoo.org/viewtopic-t-703551-highlight-.html

_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Sun Aug 10, 2008 10:16 am    Post subject: Reply with quote

rahulthewall3000 wrote:
And also, if someone could solve this problem of mine:

Code:

http://forums.gentoo.org/viewtopic-t-703551-highlight-.html


This problem is solved. One has to install gtk-kde4-theme and gtk-engines-qt, both from the kdesvn-portage overlay.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
mikkoc
Apprentice
Apprentice


Joined: 24 May 2007
Posts: 231

PostPosted: Sun Aug 10, 2008 10:20 am    Post subject: Reply with quote

Boccaccio wrote:
When using KDE 3.5 I used xbindkeys to map my multimedia laptop buttons to work together with amarok and kmix nicely using dcop. Now in KDE 4.1 dcop is replaced by dbus and I must admit I have no clue how this works. Using google to find some help also didn't give me anything useful.


Why bothering using dcop and kmix?

Here's mine:
Code:

# vol up                         
"amixer sset Master 1+ unmute"   
  XF86AudioRaiseVolume           
# vol dn                         
"amixer sset Master 1-"                                                                                                     
  XF86AudioLowerVolume                                                                                                       
# vol mute                                                                                                                   
"amixer -c 0 set Master togglemute"                                                                                         
  XF86AudioMute                                                                                                             
# play/pause
"amarok -t"
  XF86AudioPlay
# back
"amarok -r"
  XF86AudioPrev
# forward
"amarok -f"
  XF86AudioNext
# stop
"amarok -s"
  XF86AudioStop
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 276

PostPosted: Sun Aug 10, 2008 11:52 am    Post subject: Reply with quote

Thanks a lot, works like a charm!
Back to top
View user's profile Send private message
sab
n00b
n00b


Joined: 20 Feb 2007
Posts: 12
Location: London

PostPosted: Sun Aug 10, 2008 3:16 pm    Post subject: Reply with quote

Cleus wrote:
Svn bug?

Code:
* Exporting parts of working copy to /tmp/portage/kde-base/ktnef-9999/work/ktnef
rsync: link_stat "/data/distfiles/svn-src/KDE/kdepim/kdepim/ktnef" failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at main.c(1040) [sender=3.0.3]
 * ERROR: kde-base/ktnef-9999 failed.


I got exactly the same problem.
_________________
" Have you ever noticed that at trade shows Microsoft is always the one giving
away stress balls?"
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sun Aug 10, 2008 3:30 pm    Post subject: Reply with quote

sab wrote:
Cleus wrote:
Svn bug?

Code:
* Exporting parts of working copy to /tmp/portage/kde-base/ktnef-9999/work/ktnef
rsync: link_stat "/data/distfiles/svn-src/KDE/kdepim/kdepim/ktnef" failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at main.c(1040) [sender=3.0.3]
 * ERROR: kde-base/ktnef-9999 failed.


I got exactly the same problem.


++

Quote:
>>> Unpacking source...
* Fetching disabled since 1 hours has not passed since last update.
* Using existing repository copy at revision 844816.
* working copy: /data/distfiles/svn-src/KDE/kdepim/kdepim

* Exporting parts of working copy to /var/tmp/portage/kde-base/ktnef-9999/work/ktnef
rsync: link_stat "/data/distfiles/svn-src/KDE/kdepim/kdepim/ktnef" failed: No such file or directory (2)
rsync error: some files could not be transferred (code 23) at main.c(1040) [sender=3.0.3]
* ERROR: kde-base/ktnef-9999 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 3105: Called kde4svn-meta_src_unpack
* environment, line 2477: Called kde4svn-meta_src_extract
* environment, line 2464: Called die
* The specific snippet of code:
* rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
* The die message:
* subversion: can't export subdirectory 'ktnef' to '/var/tmp/portage/kde-base/ktnef-9999/work/ktnef/'.
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/log/portage/kde-base:ktnef-9999:20080810-152812.log'.
* The ebuild environment file is located at '/var/tmp/portage/kde-base/ktnef-9999/temp/environment'.
* This ebuild is from an overlay: '/usr/local/portage/kdesvn-portage/'

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
jeanfrancis
Veteran
Veteran


Joined: 17 Dec 2005
Posts: 1482
Location: Québec, Canada

PostPosted: Mon Aug 11, 2008 3:21 pm    Post subject: Reply with quote

sab wrote:
Could someone tell me what version is kdesvn-portage. I have started compiling it, but it looks to be 4.2.
Which overlay should I use if I want 4.1?
I guess a 4.1 wiki page will be awsome. There is one mixed with the rest of kde versions and not very useful.

Thanks
Sab


The SVN (live ebuilds) repository is the development of KDE 4.2.

To get KDE 4.1 "stable", you need to unmask and keywork only the 4.1 ebuilds (and not the -9999). You will find the needed files in the "Documentation/portage" folder in the overlay.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Tue Aug 12, 2008 9:13 am    Post subject: Reply with quote

Code:
[ 15%] Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/core/leavemodel.o                                     
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:29:29: error: kdisplaymanager.h: No such file or directory                                                                                                                   
[ 15%] Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/core/leavemodel.o                               
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:29:29: error: kdisplaymanager.h: No such file or directory                                                                                                                   
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp: In constructor ‘Kickoff::LeaveModel::LeaveModel(QObject*)’:                                                                                                                 
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:125: error: ‘KDisplayManager’ was not declared in this scope                                                                                                                 
make[2]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/core/leavemodel.o] Error 1                                         
make[1]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_launcher.dir/all] Error 2                                                       
make[1]: *** Waiting for unfinished jobs....                                                                                                   
[ 15%] Building CXX object plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/core/models.o                                   
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp: In constructor ‘Kickoff::LeaveModel::LeaveModel(QObject*)’:                                                                                                                 
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/kickoff/core/leavemodel.cpp:125: error: ‘KDisplayManager’ was not declared in this scope                                                                                                                 
make[2]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/core/leavemodel.o] Error 1                                   
make[2]: *** Waiting for unfinished jobs....                                                                                                   
make[1]: *** [plasma/applets/kickoff/CMakeFiles/plasma_applet_simplelauncher.dir/all] Error 2                                                 
make: *** [all] Error 2


HELP! :?
Back to top
View user's profile Send private message
sgao
Tux's lil' helper
Tux's lil' helper


Joined: 22 Apr 2006
Posts: 149

PostPosted: Tue Aug 12, 2008 4:28 pm    Post subject: Reply with quote

kdisplaymanager.h is from kde-base/libkworkspace at least for kde 4.1.0. Please check installation of libkworkspace.

Quote:

$ equery b /usr/kde/4.1/include/kworkspace/kdisplaymanager.h
[ Searching for file(s) /usr/kde/4.1/include/kworkspace/kdisplaymanager.h in *... ]
kde-base/libkworkspace-4.1.0 (/usr/kde/4.1/include/kworkspace/kdisplaymanager.h)


In your case, you may look in /usr/kde/svn/include/kworkspace for the header file. Re-emerge libkworkspace if needed.
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Tue Aug 12, 2008 5:01 pm    Post subject: Reply with quote

thanks, resolved.
now can you also help me with this? :-)

Code:
(Soprano::PluginManager) plugin has proper version.                                                                                           
(Soprano::PluginManager) found backend plugin  "redland"                                                                                       
(Soprano::PluginManager) searching plugin file from  "/usr/kde/svn/share/soprano/plugins"                                                     
(Soprano::PluginManager) searching plugin file from  "/usr/share/soprano/plugins"                                                             
(Soprano::PluginManager) found plugin file "/usr/share/soprano/plugins/nquadparser.desktop"                                                   
(Soprano::PluginManager) plugin has proper version.                                                                                           
(Soprano::PluginManager) found plugin file "/usr/share/soprano/plugins/nquadserializer.desktop"                                               
(Soprano::PluginManager) plugin has proper version.                                                                                           
(Soprano::PluginManager) found plugin file "/usr/share/soprano/plugins/raptorparser.desktop"                                                   
(Soprano::PluginManager) plugin has proper version.                                                                                           
(Soprano::PluginManager) found plugin file "/usr/share/soprano/plugins/raptorserializer.desktop"                                               
(Soprano::PluginManager) plugin has proper version.                                                                                           
(Soprano::PluginManager) found plugin file "/usr/share/soprano/plugins/redlandbackend.desktop"                                                 
(Soprano::PluginManager) plugin has proper version.                                                                                           
(Soprano::PluginManager) loaded plugin from "/usr/lib64/soprano/libsoprano_raptorparser.so"                                                   
-- Found KDE PIM libraries                                                                                                                     
-- Found Soprano: /usr/lib64/libsoprano.so                                                                                                     
-- Found Soprano includes: /usr/include                                                                                                       
-- Found Soprano Index: /usr/lib64/libsopranoindex.so                                                                                         
-- Found Soprano Client: /usr/lib64/libsopranoclient.so                                                                                       
-- Found Soprano Plugins: nquadparser nquadserializer raptorparser raptorserializer redlandbackend                                             
-- Found Plasma: /usr/kde/svn/lib64/libplasma.so                                                                                               
CMake Error at nepomuk-kde/konqueror/CMakeLists.txt:2 (add_subdirectory):                                                                     
  add_subdirectory given source "linkwidget" which is not an existing                                                                         
  directory.                                                                                                                                   


CMake Error at nepomuk-kde/CMakeLists.txt:35 (add_subdirectory):
  add_subdirectory given source "dolphin" which is not an existing directory.


-- Found Soprano: /usr/lib64/libsoprano.so
-- Found Soprano includes: /usr/include   
-- Found Soprano Index: /usr/lib64/libsopranoindex.so
-- Found Soprano Client: /usr/lib64/libsopranoclient.so
-- Found Soprano Plugins: nquadparser nquadserializer raptorparser raptorserializer redlandbackend
-- Configuring done                                                                               
 *                                                                                               
 * ERROR: kde-misc/nepomuk-kde-9999 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 3085:  Called kde4overlay-base_src_compile
 *             environment, line 2083:  Called kde4overlay-base_src_configure
 *             environment, line 2103:  Called cmake-utils_src_configureout
 *             environment, line  745:  Called die
 * The specific snippet of code:
 *       cmake ${cmakeargs} "${S}" || die "Cmake failed";
 *  The die message:
 *   Cmake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-misc/nepomuk-kde-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-misc/nepomuk-kde-9999/temp/environment'.
 *
Back to top
View user's profile Send private message
Bloodsurfer
Guru
Guru


Joined: 07 Dec 2005
Posts: 361
Location: Wolfstein, Germany (Rhineland-Palatinate)

PostPosted: Tue Aug 12, 2008 6:58 pm    Post subject: Reply with quote

I have a new problem too...

Code:
>>> Emerging (1 of 2) kde-base/kdemaildir-4.1.0
 * kdepim-4.1.0.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                                [ ok ]
 * checking ebuild checksums ;-) ...                                                                   [ ok ]
 * checking auxfile checksums ;-) ...                                                                  [ ok ]
 * checking miscfile checksums ;-) ...                                                                 [ ok ]
>>> Unpacking source...                                                                                     
Unpacking parts of kdepim-4.1.0.tar.bz2 to /usr/portage/tmp/portage/kde-base/kdemaildir-4.1.0/work           
>>> Source unpacked.                                                                                         
>>> Compiling source in /usr/portage/tmp/portage/kde-base/kdemaildir-4.1.0/work/kdemaildir-4.1.0 ...         
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc                                           
-- Check for working C compiler: /usr/bin/x86_64-pc-linux-gnu-gcc -- works                                   
-- Check size of void*                                                                                       
-- Check size of void* - done                                                                               
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++                                         
-- Check for working CXX compiler: /usr/bin/x86_64-pc-linux-gnu-g++ -- works                                 
-- Looking for Q_WS_X11                                                                                     
-- Looking for Q_WS_X11 - found                                                                             
-- Looking for Q_WS_WIN                                                                                     
-- Looking for Q_WS_WIN - not found.                                                                         
-- Looking for Q_WS_QWS                                                                                     
-- Looking for Q_WS_QWS - not found.                                                                         
-- Looking for Q_WS_MAC                                                                                     
-- Looking for Q_WS_MAC - not found.                                                                         
-- Found Qt-Version 4.4.1 (using /usr/bin/qmake)                                                             
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so                                                             
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found                                                     
-- Looking for gethostbyname                                                                                 
-- Looking for gethostbyname - found                                                                         
-- Looking for connect                                                                                       
-- Looking for connect - found                                                                               
-- Looking for remove                                                                                         
-- Looking for remove - found                                                                                 
-- Looking for shmat                                                                                         
-- Looking for shmat - found                                                                                 
-- Looking for IceConnectionNumber in ICE                                                                     
-- Looking for IceConnectionNumber in ICE - found                                                             
-- Found X11: /usr/lib64/libX11.so                                                                           
-- Looking for pthread.h                                                                                     
-- Looking for pthread.h - found                                                                             
-- Looking for pthread_create in pthreads                                                                     
-- Looking for pthread_create in pthreads - not found                                                         
-- Looking for pthread_create in pthread                                                                     
-- Looking for pthread_create in pthread - found                                                             
-- Found Automoc4: /usr/bin/automoc4                                                                         
-- Performing Test _OFFT_IS_64BIT                                                                             
-- Performing Test _OFFT_IS_64BIT - Success                                                                   
-- Performing Test HAVE_FPIE_SUPPORT                                                                         
-- Performing Test HAVE_FPIE_SUPPORT - Success                                                               
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL                                                           
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success                                                 
-- Performing Test __KDE_HAVE_GCC_VISIBILITY                                                                 
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success                                                       
-- Found Phonon: /usr/kde/4.1/lib64/libphonon.so                                                             
-- Found Phonon Includes: /usr/include/KDE;/usr/include                                                       
-- Found KDE 4.1 include dir: /usr/kde/4.1/include                                                           
-- Found KDE 4.1 library dir: /usr/kde/4.1/lib64                                                             
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/4.1/bin/kconfig_compiler                               
-- Found automoc4: /usr/bin/automoc4                                                                         
-- Found KDE PIM libraries                                                                                   
-- Boost version: 1.35.0                                                                                     
-- Found the following Boost libraries:                                                                       
CMake Error: Could not find Akonadi includes.                                                                 
-- Configuring done                                                                                           
 *                                                                                                           
 * ERROR: kde-base/kdemaildir-4.1.0 failed.                                                                   
 * Call stack:                                                                                               
 *               ebuild.sh, line   49:  Called src_compile                                                   
 *             environment, line 2979:  Called kde4overlay-meta_src_compile                                   
 *             environment, line 2338:  Called kde4overlay-meta_src_configure                                 
 *             environment, line 2344:  Called kde4overlay-base_src_configure                                 
 *             environment, line 2085:  Called cmake-utils_src_configureout                                   
 *             environment, line  727:  Called die                                                           
 * The specific snippet of code:                                                                             
 *       cmake ${cmakeargs} "${S}" || die "Cmake failed";
 *  The die message:
 *   Cmake failed


kdemaildir fails - it's a dependency of akonadi but seems to fail because it can't find akonadi???
kmail-4.1.0-r1 fails with the same error message, while 4.1.0 did compile fine...
_________________
SiberianSniper: my girlfriend's name ends with .c
Clete2: Uber geek! W00t! I'd rather have it end in .cpp... <insert name>.cpp
Dralnu: ...why not <name>.o? Then she's ready for linking...
SiberianSniper: or <name>.ko, so she's ready for insertion?
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Wed Aug 13, 2008 5:51 am    Post subject: Reply with quote

it's very annoyng when one package doesn't compile and one has to understand what is done and what is still to emerge, and continue...
Back to top
View user's profile Send private message
santaclaws
Apprentice
Apprentice


Joined: 05 Jan 2007
Posts: 161
Location: Deeper Underground

PostPosted: Wed Aug 13, 2008 11:25 am    Post subject: Reply with quote

I do have a strange problem.

I have kde-3.5.9 installed and now successfully emerged kde-4.1 via kdesvn-portage overlay.

But when I want to start kde-4.1 I get a message telling me that there is a problem with a symlink to .kde.

So what to do?

I do have a folder named .kde and one named .kde4.1. in my /home directory but Is it safe to create a symlink from .kde to -kde4.1? I have read something on gentoo.wiki that this could cause real problems.

Any hints, please?
_________________
Software is like sex. It is better when ist is free.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Aug 13, 2008 11:29 am    Post subject: Reply with quote

santaclaws wrote:
I do have a strange problem.

I have kde-3.5.9 installed and now successfully emerged kde-4.1 via kdesvn-portage overlay.

But when I want to start kde-4.1 I get a message telling me that there is a problem with a symlink to .kde.

So what to do?

I do have a folder named .kde and one named .kde4.1. in my /home directory but Is it safe to create a symlink from .kde to -kde4.1? I have read something on gentoo.wiki that this could cause real problems.

Any hints, please?


Quote:
ls -al | grep .kde
ls: cannot access .gvfs: Permission denied
-rw-rw---- 1 user user 287 2008-02-12 16:31 .gtkrc-2.0-kde
lrwxrwxrwx 1 user user 7 2008-07-14 21:09 .kde -> .kdesvn
drwxrwx--- 4 user user 192 2008-07-10 05:41 .kde3.5
drwxrwx--- 2 user user 48 2008-07-05 17:18 kde_bak
-rw------- 1 user user 350 2008-01-17 01:33 .kderc
drwxrwx--- 4 user user 224 2008-08-13 10:23 .kdesvn
drwxrwx--- 2 user user 72 2008-05-02 00:22 tmp-kde

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
morbus
Tux's lil' helper
Tux's lil' helper


Joined: 10 May 2004
Posts: 139
Location: Munich

PostPosted: Wed Aug 13, 2008 12:45 pm    Post subject: Reply with quote

is it possible to scroll through the virtual desktops using the mouse wheel? I loved that feature in kde3 and can't figure out how to configure the shortcuts properly in kde4...
Back to top
View user's profile Send private message
sonicbhoc
Veteran
Veteran


Joined: 24 Oct 2005
Posts: 1805
Location: In front of the computer screen

PostPosted: Wed Aug 13, 2008 3:10 pm    Post subject: Reply with quote

baeksu wrote:
ckx3009 wrote:
server still down since 4 days? what's happening?


I don't know why it's down, but I put up a snapshot (June 22th) of the portage overlay.

kdesvn-portage.2008-06-22.tar.bz2

Maybe someone will find that useful until the site comes back up.


Hey, I'm behind a retarded corporate firewall. Could you do me a favour and make a more recent snapshot for me? I can't get to the official website, I can't find any mirrors of it (aside from the one you posted), and rsync, git, svn and cvs are all b0rked because of the firewall, so I can't get it that way.
_________________
I'm too lazy to keep this stupid signature up to date, so here's something more interesting:
My friend Hetdegon can draw if you ask me.
Now using PClinuxOS on my laptop and Gentoo on my desktop and new laptop.
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Thu Aug 14, 2008 2:51 am    Post subject: Reply with quote

Here is a snapshot:
http://rapidshare.de/files/40231062/kdesvn-portage-2008-08-13.tar.bz2.html
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Bloodsurfer
Guru
Guru


Joined: 07 Dec 2005
Posts: 361
Location: Wolfstein, Germany (Rhineland-Palatinate)

PostPosted: Thu Aug 14, 2008 10:42 am    Post subject: Reply with quote

Oh... re-emerging akonadi-server solved my problem. I hadn't really noticed that it was installed...
_________________
SiberianSniper: my girlfriend's name ends with .c
Clete2: Uber geek! W00t! I'd rather have it end in .cpp... <insert name>.cpp
Dralnu: ...why not <name>.o? Then she's ready for linking...
SiberianSniper: or <name>.ko, so she's ready for insertion?
Back to top
View user's profile Send private message
santaclaws
Apprentice
Apprentice


Joined: 05 Jan 2007
Posts: 161
Location: Deeper Underground

PostPosted: Thu Aug 14, 2008 2:33 pm    Post subject: Reply with quote

kernelOfTruth wrote:
santaclaws wrote:
I do have a strange problem.

I have kde-3.5.9 installed and now successfully emerged kde-4.1 via kdesvn-portage overlay.

But when I want to start kde-4.1 I get a message telling me that there is a problem with a symlink to .kde.

So what to do?

I do have a folder named .kde and one named .kde4.1. in my /home directory but Is it safe to create a symlink from .kde to -kde4.1? I have read something on gentoo.wiki that this could cause real problems.

Any hints, please?


Quote:
ls -al | grep .kde
ls: cannot access .gvfs: Permission denied
-rw-rw---- 1 user user 287 2008-02-12 16:31 .gtkrc-2.0-kde
lrwxrwxrwx 1 user user 7 2008-07-14 21:09 .kde -> .kdesvn
drwxrwx--- 4 user user 192 2008-07-10 05:41 .kde3.5
drwxrwx--- 2 user user 48 2008-07-05 17:18 kde_bak
-rw------- 1 user user 350 2008-01-17 01:33 .kderc
drwxrwx--- 4 user user 224 2008-08-13 10:23 .kdesvn
drwxrwx--- 2 user user 72 2008-05-02 00:22 tmp-kde


Hi kerneloftruth,

I cannot get this symlink working. No plan.

KDE4.1 is always telling me:
Quote:
"~/.kde is not a symlink. Please move ~/.kde to ~/.kde3.5 (if appropriate) and symlink ~/.kde to it."


I am completely stuck.

On archlinux it is working properlz but this time gentoo has driven me into problems..

Cheers.
_________________
Software is like sex. It is better when ist is free.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 21, 22, 23 ... 28, 29, 30  Next
Page 22 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum