Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4.1 portage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 28, 29, 30  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
aTan
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jan 2007
Posts: 134
Location: Czech Republic (Ukraine)

PostPosted: Mon Sep 22, 2008 5:15 pm    Post subject: Reply with quote

Hi. I'm getting this error while compiling multimedia-kioslaves-4.1.67. What could it be? amd64, gcc-4.3.1, glibc-2.8, cdparanoia-3.10.2

Code:
[ 96%] Building CXX object kioslave/audiocd/plugins/lame/CMakeFiles/audiocd_encoder_lame.dir/audiocd_encoder_lame_automoc.o
Linking CXX shared module ../../../../lib/libaudiocd_encoder_lame.so
[ 96%] Built target kcm_cddb
Scanning dependencies of target kcm_audiocd
In file included from /var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp:30:
/usr/include/cdda_interface.h:87: error: expected unqualified-id before ‘private’
/usr/include/cdda_interface.h:87: error: expected ‘;’ before ‘private’
In file included from /var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp:45:
/usr/include/cdda_interface.h:87: error: expected unqualified-id before ‘private’
/usr/include/cdda_interface.h:87: error: expected ‘;’ before ‘private’
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp: In member function ‘virtual long int EncoderCda::read(int16_t*, int)’:
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp:62: warning: ‘QByteArray& QByteArray::setRawData(const char*, uint)’ is deprecated (declared at /usr/include/qt4/QtCore/qbytearray.h:325)
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp:64: warning: ‘void QByteArray::resetRawData(const char*, uint)’ is deprecated (declared at /usr/include/qt4/QtCore/qbytearray.h:327)
make[2]: *** [kioslave/audiocd/plugins/wav/CMakeFiles/audiocd_encoder_wav.dir/encodercda.o] Error 1
make[1]: *** [kioslave/audiocd/plugins/wav/CMakeFiles/audiocd_encoder_wav.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 98%] [100%] Building CXX object kioslave/audiocd/kcmaudiocd/CMakeFiles/kcm_audiocd.dir/kcmaudiocd.o
Building CXX object kioslave/audiocd/kcmaudiocd/CMakeFiles/kcm_audiocd.dir/kcm_audiocd_automoc.o
[100%] Built target audiocd_encoder_lame
Linking CXX shared module ../../../lib/kcm_audiocd.so
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp: In member function ‘void AudioCD::AudioCDProtocol::parseURLArgs(const KUrl&)’:
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp:950: warning: suggest explicit braces to avoid ambiguous ‘else’
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp: In member function ‘void AudioCD::AudioCDProtocol::loadSettings()’:
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp:984: warning: suggest explicit braces to avoid ambiguous ‘else’
[100%] Built target kcm_audiocd
make[2]: *** [kioslave/audiocd/CMakeFiles/kio_audiocd.dir/audiocd.o] Error 1
make[1]: *** [kioslave/audiocd/CMakeFiles/kio_audiocd.dir/all] Error 2
make: *** [all] Error 2
Back to top
View user's profile Send private message
Dusdan
n00b
n00b


Joined: 10 Mar 2008
Posts: 37

PostPosted: Mon Sep 22, 2008 6:28 pm    Post subject: Reply with quote

Hi,

I'm using 4.1.1, yesterday I compiled 4.1.67, everything seems to work fine besides audio. If I launch amarok, dragon or something that needs audio a popup with the text "The audio playback device HDA Intel (STAC92xx Analog) does not work. Falling back to default" appears and no sound is played.

With 4.1.1 everything works fine.

EDIT: ok, I emerged phonon-9999 and now it works.
Back to top
View user's profile Send private message
tom3q
n00b
n00b


Joined: 23 Sep 2008
Posts: 3

PostPosted: Tue Sep 23, 2008 12:07 pm    Post subject: Reply with quote

I'm trying to install a weekly snapshot of KDE 4.2 from kdesvn-portage and i'm getting following error:
Code:
emerge -avt @kde-4.2

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-base/ktnef:4.2".

I've updated eix database and it states that there is no ktnef:4.2 available...
Code:

eix ktnef
* kde-base/ktnef
     Available versions:  (3.5)  3.5.9 (~)3.5.10
        {arts debug elibc_FreeBSD kdeenablefinal xinerama}
     Homepage:            http://www.kde.org/
     Description:         KDE Viewer for mail attachments using TNEF format


EDIT:
After removing whole KDE 4.1, installation using kde-meta to pull all of KDE 4.2 ebuilds seems to work. However why doesn't kde-4.2 set work?
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3231
Location: Gainesville, Florida

PostPosted: Wed Sep 24, 2008 2:22 am    Post subject: Reply with quote

Anyone run into this on emerge @kdebase-svn? I tried removing the kdebase source in distfiles and re-checking out, but got the same error on libplasma. emerge --resume --skipfirst seems to be going OK ( now at 11 0f 21 remaining) but I need libplasma. :wink:

Code:
>>> Emerging (48 of 69) kde-base/libplasma-9999
 * checking ebuild checksums ;-) ...                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                  [ ok ]

 * WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!

>>> Unpacking source...
 * Fetching disabled since 1 hours has not passed since last update.
 * Using existing repository copy at revision 864128.
 * working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

 * Exporting parts of working copy to /var/tmp/portage/kde-base/libplasma-9999/work/libplasma
rsync: link_stat "/usr/portage/distfiles/svn-src/KDE/kdebase/kdebase/workspace/krunner/org.kde.krunner.Interface.xml" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.4]
 *
 * ERROR: kde-base/libplasma-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3022:  Called kde4svn-meta_src_unpack
 * environment, line 2405:  Called kde4svn-meta_src_extract
 * environment, line 2392:  Called die
 * The specific snippet of code:
 * rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 * The die message:
 * subversion: can't export subdirectory 'krunner/org.kde.krunner.Interface.xml' to '/var/tmp/portage/kde-base/libplasma-9999/work/libplasma/krunner'.
 *

EDIT: OK- should have expected this- plasma workspace failed:
Code:
>>> Emerging (14 of 21) kde-base/plasma-workspace-9999
 * checking ebuild checksums ;-) ...                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                  [ ok ]
>>> Unpacking source...
 * Fetching disabled since 1 hours has not passed since last update.
 * Using existing repository copy at revision 864134.
 * working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

 * Exporting parts of working copy to /var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace
rsync: link_stat "/usr/portage/distfiles/svn-src/KDE/kdebase/kdebase/workspace/krunner/org.kde.krunner.Interface.xml" failed: No such file or directory (2)
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.4]
 *
 * ERROR: kde-base/plasma-workspace-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3022:  Called kde4svn-meta_src_unpack
 * environment, line 2402:  Called kde4svn-meta_src_extract
 * environment, line 2389:  Called die
 * The specific snippet of code:
 * rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 * The die message:
 * subversion: can't export subdirectory 'krunner/org.kde.krunner.Interface.xml' to '/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/krunner'.

Guess plasma is messed up at svn- or is it something else I'm missing?

Well- krunner fails with a plasma related error, so that's it for tonight. :roll:
Code:
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:56:30: error: interfaceadaptor.h: No such file or directory
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp: In constructor 'Interface::Interface(Plasma::RunnerManager*, QWidget*)':
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:91: error: 'class Plasma::Svg' has no member named 'pixmap'
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:111: error: 'class Plasma::Svg' has no member named 'pixmap'
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:122: error: 'class Plasma::Svg' has no member named 'pixmap'
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp: In member function 'void Interface::themeUpdated()':
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:284: error: 'class Plasma::Svg' has no member named 'pixmap'
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:285: error: 'class Plasma::Svg' has no member named 'pixmap'
/var/tmp/portage/kde-base/krunner-9999/work/krunner/krunner/interface.cpp:286: error: 'class Plasma::Svg' has no member named 'pixmap'
make[2]: *** [krunner/CMakeFiles/kdeinit_krunner.dir/interface.o] Error 1
make[1]: *** [krunner/CMakeFiles/kdeinit_krunner.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 51%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/autologout.o
[ 53%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/main.o
[ 55%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/lockprocessadaptor.o
[ 57%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/ksmserver_interface.o
[ 59%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/kscreensaver_interface.o
[ 61%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/kxkb_interface.o
[ 63%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/kscreensaversettings.o
[ 65%] Building CXX object krunner/lock/CMakeFiles/krunner_lock.dir/krunner_lock_automoc.o
Linking CXX executable krunner_lock
[ 65%] Built target krunner_lock
make: *** [all] Error 2
 *
 * ERROR: kde-base/krunner-9999 failed.


Hmmm. looked on http://websvn.kde.org/trunk/KDE/kdebase/workspace/krunner/interface.cpp?view=log and that file mentioned in the first error out above no longer exists- the line referring to it was removed in r864136. Maybe I should have removed ALL of svn-src first before I tried the complete rebuild. kdelibs was built with a two week old source file. :roll:
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r2, gcc-9.1.0 kernel-5.0.14-gentoo USE=experimental
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Wed Sep 24, 2008 4:51 am    Post subject: Reply with quote

After I wrote layman -S and emerge -uD world, playground-plasma, kdesvn and some other packages were installed. Now I cannot start Kde anymore. Everytime I want to start, It crashes and says;

Quote:
Application: Plasma Workspace (plasma), signal SIGSEGV
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 0 (LWP 13944)]

Thread 2 (Thread 0xb6611b90 (LWP 13951)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0x44c111c6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#2 0x49cfd441 in QWaitCondition::wait () from /usr/lib/qt4/libQtCore.so.4
#3 0xb66269ee in ?? () from /usr/kde/svn/lib/kde4/plasma_wallpaper_image.so

Thread 1 (Thread 0xb7f3c6f0 (LWP 13944)):
#0 0xffffe424 in __kernel_vsyscall ()
#1 0x44b3abc6 in nanosleep () from /lib/libc.so.6
#2 0x44b3a9e7 in sleep () from /lib/libc.so.6
#3 0x4aded9c7 in ?? () from /usr/kde/svn/lib/libkdeui.so.5
#4 0x00000001 in ?? ()
#5 0x00000000 in ?? ()



rebuilding libplasma, plasma-workspace and plasma-apps did not help. Portage refuses to unmerge playground-plasma, saying it would be in the overlay.....

What can I do to get Kde working again?
Back to top
View user's profile Send private message
Benni123
Tux's lil' helper
Tux's lil' helper


Joined: 13 Mar 2005
Posts: 110

PostPosted: Wed Sep 24, 2008 9:40 am    Post subject: Reply with quote

I was able to avoid the crash by removing playground-plasma from /usr/portage/local/layman/kdesvn-portage/sets/kde-extras-svn and then unmerge playground-plasma.

Now I can work again with kde4.2.

It seems, that playground-plasma is not ready.
Back to top
View user's profile Send private message
z_sfeng
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 154
Location: Finland

PostPosted: Wed Sep 24, 2008 1:43 pm    Post subject: Failed to emerge kipi-plugins and digikam Reply with quote

Emerge kipi-plugins and digikam ant 4.2 branch failed.
Quote:

Scanning dependencies of target kipiplugins
[ 0%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kipiplugins_automoc.o
[ 1%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kpaboutdata.o
[ 2%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kpwriteimage.o
[ 2%] Building C object common/libkipiplugins/CMakeFiles/kipiplugins.dir/iccjpeg.o
[ 3%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/squeezedcombobox.o
[ 4%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/batchprogressdialog.o
[ 4%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/imagedialog.o
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:43:35: error: libkdcraw/dcrawbinary.h: No such file or directory
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp: In constructor ‘KIPIPlugins::ImageDialog::ImageDialog(QWidget*, KIPI::Interface*, bool, bool)’:
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:328: error: ‘KDcrawIface::DcrawBinary’ has not been declared
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:330: error: ‘DcrawBinary’ is not a member of ‘KDcrawIface’
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:337: error: ‘KDcrawIface::DcrawBinary’ has not been declared
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:339: error: ‘DcrawBinary’ is not a member of ‘KDcrawIface’
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:347: error: ‘KDcrawIface::DcrawBinary’ has not been declared
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:348: error: ‘DcrawBinary’ is not a member of ‘KDcrawIface’
make[2]: *** [common/libkipiplugins/CMakeFiles/kipiplugins.dir/imagedialog.o] Error 1
make[1]: *** [common/libkipiplugins/CMakeFiles/kipiplugins.dir/all] Error 2
make: *** [all] Error 2
*
* ERROR: media-plugins/kipi-plugins-20080714 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3002: Called die
* The specific snippet of code:
* emake || die "emake failed"
* The die message:
* emake failed


It's looking for dcrawbinary.h in libkdcraw. But seems there no such a file, even in libkdcraw-4.2 distfile tarball.
However, I found these files in libkdcraw-0.15 tarball from its homepage.
digikam-0.10.0-beta3 failed for same reason.

Is there something wrong with kdegraphics-4.2?
Back to top
View user's profile Send private message
claneys
n00b
n00b


Joined: 25 Sep 2008
Posts: 2

PostPosted: Thu Sep 25, 2008 12:17 pm    Post subject: Reply with quote

aTan wrote:
Hi. I'm getting this error while compiling multimedia-kioslaves-4.1.67. What could it be? amd64, gcc-4.3.1, glibc-2.8, cdparanoia-3.10.2

Code:
[ 96%] Building CXX object kioslave/audiocd/plugins/lame/CMakeFiles/audiocd_encoder_lame.dir/audiocd_encoder_lame_automoc.o
Linking CXX shared module ../../../../lib/libaudiocd_encoder_lame.so
[ 96%] Built target kcm_cddb
Scanning dependencies of target kcm_audiocd
In file included from /var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp:30:
/usr/include/cdda_interface.h:87: error: expected unqualified-id before ‘private’
/usr/include/cdda_interface.h:87: error: expected ‘;’ before ‘private’
In file included from /var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp:45:
/usr/include/cdda_interface.h:87: error: expected unqualified-id before ‘private’
/usr/include/cdda_interface.h:87: error: expected ‘;’ before ‘private’
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp: In member function ‘virtual long int EncoderCda::read(int16_t*, int)’:
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp:62: warning: ‘QByteArray& QByteArray::setRawData(const char*, uint)’ is deprecated (declared at /usr/include/qt4/QtCore/qbytearray.h:325)
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/plugins/wav/encodercda.cpp:64: warning: ‘void QByteArray::resetRawData(const char*, uint)’ is deprecated (declared at /usr/include/qt4/QtCore/qbytearray.h:327)
make[2]: *** [kioslave/audiocd/plugins/wav/CMakeFiles/audiocd_encoder_wav.dir/encodercda.o] Error 1
make[1]: *** [kioslave/audiocd/plugins/wav/CMakeFiles/audiocd_encoder_wav.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
[ 98%] [100%] Building CXX object kioslave/audiocd/kcmaudiocd/CMakeFiles/kcm_audiocd.dir/kcmaudiocd.o
Building CXX object kioslave/audiocd/kcmaudiocd/CMakeFiles/kcm_audiocd.dir/kcm_audiocd_automoc.o
[100%] Built target audiocd_encoder_lame
Linking CXX shared module ../../../lib/kcm_audiocd.so
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp: In member function ‘void AudioCD::AudioCDProtocol::parseURLArgs(const KUrl&)’:
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp:950: warning: suggest explicit braces to avoid ambiguous ‘else’
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp: In member function ‘void AudioCD::AudioCDProtocol::loadSettings()’:
/var/tmp/portage/portage/kde-base/kdemultimedia-kioslaves-4.1.67/work/kdemultimedia-kioslaves-4.1.67/kioslave/audiocd/audiocd.cpp:984: warning: suggest explicit braces to avoid ambiguous ‘else’
[100%] Built target kcm_audiocd
make[2]: *** [kioslave/audiocd/CMakeFiles/kio_audiocd.dir/audiocd.o] Error 1
make[1]: *** [kioslave/audiocd/CMakeFiles/kio_audiocd.dir/all] Error 2
make: *** [all] Error 2


downgrade your cdparanoia ebuild to 3.10.0. With cdparanoia-3.10.2, it's does'nt work.

First post \o/ ( useless i know... )

EDIT : for kipi-plugins, take libkdcraw with kdcrawbinary.h and copy to kipi-plugins/common/libkipiplugins of kipi-plugins source. But i have an other problem after :

Code:
emerge kipi-plugins             
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Emerging (1 of 1) media-plugins/kipi-plugins-20080714
 * checking ebuild checksums ;-) ...                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                       [ ok ]

 * WARNING! This is an experimental ebuild of the extragear/graphics KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!

>>> Unpacking source...
 * subversion update start -->
 * repository: svn://anonsvn.kde.org/home/kde/trunk/extragear/graphics/kipi-plugins@{20080714}
At revision 832032.
 * working copy: /usr/portage/distfiles/svn-src/KDE/extragear/graphics/kipi-plugins

 * Applying kipi-plugins-20080714-fix.patch ...                                                                               [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714 ...
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc
-- Check for working C compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++
-- Check for working CXX compiler: /usr/lib/ccache/bin/x86_64-pc-linux-gnu-g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.4.2 (using /usr/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so
-- Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so;/usr/lib64/libXft.so;/usr/lib64/libXau.so;/usr/lib64/libXdmcp.so;/usr/lib64/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib64/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Automoc4: /usr/bin/automoc4
-- Found Perl: /usr/bin/perl
-- Adding /usr/share/apps/cmake/modules to CMAKE_MODULE_PATH
-- Performing Test _OFFT_IS_64BIT
-- Performing Test _OFFT_IS_64BIT - Success
-- Performing Test HAVE_FPIE_SUPPORT
-- Performing Test HAVE_FPIE_SUPPORT - Success
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL
-- Performing Test __KDE_HAVE_W_OVERLOADED_VIRTUAL - Success
-- Performing Test __KDE_HAVE_GCC_VISIBILITY
-- Performing Test __KDE_HAVE_GCC_VISIBILITY - Success
-- Found Phonon: /usr/lib64/libphonon.so
-- Found Phonon Includes: /usr/include/KDE;/usr/include
-- Found KDE 4.2 include dir: /usr/kde/4.2/include
-- Found KDE 4.2 library dir: /usr/kde/4.2/lib64
-- Found KDE4 kconfig_compiler preprocessor: /usr/kde/4.2/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Check Kexiv2 library in local sub-folder...
-- Check Kexiv2 library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkexiv2 release >= 0.2.0
-- Found libkexiv2: /usr/kde/4.2/lib64/libkexiv2.so
-- Check Kdcraw library in local sub-folder...
-- Check Kdcraw library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkdcraw release >= 0.2.0
-- Found libkdcraw: /usr/kde/4.2/lib64/libkdcraw.so
-- Check Kipi library in local sub-folder...
-- Check Kipi library using pkg-config...
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found libkipi release >= 0.2.0
-- Found libkipi: /usr/kde/4.2/lib64/libkipi.so
-- Found JPEG: /usr/lib64/libjpeg.so
-- Found ZLIB: /lib64/libz.so
-- Found PNG: /usr/lib64/libpng.so
-- Found TIFF: /usr/include
-- Found X11: /usr/lib64/libX11.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found LibXml2: /usr/lib64/libxml2.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found LibXslt: /usr/lib64/libxslt.so
-- cmake package FindKSane.cmake was not found. This package needs ksane to be compile all program
-- Configuring done
-- Generating done
-- Build files have been written to: /var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714
Generating batchprogressdialog.moc
Generating imagedialog.moc
Generating squeezedcombobox.moc
Scanning dependencies of target kipiplugins
[  1%] [  2%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kpaboutdata.o
[  2%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kpwriteimage.o
Building C object common/libkipiplugins/CMakeFiles/kipiplugins.dir/iccjpeg.o
[  3%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/squeezedcombobox.o
[  4%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/batchprogressdialog.o
[  4%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/imagedialog.o
[  4%] Building CXX object common/libkipiplugins/CMakeFiles/kipiplugins.dir/kipiplugins_automoc.o
In file included from /var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/imagedialog.cpp:43:
/usr/include/qt4/QtCore/qobject.h:258: warning: 'virtual void QObject::customEvent(QEvent*)' was hidden
/var/tmp/portage/media-plugins/kipi-plugins-20080714/work/kipi-plugins-20080714/common/libkipiplugins/libkdcraw/kdcraw.h:188: warning:   by 'virtual void KDcrawIface::KDcraw::customEvent(QCustomEvent*)'
Linking CXX shared library ../../lib/libkipiplugins.so
CMakeFiles/kipiplugins.dir/imagedialog.o: In function `KIPIPlugins::ImageDialog::ImageDialog(QWidget*, KIPI::Interface*, bool, bool)':
imagedialog.cpp:(.text+0xb6c): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0xb74): undefined reference to `KDcrawIface::DcrawBinary::versionIsRight() const'
imagedialog.cpp:(.text+0xb81): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0xb89): undefined reference to `KDcrawIface::DcrawBinary::versionIsRight() const'
imagedialog.cpp:(.text+0xd7d): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0xd85): undefined reference to `KDcrawIface::DcrawBinary::versionIsRight() const'
imagedialog.cpp:(.text+0xe76): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0xe81): undefined reference to `KDcrawIface::DcrawBinary::rawFiles()'
imagedialog.cpp:(.text+0xf8a): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0xf8f): undefined reference to `KDcrawIface::DcrawBinary::rawFiles()'
imagedialog.cpp:(.text+0x110f): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x1114): undefined reference to `KDcrawIface::DcrawBinary::rawFiles()'
CMakeFiles/kipiplugins.dir/imagedialog.o: In function `KIPIPlugins::ImageDialog::ImageDialog(QWidget*, KIPI::Interface*, bool, bool)':
imagedialog.cpp:(.text+0x14d4): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x14dc): undefined reference to `KDcrawIface::DcrawBinary::versionIsRight() const'
imagedialog.cpp:(.text+0x14e9): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x14f1): undefined reference to `KDcrawIface::DcrawBinary::versionIsRight() const'
imagedialog.cpp:(.text+0x16e5): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x16ed): undefined reference to `KDcrawIface::DcrawBinary::versionIsRight() const'
imagedialog.cpp:(.text+0x17e1): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x17e6): undefined reference to `KDcrawIface::DcrawBinary::rawFiles()'
imagedialog.cpp:(.text+0x18f1): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x18f6): undefined reference to `KDcrawIface::DcrawBinary::rawFiles()'
imagedialog.cpp:(.text+0x1a75): undefined reference to `KDcrawIface::DcrawBinary::instance()'
imagedialog.cpp:(.text+0x1a7a): undefined reference to `KDcrawIface::DcrawBinary::rawFiles()'
collect2: ld returned 1 exit status
make[2]: *** [lib/libkipiplugins.so.1.0.0] Error 1
make[1]: *** [common/libkipiplugins/CMakeFiles/kipiplugins.dir/all] Error 2
make: *** [all] Error 2
 *
 * ERROR: media-plugins/kipi-plugins-20080714 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 3052:  Called die
 * The specific snippet of code:
 * emake || die "emake failed"
 * The die message:
 * emake failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-plugins/kipi-plugins-20080714/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-plugins/kipi-plugins-20080714/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *

>>> Failed to emerge media-plugins/kipi-plugins-20080714, Log file:

>>>  '/var/tmp/portage/media-plugins/kipi-plugins-20080714/temp/build.log'



Last edited by claneys on Thu Sep 25, 2008 1:19 pm; edited 1 time in total
Back to top
View user's profile Send private message
TheCat
Tux's lil' helper
Tux's lil' helper


Joined: 20 Feb 2004
Posts: 139
Location: Belarus

PostPosted: Thu Sep 25, 2008 1:17 pm    Post subject: Reply with quote

after updating to 4.1.67 I can't start kopete
I'm getting this in console:
Code:
$ kopete
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
Calling appendChild() on a null node does nothing.
kopete(15718)/libkopete Kopete::PluginManager::loadPluginInternal: Unable to find a plugin named ' "" '!
Calling appendChild() on a null node does nothing.                                                       
Calling appendChild() on a null node does nothing.                                                       
kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."                   

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

Object::connect: Parentheses expected, signal QSslSocket::QAbstractSocket::SocketError
Object::connect: No such signal QSslSocket::closed()
Object::connect: Parentheses expected, signal QSslSocket::QAbstractSocket::SocketError
Object::connect: No such signal QSslSocket::closed()
Object::connect: Parentheses expected, signal QSslSocket::QAbstractSocket::SocketError
Object::connect: No such signal QSslSocket::closed()
kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."

kopete(15718): Couldn't start kwalletd:  "Could not find service 'kwalletd.desktop'."


and if I click on tray icon it crash with this:
Code:
This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7fcecf838700 (LWP 15718)]
[New Thread 0x4149a950 (LWP 15720)]
[New Thread 0x40c99950 (LWP 15719)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00007fcec9bd87e1 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 15718)]

Thread 3 (Thread 0x40c99950 (LWP 15719)):
#0  0x00007fcec9c000c2 in select () from /lib/libc.so.6
#1  0x00007fcecb323cad in QEventDispatcherUNIX::select () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007fcecb3243d3 in QEventDispatcherUNIXPrivate::doSelect () from /usr/lib64/qt4/libQtCore.so.4
#3  0x00007fcecb325029 in QEventDispatcherUNIX::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fcecb2f3bbb in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007fcecb2f3c95 in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#6  0x00007fcebf7887ff in QCA::SyncThread::run () from /usr/lib64/qca2/libqca.so.2
#7  0x00007fcecb1c8dd1 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#8  0x00007fcecaf57047 in start_thread () from /lib/libpthread.so.0
#9  0x00007fcec9c0628d in clone () from /lib/libc.so.6
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x4149a950 (LWP 15720)):
#0  0x00007fcecaf5b6a6 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fcecb1c9285 in QWaitCondition::wait () from /usr/lib64/qt4/libQtCore.so.4
#2  0x00007fcecc6af48b in ?? () from /usr/lib64/qt4/libQtNetwork.so.4
#3  0x00007fcecb1c8dd1 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007fcecaf57047 in start_thread () from /lib/libpthread.so.0
#5  0x00007fcec9c0628d in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcecf838700 (LWP 15718)):
#0  0x00007fcec9bd87e1 in nanosleep () from /lib/libc.so.6
#1  0x00007fcec9bd8604 in sleep () from /lib/libc.so.6
#2  0x00007fcecd240879 in ?? () from /usr/kde/4.2/lib64/libkdeui.so.5
#3  0x00007fcecd240fcb in KCrash::defaultCrashHandler () from /usr/kde/4.2/lib64/libkdeui.so.5
#4  <signal handler called>
#5  0x00007fcecbaa1344 in QMovie::state () from /usr/lib64/qt4/libQtGui.so.4
#6  0x00000000004476a3 in ?? ()
#7  0x0000000000447f01 in ?? ()
#8  0x00007fcecb309a0e in QMetaObject::activate () from /usr/lib64/qt4/libQtCore.so.4
#9  0x00007fcecbfe86ba in QSystemTrayIcon::activated () from /usr/lib64/qt4/libQtGui.so.4
#10 0x00007fcecbfdf178 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#11 0x00007fcecba36d62 in QWidget::event () from /usr/lib64/qt4/libQtGui.so.4
#12 0x00007fcecbfdf346 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007fcecb9e66d9 in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#14 0x00007fcecb9e6f83 in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#15 0x00007fcecd1ec51c in KApplication::notify () from /usr/kde/4.2/lib64/libkdeui.so.5
#16 0x00007fcecb2f44db in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007fcecb9ee5d2 in QApplicationPrivate::sendMouseEvent () from /usr/lib64/qt4/libQtGui.so.4
#18 0x00007fcecba4ae81 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#19 0x00007fcecba49790 in QApplication::x11ProcessEvent () from /usr/lib64/qt4/libQtGui.so.4
#20 0x00007fcecba70131 in ?? () from /usr/lib64/qt4/libQtGui.so.4
#21 0x00007fcecb2f3bbb in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#22 0x00007fcecb2f3c95 in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007fcecb2f5a72 in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#24 0x0000000000445c46 in ?? ()
#25 0x00007fcec9b63b74 in __libc_start_main () from /lib/libc.so.6
#26 0x0000000000424479 in _start ()
#0  0x00007fcec9bd87e1 in nanosleep () from /lib/libc.so.6
Back to top
View user's profile Send private message
claneys
n00b
n00b


Joined: 25 Sep 2008
Posts: 2

PostPosted: Thu Sep 25, 2008 1:37 pm    Post subject: Reply with quote

For libplasma-9999 rsync link stat error, edit the ebuild and change org.kde.krunner.Interface.xml into org.kde.krunner.App.xml
Idem for plasma-workspace-9999

Code:
>>> Emerging (2 of 41) kde-base/libplasma-9999
 * checking ebuild checksums ;-) ...                                                                                         [ ok ]
 * checking auxfile checksums ;-) ...                                                                                        [ ok ]
 * checking miscfile checksums ;-) ...                                                                                       [ ok ]

 * WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!

>>> Unpacking source...
 * Fetching disabled since 1 hours has not passed since last update.
 * Using existing repository copy at revision 864781.
 * working copy: /usr/portage/distfiles/svn-src/KDE/kdebase/kdebase

 * Exporting parts of working copy to /var/tmp/portage/kde-base/libplasma-9999/work/libplasma
[color=red]rsync: link_stat "/usr/portage/distfiles/svn-src/KDE/kdebase/kdebase/workspace/krunner/org.kde.krunner.Interface.xml" failed: No such file or directory (2)[/color]
rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1040) [sender=3.0.4]
 *
 * ERROR: kde-base/libplasma-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3093:  Called kde4svn-meta_src_unpack
 * environment, line 2467:  Called kde4svn-meta_src_extract
 * environment, line 2454:  Called die
 * The specific snippet of code:
 * rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 * The die message:
 * subversion: can't export subdirectory 'krunner/org.kde.krunner.Interface.xml' to '/var/tmp/portage/kde-base/libplasma-9999/work/libplasma/krunner'.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/libplasma-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/libplasma-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *

>>> Failed to emerge kde-base/libplasma-9999, Log file:

>>>  '/var/tmp/portage/kde-base/libplasma-9999/temp/build.log'

 * Messages for package kde-base/kcheckpass-9999:

 * WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!

 * Messages for package kde-base/libplasma-9999:

 * WARNING! This is an experimental ebuild of the kdebase-workspace KDE4 SVN tree.
 * Use at your own risk. Do _NOT_ file bugs at bugs.gentoo.org because
 * of this ebuild!
 *
 * ERROR: kde-base/libplasma-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_unpack
 * environment, line 3093:  Called kde4svn-meta_src_unpack
 * environment, line 2467:  Called kde4svn-meta_src_extract
 * environment, line 2454:  Called die
 * The specific snippet of code:
 * rsync --recursive ${rsync_options} "${ESVN_WC_PATH}/${kmnamedir}${subdir%/}" "${S}/${targetdir}" || die "${ESVN}: can't export subdirectory '${subdir}' to '${S}/${targetdir}'.";
 * The die message:
 * subversion: can't export subdirectory 'krunner/org.kde.krunner.Interface.xml' to '/var/tmp/portage/kde-base/libplasma-9999/work/libplasma/krunner'.
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/libplasma-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/libplasma-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *

 * GNU info directory index is up-to-date.
Back to top
View user's profile Send private message
benneque
Tux's lil' helper
Tux's lil' helper


Joined: 01 Dec 2007
Posts: 134

PostPosted: Thu Sep 25, 2008 3:49 pm    Post subject: Reply with quote

what's up with phonon ?
portage wants to unmerge phonon-xine ... is it safe ? .. or do i miss sound afterwards ?
Back to top
View user's profile Send private message
body
n00b
n00b


Joined: 27 Jun 2004
Posts: 41

PostPosted: Thu Sep 25, 2008 3:53 pm    Post subject: Reply with quote

plasma-workspace-9999 error
Code:

her.dir/recentadaptor.o
Linking CXX shared module ../../../lib/plasma_applet_simplelauncher.so
Linking CXX shared module ../../../lib/plasma_applet_launcher.so
[ 35%] Built target plasma_applet_simplelauncher
[ 35%] Built target plasma_applet_launcher
make: *** [all] Error 2
 *
 * ERROR: kde-base/plasma-workspace-9999 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 3080:  Called kde4overlay-meta_src_compile
 * environment, line 2353:  Called kde4overlay-meta_src_make
 * environment, line 2402:  Called kde4overlay-base_src_make
 * environment, line 2111:  Called cmake-utils_src_make
 * environment, line  755:  Called die
 * The specific snippet of code:
 * emake "$@" || die "Make failed!";
 * The die message:
 * Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/plasma-workspace-9999/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/plasma-workspace-9999/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/kdesvn-portage/'
 *

>>> Failed to emerge kde-base/plasma-workspace-9999, Log file:


bulid.log
Code:

In file included from /var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/libs/taskmanager/taskmanager.h:30,
                 from /var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/tasks/windowtaskitem.h:26,
                 from /var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/plasma/applets/tasks/windowtaskitem.cpp:22:
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/libs/taskmanager/task.h:76: error: expected ',' or '...' before 'READ'
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/libs/taskmanager/task.h:76: error: ISO C++ forbids declaration of 'Q_PSOPERTY' with no type
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/libs/taskmanager/task.h:94: error: expected ';' before 'public'
/var/tmp/portage/kde-base/plasma-workspace-9999/work/plasma-workspace/libs/taskmanager/task.h:424: warning: non-static const member 'TaskManager::Task::Private* const TaskManager::Task::d' in class without a constructor
[ 20%]
Back to top
View user's profile Send private message
Cleus
Apprentice
Apprentice


Joined: 21 Aug 2004
Posts: 157

PostPosted: Fri Sep 26, 2008 4:50 pm    Post subject: Reply with quote

*svn packets removed from kdesvn-portage/Documentation/portage/package.unmask/ ?

Code:
!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
dev-util/kdesvn:kde-svn app-cdr/k9copy:kde-svn kde-base/ksystemlog:kde-svn media-sound/amarok:4.2 net-misc/smb4k:kde-svn net-im/kmess:4.2 kde-base/knetworkconf:kde-svn kde-base/kcron:kde-svn kde-misc/yakuake:4.2 kde-base/kuser:kde-svn
Back to top
View user's profile Send private message
Cottonee
n00b
n00b


Joined: 23 Sep 2003
Posts: 73
Location: Palmerston North, New Zealand

PostPosted: Fri Sep 26, 2008 8:31 pm    Post subject: Reply with quote

Hi
I have problem start amarok v1.9999 from kdesvn-portage.
Code:
 /usr/kde/4.2/bin/amarok --version
Qt: 4.4.2
KDE: 4.1.67 (KDE 4.1.67 (KDE 4.2 >= 20080918))
Amarok: 2.0-SVN

Here is the error message
Code:
/usr/kde/4.2/bin/amarok                                     
setting xine verbosity to 0                                               
Using Xine version  1.1.15                                                 
isEmpty                                                                   
outputPlugin:  alsa
outputPlugin:  oss
outputPlugin:  file
outputPlugin:  none
Phonon::Xine::Backend(0x816ade8) 0
################################ Event:  TransitionTypeChanged
Phonon::Xine::MediaObject(0x8124eb8) -> Phonon::Xine::AudioOutput(0x81231a0)
0x80e4608 -> AudioOutput(0x8120718)
stored audio port is invalid

UpdateVolumeEvent
################################ Event:  SetTickInterval
################################ Event:  SetPrefinishMark
################################ Event:  UpdateVolume
XineThread Rewire event:
      MediaObject(0x80e4608)  ->  AudioOutput(0x8120718)
################################ Event:  SetTickInterval
QObject::connect: Cannot connect (null)::rowsInserted( const QModelIndex&, int, int ) to Playlist::RowList::rowsInserted( const QModelIndex &, int, int )
QObject::connect: Cannot connect (null)::rowsRemoved( const QModelIndex&, int, int ) to Playlist::RowList::rowsRemoved( const QModelIndex&, int, int )
QObject::connect: Cannot connect (null)::rowMoved( int, int ) to Playlist::RowList::rowMoved( int, int )
QCoreApplication::postEvent: Unexpected null receiver
################################ Event:  SetPrefinishMark
080926 14:46:37  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name /var/lib/mysql/ibdata1
InnoDB: File operation call: 'create'.
InnoDB: Cannot continue operation.
<unknown program name>(4522)/: Communication problem with  "amarok" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

I have kde-base/phonon-kde v4.1.67 and media-sound/phonon v.9999 installed. The last error message was about MySQL InnoDB. Is that the problem that prevent amarok to start? Did I missing anything? Can anyone help me?
Cheers
-Nat
Back to top
View user's profile Send private message
rahulthewall
Veteran
Veteran


Joined: 01 Nov 2007
Posts: 1264
Location: Zürich

PostPosted: Fri Sep 26, 2008 8:35 pm    Post subject: Reply with quote

Guys, I have a very weird problem here. I installed kde-4.1 first from the overlay kde-testing and now from the overlay kdesvn-portage. In both cases, I have the peculiar problem that the notification icons that appear in the panel (through the widget system tray) are messed up. I do not see the icons for applications there, I just see the kde plasma icon being repeated overlapping for each application's icons that should be there.
If some one has any suggestion to this extremely annoying problem, please help me.
_________________
Who shall guard the guards?
Back to top
View user's profile Send private message
Krog
Guru
Guru


Joined: 26 Jun 2007
Posts: 330
Location: Roma, Italy

PostPosted: Sat Sep 27, 2008 8:50 am    Post subject: Reply with quote

i've switched to 4.2 and now i have 2 problems:

1)plasmoids don't save their position, very annoying

2)no audio support.

this is my situation:

Code:
*  kde-base/phonon-kde
      Latest version available: 4.1.67
      Latest version installed: 4.1.67
      Size of files: 56,939 kB       
      Homepage:      http://www.kde.org/
      Description:   phonon KDE integration
      License:       GPL-2                 

*  media-sound/phonon
      Latest version available: 9999
      Latest version installed: 9999
      Size of files: 0 kB           
      Homepage:      http://phonon.kde.org
      Description:   KDE multimedia API   
      License:       GPL-2               

*  x11-libs/qt-phonon
      Latest version available: 4.4.2
      Latest version installed: [ Not Installed ]
      Size of files: 102,857 kB                 
      Homepage:      http://www.trolltech.com/   
      Description:   The Phonon module for the Qt toolkit.
      License:       || ( GPL-3 GPL-2 )
Back to top
View user's profile Send private message
laughinggnome
n00b
n00b


Joined: 07 Mar 2006
Posts: 45

PostPosted: Sat Sep 27, 2008 6:55 pm    Post subject: Reply with quote

Cottonee wrote:
Hi
I have problem start amarok v1.9999 from kdesvn-portage...


I had the same problem, but a couple of recent changes to Amarok have fixed it. However, now I can't build a collection. I get this:

Code:
amarok:      [ERROR!] Tried to perform insert on uninitialized MySQLe
amarok:      [ERROR!] Tried to perform query on uninitialized MySQLe


repeated over and over again.

Cheers.
Back to top
View user's profile Send private message
Cottonee
n00b
n00b


Joined: 23 Sep 2003
Posts: 73
Location: Palmerston North, New Zealand

PostPosted: Sun Sep 28, 2008 7:10 am    Post subject: Reply with quote

laughinggnome wrote:
Cottonee wrote:
Hi
I have problem start amarok v1.9999 from kdesvn-portage...


I had the same problem, but a couple of recent changes to Amarok have fixed it. However, now I can't build a collection. I get this:

Code:
amarok:      [ERROR!] Tried to perform insert on uninitialized MySQLe
amarok:      [ERROR!] Tried to perform query on uninitialized MySQLe


repeated over and over again.

Cheers.
OK.. I had the same problem as yours. First, I can't even compile Amarok. But after do "layman -S" again yesterday I can compile it. However Amarok couldn't find any song (MySQL error problem, same as yours). Today, I manage to fix it by not using MySQL but use SQLite instead (-mysql USE flag doesn't work). All I did was, remove Mysql from system (just FORCE it --no need to worry about dep, we will put it back later, and make sure that you have SQLite in your box) then compile Amarok manually. But before compile I add "set(CMAKE_INSTALL_PREFIX "/usr/kde/4.2")" to CMakeLists.txt to make it install to KDE 4.2 root path. Then extract file and compile with
Code:
cmake .
make
make install

After installed, Amarok went fine and can scan and found all my songs BUT NO AUDIO. I think sound is another problem issue related to 4.2. I had sound with 4.1.1 but not 4.2
-Nat
p.s. Don't forget to reinstall MySQL back to your system after compile Amarok
Back to top
View user's profile Send private message
Boccaccio
Apprentice
Apprentice


Joined: 19 Jul 2005
Posts: 276

PostPosted: Sun Sep 28, 2008 9:14 am    Post subject: Reply with quote

After doing a layman -S I wanted to emerge -uDNva world right now, but I get the following error

Quote:

Calculating world dependencies |
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

dev-libs/soprano:0

('installed', '/', 'dev-libs/soprano-2.1', 'nomerge') pulled in by
('installed', '/', 'kde-base/nepomuk-4.1.67', 'nomerge')

('ebuild', '/', 'dev-libs/soprano-2.0.2', 'merge') pulled in by
('installed', '/', 'kde-base/kdelibs-4.1.67', 'nomerge')
('installed', '/', 'media-sound/amarok-1.9999', 'nomerge')


So what should I do in order to solve this?
Back to top
View user's profile Send private message
AnXa
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 250

PostPosted: Sun Sep 28, 2008 1:53 pm    Post subject: Reply with quote

I haven't run Gentoo for a while so I got to ask about portage here.

I kde 4.1 in portage officially now? If I install gentoo and start emerge kde on it will it install kde 4.1?
_________________
The idea isn't about how do you see or hear it, it's about how do you experience it...
Back to top
View user's profile Send private message
ok
Guru
Guru


Joined: 11 Jul 2006
Posts: 390
Location: germany

PostPosted: Sun Sep 28, 2008 2:39 pm    Post subject: Reply with quote

@AnXa: No. http://packages.gentoo.org/category/kde-base?full_cat
Back to top
View user's profile Send private message
TemplarKnight
Guru
Guru


Joined: 14 Jun 2005
Posts: 311
Location: Greece/patras/

PostPosted: Sun Sep 28, 2008 5:02 pm    Post subject: what is wrong? Reply with quote

Is something wrong with the overlay?
I had portage 2.1.4.4 earlier today and emerges where complaining, e.g.

emerge kdm:4

Code:

 * Overlay eclasses override eclasses from PORTDIR:
 *
 *   '/usr/portage/local/layman/kde-testing/eclass/kde4-base.eclass'
 *   '/usr/portage/local/layman/kde-testing/eclass/kde4-functions.eclass'
 *   '/usr/portage/local/layman/kde-testing/eclass/kde4-meta.eclass'
 *
 * It is best to avoid overridding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to run `emerge --regen` after each time that you run `emerge
 * --sync`. Set PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you
 * would like to disable this warning.
Calculating dependencies \
!!! All ebuilds that could satisfy "kde-base/kdm:4" have been masked.
!!! One of the following masked packages is required to complete your request:
- kde-base/kdm-4.1.1 (masked by: )

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.



I emerged portage 2.2 to use sets but no go:

emerge @kdebase-4.1

Code:

WARNING: repository at /usr/local/portage is missing a repo_name entry
 * Overlay eclasses override eclasses from PORTDIR:
 *
 *   '/usr/portage/local/layman/kde-testing/eclass/kde4-base.eclass'
 *   '/usr/portage/local/layman/kde-testing/eclass/kde4-functions.eclass'
 *   '/usr/portage/local/layman/kde-testing/eclass/kde4-meta.eclass'
 *
 * It is best to avoid overriding eclasses from PORTDIR because it will
 * trigger invalidation of cached ebuild metadata that is distributed with
 * the portage tree. If you must override eclasses from PORTDIR then you
 * are advised to add FEATURES="metadata-transfer" to /etc/make.conf and to
 * run `emerge --regen` after each time that you run `emerge --sync`. Set
 * PORTAGE_ECLASS_WARNING_ENABLE="0" in /etc/make.conf if you would like to
 * disable this warning.
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "kde-base/kinfocenter:4.1".


Code:

eix kinfocenter
[I] kde-base/kinfocenter
     Available versions: 
        (kde-4) {M}~4.0.4 {M}~4.0.5
        (4.1)   (~)4.1.1[1]
        {debug htmlhandbook ieee1394 kdeprefix opengl}
     Installed versions:  4.1.1(4.1)[1](19:33:56 09/28/08)(ieee1394 opengl -debug -htmlhandbook -kdeprefix)
     Homepage:            http://www.kde.org/
     Description:         The KDE Info Center

[1] "kde" /usr/portage/local/layman/kde-testing


Opinions??
Back to top
View user's profile Send private message
reavertm
Developer
Developer


Joined: 05 Feb 2004
Posts: 264
Location: Wrocław

PostPosted: Sun Sep 28, 2008 6:46 pm    Post subject: Reply with quote

Have you been syncing kde-testing overlay recently?
They have migrated to EAPI-2 completely - you have to emerge --sync and emerge latest (portage-2.2 rc11) to make use of kde-testing overlay.
_________________
Maciek
Back to top
View user's profile Send private message
TemplarKnight
Guru
Guru


Joined: 14 Jun 2005
Posts: 311
Location: Greece/patras/

PostPosted: Sun Sep 28, 2008 7:23 pm    Post subject: Reply with quote

reavertm wrote:
Have you been syncing kde-testing overlay recently?
They have migrated to EAPI-2 completely - you have to emerge --sync and emerge latest (portage-2.2 rc11) to make use of kde-testing overlay.

hmm thanks. So portage<2.2 is not supported anymore? This should be stated in the doc / wiki
Back to top
View user's profile Send private message
code_raptor
n00b
n00b


Joined: 24 Jun 2005
Posts: 47

PostPosted: Mon Sep 29, 2008 2:30 am    Post subject: eapi-2 *sighs* Reply with quote

The friday i unistalled the kdesvn-portage overlay with all their packages then switched over the kde-testing without any problems, now after the eapi 2 change i was forced to update portage to 2.2_rc11 to avoid downgrade a large number of packages, but now emerge --depclean seems broken:

Code:

~ # emerge --depclean --ask

 * Always study the list of packages to be cleaned for any obvious
 * mistakes. Packages that are part of the world set will always 
 * be kept.  They can be manually added to this set with         
 * `emerge --noreplace <atom>`.  Packages that are listed in     
 * package.provided (see portage(5)) will be removed by           
 * depclean, even if they are part of the world set.             
 *                                                               
 * As a safety measure, depclean will not remove any packages     
 * unless *all* required dependencies have been resolved.  As a   
 * consequence, it is often necessary to run `emerge --update     
 * --newuse --deep --oneshot @system @world` prior to depclean.   

Calculating dependencies... done!
 * Dependencies could not be completely resolved due to
 * the following required packages not being installed:
 *                                                     
 *   kde-base/konsole:4.1 pulled in by:               
 *     kde-misc/yakuake-2.9.3                         
 *                                                     
 *   >=kde-base/khotkeys-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                     
 *                                                     
 *   >=kde-base/kdepasswd-4.1.1:4.1 pulled in by:     
 *     kde-base/kdebase-meta-4.1.1                     
 *                                                     
 *   >=kde-base/kdepimlibs-4.1.1:4.1 pulled in by:     
 *     kde-base/kdeplasma-addons-4.1.1                 
 *                                                     
 *   >=kde-base/kdebase-cursors-4.1.1:4.1 pulled in by:
 *     kde-base/kdebase-meta-4.1.1                     
 *                                                     
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kdf-4.1.1                                 
 *                                                       
 *   >=kde-base/libkpgp-4.1.1:4.1 pulled in by:           
 *     kde-base/kmail-4.1.1                               
 *                                                       
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kdemultimedia-kioslaves-4.1.1             
 *                                                       
 *   >=kde-base/libkdepim-4.1.1:4.1 pulled in by:         
 *     kde-base/kmail-4.1.1                               
 *                                                       
 *   >=kde-base/knotify-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-startkde-4.1.1                   
 *                                                       
 *   >=kde-base/knotify-4.1.1:4.1 pulled in by:           
 *     kde-base/kuser-4.1.1                               
 *                                                       
 *   >=kde-base/kde-menu-icons-4.1.1:4.1 pulled in by:   
 *     kde-base/kdebase-meta-4.1.1                       
 *                                                       
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/okular-4.1.1                             
 *                                                       
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by: 
 *     media-sound/amarok-1.90                           
 *                                                       
 *   >=kde-base/kdesu-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                       
 *                                                       
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/gwenview-4.1.1                           
 *                                                       
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by: 
 *     kde-misc/extractandcompress-1.4.3                 
 *                                                       
 *   >=kde-base/kiconfinder-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                       
 *                                                       
 *   kde-base/kscreensaver:4.1 pulled in by:             
 *     kde-misc/powerdevil-1.2.0                         
 *                                                       
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by:
 *     kde-misc/yakuake-2.9.3                             
 *                                                         
 *   >=kde-base/klipper-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                         
 *                                                         
 *   >=kde-base/kode-4.1.1:4.1 pulled in by:               
 *     kde-base/kmail-4.1.1                               
 *                                                         
 *   >=kde-base/kmimetypefinder-4.1.1:4.1 pulled in by:   
 *     kde-base/kdebase-meta-4.1.1                         
 *                                                         
 *   >=kde-base/ksystraycmd-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                         
 *                                                         
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kcharselect-4.1.1                           
 *                                                           
 *   >=kde-base/kpasswdserver-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kmailcvt-4.1.1:4.1 pulled in by:             
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kolourpaint-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/krdc-4.1.1                                   
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kuser-4.1.1                                 
 *                                                           
 *   >=kde-base/kscreensaver-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   kde-base/libplasma:4.1 pulled in by:                   
 *     kde-base/kget-4.1.1                                   
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kolourpaint-4.1.1                           
 *                                                           
 *   >=kde-base/knewstuff-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kmix-4.1.1                                   
 *                                                           
 *   >=kde-base/mimelib-4.1.1:4.1 pulled in by:             
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/kcmshell-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kde-l10n-4.1.1                               
 *                                                           
 *   >=kde-base/ktraderclient-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                           

 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/gwenview-4.1.1                               
 *                                                           
 *   kde-base/phonon-xine:4.1[xcb] pulled in by:             
 *     kde-base/dragonplayer-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     media-video/kmplayer-0.11.0_rc4                       
 *                                                           
 *   kde-base/libplasma:4.1 pulled in by:                   
 *     media-sound/amarok-1.90                               
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kopete-4.1.1                                 
 *                                                           
 *   >=kde-base/ksplash-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   kde-base/libplasma:4.1[opengl] pulled in by:           
 *     kde-misc/plasmoids-0.2                               
 *                                                           
 *   >=kde-base/libkleo-4.1.1:4.1 pulled in by:             
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     kde-base/kdeplasma-addons-4.1.1                       
 *                                                           
 *   >=kde-base/kappfinder-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kde-wallpapers-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kget-4.1.1                                   
 *                                                           
 *   >=kde-base/ktimezoned-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kamera-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/sweeper-4.1.1                               
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     net-p2p/ktorrent-3.1.2                               
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/svgpart-4.1.1                               
 *                                                           
 *   >=kde-base/kcheckpass-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/krunner-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/renamedlg-plugins-4.1.1:4.1 pulled in by:   
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/knetattach-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   kde-base/nepomuk:4.1 pulled in by:                     
 *     kde-base/gwenview-4.1.1                               
 *                                                           
 *   >=kde-base/kontactinterfaces-4.1.1:4.1 pulled in by:   
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kwallet-4.1.1                               
 *                                                           
 *   >=kde-base/phonon-xine-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/systemsettings-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/okteta-4.1.1                                 
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kmix-4.1.1                                   
 *                                                           
 *   >=kde-base/libksieve-4.1.1:4.1 pulled in by:           
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   kde-base/konqueror:4.1 pulled in by:                   
 *     net-wireless/kdebluetooth4-0.2                       
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kuser-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     kde-misc/extractandcompress-1.4.3                     
 *                                                           
 *   >=kde-base/kstartupconfig-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/khelpcenter-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   kde-base/plasma-workspace:4.1 pulled in by:             
 *     kde-misc/plasmoids-0.2                               
 *                                                           
 *   >=kde-base/kfile-4.1.1:4.1 pulled in by:               
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/soliduiserver-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/libkcddb-4.1.1:4.1 pulled in by:             
 *     kde-base/kdemultimedia-kioslaves-4.1.1               
 *                                                           
 *   kde-base/kdelibs:4.1 pulled in by:                     
 *     media-sound/amarok-1.90                               
 *                                                           
 *   >=kde-base/ksmserver-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kde-menu-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kgpg-4.1.1                                   
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     kde-base/kdeplasma-addons-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     kde-misc/krename-3.9.1                               
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/ksnapshot-4.1.1                             
 *                                                           
 *   >=kde-base/drkonqi-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kcontrol-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdebase-startkde-4.1.1:4.1 pulled in by:     
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/dragonplayer-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kamera-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     kde-misc/plasmoids-0.2                               
 *                                                           
 *   >=kde-base/krunner-4.1.1:4.1 pulled in by:             
 *     kde-base/kdeplasma-addons-4.1.1                       
 *                                                           
 *   >=kde-base/kdialog-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/okteta-4.1.1                                 
 *                                                           
 *   >=kde-base/kdebase-data-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kopete-4.1.1                                 
 *                                                           
 *   >=kde-base/kwrite-4.1.1:4.1 pulled in by:               
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/libtaskmanager-4.1.1:4.1 pulled in by:       
 *     kde-base/kdeplasma-addons-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kdegraphics-strigi-analyzer-4.1.1           
 *                                                           
 *   >=kde-base/solid-hardware-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kdegraphics-strigi-analyzer-4.1.1           
 *                                                           
 *   >=kde-base/libplasma-4.1.1:4.1 pulled in by:           
 *     kde-base/superkaramba-4.1.1                           
 *                                                           
 *   kde-base/kdebase-kioslaves:4.1 pulled in by:           
 *     net-p2p/ktorrent-3.1.2                               
 *                                                           
 *   >=kde-base/kwin-4.1.1:4.1 pulled in by:                 
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdebase-kioslaves-4.1.1:4.1 pulled in by:   
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     kde-misc/powerdevil-1.2.0                             
 *                                                           
 *   >=kde-base/kstart-4.1.1:4.1 pulled in by:               
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kompare-4.1.1                               
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     net-wireless/kdebluetooth4-0.2                       
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     net-p2p/ktorrent-3.1.2                               
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kompare-4.1.1                               
 *                                                           
 *   >=kde-base/konsole-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/nsplugins-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/dolphin-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kioclient-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/okular-4.1.1                                 
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kcharselect-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     media-video/kmplayer-0.11.0_rc4                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/kquitapp-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kwallet-4.1.1                               
 *                                                           
 *   >=kde-base/kfind-4.1.1:4.1 pulled in by:               
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdebugdialog-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/libplasma-4.1.1:4.1 pulled in by:           
 *     kde-base/kdeplasma-addons-4.1.1                       
 *                                                           
 *   >=kde-base/kuiserver-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/ksystemlog-4.1.1                             
 *                                                           
 *   >=kde-base/plasma-apps-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kdf-4.1.1                                   
 *                                                           
 *   >=kde-base/plasma-workspace-4.1.1:4.1 pulled in by:     
 *     kde-base/kdeplasma-addons-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/krdc-4.1.1                                   
 *                                                           
 *   >=kde-base/kcmshell-4.1.1:4.1 pulled in by:             
 *     kde-base/kwallet-4.1.1                               
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     kde-misc/plasmoids-0.2                               
 *                                                           
 *   kde-base/kdialog:4.1 pulled in by:                     
 *     net-wireless/kdebluetooth4-0.2                       
 *                                                           
 *   >=kde-base/kstyles-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kinfocenter-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kcminit-4.1.1:4.1 pulled in by:             
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kdemultimedia-kioslaves-4.1.1               
 *                                                           
 *   >=kde-base/nepomuk-4.1.1:4.1 pulled in by:             
 *     kde-base/kmail-4.1.1                                 
 *                                                           
 *   >=kde-base/libkcompactdisc-4.1.1:4.1 pulled in by:     
 *     kde-base/kdemultimedia-kioslaves-4.1.1               
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/superkaramba-4.1.1                           
 *                                                           
 *   >=kde-base/plasma-workspace-4.1.1:4.1 pulled in by:     
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/superkaramba-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/kgpg-4.1.1                                   
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     kde-misc/yakuake-2.9.3                               
 *                                                           
 *   >=kde-base/kurifilter-plugins-4.1.1:4.1 pulled in by:   
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/svgpart-4.1.1                               
 *                                                           
 *   >=kde-base/kmenuedit-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdm-4.1.1:4.1 pulled in by:                 
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     kde-misc/powerdevil-1.2.0                             
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/ksnapshot-4.1.1                             
 *                                                           
 *   kde-base/systemsettings:4.1 pulled in by:               
 *     kde-misc/powerdevil-1.2.0                             
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     net-wireless/kdebluetooth4-0.2                       
 *                                                           
 *   >=kde-base/kdelibs-4.1:4.1[kdeprefix] pulled in by:     
 *     kde-misc/krename-3.9.1                               
 *                                                           
 *   >=kde-base/ksysguard-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdepimlibs-4.1:4.1[kdeprefix] pulled in by: 
 *     media-sound/amarok-1.90                               
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kget-4.1.1                                   
 *                                                           
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/sweeper-4.1.1                               
 *                                                           
 *   >=kde-base/kreadconfig-4.1.1:4.1 pulled in by:         
 *     kde-base/kdebase-startkde-4.1.1                       
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/ksystemlog-4.1.1                             
 *                                                           
 *   >=kde-base/konqueror-4.1.1:4.1 pulled in by:           
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/keditbookmarks-4.1.1:4.1 pulled in by:       
 *     kde-base/kdebase-meta-4.1.1                           
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/ark-4.1.1                                   
 *                                                           
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:   
 *     kde-base/dragonplayer-4.1.1                           
 *
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kcalc-4.1.1
 *
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/ark-4.1.1
 *
 *   >=kde-base/kdelibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kde-l10n-4.1.1
 *
 *   >=kde-base/kdepimlibs-4.1.1:4.1[kdeprefix] pulled in by:
 *     kde-base/kcalc-4.1.1
 *
 * Have you forgotten to run `emerge --update --newuse --deep world` prior to
 * depclean?  It may be necessary to manually uninstall packages that no longer
 * exist in the portage tree since it may not be possible to satisfy their
 * dependencies.  Also, be aware of the --with-bdeps option that is documented
 * in `man emerge`.

 * GNU info directory index is up-to-date.


All the above packages are installed and my tree/overlay is synced, and yes, my world list is up to date
Code:

~ # emerge world -uDNvp
Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB
Portage tree and overlays:
 [0] /usr/portage


There is something that i can do to resolve this :( ? (srly i dont feel like reinstalling all my kde twice 8O in the week to obtain the same binary packages again)
_________________
just feel the code...
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... , 28, 29, 30  Next
Page 29 of 30

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum