Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing Flex Builder 2 "No Java virtual machine"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Lithonite
n00b
n00b


Joined: 10 May 2008
Posts: 14

PostPosted: Thu May 29, 2008 12:08 pm    Post subject: Installing Flex Builder 2 "No Java virtual machine" Reply with quote

So here is what i get when i check the classpath:
Code:

java-config -r
/opt/sun-jdk-1.6.0.05/jre/lib/resources.jar:/opt/sun-jdk-1.6.0.05/jre/lib/rt.jar:/opt/sun-jdk-1.6.0.05/jre/lib/jsse.jar:/opt/sun-jdk-1.6.0.05/jre/lib/jce.jar:/opt/sun-jdk-1.6.0.05/jre/lib/charsets.jar


And when i check the version:
Code:

java-config -v
java version "1.6.0_05"
Java(TM) SE Runtime Environment (build 1.6.0_05-b13)
Java HotSpot(TM) Client VM (build 10.0-b19, mixed mode)



So can someone tell me why i am getting the following error?:
Code:

./flexbuilder_linux_install_a3_033108.bin
Preparing to install...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...
No Java virtual machine could be found from your PATH
environment variable.  You must install a VM prior to
running this program.


Anyone know how to get past this? I am confused i am surei have done something wrong. but as far as i can tell i do have java Vm installed, and eclipse runs no sweat so im at a loss
Back to top
View user's profile Send private message
Bio
Apprentice
Apprentice


Joined: 17 Mar 2003
Posts: 197
Location: Geneva which should be in Switzerland...

PostPosted: Tue Jul 22, 2008 3:21 pm    Post subject: Reply with quote

Make sure your 1.6 jdk is set in the PATH variable.

java-config will modify your JAVA_HOME but not your PATH and flex builder installer looks at your PATH variable
_________________
I'm all in !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum