Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4 and KDE 3.5.x co-existing and system: [Quasi-Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
MrEntropy
n00b
n00b


Joined: 03 Nov 2005
Posts: 74
Location: Austin

PostPosted: Wed Jun 04, 2008 1:09 am    Post subject: KDE 4 and KDE 3.5.x co-existing and system: [Quasi-Solved] Reply with quote

Hi,

I did a search for this on the forums and Google and can't find any information on it. If it's a repeat question, I'd appreciate any handy tip on searching the forums here and just a reference link to a possible solution.

My problem is two-fold. I have KDE 3.5.9 installed, and I also have KDE 4.1(?) from the SVN overlay. I have a seperate user set up to use KDE 4, too. However, the user that's in KDE 3.5.9 can't use the desktop Home or System icons because it tries to load Dolphin. Is there any way to get those icons to use Konqueror again?

The other problem is possibly related. In KDE 4, I can't use Dolphin or Konqueror to use system: and I get a protocol not supported error. I'm pretty sure I emerged everything I could for KDE 4, but maybe I missed something?

Any help is mightily appreciated, as always.


Last edited by MrEntropy on Wed Jun 04, 2008 4:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
pappy_mcfae
Watchman
Watchman


Joined: 27 Dec 2007
Posts: 5999
Location: Pomona, California.

PostPosted: Wed Jun 04, 2008 9:28 am    Post subject: Re: KDE 4 and KDE 3.5.x co-existing and system: not supporte Reply with quote

MrEntropy wrote:
Hi,

I did a search for this on the forums and Google and can't find any information on it. If it's a repeat question, I'd appreciate any handy tip on searching the forums here and just a reference link to a possible solution.

My problem is two-fold. I have KDE 3.5.9 installed, and I also have KDE 4.1(?) from the SVN overlay. I have a seperate user set up to use KDE 4, too. However, the user that's in KDE 3.5.9 can't use the desktop Home or System icons because it tries to load Dolphin. Is there any way to get those icons to use Konqueror again?

Yes, by removing KDE4. While it's said that it doesn't mess with KDE3.5, my experience is, it does, and in some rather annoying ways.

Quote:
The other problem is possibly related. In KDE 4, I can't use Dolphin or Konqueror to use system: and I get a protocol not supported error. I'm pretty sure I emerged everything I could for KDE 4, but maybe I missed something?

Any help is mightily appreciated, as always.


No, you're not missing anything. KDE4 isn't really all that ready for public consumption. The problems you have noted have been noted by others, such as myself. It is for those errors, and a few other things about KDE4 that I removed it from my system. I simply couldn't justify keeping something I see as seriously broken on my system. When it lacks even the basic configurability and functionality of XFCE even, I think I'll wait until the Madagascar Hissing Cockroaches in KDE4 are killed by others. I'm more willing to help out with the smaller bugs, at least in this case.

Blessed be!
Pappy
_________________
This space left intentionally blank, except for these ASCII symbols.
Back to top
View user's profile Send private message
Non_E
Apprentice
Apprentice


Joined: 17 Jan 2006
Posts: 160
Location: Czech Republic

PostPosted: Wed Jun 04, 2008 10:59 am    Post subject: Reply with quote

Until you remove kde4 or it is fixed you may try symlinking konqueror as dolphin somewhere in your PATH.
Code:
ln -s $(which konqueror) dolphin

_________________
Only Sith deals in absolutes.
Back to top
View user's profile Send private message
MrEntropy
n00b
n00b


Joined: 03 Nov 2005
Posts: 74
Location: Austin

PostPosted: Wed Jun 04, 2008 4:57 pm    Post subject: Reply with quote

Ah, okay. Not quite the answer I was hoping for but at least it was easy to follow. I'll try the symlink bit. I'm kind of happy I'm not the only person to have the system: protocol problem, but I'd prefer it to be fixed. Still, I'm enjoying KDE 4 and think it'll be quite nice when it's finished and polished up, so I'm not quite ready to scrap it yet.

Thanks again for the help!
Back to top
View user's profile Send private message
zAfi
Apprentice
Apprentice


Joined: 08 Aug 2006
Posts: 220
Location: Austria

PostPosted: Sun Jun 08, 2008 12:45 pm    Post subject: Reply with quote

Here some quickfacts to Kde4.0...
http://www.kdedevelopers.org/node/3174 (found @ http://en.opensuse.org/KDE4 with some other quite interesting links)

Everytime I think about going for kde4 i read one of those...and continue waiting for 4.1. (or 4.2....or 4.3...) ;)
This summarizes it very good
Quote:
To make a long story short: KDE 4.0 is not and never was meant to replace 3.5.x for regular users. The main goals were porting to Qt4 and creating the frameworks to create all the things announced for KDE 4. Frameworks are unfortunately hardly visible to the user, so most things that use them, like plasmoids, panel-functionality etc., will only appear after the frameworks are in place, i.e. starting with 4.1.

_________________
Gentoo 2008.0/desktop | Kernel: 2.6.27-tuxonice | Arch: amd64 | KDE 3.5.9 | WU Wien |
----------
Share your kernel information @ http://klive.cpushare.com/
Back to top
View user's profile Send private message
MrEntropy
n00b
n00b


Joined: 03 Nov 2005
Posts: 74
Location: Austin

PostPosted: Sun Jun 08, 2008 2:28 pm    Post subject: Reply with quote

I'll have to take a look at those.

I knew going in, though, that 4.0 wasn't ready for prime time. It's a good sign to me that I like using it considering the state it's in. When they reach their user-ready release I should be quite the happy camper.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum