Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xorg-server-1.4.99.901 Fails - indirect_dispatch.c
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 568

PostPosted: Wed Jun 04, 2008 7:56 am    Post subject: xorg-server-1.4.99.901 Fails - indirect_dispatch.c Reply with quote

Hi

Iam currently trying to install the new xorg-server from X11 overlay, but it fails because this file is missing in the mesa tree. Any ideas? (appart from disabling glx)
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 769

PostPosted: Wed Jun 04, 2008 11:50 am    Post subject: Reply with quote

For me it didn't even go that far:
Code:
 * Forcing on xorg-x11 for new enough glxtokens.h...
Switching to xorg-x11 OpenGL interface... done
>>> Unpacking source...
 * git update start -->
 *    repository: git://anongit.freedesktop.org/mesa/mesa
 *    local clone: /usr/portage/distfiles/git-src/mesa
 *    committish: master
>>> Unpacked to /var/tmp/portage/x11-base/xorg-server-1.4.99.901/work/mesa
>>> Unpacking xorg-server-1.4.99.901.tar.bz2 to /var/tmp/portage/x11-base/xorg-server-1.4.99.901/work
 * Applying 1.4-fpic-libxf86config.patch ...                                   [ ok ]
 * Applying 1.4-fix-kdrive-automake.patch ...                                  [ ok ]
 * Applying 0001-Fix-segfault-when-a-monitor-exists-but-has-no-modes.patch ..  [ ok ]
 * Applying 0002-Size-xf86DefaultModes-explicitly.patch ...                    [ ok ]
 * Applying 0003-Bug-14927-Fix-the-math-for-xf86NumDefaultModes.patch ...      [ ok ]
 * Applying 0004-Add-the-amd-driver-to-magic-driver-selection.patch ...        [ ok ]
 * Applying 0005-Fix-DRI2-texture-target-for-GLX_EXT_texture_from_pix.patch .  [ ok ]
 * Applying 0006-DRI2-Return-event-buffer-head-index-in-DRI2CreateDr.patch ..  [ ok ]
 * Applying 0007-GLX-Track-changes-to-DRI_TEX_BUFFER-extension.patch ...       [ ok ]
 * Applying 0001-Xephyr-Build-fix-Port-across-XF86dri.c-changes-fro.patch ...  [ ok ]
 * Running eautoreconf in '/var/tmp/portage/x11-base/xorg-server-1.4.99.901/work/xorg-server-1.4.99.901' ...
 * Running aclocal ...                                                         [ !! ]

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/x11-base/xorg-server-1.4.99.901/temp/aclocal-30551.out

 *
 * ERROR: x11-base/xorg-server-1.4.99.901 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_unpack
 *             environment, line 3322:  Called x-modular_reconf_source
 *             environment, line 4012:  Called eautoreconf
 *             environment, line 1084:  Called eaclocal
 *             environment, line 1023:  Called autotools_run_tool 'aclocal'
 *             environment, line  471:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *  The die message:
 *   Failed Running aclocal !
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/x11-base/xorg-server-1.4.99.901/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-base/xorg-server-1.4.99.901/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/layman/x11/'
 *

Code:
localhost temp # cat aclocal-30551.out
***** aclocal *****
***** aclocal

configure.ac:1535: error: AC_SUBST: `abi_ansic abi_videodrv abi_xinput abi_extension abi_font' is not a valid shell variable name
configure.ac:1535: the top level
autom4te-2.62: /usr/bin/m4 failed with exit status: 1
aclocal-1.10: autom4te failed with exit status: 1

:C
_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 568

PostPosted: Wed Jun 04, 2008 12:08 pm    Post subject: Reply with quote

Yeah, seems hard to install this :-)

Code:

Checking that the source files exist for mesa module ... DONE
Checking that the source files exist for glx module ...
   error:   /var/tmp/portage/x11-base/xorg-server-1.4.99.901/work/mesa/src/glx/x
11/indirect_dispatch.c not found
configure: error: Failed to link Mesa source tree.  Please specify a proper path
 to Mesa sources, or disable GLX.


How did you unmask your packages? I used autounmask and there were a lot more packages than i would have thought...
I would try revdep-rebuilt and then autounmasking the packages and
emerge -u world to upgrade all neccessary packages. But it looks as if you won't get any further than I did anyway because that file is defenetly missing in the work tree
Back to top
View user's profile Send private message
unK
l33t
l33t


Joined: 06 Feb 2007
Posts: 769

PostPosted: Wed Jun 04, 2008 12:48 pm    Post subject: Reply with quote

bastibasti wrote:
Yeah, seems hard to install this :-)

Code:

Checking that the source files exist for mesa module ... DONE
Checking that the source files exist for glx module ...
   error:   /var/tmp/portage/x11-base/xorg-server-1.4.99.901/work/mesa/src/glx/x
11/indirect_dispatch.c not found
configure: error: Failed to link Mesa source tree.  Please specify a proper path
 to Mesa sources, or disable GLX.


How did you unmask your packages? I used autounmask and there were a lot more packages than i would have thought...
I would try revdep-rebuilt and then autounmasking the packages and
emerge -u world to upgrade all neccessary packages. But it looks as if you won't get any further than I did anyway because that file is defenetly missing in the work tree

I echoed every package portage complained it is masked to package.unmask ;p
However, I tried with xorg-server-9999, it didn't make such problems and compiled. But it crashes every time I try to set something in nvidia-settings, yhm.

I put into package.mask these:
Code:
x11-base/xorg-server
x11-libs/libpciaccess
media-libs/mesa
x11-proto/xf86driproto
x11-libs/libdrm
x11-proto/dri2proto
x11-proto/xproto
x11-proto/inputproto
x11-libs/libX11
x11-libs/libXext
x11-proto/xextproto
x11-libs/libXi
x11-drivers/xf86-input-mouse
x11-drivers/xf86-input-keyboard

_________________
ncmpcpp - featureful ncurses based MPD client inspired by ncmpc
Back to top
View user's profile Send private message
bastibasti
Guru
Guru


Joined: 27 Nov 2006
Posts: 568

PostPosted: Thu Jun 05, 2008 5:28 am    Post subject: Reply with quote

Code:

$ cat /etc/portage/package.unmask
# ---
# BEGIN: x11-base/xorg-server-1.4.99.901
# ---
=x11-base/xorg-server-1.4.99.901
=x11-libs/libpciaccess-9999
=x11-proto/xproto-9999
=x11-libs/libXrender-9999
=x11-proto/renderproto-9999
=x11-libs/libXext-9999
=x11-proto/xextproto-9999
=x11-libs/libX11-9999
=media-libs/mesa-9999
=x11-libs/libdrm-9999
=x11-proto/dri2proto-9999
=x11-proto/inputproto-9999
=x11-libs/pixman-9999
=x11-libs/libXfont-9999
=x11-drivers/xf86-video-i810-9999
=x11-drivers/xf86-input-keyboard-9999
# ---
# END: x11-base/xorg-server-1.4.99.901
# ---


and of course

Code:

$ cat /etc/portage/package.keywords
# ---
# BEGIN: x11-base/xorg-server-1.4.99.901
# ---
=x11-base/xorg-server-1.4.99.901 ~x86
=x11-libs/libpciaccess-9999 ~x86
=x11-proto/xproto-9999 ~x86
=x11-proto/xproto-7.0.12 ~x86
=x11-apps/xauth-1.0.3 ~x86
=x11-libs/libXrender-9999 ~x86
=x11-libs/libXrender-0.9.4 ~x86
=x11-proto/renderproto-9999 ~x86
=x11-proto/renderproto-0.9.3 ~x86
=x11-libs/libXext-9999 ~x86
=x11-libs/libXext-1.0.4 ~x86
=x11-proto/xextproto-9999 ~x86
=x11-libs/libX11-9999 ~x86
=media-libs/mesa-9999 ~x86
=x11-proto/dri2proto-9999 ~x86
=x11-proto/inputproto-9999 ~x86
=x11-proto/inputproto-1.4.3-r1 ~x86
=x11-proto/inputproto-1.4.3 ~x86
=x11-misc/xkeyboard-config-1.2 ~x86
=x11-apps/xinit-1.0.8-r3 ~x86
=x11-apps/xinit-1.0.8-r2 ~x86
=x11-apps/xinit-1.0.8 ~x86
=x11-libs/pixman-9999 ~x86
=x11-libs/pixman-0.10.0 ~x86
=x11-libs/libXfont-9999 ~x86
=x11-libs/libXfont-1.3.2 ~x86
=x11-drivers/xf86-video-i810-9999 ~x86
=x11-drivers/xf86-video-i810-2.3.1-r1 ~x86
=x11-drivers/xf86-video-i810-2.3.1 ~x86
=x11-drivers/xf86-video-i810-2.3.0 ~x86
=x11-drivers/xf86-video-i810-2.2.1 ~x86
=x11-drivers/xf86-input-keyboard-9999 ~x86
=x11-drivers/xf86-input-keyboard-1.3.0 ~x86
=x11-drivers/xf86-input-keyboard-1.2.2 ~x86
=x11-libs/xtrans-1.0.4 ~x86
=x11-libs/mesa ~x86
# ---
# END: x11-base/xorg-server-1.4.99.901
# ---

Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum