Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox 3 and nspr
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gentunian
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jul 2006
Posts: 118
Location: Río Cuarto, Argentina

PostPosted: Fri Jun 06, 2008 8:11 pm    Post subject: firefox 3 and nspr Reply with quote

Hi,

I decided to test the new firefox. The nspr dependency package after the merge says:
Code:
 * Messages for package dev-libs/nspr-4.7.1:

 * Old versions of installed libraries were detected on your system.
 * In order to avoid breaking packages that depend on these old libs,
 * the libraries are not being removed.  You need to run revdep-rebuild
 * in order to remove these old dependencies.  If you do not have this
 * helper program, simply emerge the 'gentoolkit' package.
 *
 *   # revdep-rebuild --library libnspr4.so.6
 *   # revdep-rebuild --library libplc4.so.6
 *   # revdep-rebuild --library libplds4.so.6
 *
 * Once you've finished running revdep-rebuild, it should be safe to
 * delete the old libraries.  Here is a copy & paste for the lazy:
 *   # rm '/usr/lib64/nspr/libnspr4.so.6'
 *   # rm '/usr/lib64/nspr/libplc4.so.6'
 *   # rm '/usr/lib64/nspr/libplds4.so.6'


I ran:
Code:
revdep-rebuild --library libnspr4.so.6


And then I realized that firefox 2 was being installed! wtf?

Regards,
_________________
Si un pueblo tiene hambre, no le des un pez. Enséñale a pescar.
http://labombiya.com.ar
Back to top
View user's profile Send private message
goffrie
n00b
n00b


Joined: 14 Mar 2007
Posts: 67

PostPosted: Fri Jun 06, 2008 9:09 pm    Post subject: Reply with quote

Chances are that one of the applications which linked against the old nspr also wants Firefox 2. If you use Firefox 3, make sure that you enable the xulrunner USE flag, which will stop applications from wanting Firefox 2 (linking with XULRunner instead.)
Back to top
View user's profile Send private message
deno
Guru
Guru


Joined: 13 Sep 2006
Posts: 406

PostPosted: Fri Jun 06, 2008 10:21 pm    Post subject: Reply with quote

Make sure you also set "USE= -firefox" for apps that have that use flag (i.e. mplayerplug-in).
Back to top
View user's profile Send private message
CloseYetFar
Tux's lil' helper
Tux's lil' helper


Joined: 17 Aug 2006
Posts: 102

PostPosted: Wed Jun 18, 2008 10:04 pm    Post subject: Reply with quote

I got the same instructions after upgrading nspr. When I run:
Code:

# revdep-rebuild --library libnspr4.so.6
# revdep-rebuild --library libplc4.so.6
# revdep-rebuild --library libplds4.so.6

is the script gonna try to rebuild all the apps three times, one time for each of the commands? If so is there a way I can force it to only recompile everything once?
Back to top
View user's profile Send private message
kev009
n00b
n00b


Joined: 17 Oct 2005
Posts: 43
Location: Tempe, Arizona

PostPosted: Thu Jun 19, 2008 5:11 am    Post subject: Reply with quote

Why not just run revdep-rebuild (without arguments), and let it sort it all out? Run it again until all links are clean.
_________________
http://www.kev009.com
Back to top
View user's profile Send private message
thelee
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jul 2007
Posts: 132

PostPosted: Thu Jun 19, 2008 6:06 am    Post subject: Reply with quote

Perhaps this is me not understanding revdep-rebuild, but I thought that would do it, but I guess not - I have to manually run those commands.
Back to top
View user's profile Send private message
thelee
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jul 2007
Posts: 132

PostPosted: Thu Jun 19, 2008 6:13 am    Post subject: Reply with quote

sorry to double post, but i guess it's actually because nothing is actually broken for revdep-rebuild to fix (the old libraries are still there), so you have to manually pass the arguments to force a rebuild against those.

EDIT - for anyone worried about massive rebuild times, atleast for me, after the first revdep-rebuild, the other ones didn't need to do anything, so i guess no repetivie builds.
Back to top
View user's profile Send private message
CloseYetFar
Tux's lil' helper
Tux's lil' helper


Joined: 17 Aug 2006
Posts: 102

PostPosted: Fri Jun 20, 2008 1:56 am    Post subject: Reply with quote

Yea, I got it all sorted out. Thanks for the help.
Back to top
View user's profile Send private message
johnisevil
n00b
n00b


Joined: 14 Dec 2003
Posts: 45
Location: Hamilton, ON Canada

PostPosted: Wed Dec 24, 2008 3:53 pm    Post subject: Reply with quote

I've run into the same thing but I'm confused by something that revdep-rebuild wants to revert to. It's saying it wants to pull in xulrunner-1.8.1.19. So I'm not sure why it wants to revert when Firefox 3 needs the newer version. Any ideas?
Back to top
View user's profile Send private message
armin76
Retired Dev
Retired Dev


Joined: 24 Apr 2006
Posts: 174

PostPosted: Wed Dec 24, 2008 4:34 pm    Post subject: Reply with quote

johnisevil wrote:
I've run into the same thing but I'm confused by something that revdep-rebuild wants to revert to. It's saying it wants to pull in xulrunner-1.8.1.19. So I'm not sure why it wants to revert when Firefox 3 needs the newer version. Any ideas?


Thats because firefox2 and firefox3 can't be installed at the same time, but xulrunner can. At the moment i think all apps are using xulrunner-1.8.
Back to top
View user's profile Send private message
johnisevil
n00b
n00b


Joined: 14 Dec 2003
Posts: 45
Location: Hamilton, ON Canada

PostPosted: Wed Dec 24, 2008 4:57 pm    Post subject: Reply with quote

armin76 wrote:
johnisevil wrote:
I've run into the same thing but I'm confused by something that revdep-rebuild wants to revert to. It's saying it wants to pull in xulrunner-1.8.1.19. So I'm not sure why it wants to revert when Firefox 3 needs the newer version. Any ideas?


Thats because firefox2 and firefox3 can't be installed at the same time, but xulrunner can. At the moment i think all apps are using xulrunner-1.8.


I know but Firefox 3 was recently installed as well as the newer xulrunner. Now when I run revdep-rebuild it's wanting to go back to the older xulrunner. Does Firefox 3 work with the 1.8.x version of xulrunner?
Back to top
View user's profile Send private message
armin76
Retired Dev
Retired Dev


Joined: 24 Apr 2006
Posts: 174

PostPosted: Wed Dec 24, 2008 9:47 pm    Post subject: Reply with quote

johnisevil wrote:
armin76 wrote:
johnisevil wrote:
I've run into the same thing but I'm confused by something that revdep-rebuild wants to revert to. It's saying it wants to pull in xulrunner-1.8.1.19. So I'm not sure why it wants to revert when Firefox 3 needs the newer version. Any ideas?


Thats because firefox2 and firefox3 can't be installed at the same time, but xulrunner can. At the moment i think all apps are using xulrunner-1.8.


I know but Firefox 3 was recently installed as well as the newer xulrunner. Now when I run revdep-rebuild it's wanting to go back to the older xulrunner. Does Firefox 3 work with the 1.8.x version of xulrunner?


Nope, firefox3 is the only app that uses xul 1.9.There are some ebuilds in the tree that use xul-1.9, but i think they're masked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum