Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[BUMP REQUEST] liquidx: app-misc/ec2-api-tools
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
NightMonkey
Guru
Guru


Joined: 21 Mar 2003
Posts: 328
Location: Pittsburgh, PA

PostPosted: Sat Jun 07, 2008 5:00 am    Post subject: [BUMP REQUEST] liquidx: app-misc/ec2-api-tools Reply with quote

Howdy. Either there are new versions of the Amazon EC2 tools, or there's something funny going on:

Code:
fuji ~ # emerge ec2-api-tools ec2-ami-tools
Calculating dependencies... done!
>>> Verifying ebuild Manifests...
>>> starting parallel fetching pid 24127

>>> Emerging (1 of 2) app-misc/ec2-api-tools-1.2.6232 to /
>>> Downloading 'http://gentoo.arcticnetwork.ca/source/distfiles/ec2-api-tools.zip'
--2008-06-06 21:49:18--  http://gentoo.arcticnetwork.ca/source/distfiles/ec2-api-tools.zip
Connecting to 192.168.1.55:8081... connected.
Proxy request sent, awaiting response... 404 Not Found
2008-06-06 21:49:18 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.osuosl.org/distfiles/ec2-api-tools.zip'
--2008-06-06 21:49:18--  http://gentoo.osuosl.org/distfiles/ec2-api-tools.zip
Connecting to 192.168.1.55:8081... connected.
Proxy request sent, awaiting response... 404 Not Found
2008-06-06 21:49:19 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.mirrors.tera-byte.com/distfiles/ec2-api-tools.zip'
--2008-06-06 21:49:19--  http://gentoo.mirrors.tera-byte.com/distfiles/ec2-api-tools.zip
Connecting to 192.168.1.55:8081... connected.
Proxy request sent, awaiting response... 404 Not Found
2008-06-06 21:49:19 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.llarian.net/distfiles/ec2-api-tools.zip'
--2008-06-06 21:49:19--  http://gentoo.llarian.net/distfiles/ec2-api-tools.zip
Connecting to 192.168.1.55:8081... connected.
Proxy request sent, awaiting response... 404 Not Found
2008-06-06 21:49:19 ERROR 404: Not Found.

>>> Downloading 'http://gentoo.mirrors.easynews.com/linux/gentoo/distfiles/ec2-api-tools.zip'
--2008-06-06 21:49:19--  http://gentoo.mirrors.easynews.com/linux/gentoo/distfiles/ec2-api-tools.zip
Connecting to 192.168.1.55:8081... connected.
Proxy request sent, awaiting response... 404 Not Found
2008-06-06 21:49:20 ERROR 404: Not Found.

>>> Downloading 'http://s3.amazonaws.com/ec2-downloads/ec2-api-tools.zip'
--2008-06-06 21:49:20--  http://s3.amazonaws.com/ec2-downloads/ec2-api-tools.zip
Connecting to 192.168.1.55:8081... connected.
Proxy request sent, awaiting response... 200 OK
Length: 7510750 (7.2M) [application/x-zip-compressed]
Saving to: `/usr/portage/distfiles/ec2-api-tools.zip'

100%[==================================================================>] 7,510,750    597K/s   in 12s     

2008-06-06 21:49:33 (599 KB/s) - `/usr/portage/distfiles/ec2-api-tools.zip' saved [7510750/7510750]

 * checking ebuild checksums ;-) ...                                                                  [ ok ]
 * checking auxfile checksums ;-) ...                                                                 [ ok ]
 * checking miscfile checksums ;-) ...                                                                [ ok ]
 * checking ec2-api-tools.zip ;-) ...                                                                 [ !! ]

!!! Digest verification failed:
!!! /usr/portage/distfiles/ec2-api-tools.zip
!!! Reason: Filesize does not match recorded size
!!! Got: 7510750
!!! Expected: 8334663
fuji ~ #


Bump or correct manifest, please? :) Note that the same symptom exists for the app-misc/ec2-ami-tools. Thanks.
_________________
I like Linux. :D
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Jun 07, 2008 2:00 pm    Post subject: Reply with quote

You don't post that here, you create a bug if it's a portage package or message the developer of the ebuild if not.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
NightMonkey
Guru
Guru


Joined: 21 Mar 2003
Posts: 328
Location: Pittsburgh, PA

PostPosted: Sat Jun 07, 2008 8:57 pm    Post subject: Reply with quote

Funny, I was told in #gentoo to post here and explicitly *not* create a bug, since it is in a Gentoo Overlay (liquidx).
_________________
I like Linux. :D
Back to top
View user's profile Send private message
lexington
n00b
n00b


Joined: 10 Apr 2005
Posts: 25
Location: Cambridge, MA

PostPosted: Wed Dec 03, 2008 5:18 pm    Post subject: Reply with quote

Quote:
Funny, I was told in #gentoo to post here and explicitly *not* create a bug, since it is in a Gentoo Overlay (liquidx).


I uploaded an ebuild to bugs.gentoo.org for ec2-api-tools back in March. IMO, it's a better version then the liquidx overlay (definitely better documented) and it works for me.

I don't have a build for the ami tools however...

The latest ebuild is an attachment to this bug: ec2-api-tools
You will need the 99ec2 file as well (put it in the files directory)

It'd be nice to get this into portage...

~jtriley
Back to top
View user's profile Send private message
lexington
n00b
n00b


Joined: 10 Apr 2005
Posts: 25
Location: Cambridge, MA

PostPosted: Wed Dec 03, 2008 5:22 pm    Post subject: Reply with quote

BTW the problem you were having is exactly that there is a new version. The src_uri for that ebuild you're using references the ec2-api-tools.zip file which is an unversioned zip which always points to the latest. This is something the developer of that build didn't take into account. So, to fix THAT build, you will need to figure out what version the ec2-api-tools.zip contains and bump the build yourself.

Or, just use the ebuild I pointed to earlier. (please post any bugs you encounter to that post as well :D)

~jtriley
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum