Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Résolu] Pas de son & Pas d'acceleration 3D ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 9:44 am    Post subject: [Résolu] Pas de son & Pas d'acceleration 3D ? Reply with quote

Bonjour à tous les gentooistes :).

Comme vous pouvez le voir dans le titre de ce topic, j'ai un problème avec Alsa et Nvidia :s.

Je tiens à vous signaler que j'ai lu attentivement la documentation et que je l'ai suivi à la lettre ;).

Donc voici mon problème avec alsa : La carte son ne semble pas être reconnu et purtant il me semble bien avoir compilé le support pour ma carte son dans le noyau (ou en module) =/.

Code:

le résultat de cat /proc/asound/cards :
cat /proc/asound/cards
--- no soundcards ---


Code:
le résultat de alsamixer, de killall udevd; udevstart :
Desktop conqueror # alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or directory
Desktop conqueror # killall udevd; udevstart
Desktop conqueror # alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or directory


:? .

Bref voici l résultat d'un lspci -v | grep -i audio
Code:
Desktop conqueror # lspci -v | grep -i audio
00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)


Voilà, sinon j'ai une carte vidéo NVIDIA 7600gt et j'ai installé les bon drivers. Mon xorg.conf est également configuré comme il le faut :s.
Mais voici ce qui se passe quand je lance un jeu-video nécéssitant l'opengl et l'accélération 3D :
Code:
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: No dynamic GL support in video driver
failed


Et pourtant eselect me montre bien :
Code:
Desktop conqueror # eselect opengl list
Available OpenGL implementations:
  [1]   nvidia *
  [2]   xorg-x11


En espérant que vous pourrez m'aider :)


Last edited by conqueror1733 on Tue Jun 10, 2008 3:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Jun 08, 2008 9:55 am    Post subject: Reply with quote

Pour le son, vérifie que tu as bien activé le module CONFIG_SND_HDA_INTEL dans ton noyau.
Le résultat d'un dmesg serait certainement aussi très utile.

Pour le pilote NVIDIA, réinstalle le.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 10:07 am    Post subject: Reply with quote

dmesg | grep -i audio ne renvoit rien
Code:
Desktop conqueror # dmesg | grep -i audio
Desktop conqueror #   


mais dmesg | grep -i nvidia si ;)
Code:
Desktop conqueror # dmesg | grep -i nvidia
Nvidia board detected. Ignoring ACPI timer override.
nvidia: module license 'NVIDIA' taints kernel.
NVRM: loading NVIDIA UNIX x86 Kernel Module  169.09  Fri Jan 11 14:38:28 PST 2008
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 10:24 am    Post subject: Reply with quote

conqueror1733 wrote:
dmesg | grep -i audio ne renvoit rien
Code:
Desktop conqueror # dmesg | grep -i audio
Desktop conqueror #   

Desintegr parlait de vérifier le support dans le noyau :
grep -i SND_HDA /usr/src/linux/.config

Quote:
mais dmesg | grep -i nvidia si ;)
Code:
Desktop conqueror # dmesg | grep -i nvidia
Nvidia board detected. Ignoring ACPI timer override.
nvidia: module license 'NVIDIA' taints kernel.
NVRM: loading NVIDIA UNIX x86 Kernel Module  169.09  Fri Jan 11 14:38:28 PST 2008

Comme dit plus haut : le module existe peut-être mais il est probablement mal installé : réinstalle-le !

[EDIT] pour tester si un module est chargé, on utilise lsmod, pas dmesg ! ;)
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 10:32 am    Post subject: Reply with quote

Après un grep -i SND_HDA /usr/src/linux/.config voici le résultat ;) :

Code:
Desktop conqueror # grep -i SND_HDA /usr/src/linux/.config
# CONFIG_SND_HDA_INTEL is not set


J'en déduis que le module n'a pas été sélectionné, je vais donc le faire :).

Concernant mes drivers nvidia, j'ai beau les réinstaller ça ne marche pas mieux :/

Edit : J'ai compilé mon noyau avec le support intel et maintenant tout semble fonctionner (au niveau audio en tous cas :p) :). Merci pour votre aide =)


Last edited by conqueror1733 on Sun Jun 08, 2008 10:43 am; edited 1 time in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Jun 08, 2008 10:43 am    Post subject: Reply with quote

Et essaye de tester simplement l'OpenGL en utilisant glxgears. Le fichier libGL.so.1 n'existe pas sur mon système et l'OpenGL fonctionne très bien.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 10:44 am    Post subject: Reply with quote

Glxgears foncitonne et me donne le résultat qui suit :
Code:
49112 frames in 5.0 seconds = 9822.288 FPS
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Sun Jun 08, 2008 10:49 am    Post subject: Reply with quote

Vu le résultat que tu obtiens, l'OpenGL fonctionne parfaitement.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 10:57 am    Post subject: Reply with quote

Visiblement oui, mais dans ce cas pourquoi les applications nécéssitant l'openGl refusent-elles de se lancer ? =/
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 12:05 pm    Post subject: Reply with quote

Desintegr wrote:
Le fichier libGL.so.1 n'existe pas sur mon système et l'OpenGL fonctionne très bien.

Si l'OpenGL fonctionne alors la bibliothèque ibGL.so.1 existe mais peut-être pas où tu crois ! ;)
Code:
bigben ~ # equery f nvidia-drivers|grep libGL.so
/usr/lib/opengl/nvidia/lib/libGL.so
/usr/lib/opengl/nvidia/lib/libGL.so.1
/usr/lib/opengl/nvidia/lib/libGL.so.173.14.05

Code:
bigben ~ # ls -l /usr/lib/opengl/nvidia/lib/libGL.so*
lrwxrwxrwx 1 root root     18 mai 29 23:06 /usr/lib/opengl/nvidia/lib/libGL.so -> libGL.so.173.14.05
lrwxrwxrwx 1 root root     18 mai 29 23:06 /usr/lib/opengl/nvidia/lib/libGL.so.1 -> libGL.so.173.14.05
-rwxr-xr-x 1 root root 671684 mai 29 23:06 /usr/lib/opengl/nvidia/lib/libGL.so.173.14.05


Dans /etc/ld.so.conf, il y a également ceci :
Code:
bigben ~ # grep -i nvidia /etc/ld.so.conf
/usr/lib/opengl/nvidia/lib

C'est nécessaire pour que libGL.so soit trouvé.

On pourrait utiliser ldconfig pour rectifier le tir mais perso, je préfère un emerge nvidia-drivers.
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 12:41 pm    Post subject: Reply with quote

Merci de ton aide ghoti ;).

Cependant mon /etc/ld.so.conf porte déjà sur /usr/lib/opengl/nvidia/lib, de plus dans ce répertoire j'ai déjà la libGL.so.1qui porte sur libGl.so.169.* :s.

J'en viens à penser que la librairie fournie avec nvidia-drivers ne contient pas d'accélération 3D =/
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 1:06 pm    Post subject: Reply with quote

Réinstalle quand même nvidia-drivers : ça prend 30 secondes et ainsi, on sera sûr de partir sur de bonnes bases ! ;)
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 1:23 pm    Post subject: Reply with quote

Le résultat reste le même :s.
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 1:50 pm    Post subject: Reply with quote

Ok, que donne glxinfo|grep direct ?
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 2:34 pm    Post subject: Reply with quote

Résultat de glxinfo | grep direct :
Code:
Desktop conqueror # glxinfo | grep direct
direct rendering: Yes


Donc l'acceleration 3D est bel et bien activée. Mais pourquoi donc ce programme refuse-t-il de se lancer ? ><
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 2:46 pm    Post subject: Reply with quote

C'est quel programme ?
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 2:50 pm    Post subject: Reply with quote

Urban Terror (mais j'ai le même problème avec d'autres jeux opengl)
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 2:54 pm    Post subject: Reply with quote

Essaye de réemerger libsdl ;)
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Sun Jun 08, 2008 3:06 pm    Post subject: Reply with quote

Le résultat reste le même :s.
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Sun Jun 08, 2008 6:33 pm    Post subject: Reply with quote

Bah, je viens de l'installer et ça démarre sans souci. Tu ne serais pas en amd64, des fois ?
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1426
Location: Bamako - Mali - Afrique

PostPosted: Sun Jun 08, 2008 7:14 pm    Post subject: Reply with quote

Tu as bien le flag opengl pour libsdl ?
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Mon Jun 09, 2008 3:20 pm    Post subject: Reply with quote

Je suis sur un architecture x86, j'utilise donc un système x86 (l'amd64 étant encore trop peu adapté au niveau de slogiciels).

Sinon, en effet j'avais bien oublié de compiler avec l'opiton "opengl" dans ma variable USE.

Cependant, même après recompilation de cette librairie avec "opengl", les résultats sont peu satisfaisants :s :

Code:
...loading libGL.so.1:
Calling SDL_Init(SDL_INIT_VIDEO)...
SDL_Init(SDL_INIT_VIDEO) passed.
QGL_Init: Can't load libGL.so.1 from /etc/ld.so.conf or current dir: Failed loading DPMSDisable: /usr/lib/libX11.so.6: undefined symbol: DPMSDisable
failed
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------


Bref je pense qu'après une recompilation totale du système avec --newuse ça devrait marcher ;).
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Mon Jun 09, 2008 7:43 pm    Post subject: Reply with quote

Bon, ben ça n'a pas marché :/.

J'ai donc du installer gcc-4.2.* de la branche instable pour compiler le driver de nvidia.com, et maintenant ça marche =)
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3581
Location: Belgium

PostPosted: Mon Jun 09, 2008 8:09 pm    Post subject: Reply with quote

Bonne nouvelle ! :)

Donc, c'est (résolu) ? ;)
Back to top
View user's profile Send private message
conqueror1733
n00b
n00b


Joined: 08 Jun 2008
Posts: 13

PostPosted: Tue Jun 10, 2008 3:17 pm    Post subject: Reply with quote

En effet ;).


Je vais donc changer le titre de mon sujet pour y mettre le tag résolu ;).
_________________
The USE variable is USE="full" :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum