Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] ccsm & fusion-icon fail to start
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
cdstealer
Guru
Guru


Joined: 30 Oct 2005
Posts: 423
Location: Leeds

PostPosted: Tue Jun 10, 2008 10:45 am    Post subject: [SOLVED] ccsm & fusion-icon fail to start Reply with quote

Hi,
I can run emeral --replace and compiz-manager manually and everything works (well, wobbly windows, cube) but if I try to start ccsm or fusion-icon, I get the following.

Code:
cdstealer@Munted ~ $ ccsm
Traceback (most recent call last):
  File "/usr/bin/ccsm", line 67, in ?
    mainWin = ccm.MainWin(context, plugin, category)
  File "usr/lib/python2.4/site-packages/ccm/Window.py", line 60, in __init__
  File "usr/lib/python2.4/site-packages/ccm/Pages.py", line 1169, in __init__
  File "usr/lib/python2.4/site-packages/ccm/Widgets.py", line 1558, in __init__
AttributeError: 'NoneType' object has no attribute 'values'


Code:
cdstealer@Munted ~ $ fusion-icon
 * Detected Session: gnome
 * Searching for installed applications...
Traceback (most recent call last):
  File "/usr/bin/fusion-icon", line 57, in ?
    from FusionIcon.interface import choose_interface
  File "usr/lib/python2.4/site-packages/FusionIcon/interface.py", line 22, in ?
  File "usr/lib/python2.4/site-packages/FusionIcon/util.py", line 421, in ?
  File "usr/lib/python2.4/site-packages/FusionIcon/util.py", line 228, in __init__
TypeError: unsubscriptable object


all compiz related packages are emerged via layman so I'm using version 9999.

Has anyone seen this error before or can advise me what the problem is?
I've recompiled all compiz stuff but still the same error.

TIA
CD
_________________
# touch it
touch: cannot touch `it': Permission denied


Last edited by cdstealer on Thu Jun 12, 2008 8:13 am; edited 1 time in total
Back to top
View user's profile Send private message
NightDragon
Veteran
Veteran


Joined: 21 Aug 2004
Posts: 1153
Location: Vienna (Austria)

PostPosted: Tue Jun 10, 2008 8:23 pm    Post subject: Reply with quote

Hi!

I get the same error.
Maybe we should just wait a few days... I'm sure, the devs of compiz will fix that soon.
_________________
You are the problem too all my solutions ;)
Back to top
View user's profile Send private message
just
n00b
n00b


Joined: 14 Mar 2008
Posts: 8

PostPosted: Wed Jun 11, 2008 7:13 am    Post subject: Reply with quote

try:

=dev-python/pyrex-0.9.8.3
(=dev-python/setuptools-0.6_rc8-r1)
Back to top
View user's profile Send private message
malzeme_muhendisi
n00b
n00b


Joined: 01 Feb 2008
Posts: 11
Location: Gentoo

PostPosted: Wed Jun 11, 2008 8:59 am    Post subject: Reply with quote

just wrote:
try:

=dev-python/pyrex-0.9.8.3
(=dev-python/setuptools-0.6_rc8-r1)


Hi,
I have the same problem. I have tried this way but ccsm and fusion-icon still don't work. :? I think this is a bug and CF developers will fix that soon...
sorry for my english
_________________
Code:
burak@gentoobox ~ $ cat /etc/gentoo-release
Gentoo Base System release 2.0.0
Back to top
View user's profile Send private message
cdstealer
Guru
Guru


Joined: 30 Oct 2005
Posts: 423
Location: Leeds

PostPosted: Wed Jun 11, 2008 9:12 am    Post subject: Reply with quote

just wrote:
try:

=dev-python/pyrex-0.9.8.3
(=dev-python/setuptools-0.6_rc8-r1)


Nope sorry.. not working for me.

I'm going to try rebuilding x11 packages using
Code:
for f in `emerge -pevND world | grep x11 | awk {'print$4'}`;do emerge =$f;done


I'll let you know.
_________________
# touch it
touch: cannot touch `it': Permission denied
Back to top
View user's profile Send private message
just
n00b
n00b


Joined: 14 Mar 2008
Posts: 8

PostPosted: Wed Jun 11, 2008 2:30 pm    Post subject: Reply with quote

ahh sorry...

and rebuild dev-python/compizconfig-python
Back to top
View user's profile Send private message
malzeme_muhendisi
n00b
n00b


Joined: 01 Feb 2008
Posts: 11
Location: Gentoo

PostPosted: Wed Jun 11, 2008 2:42 pm    Post subject: Reply with quote

just wrote:
ahh sorry...

and rebuild dev-python/compizconfig-python


Thanks... :) ccsm and fusion-icon work fine...
_________________
Code:
burak@gentoobox ~ $ cat /etc/gentoo-release
Gentoo Base System release 2.0.0
Back to top
View user's profile Send private message
cdstealer
Guru
Guru


Joined: 30 Oct 2005
Posts: 423
Location: Leeds

PostPosted: Wed Jun 11, 2008 7:47 pm    Post subject: Reply with quote

just wrote:
ahh sorry...

and rebuild dev-python/compizconfig-python


DOH!! of course.. I'll re-emerge it when I get back in the office tomorrow and report back.

Re-emerging all the x11 packages didn't work obviously :(
_________________
# touch it
touch: cannot touch `it': Permission denied
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Wed Jun 11, 2008 10:03 pm    Post subject: Reply with quote

I was having this same problem after updating, following user Just's advice, fusion-icon and ccsm start, but my screen turns white and flickers erratically now.

i get this output from terminal:

fusion-icon
Code:
borg@Collective ~ $ fusion-icon
 * Detected Session: xfce
 * Searching for installed applications...
 * Intel detected, exporting: INTEL_BATCH=1
 * Using the GTK Interface
 * Starting Compiz
 ... executing: compiz --replace --sm-disable --ignore-desktop-hints ccp --indirect-rendering
compiz (core) - Warn: No GLXFBConfig for depth 32
compiz (core) - Info: Couldn't bind redirected window 0x220000e to texture

failed to create drawable
failed to create drawable
compiz (core) - Warn: No GLXFBConfig for depth 32
compiz (core) - Info: Couldn't bind redirected window 0x1e0000b to texture

compiz (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
^CTraceback (most recent call last):
  File "/usr/bin/fusion-icon", line 58, in ?
    choose_interface(try_first=options.interface)
  File "usr/lib/python2.4/site-packages/FusionIcon/interface.py", line 89, in choose_interface
  File "usr/lib/python2.4/site-packages/FusionIcon/interface.py", line 35, in import_interface
  File "usr/lib/python2.4/site-packages/FusionIcon/interface_gtk/__init__.py", line 3, in ?
  File "usr/lib/python2.4/site-packages/FusionIcon/interface_gtk/main.py", line 214, in ?
KeyboardInterrupt



and ccsm:
Code:
borg@Collective ~ $ ccsm
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 233, in ParseSettings
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 289, in Update
  File "compizconfig.pyx", line 968, in compizconfig.Context.ProcessEvents
  File "compizconfig.pyx", line 1054, in compizconfig.Context.ChangedSettings.__get__
  File "compizconfig.pyx", line 410, in compizconfig.SettingListToList
  File "compizconfig.pyx", line 740, in compizconfig.Plugin.Display.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine


Everything had been working just fine before I updated compiz...

:(
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Jun 12, 2008 12:17 am    Post subject: Reply with quote

Update Pyrex yet again.

Until 0.9.8.4 is in portage, do
Code:
cd /usr/portage/dev-python/pyrex
cp pyrex-0.9.8.3.ebuild pyrex-0.9.8.4.ebuild
ebuild pyrex-0.9.8.4.ebuild digest
emerge pyrex

.. or copy it to your overlay.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay


Last edited by gimpel on Thu Jun 12, 2008 9:28 am; edited 1 time in total
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Thu Jun 12, 2008 12:44 am    Post subject: Reply with quote

oh hai gimpel, thanks again for the help

i did that, fusion icon starts but when i use compiz as the window manager the screen flickers all strangely and eventually goes white and gray

if i try to move the cube it flickers and moves really slow, with most of the screen cut diagonally with flickering white, any window i open is just white

if i type "killall compiz" after opening an unreadable flickering white terminal it goes back to a plain desktop, then i can change the window manager option in fusion-icon or enter "xfwm4" in the terminal

if it helps, im using intel 945gm with the i810 driver

i just tried re-emerge xorg-server, but no help, and tried using the intel driver with the same results


i really want to get this fixed :(
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Thu Jun 12, 2008 3:18 am    Post subject: Reply with quote

trying to re-emerge the i810 driver fails with
Code:

i830_driver.c: In function 'I830DrmMMInit':
i830_driver.c:2115: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c:2115: error: 'mm_init' undeclared (first use in this function)
i830_driver.c:2115: error: (Each undeclared identifier is reported only once
i830_driver.c:2115: error: for each function it appears in.)
i830_driver.c:2116: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c:2117: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c:2118: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c: In function 'I830DrmMMTakedown':
i830_driver.c:2136: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c:2136: error: 'mm_takedown' undeclared (first use in this function)
i830_driver.c:2137: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c: In function 'I830DrmMMLock':
i830_driver.c:2151: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c:2151: error: 'mm_lock' undeclared (first use in this function)
i830_driver.c:2152: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c: In function 'I830DrmMMUnlock':
i830_driver.c:2167: error: 'drm_mm_init_arg_t' has no member named 'req'
i830_driver.c:2167: error: 'mm_unlock' undeclared (first use in this function)
i830_driver.c:2168: error: 'drm_mm_init_arg_t' has no member named 'req'
make[3]: *** [i830_driver.lo] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-drivers/xf86-video-i810-2.1.1/work/xf86-video-intel-2.1.1/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-drivers/xf86-video-i810-2.1.1/work/xf86-video-intel-2.1.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-drivers/xf86-video-i810-2.1.1/work/xf86-video-intel-2.1.1'
make: *** [all] Error 2
 *
 * ERROR: x11-drivers/xf86-video-i810-2.1.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2939:  Called x-modular_src_compile
 *             environment, line 3678:  Called x-modular_src_make
 *             environment, line 3714:  Called die
 * The specific snippet of code:
 *       emake || die "emake failed"
 *  The die message:
 *   emake failed


i dont know if that would even help the white flickering and overall lagging, but thought it would be worth a try


note to self: never ever upgrade things that don't absolutely need updating
Back to top
View user's profile Send private message
cdstealer
Guru
Guru


Joined: 30 Oct 2005
Posts: 423
Location: Leeds

PostPosted: Thu Jun 12, 2008 7:47 am    Post subject: Reply with quote

just wrote:
ahh sorry...

and rebuild dev-python/compizconfig-python


Excellent work.. that fixed it.. :D

Thank you!
_________________
# touch it
touch: cannot touch `it': Permission denied
Back to top
View user's profile Send private message
malzeme_muhendisi
n00b
n00b


Joined: 01 Feb 2008
Posts: 11
Location: Gentoo

PostPosted: Thu Jun 12, 2008 9:24 am    Post subject: Reply with quote

Hi,
I have a problem... I tried to start ccsm and I get following...
Code:
john@gentoobox ~ $ ccsm
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 289, in Update
  File "compizconfig.pyx", line 968, in compizconfig.Context.ProcessEvents
  File "compizconfig.pyx", line 1054, in compizconfig.Context.ChangedSettings.__get__
  File "compizconfig.pyx", line 410, in compizconfig.SettingListToList
  File "compizconfig.pyx", line 740, in compizconfig.Plugin.Display.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 233, in ParseSettings
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
.Plugin.Update
SystemError: null argument to internal routine

ccsm works but some plugins don't work... fusion-icon seems to work fine.
sorry for my English
_________________
Code:
burak@gentoobox ~ $ cat /etc/gentoo-release
Gentoo Base System release 2.0.0
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Jun 12, 2008 9:26 am    Post subject: Reply with quote

malzeme_muhendisi, see https://forums.gentoo.org/viewtopic-p-5119478.html#5119478

I also had to re-import my config from the backup, as pyrex-0.9.8.3 totally messed it up it seems.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
malzeme_muhendisi
n00b
n00b


Joined: 01 Feb 2008
Posts: 11
Location: Gentoo

PostPosted: Thu Jun 12, 2008 9:49 am    Post subject: Reply with quote

gimpel wrote:
malzeme_muhendisi, see https://forums.gentoo.org/viewtopic-p-5119478.html#5119478

I also had to re-import my config from the backup, as pyrex-0.9.8.3 totally messed it up it seems.


ahh sorry, I don't notice your post. I tried your way but I get the same error...

Code:
gentoobox pyrex # ebuild pyrex-0.9.8.4.ebuild digest
>>> Creating Manifest for /usr/portage/dev-python/pyrex
  digest.assumed                 2
   digest-pyrex-0.9.5.1a::Pyrex-0.9.5.1a.tar.gz
   digest-pyrex-0.9.6.4::Pyrex-0.9.6.4.tar.gz
gentoobox pyrex # emerge pyrex
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) dev-python/pyrex-0.9.8.3 to /
 * Pyrex-0.9.8.3.tar.gz RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking Pyrex-0.9.8.3.tar.gz ;-) ...                                  [ ok ]
>>> Unpacking source...
>>> Unpacking Pyrex-0.9.8.3.tar.gz to /var/tmp/portage/dev-python/pyrex-0.9.8.3/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-python/pyrex-0.9.8.3/work/Pyrex-0.9.8.3 ...
bla bla bla
>>> Source compiled.
>>> Test phase [not enabled]: dev-python/pyrex-0.9.8.3
bla bla bla bla
 * Cleaning orphaned Python bytecode from /usr/lib/python2.4/site-packages/Pyrex ..                                                                       [ ok ]
>>> Original instance of package unmerged safely.
 * Byte compiling python modules for python-2.4 .. ...                    [ ok ]
>>> dev-python/pyrex-0.9.8.3 merged.

>>> No packages selected for removal by clean
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.
 * GNU info directory index is up-to-date.
gentoobox pyrex #


I still get the same errors...
Code:
john@gentoobox ~ $ ccsm
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 233, in ParseSettings
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 289, in Update
  File "compizconfig.pyx", line 968, in compizconfig.Context.ProcessEvents
  File "compizconfig.pyx", line 1054, in compizconfig.Context.ChangedSettings.__get__
  File "compizconfig.pyx", line 410, in compizconfig.SettingListToList
  File "compizconfig.pyx", line 740, in compizconfig.Plugin.Display.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine


Did I make a mistake? :?
_________________
Code:
burak@gentoobox ~ $ cat /etc/gentoo-release
Gentoo Base System release 2.0.0
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Jun 12, 2008 9:54 am    Post subject: Reply with quote

malzeme_muhendisi wrote:
Code:
gentoobox pyrex # ebuild pyrex-0.9.8.4.ebuild digest
>>> Creating Manifest for /usr/portage/dev-python/pyrex
  digest.assumed                 2
   digest-pyrex-0.9.5.1a::Pyrex-0.9.5.1a.tar.gz
   digest-pyrex-0.9.6.4::Pyrex-0.9.6.4.tar.gz
gentoobox pyrex # emerge pyrex
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) dev-python/pyrex-0.9.8.3 to /
 * Pyrex-0.9.8.3.tar.gz RMD160 SHA1 SHA256 size ;-) ...                   [ ok ]

^^^^^^^^^^^^

Something went wrong as you still have 0.9.8.3 installed.

Maybe be more specific with the emerge to see what the error is
Code:
emerge -av =pyrex-0.9.8.4

_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
malzeme_muhendisi
n00b
n00b


Joined: 01 Feb 2008
Posts: 11
Location: Gentoo

PostPosted: Thu Jun 12, 2008 11:34 am    Post subject: Reply with quote

Code:
gentoobox john # emerge -av =pyrex-0.9.8.4

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] dev-python/pyrex-0.9.8.4 [0.9.8.3] USE="-examples" 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) dev-python/pyrex-0.9.8.4 to /
 * Pyrex-0.9.8.4.tar.gz RMD160 SHA1 SHA256 size ;-) ...                                                                                                     [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                        [ ok ]
 * checking auxfile checksums ;-) ...                       
bla bla bla
gentoobox john # eix pyrex
[D] dev-python/pyrex
     Available versions:  0.9.4.1 ~0.9.5.1a ~0.9.6.4 ~0.9.8.3 {examples}
     Installed versions:  0.9.8.4(14:28:39 12/06/08)(-examples)
     Homepage:            http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex
     Description:         A language for writing Python extension modules

gentoobox john #                                             


I installed pyrex 0.9.8.4 but I get the same error. :?
Code:
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 289, in Update
  File "compizconfig.pyx", line 968, in compizconfig.Context.ProcessEvents
  File "compizconfig.pyx", line 1054, in compizconfig.Context.ChangedSettings.__get__
  File "compizconfig.pyx", line 410, in compizconfig.SettingListToList
  File "compizconfig.pyx", line 740, in compizconfig.Plugin.Display.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine

In addition I clicked a button in ccsm and I get following error
Code:
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Pages.py", line 1285, in ShowPlugin
  File "usr/lib/python2.4/site-packages/ccm/Pages.py", line 126, in __init__
  File "compizconfig.pyx", line 734, in compizconfig.Plugin.Groups.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine

Sorry for my English
_________________
Code:
burak@gentoobox ~ $ cat /etc/gentoo-release
Gentoo Base System release 2.0.0
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Thu Jun 12, 2008 11:41 am    Post subject: :\ Reply with quote

Same error with malzeme_muhendisi..
:?
_________________
what about an answer here?
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Thu Jun 12, 2008 11:46 am    Post subject: Reply with quote

Did you guys recompile compizconfig-python after updating pyrex?
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
malzeme_muhendisi
n00b
n00b


Joined: 01 Feb 2008
Posts: 11
Location: Gentoo

PostPosted: Thu Jun 12, 2008 11:52 am    Post subject: Reply with quote

gimpel wrote:
Did you guys recompile compizconfig-python after updating pyrex?


:)
Code:
emerge compizconfig-python


Thanks, ccsm works fine...
_________________
Code:
burak@gentoobox ~ $ cat /etc/gentoo-release
Gentoo Base System release 2.0.0
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Thu Jun 12, 2008 1:11 pm    Post subject: :\ Reply with quote

Sorry i've forgot it too :)

now just works.. thx..
_________________
what about an answer here?
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Thu Jun 12, 2008 9:29 pm    Post subject: Reply with quote

gimpel wrote:
Did you guys recompile compizconfig-python after updating pyrex?


Yes, but still have the same issue with white flickering screen and really slow performance.

I've made a post about it on compiz-fusion forums though...

Hopefully this can be resolved.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Mon Jun 23, 2008 5:59 pm    Post subject: Reply with quote

0000000000000 wrote:


[cut]
...
[cut]

and ccsm:
Code:
borg@Collective ~ $ ccsm
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 233, in ParseSettings
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 289, in Update
  File "compizconfig.pyx", line 968, in compizconfig.Context.ProcessEvents
  File "compizconfig.pyx", line 1054, in compizconfig.Context.ChangedSettings.__get__
  File "compizconfig.pyx", line 410, in compizconfig.SettingListToList
  File "compizconfig.pyx", line 740, in compizconfig.Plugin.Display.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine


Everything had been working just fine before I updated compiz...

:(


++

just got the same and *subscribes*

hopefully I'll find a fix soon ...

edit: that DID IT !
thanks :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
0000000000000
Apprentice
Apprentice


Joined: 21 Mar 2008
Posts: 163

PostPosted: Wed Jun 25, 2008 12:14 am    Post subject: Reply with quote

I'm still unable to click on any options within ccsm

it opens alright, but i get this when i click on anything:
Code:
borg@Collective ~ $ ccsm
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 289, in Update
  File "compizconfig.pyx", line 968, in compizconfig.Context.ProcessEvents
  File "compizconfig.pyx", line 1054, in compizconfig.Context.ChangedSettings.__get__
  File "compizconfig.pyx", line 410, in compizconfig.SettingListToList
  File "compizconfig.pyx", line 740, in compizconfig.Plugin.Display.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Utils.py", line 233, in ParseSettings
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine
Traceback (most recent call last):
  File "usr/lib/python2.4/site-packages/ccm/Pages.py", line 1285, in ShowPlugin
  File "usr/lib/python2.4/site-packages/ccm/Pages.py", line 126, in __init__
  File "compizconfig.pyx", line 734, in compizconfig.Plugin.Groups.__get__
  File "compizconfig.pyx", line 712, in compizconfig.Plugin.Update
SystemError: null argument to internal routine


i've re-emerged compizconfig-python after updating pyrex, and no change.

i am trying to emerge compizconfig-python again, but anongit.compiz-fusion.org appears to be down...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum