Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Ik krijg mod_php niet geinstalleerd [opgelost]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 106
Location: The Netherlands

PostPosted: Thu Jul 24, 2003 8:58 am    Post subject: Ik krijg mod_php niet geinstalleerd [opgelost] Reply with quote

Hoi allemaal,

Ik krijg mod_php niet geinstalleerd, hier volgt de melding (uiteraard doe ik gewoon "emerge mod_php")

Code:

Calculating dependencies ...done!
>>> emerge (1 of 1) dev-php/mod_php-4.3.2-r4 to /
>>> md5 src_uri ;-) php-4.3.2.tar.bz2
>>> md5 src_uri ;-) php-4.3.2-fopen-url-secure.patch
>>> Unpacking source...
 * This is a security upgrade for PHP!
 * However it is not critical for your machine
 * Due to some previous bloopers with PHP and slotting, you may have
 * multiple copies of mod_php installed. Please look at the autoclean
 * output at the end of the emerge and unmerge all but relevant
 * copies.
 * Apache2 only detected
 * You have the xml USE flag turned off. Previously this
 * disabled XML support in PHP. However PEAR has a hard
 * dependancy on it, so they are now enabled.
>>> Unpacking php-4.3.2.tar.bz2 to /var/tmp/portage/mod_php-4.3.2-r4/work
>>> Source unpacked.
 * BerkDB is disabled due to DB4 issues and changes in PHP 4.3.2 presently.
 * If you need BerkDB support, please do NOT upgrade at this time
 * Building IMAP with SSL support.
creating cache ./config.cache
checking host system type... i586-pc-linux-gnu
Updated main/php_version.h
checking for gcc... gcc
checking whether the C compiler (gcc -march=pentium-mmx -O2 -pipe -fomit-frame-p
ointer -mmmx ) works... yes
checking whether the C compiler (gcc -march=pentium-mmx -O2 -pipe -fomit-frame-p
ointer -mmmx ) is a cross-compiler... yes
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for gawk... gawk
checking for bison... bison -y
checking bison version... 1.35 (ok)
checking for flex... flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for working const... yes
checking flex version... 2.5.4 (ok)
checking for pthreads_cflags...
checking for pthreads_lib...

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking for member fd in BUFF *... no
checking for mod_charset compatibility option... no
checking for Apache 2.0 module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS... yes
checking for Caudium support... no
checking for CLI build... yes
checking for embedded SAPI library support... no
checking for Zeus ISAPI support... no
checking for NSAPI support... no
checking for PHTTPD support... no
checking for Pi3Web support... no
checking for Roxen/Pike support... no
checking for Servlet support... no
checking for thttpd... no
checking for TUX... no
checking for webjames... no
checking for chosen SAPI module... apache2handler

Running system checks
checking for missing declarations of reentrant functions... done
checking for sendmail... /usr/sbin/sendmail
checking whether system uses EBCDIC... no
checking for socket... yes
checking for htonl... yes
checking for gethostname... yes
checking for gethostbyaddr... yes
checking for yp_get_default_domain... no
checking for __yp_get_default_domain... no
checking for yp_get_default_domain in -lnsl... yes
checking for dlopen... yes
checking for sin in -lm... yes
checking for res_search... no
checking for __res_search... no
checking for res_search in -lresolv... yes
checking for res_search in -lbind... no
checking for __res_search in -lbind... no
checking for res_search in -lsocket... no
checking for __res_search in -lsocket... no
checking for inet_aton... yes
checking for dn_skipname... no
checking for __dn_skipname... no
checking for dn_skipname in -lresolv... no
checking for __dn_skipname in -lresolv... yes
checking for dn_skipname in -lbind... no
checking for __dn_skipname in -lbind... no
checking for ANSI C header files... yes
checking for dirent.h that defines DIR... yes
checking for opendir in -ldir... no
checking for fclose declaration... ok
checking for ApplicationServices/ApplicationServices.h... no
checking for sys/types.h... yes
checking for sys/time.h... yes
checking for netinet/in.h... yes
checking for alloca.h... yes
checking for arpa/inet.h... yes
checking for arpa/nameser.h... yes
checking for assert.h... yes
checking for crypt.h... yes
checking for fcntl.h... yes
checking for grp.h... yes
checking for ieeefp.h... no
checking for langinfo.h... yes
checking for limits.h... yes
checking for locale.h... yes
checking for monetary.h... yes
checking for mach-o/dyld.h... no
checking for netdb.h... yes
checking for pwd.h... yes
checking for resolv.h... yes
checking for signal.h... yes
checking for stdarg.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for syslog.h... yes
checking for sysexits.h... yes
checking for sys/file.h... yes
checking for sys/mman.h... yes
checking for sys/mount.h... yes
checking for sys/poll.h... yes
checking for sys/resource.h... yes
checking for sys/select.h... yes
checking for sys/socket.h... yes
checking for sys/statfs.h... yes
checking for sys/statvfs.h... yes
checking for sys/vfs.h... yes
checking for sys/sysexits.h... no
checking for sys/varargs.h... no
checking for sys/wait.h... yes
checking for unistd.h... yes
checking for unix.h... no
checking for utime.h... yes
checking for sys/utsname.h... yes
checking for sys/ipc.h... yes
checking for fopencookie... yes
configure: error: can not run test program while cross compiling

!!! ERROR: dev-php/mod_php-4.3.2-r4 failed.
!!! Function econf, Line 320, Exitcode 1
!!! econf failed


Weet iemand hoe ik dit op kan lossen?

Hartelijk dank!


Last edited by knopper on Thu Jul 31, 2003 10:30 am; edited 1 time in total
Back to top
View user's profile Send private message
GuidoJ
Guru
Guru


Joined: 24 Dec 2002
Posts: 444
Location: Netherlands

PostPosted: Thu Jul 24, 2003 9:21 am    Post subject: Reply with quote

Vreemd. Jouw versie van gcc wordt herkent als cross-compiler. Wat geeft
Code:
gcc -v
?
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 106
Location: The Netherlands

PostPosted: Thu Jul 24, 2003 9:34 am    Post subject: Reply with quote

Daar komt dit uit rollen:

Code:

gcc -v
Reading specs from /usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.3/specs
Configured with: /var/tmp/portage/gcc-3.2.3-r1/work/gcc-3.2.3/configure --prefix=/usr --bindir=/usr/i586-pc-linux-gnu/gcc-bin/3.2 --includedir=/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.3/include --datadir=/usr/share/gcc-data/i586-pc-linux-gnu/3.2 --mandir=/usr/share/gcc-data/i586-pc-linux-gnu/3.2/man --infodir=/usr/share/gcc-data/i586-pc-linux-gnu/3.2/info --enable-shared --host=i586-pc-linux-gnu --target=i586-pc-linux-gnu --with-system-zlib --enable-languages=c,c++,ada,f77,objc --enable-threads=posix --enable-long-long --disable-checking --enable-cstdio=stdio --enable-clocale=generic --enable-__cxa_atexit --enable-version-specific-runtime-libs --with-gxx-include-dir=/usr/lib/gcc-lib/i586-pc-linux-gnu/3.2.3/include/g++-v3 --with-local-prefix=/usr/local --enable-shared --enable-nls --without-included-gettext
Thread model: posix
gcc version 3.2.3 20030422 (Gentoo Linux 1.4 3.2.3-r1, propolice)


Wat is een cross-compiler eigenlijk?
Back to top
View user's profile Send private message
wouzer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2003
Posts: 82
Location: The Hague, The Netherlands

PostPosted: Tue Jul 29, 2003 9:07 am    Post subject: Reply with quote

Hey knopper, waarschijnlijk heb je
Code:
emerge -u world
gedaan. Als je ook mysql4 hebt, gaat er iets mis met je libwww. De oplossing bij mij was:

Code:
emerge libwww


en dan:

Code:
emerge apache mod_php


Ik hoop dat het werkt.
Grtz,

Wouzer
_________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt. (Mark Twain)
Back to top
View user's profile Send private message
knopper
Tux's lil' helper
Tux's lil' helper


Joined: 20 Apr 2002
Posts: 106
Location: The Netherlands

PostPosted: Tue Jul 29, 2003 3:19 pm    Post subject: Reply with quote

Het werkt inderdaad!

Bedankt
Back to top
View user's profile Send private message
wouzer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2003
Posts: 82
Location: The Hague, The Netherlands

PostPosted: Tue Jul 29, 2003 11:31 pm    Post subject: Reply with quote

knopper, edit je het subject van deze thread even naar:

Ik krijg mod_php niet geinstalleerd [opgelost]

Als anderen een soorgelijk probleem hebben is het makkelijker zoeken.
Grtz,

Wouzer
_________________
It is better to keep your mouth closed and let people think you are a fool than to open it and remove all doubt. (Mark Twain)
Back to top
View user's profile Send private message
RikBlankestijn
Guru
Guru


Joined: 01 May 2003
Posts: 315
Location: Arnhem the Netherlands

PostPosted: Tue Sep 30, 2003 5:38 am    Post subject: Reply with quote

Goed plan want ik wist gelijk waar ik wezen moest. Thanks!

wouzer wrote:
knopper, edit je het subject van deze thread even naar:

Ik krijg mod_php niet geinstalleerd [opgelost]

Als anderen een soorgelijk probleem hebben is het makkelijker zoeken.
Grtz,

Wouzer
Back to top
View user's profile Send private message
ito
n00b
n00b


Joined: 22 Jul 2002
Posts: 27

PostPosted: Tue Sep 30, 2003 10:16 am    Post subject: revdep-rebuild [ gentoolkit ] Reply with quote

Na revdep rebuild moet dit probleem ook zijn opgelost.

------

revdep-rebuild -h
Usage: /usr/bin/revdep-rebuild [OPTIONS] [--] [EMERGE_OPTIONS]

Broken reverse dependency rebuilder.

-X, --package-names recompile based on package names, not exact versions
-q, --quiet be less verbose

Calls emerge, all other options are used for it (e. g. -p, --pretend).

Report bugs to <utx@gentoo.org>
------

voor meer info http://www.mail-archive.com/gentoo-user@gentoo.org/msg12871.html

GENTOOLKIT http://www.gentoo.org/doc/en/gentoolkit.xml
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum