Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Official thread: "zen-sources" - Part IV
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jun 24, 2008 2:32 pm    Post subject: Reply with quote

mroconnor wrote:
@KernelofTruth: I am on the adventure too. And I was not using the classic RCU. So when I get a chance to git-pull today, I'll try and go back to classic RCU.

I had a few more hardlocks yesterday on moderate disk IO, moving a dir of mp3s to a blackberry attached as mass storage device.


Just curious - is there a pretty way to get out of the hardlock with out holding the power button down?


thanks :)

if it's a hardlock it locks "hard" - no other way to omit that

you could however try magic sysrq-key + REISUB:

Raising Elephants Is So Utterly Boring.

in some cases it was still not THAT hard locked that I could reboot it .... :idea:
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 2:58 pm    Post subject: Reply with quote

Wow! That works.....at least while testing it from a non hardlocked machine. Thanks for the tip.

I'll report back once I update my repo.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jun 24, 2008 3:00 pm    Post subject: Reply with quote

classic rcu hardlocks too as soon as i touch emerge.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 24, 2008 3:19 pm    Post subject: Reply with quote

tranquilcool wrote:
classic rcu hardlocks too as soon as i touch emerge.


ok if u guys want to start playing, me and cheater-conrad (he is one of the old no-sources devs) are working on -zenmm (an mm based patchset), reiser4 and lockless and all that is working real nice so far, its not completely done yet (for example no tuxonice yet) but its running like butter, it has its own repo, its the same as the zen url but change kernel.git to kernel-mm.git
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 3:45 pm    Post subject: Reply with quote

what did you do to minimize the hardlock issue rmh3093?
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jun 24, 2008 4:02 pm    Post subject: Reply with quote

rmh3093 wrote:
tranquilcool wrote:
classic rcu hardlocks too as soon as i touch emerge.


ok if u guys want to start playing, me and cheater-conrad (he is one of the old no-sources devs) are working on -zenmm (an mm based patchset), reiser4 and lockless and all that is working real nice so far, its not completely done yet (for example no tuxonice yet) but its running like butter, it has its own repo, its the same as the zen url but change kernel.git to kernel-mm.git


all i need now is get nvidia-drivers to compile with zenmm.
fails with this errors;

v/Module.symvers -o /var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/Module.symvers -S -w -c -s
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
*
* ERROR: x11-drivers/nvidia-drivers-173.14.09 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3690: Called linux-mod_src_compile
* environment, line 2718: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CC=\"$(get-KERNEL_CC)\" LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
* The die message:
* Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/usr/src/linux HOST_CC=i686-pc-linux-gnu-gcc clean module
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 24, 2008 4:03 pm    Post subject: Reply with quote

mroconnor wrote:
what did you do to minimize the hardlock issue rmh3093?


nothing, the lockless patches were designed for -mm, they work fine there, we were probably breaking it or not including all the patches they required
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 4:05 pm    Post subject: Reply with quote

YAY!

/me wonders if he could convince dodo to apply HDAPS patches to -zenmm?
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 24, 2008 4:10 pm    Post subject: Reply with quote

tranquilcool wrote:
rmh3093 wrote:
tranquilcool wrote:
classic rcu hardlocks too as soon as i touch emerge.


ok if u guys want to start playing, me and cheater-conrad (he is one of the old no-sources devs) are working on -zenmm (an mm based patchset), reiser4 and lockless and all that is working real nice so far, its not completely done yet (for example no tuxonice yet) but its running like butter, it has its own repo, its the same as the zen url but change kernel.git to kernel-mm.git


all i need now is get nvidia-drivers to compile with zenmm.
fails with this errors;

v/Module.symvers -o /var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/Module.symvers -S -w -c -s
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
*
* ERROR: x11-drivers/nvidia-drivers-173.14.09 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3690: Called linux-mod_src_compile
* environment, line 2718: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CC=\"$(get-KERNEL_CC)\" LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
* The die message:
* Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/usr/src/linux HOST_CC=i686-pc-linux-gnu-gcc clean module


there is an ebuild in the zen over lay for the 177 version with a patch that makes it work for -mm, it it dont work for u, try applying the patch to the 173 ebuild its called mm-fix.patch
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
dodo1122
Guru
Guru


Joined: 02 Sep 2006
Posts: 347
Location: York, England

PostPosted: Tue Jun 24, 2008 4:13 pm    Post subject: Reply with quote

mroconnor wrote:
YAY!

/me wonders if he could convince dodo to apply HDAPS patches to -zenmm?


It's there since yesterday :P tp_smapi + hdaps from tp_smapi.
_________________
#zen-sources on irc.rizon.net
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jun 24, 2008 4:19 pm    Post subject: Reply with quote

rmh3093 wrote:
tranquilcool wrote:
rmh3093 wrote:
tranquilcool wrote:
classic rcu hardlocks too as soon as i touch emerge.


ok if u guys want to start playing, me and cheater-conrad (he is one of the old no-sources devs) are working on -zenmm (an mm based patchset), reiser4 and lockless and all that is working real nice so far, its not completely done yet (for example no tuxonice yet) but its running like butter, it has its own repo, its the same as the zen url but change kernel.git to kernel-mm.git


all i need now is get nvidia-drivers to compile with zenmm.
fails with this errors;

v/Module.symvers -o /var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/Module.symvers -S -w -c -s
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
*
* ERROR: x11-drivers/nvidia-drivers-173.14.09 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3690: Called linux-mod_src_compile
* environment, line 2718: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CC=\"$(get-KERNEL_CC)\" LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CC="$(get-KERNEL_CC)" LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
* The die message:
* Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CC=i686-pc-linux-gnu-gcc LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/usr/src/linux HOST_CC=i686-pc-linux-gnu-gcc clean module


there is an ebuild in the zen over lay for the 177 version with a patch that makes it work for -mm, it it dont work for u, try applying the patch to the 173 ebuild its called mm-fix.patch


patch applied to nvidia-drivers-173.14.09. compiles and installs.
now let me take zenmm fo a test ride.
thanks.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 4:40 pm    Post subject: Reply with quote

Thanks @dodo!

What I would give for a less restrictive firewall right now!

I assume there is still no git access through http?
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jun 24, 2008 5:04 pm    Post subject: Reply with quote

mroconnor wrote:
Thanks @dodo!

What I would give for a less restrictive firewall right now!

I assume there is still no git access through http?


git-http-fetch ???
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 5:55 pm    Post subject: Reply with quote

I thought rmh said that the repo wasnt set up for that? Am I wrong? please please let me be wrong....I havent pulled in 24 hours. ;)
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 24, 2008 6:04 pm    Post subject: Reply with quote

kernelOfTruth wrote:
mroconnor wrote:
Thanks @dodo!

What I would give for a less restrictive firewall right now!

I assume there is still no git access through http?


git-http-fetch ???


shit i forgot to follow up on that, its not setup yet
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 6:06 pm    Post subject: Reply with quote

no worries!! it isnt like you sit around all day and do nothing?? You had to drink a lot of beer in mexico!
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 24, 2008 7:34 pm    Post subject: Reply with quote

mroconnor wrote:
no worries!! it isnt like you sit around all day and do nothing?? You had to drink a lot of beer in mexico!

didnt drink much beer actually, Mojito's in the morning/afternoon and Remy or Patron in the evening
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jun 24, 2008 7:36 pm    Post subject: Reply with quote

didn't know you are tequila and cognac man! knew I liked you for a reason. :)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jun 24, 2008 10:57 pm    Post subject: Reply with quote

so far zenmm is kicking ass.
the mouse_poll errors are still here but doesn't seem to
worry at all.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jun 24, 2008 11:17 pm    Post subject: Reply with quote

tranquilcool wrote:
so far zenmm is kicking ass.
the mouse_poll errors are still here but doesn't seem to
worry at all.


now see that is weird, cause we are using conrad's mousepoll patch which could be the same but we made them separately, i have compiled my kernel with and without that enabled and I dnt get the error, i wonder what ua re doing to get that error
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jun 24, 2008 11:27 pm    Post subject: Reply with quote

rmh3093 wrote:
tranquilcool wrote:
so far zenmm is kicking ass.
the mouse_poll errors are still here but doesn't seem to
worry at all.


now see that is weird, cause we are using conrad's mousepoll patch which could be the same but we made them separately, i have compiled my kernel with and without that enabled and I dnt get the error, i wonder what ua re doing to get that error


dunno why i have the errors.
i don't have these errors in rc7-zen0
comes back with zenmm. as a matter of fact i use the same .config with all my kernels
so there are no changes to mouse poll stuff
_________________
this is a strange strange world.


Last edited by tranquilcool on Wed Jun 25, 2008 7:13 am; edited 1 time in total
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Wed Jun 25, 2008 1:58 am    Post subject: Reply with quote

tranquilcool wrote:
rmh3093 wrote:
tranquilcool wrote:
so far zenmm is kicking ass.
the mouse_poll errors are still here but doesn't seem to
worry at all.


now see that is weird, cause we are using conrad's mousepoll patch which could be the same but we made them separately, i have compiled my kernel with and without that enabled and I dnt get the error, i wonder what ua re doing to get that error


dunno why i have the errors.
i don't have these errors in rc7-zen0
comes back with zenmm. as a matter i use the same .config with all my kernels
so there are no changes to mouse poll stuff


-rc7 didnt have mousepoll
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Wed Jun 25, 2008 3:00 am    Post subject: Reply with quote

tranquilcool wrote:
rmh3093 wrote:
tranquilcool wrote:
so far zenmm is kicking ass.
the mouse_poll errors are still here but doesn't seem to
worry at all.


now see that is weird, cause we are using conrad's mousepoll patch which could be the same but we made them separately, i have compiled my kernel with and without that enabled and I dnt get the error, i wonder what ua re doing to get that error


dunno why i have the errors.
i don't have these errors in rc7-zen0
comes back with zenmm. as a matter i use the same .config with all my kernels
so there are no changes to mouse poll stuff


It's now fixed in -zenmm, not sure if dodo added it to -zen (but i told him to)

I just dumbed down the patch like it originally was, i have no idea where and why the sysctl stuff even came about. It works exactly the same, except for the fact that it works :-p
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Wed Jun 25, 2008 9:38 am    Post subject: Reply with quote

with latest git pull the zenmm mouse poll errors are fixed.
thanks guys!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Wed Jun 25, 2008 2:35 pm    Post subject: Reply with quote

-zenmm seems really great. I was able to run some emerges, do some file IO, use amarok all at the same time and not a lockup at all.

Is there anything special in the -zenmm kernel that should be turned on/off for best performance??

EDIT: the hdaps seems to be throwing that missing 'blk_freeze patch missing' error. I have it HDAPS and tp_smapi built as modules.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 15, 16, 17  Next
Page 7 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum