Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Failed emerge on OpenOffice-2.4.1 -- ppc64 [3.0 emerged]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Sat Jun 14, 2008 4:04 pm    Post subject: Failed emerge on OpenOffice-2.4.1 -- ppc64 [3.0 emerged] Reply with quote

I got past the imagemagick double compile bug and was able to get a couple of hours of an OpenOffice build. However, after about 5-6 hours of compile time, it fails with this:
Code:
------------------------------
Making: ../../../unxlngppc64.pro/slo/odbc2_version.obj
powerpc64-unknown-linux-gnu-gcc -fsigned-char -fmessage-length=0 -c -Os -fno-str
ict-aliasing   -I.  -I../../../unxlngppc64.pro/inc/odbcbase -I../inc -I../../inc
 -I../../../inc/pch -I../../../inc -I../../../unx/inc -I../../../unxlngppc64.pro
/inc -I. -I/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m1
2/solver/680/unxlngppc64.pro/incdont_use_stl -I/var/tmp/portage/app-office/openo
ffice-2.4.0/work/ooo/build/OOH680_m12/solver/680/unxlngppc64.pro/inc/external -I
/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m12/solver/68
0/unxlngppc64.pro/inc -I/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/bu
ild/OOH680_m12/solenv/unxlngppc64/inc -I/var/tmp/portage/app-office/openoffice-2
.4.0/work/ooo/build/OOH680_m12/solenv/inc -I/var/tmp/portage/app-office/openoffi
ce-2.4.0/work/ooo/build/OOH680_m12/res -I/var/tmp/portage/app-office/openoffice-
2.4.0/work/ooo/build/OOH680_m12/solver/680/unxlngppc64.pro/incdont_use_stl -I/va
r/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m12/solenv/inc/X
p31 -INO_JAVA_HOME/include -INO_JAVA_HOME/include/linux -INO_JAVA_HOME/include/n
ative_threads/include -Idefault_x_includes     -I/var/tmp/portage/app-office/ope
noffice-2.4.0/work/ooo/build/OOH680_m12/solver/680/unxlngppc64.pro/inc/offuh -I.
 -I../../../res -I. -fsigned-char -pipe -pipe -mcpu=power3 -mtune=power3  -fPIC
-DLINUX -DUNX -DVCL -DGCC -DC300 -DPOWERPC64 -DCVER=C300 -DNPTL -DGLIBC=2 -D_PTH
READS -D_REENTRANT -DNEW_SOLAR -D_USE_NAMESPACE=1 -DSTLPORT_VERSION=400 -DPOWERP
C -DPPC -DHAVE_GCC_VISIBILITY_FEATURE -DPOWERPC64 -D__DMAKE -DUNIX -DCPPU_ENV=gc
c3 -DGXX_INCLUDE_PATH=/usr/lib/gcc/powerpc64-unknown-linux-gnu/4.2.4/include/g++
-v4 -DSUPD=680 -DPRODUCT -DNDEBUG -DPRODUCT_FULL -DOSL_DEBUG_LEVEL=0 -DOPTIMIZE
-DCUI -DOOH680=OOH680   -DSHAREDLIB -D_DLL_   -o ../../../unxlngppc64.pro/slo/od
bc2_version.o ../../../unxlngppc64.pro/misc/odbc2_version.c
if test -e ../../../unxlngppc64.pro/slo/odbc2_version.o ; then touch ../../../un
xlngppc64.pro/slo/odbc2_version.obj ; fi
Making: ../../../unxlngppc64.pro/slo/OPreparedStatement.obj
Making: ../../../unxlngppc64.pro/slo/OStatement.obj
distcc[14635] ERROR: compile /var/tmp/ccache/OStatement.tmp.ibm_left.14631.ii on
 localhost failed
/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m12/connectiv
ity/source/drivers/odbc/OStatement.cxx: In member function 'sal_Int32 connectivi
ty::odbc::OStatement_Base::getRowCount()':
/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m12/connectiv
ity/source/drivers/odbc/OStatement.cxx:301: error: cannot convert 'sal_Int32*' t
o 'SQLINTEGER*' in argument passing
/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m12/connectiv
ity/source/drivers/odbc/OStatement.cxx: In member function 'virtual com::sun::st
ar::uno::Sequence<int> connectivity::odbc::OStatement::executeBatch()':
/var/tmp/portage/app-office/openoffice-2.4.0/work/ooo/build/OOH680_m12/connectiv
ity/source/drivers/odbc/OStatement.cxx:567: error: cannot convert 'sal_Int32*' t
o 'SQLINTEGER*' in argument passing
dmake:  Error code 1, while making '../../../unxlngppc64.pro/slo/OStatement.obj'
---* tg_merge.mk *---

My ccache was set to 4G. Is it possible it would fail do to limited ccache memory? I'm going to up it to 7G, but I want to look at every possible cause before another 6 hours only to fail.

emerge --info
Code:
Portage 2.1.4.4 (default/linux/powerpc/ppc64/2008.0/64bit-userland, gcc-4.2.4, glibc-2.7-r2, 2.6.24-gentoo-r3 ppc64)
=================================================================
System uname: 2.6.24-gentoo-r3 ppc64 POWER3 (630+)
Timestamp of tree: Fri, 13 Jun 2008 10:30:01 +0000
distcc 2.18.3 powerpc64-unknown-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="ppc64"
CBUILD="powerpc64-unknown-linux-gnu"
CFLAGS="-O3 -pipe -mcpu=power3 -mtune=power3"
CHOST="powerpc64-unknown-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O3 -pipe -mcpu=power3 -mtune=power3"
DISTDIR="/usr/portage/distfiles"
FEATURES="buildpkg ccache distcc distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://open-systems.ufl.edu/mirrors/gentoo "
LANG="en_US.utf8"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="acl berkdb bzip2 cli cracklib crypt cups dri fortran gdbm gpm ibm iconv ipv6 isdnlog midi mudflap ncurses nls nptl nptlonly openmp pam pcre perl ppc64 pppd python readline reflection session spl ssl tcpd unicode xorg zlib" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fbdev mach64 mga nv r128 radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

I'm also planning on changing "localhost" to the IP address of ibm_left.

I'll probably just go ahead and start a build while waiting for an answer. I'm also going to do a google search just to make sure this isn't something that's happened to someone else.
_________________
Greg


Last edited by trigggl on Wed Oct 15, 2008 11:15 am; edited 3 times in total
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Sat Jun 14, 2008 4:25 pm    Post subject: Found the bug report Reply with quote

OK, so once again, I found a bug report.
https://bugs.gentoo.org/show_bug.cgi?id=223385

2.4.0 is broken and I need to try 2.4.1 on ppc64
_________________
Greg
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Sun Jun 15, 2008 1:25 am    Post subject: Reply with quote

No Go.

I came to the exact same error on 2.4.1. I guess I need to try the patch.
_________________
Greg
Back to top
View user's profile Send private message
trigggl
Apprentice
Apprentice


Joined: 26 Aug 2007
Posts: 234
Location: Arkansas

PostPosted: Wed Oct 15, 2008 11:14 am    Post subject: Reply with quote

I did manage to emerge openoffice-3.0.0 after adding ~ppc64 to the ebuild.

Bug 238642
_________________
Greg
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum