Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox 3 upgrade weirdness
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
thelee
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jul 2007
Posts: 132

PostPosted: Thu Jun 19, 2008 6:27 am    Post subject: firefox 3 upgrade weirdness Reply with quote

so i unmaksed ~x86 for mozilla-firefox-3.0 and its dependencies and merged it... did the whole revdep-rebuild shebang on the nspr library.

now i do a emerge --deep --ask --verbose --newuse --update world and see that mozilla-firefox-2.0.0.14 is getting pulled in! i manually went through all the packages to see if any of them would be pulling it in, but no such luck. i had to manually add <www-client/mozilla-firefox-3.0 to my package.mask to prevent it from happening.

can someone explain to me why this is happening?
Back to top
View user's profile Send private message
yoshi314
l33t
l33t


Joined: 30 Dec 2004
Posts: 848
Location: PL

PostPosted: Thu Jun 19, 2008 10:00 am    Post subject: Reply with quote

most likely something has a dependency on older firefox.

i haven't used portage in a while (year or so), i know that paludis can show you the downgrade reason. maybe portage also has that function.
_________________
~amd64
shrink your /usr/portage with squashfs+aufs
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 467
Location: London, UK

PostPosted: Thu Jun 19, 2008 10:11 am    Post subject: Reply with quote

I noticed that too. I am guessing its because when revdep-rebuild is being run, Firefox-3.0 is not there yet, so rev-dep rebuild will re-emerge firefox-2.x to update the library dependency as it does with all the rest of the packages. In my case it also re-emerged Openoffice-2.4.0. So that had to run over night. Ones that was completed this morning, I deleted the old libraries as the info text showed and emerged firefox-3.0. It did succeed then and Firefox 3 is running excellently at the moment (I am using it right now :) ). Took a while to get there though....

EDIT: Sorry, didn't notice that your problem is slightly different. You sure you didn't get any messages regarding those libraries when you first emerged Firefox-3.0? I'll have to test that world update and check what it says on my machine...

EDIT2: Back again. Check this thread from this post onwards: https://forums.gentoo.org/viewtopic-p-5125484.html#5125484 It seems we might have more work to get all these libraries in a good state...
Back to top
View user's profile Send private message
Bluespear
Apprentice
Apprentice


Joined: 20 Jul 2005
Posts: 164
Location: Switzerland

PostPosted: Thu Jun 19, 2008 11:37 am    Post subject: Reply with quote

I have turn off firefox useflag because all apps using it want version 2-* which cause de downgrade.
Some packages using this flags : vlc, swt, openoffice (not bin)
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 467
Location: London, UK

PostPosted: Thu Jun 19, 2008 1:11 pm    Post subject: Reply with quote

Bluespear wrote:
I have turn off firefox useflag because all apps using it want version 2-* which cause de downgrade.
Some packages using this flags : vlc, swt, openoffice (not bin)


Yes, that what is being said. You should instead set the xulrunner flag for these packages to use. I haven't tried this myself.

Meanwhile, it looks like the download record is 8.3 million: http://news.bbc.co.uk/1/hi/technology/7462900.stm :D

EDIT: Trying to work out what this xulrunner is, I came across this nice article explaining it all: http://en.wikipedia.org/wiki/XULRunner
Back to top
View user's profile Send private message
thelee
Tux's lil' helper
Tux's lil' helper


Joined: 23 Jul 2007
Posts: 132

PostPosted: Thu Jun 19, 2008 6:49 pm    Post subject: Reply with quote

my problem is slightly different from what everyone has been saying.

firefox 2.0.0.14 isn't being pulled in from any package dependency, as far as i know. all the "bold" packages i did an emerge --pretend --verbose, and none of them were pulling in firefox 2.0. I did an equery hasuse firefox to see what packages i had used it, and the only packages that showed up had already been rebuilt through a revdep-rebuild after my firefox 3.0 merge; my use flags had been changed to have '-firefox' and 'xulrunner'. it's just that for some reason, without masking versions of firefox less than 3.0, doing a world update seems to make my portage to downgrade my firefox 3.0 to 2.0.0.14.
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Sat Jun 21, 2008 7:56 pm    Post subject: Reply with quote

vlc seems to depend on firefox-2.x...that is the problem in my case...do 'equery d mozilla-firefox' to see what programmes depend on firefox in your case...
Back to top
View user's profile Send private message
platojones
Veteran
Veteran


Joined: 23 Oct 2002
Posts: 1595
Location: Just over the horizon

PostPosted: Sat Jun 21, 2008 8:50 pm    Post subject: Reply with quote

I'm trying the xulrunner flag to replace the firefox flag now...hopefully that is the right solution. In my case, it's forced a rebuild of openoffice.
Back to top
View user's profile Send private message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Jun 21, 2008 11:09 pm    Post subject: Reply with quote

If there is anything that still pulls in mozilla-firefox-2 and can not be convinced with USE flags xulrunner -firefox then you should consider that a bug and report it.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
monsm
Guru
Guru


Joined: 26 Sep 2007
Posts: 467
Location: London, UK

PostPosted: Mon Jun 23, 2008 11:51 am    Post subject: Reply with quote

Quote:
Location: in the Dutch Mountains ;-)


Ah, yes, the glorious Dutch mountains. Went past those ones on a train to Maastrict visiting a friend. A little hill and some trees. Similar to the Danish Himmelbjerget (translates to Skymountain). At least you don't need oxygen masks to climb them :D

Anyway, Firefox-2.x seems to be history after changing the useflags.
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Mon Jun 23, 2008 1:29 pm    Post subject: Reply with quote

not for me...still a lot of the addons i use with firefox-2.x are not compatible with version 3.x...so i reverted back to firefox-2.x for the time being...
Back to top
View user's profile Send private message
Timbers2k
Apprentice
Apprentice


Joined: 03 Oct 2003
Posts: 215

PostPosted: Thu Jun 26, 2008 5:43 pm    Post subject: Reply with quote

I've done an emerge -auDN world with the -firefox and xulrunner flags in my make.conf. This recompiled a few things including openoffice. The only way I can get portage to stop wanting to downgrade firefox is to mask < 3.0. Using the -t flag to portage shows ONLY the firefox downgrade, not what is pulling it in.
Back to top
View user's profile Send private message
dpetka2001
l33t
l33t


Joined: 04 Mar 2005
Posts: 804

PostPosted: Thu Jun 26, 2008 9:35 pm    Post subject: Reply with quote

go with an 'equery d mozilla-firefox' and see what depends on firefox...that should be pulling it in causing the downgrade...
Back to top
View user's profile Send private message
furlongm
n00b
n00b


Joined: 12 Oct 2004
Posts: 23

PostPosted: Thu Jun 26, 2008 9:44 pm    Post subject: Reply with quote

Same problem here. For me, it was net-www/mplayerplug-in that was pulling in firefox2. I unmerged that and it stopped trying to downgrade firefox.

There's an ~x86 version of mplayerplug-in but it pulls in a slotted xulrunner, I'll wait for that ebuild to be updated against the firefox3 version of xulrunner.
Back to top
View user's profile Send private message
UB|K
l33t
l33t


Joined: 27 May 2004
Posts: 786
Location: Villeurbanne, France

PostPosted: Fri Jun 27, 2008 8:02 am    Post subject: Reply with quote

furlongm wrote:
Same problem here. For me, it was net-www/mplayerplug-in that was pulling in firefox2. I unmerged that and it stopped trying to downgrade firefox.

There's an ~x86 version of mplayerplug-in but it pulls in a slotted xulrunner, I'll wait for that ebuild to be updated against the firefox3 version of xulrunner.

see this bug (patch inside)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum