Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems with ifort / torque / maui program output
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
grktaurus83
n00b
n00b


Joined: 04 Feb 2007
Posts: 7

PostPosted: Fri Jun 20, 2008 6:49 am    Post subject: Problems with ifort / torque / maui program output Reply with quote

Hey all,

I recently started using the free intel fortran compiler for linux on my gentoo cluster (running torque/maui) and I've noticed some bizarre output from my code print statements. Occasionally there is a section that is replaced by "^@^@^@^@" for a couple of thousand columns. Example below.

Code:

                            LOG10 MAX NORM    NEWTON ALGORITHM
                    LOG10   ---------------   ----------------
            TIME     TIME   STEADY   CHANGE   STEPS
            STEP     STEP    STATE   TO THE      JACOBIANS
          NUMBER     SIZE   RESIDL   SOLUTN          CONDITION   REMARK

           60200              0.74
           60201    -6.51     0.61    -6.07      1    1  27.17
           60202    -6.51     0.84    -6.07      1
           60203    -6.51     0.44    -6.07      1
           60204    -6.51     0.44    -6.07      1
           60205    -6.51     0.84    -6.07      1
           60206    -6.51     0.84    -6.07      1
           60207    -6.51     0.44    -6.07      1
           60208    -6.51     0.44    -6.07      1
           60209    -6.51     0.44    -6.07      1
           60210    -6.51     0.44    -6.07      1
           60211    -6.51     0.66    -6.07      1
           60212    -6.51     0.61    -6.07      1
           60213    -6.51     0.66    -6.07      1
           60214    -6.51     0.44    -6.07      1
           60215    -6.51     0.84    -6.07      1
           60216    -6.51     0.44    -6.07      1
           60217    -6.51     0.67    -6.07      1
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@
           60247    -6.47     0.95    -6.03      1
           60248    -6.47     0.44    -6.03      1
           60249    -6.47     0.67    -6.03      1
           60250    -6.47     0.84    -6.03      1
           60251    -6.47     0.90    -6.03      1
           60252    -6.47     0.74    -6.03      1
           60253    -6.47     0.96    -6.03      1
           60254    -6.47     0.72    -6.03      1
           60255    -6.47     0.57    -6.03      1


The crazy thing is that these artifacts go away when the code is done running and they are replaced with what is actually supposed to be in the output file.

I'm pretty baffled by this behavior (as it doesn't seem to appear when g77 is used to compile the codes, or I just haven't noticed it if it did) and have no idea how to avoid this.

The reason this is a problem is because these codes can take weeks to run, and if one of the solutions hits a specified condition, we can stop running and move on to other simulations. But when the output is replaced by "^@^@^@" we can't analyze the data as the code is running.

Any help would be greatly appreciated. Thanks guys!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum