Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[GTK]dynamic modules arenot supported by this system[resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Thu Jun 26, 2008 6:51 am    Post subject: [GTK]dynamic modules arenot supported by this system[resolu] Reply with quote

Bonjour,

Je fais appel à votre science car je n'y comprend plus rien. Tout a commencé avec du jour au lendemain l'impossibilité de lancer Firefox, vlc... l'emulateur Amiga et gxmame affichaient des carrés à la place du texte. esync, emerge -e system et emerge -avtNuD world, toujours pareil... mais pire, à chaque compilation de gtk, plantage et le message est :

Code:
/var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-ti-et.la does not export GTK+ IM module API: dynamic modules are not supported by this system
Cannot load module /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-viqr.la: dynamic modules are not supported by this system
/var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-viqr.la does not export GTK+ IM module API: dynamic modules are not supported by this system
Cannot load module /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-multipress.la: dynamic modules are not supported by this system
/var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-multipress.la does not export GTK+ IM module API: dynamic modules are not supported by this system
make[3]: *** [gtk.immodules] Erreur 1
make[3]: quittant le répertoire « /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/int »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9 »
make: *** [all] Erreur 2


C'est donc avec beaucoup d'humilité que je m'en remets à vous dans l'espoir que vous pourrez eclairé mon ignorance.

au fait, j'ai entre temps viré KDE (je voulais le faire depuis longtemps...) pour installé Gnome mais hélas Gnome est gtk et gtk me hais...



Un petit emerge --info de mon system :

Code:

Portage 2.1.4.4 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-gentoo-r3 i686)
=================================================================
System uname: 2.6.24-gentoo-r3 i686 AMD Athlon(tm) XP 3200+
Timestamp of tree: Thu, 26 Jun 2008 05:33:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.proxad.net/mirrors/ftp.gentoo.org"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib alsa arts avahi berkdb bitmap-fonts cairo cdr cli cracklib crypt cups dbus directfb divx dri dts dvd dvdr dvdread eds emboss encode esd fam fbcon ffmpeg firefox flac fortran gdbm gif glitz gnome gpm gstreamer gtk hal iconv ipv6 java jpeg kde lame ldap libcaca live mad matroska midi mikmod mmx mmxext mp3 mpeg mplayer mudflap musepack ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png ppds pppd python qt qt3 qt4 quicktime readline real realmedia reflection sdl session skins sound spell spl sse ssl svg tcpd theora truetype truetype-fonts type1-fonts unicode userlocales vcd vorbis win32codecs wmp x264 x86 xanim xine xinerama xml xorg xv xvid zlib"
ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LINGUAS="fr"
USERLAND="GNU"
VIDEO_CARDS="nvidia"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Merci d'avance à tous ceux qui prendront le temps de lire mon message ;)


Last edited by sonofjah on Fri Jun 27, 2008 9:32 pm; edited 2 times in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Jun 26, 2008 7:14 am    Post subject: Reply with quote

Salut ! Peux-tu mettre ton titre du topic en conformité avec les conventions de notre forum et mettre un peu en forme ton post avec les balises [code] et [quote] pour la lisibilité s'il te plait ? Merci :)
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Jun 26, 2008 8:04 am    Post subject: Reply with quote

C'est probable que ça ne changera rien, mais mettre à jour ton profil pourrait être une bonne idée, tu utilises encore le profil 2006.1. Voir
Code:
eselect profile list
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Thu Jun 26, 2008 9:08 am    Post subject: Reply with quote

Que dit qlist glibc | grep libdl ou equery f glibc | grep libdl ?
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Thu Jun 26, 2008 6:46 pm    Post subject: Reply with quote

Bonsoir,

merci pour ces quelques pistes :)

donc :

Code:

dagonland ~ #  equery f glibc | grep libdl
/lib/libdl-2.6.1.so
/lib/libdl.so.2
/usr/lib/libdl.a
/usr/lib/libdl.so


et...

Code:

dagonland ~ # eselect profile list
Available profile symlink targets:
  [1]   default-linux/x86/2006.1
  [2]   default-linux/x86/no-nptl
  [3]   default-linux/x86/2006.1/desktop *
  [4]   default-linux/x86/2007.0
  [5]   default-linux/x86/2007.0/desktop
  [6]   hardened/x86/2.6
  [7]   selinux/2007.0/x86
  [8]   selinux/2007.0/x86/hardened
  [9]   default/linux/x86/2008.0
  [10]  default/linux/x86/2008.0/desktop
  [11]  default/linux/x86/2008.0/developer
  [12]  default/linux/x86/2008.0/no-nptl
  [13]  default/linux/x86/2008.0/server
  [14]  hardened/linux/x86


Si ça vous inspire, moi pôa du tout...je reste en ligne prêt à bondir sur l'unes de vos idées :roll:
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Thu Jun 26, 2008 7:04 pm    Post subject: Reply with quote

je change de profile pour voir :

Code:

dagonland ~ # eselect profile list
Available profile symlink targets:
  [1]   default-linux/x86/2006.1
  [2]   default-linux/x86/no-nptl
  [3]   default-linux/x86/2006.1/desktop
  [4]   default-linux/x86/2007.0
  [5]   default-linux/x86/2007.0/desktop
  [6]   hardened/x86/2.6
  [7]   selinux/2007.0/x86
  [8]   selinux/2007.0/x86/hardened
  [9]   default/linux/x86/2008.0
  [10]  default/linux/x86/2008.0/desktop *
  [11]  default/linux/x86/2008.0/developer
  [12]  default/linux/x86/2008.0/no-nptl
  [13]  default/linux/x86/2008.0/server
  [14]  hardened/linux/x86


je fais un esync puis emerge -avtNuD world ?? 400 Mo à compiler wow !!!

je vois dans dmesg :

Code:

libdl-2.6.1.so[6191]: segfault at 00000001 eip 00000001 esp bf8d5bb4 error 4
libdl.so.2[6192]: segfault at 00000001 eip 00000001 esp bf863354 error 4
libdl.so[6194]: segfault at 00000001 eip 00000001 esp bfe72954 error 4
libdl.so[6195]: segfault at 00000001 eip 00000001 esp bf9df4c4 error 4
ld[7768]: segfault at ff000000 eip b7e15cbc esp bff3e2fc error 4
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8075
Location: ~Brussels - Belgique

PostPosted: Thu Jun 26, 2008 8:24 pm    Post subject: Reply with quote

fais un memtest86+, histoire de voir si la mémoire est en bon état. Vérifie aussi tes ventilateurs de CPU et d'alimentation...
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Thu Jun 26, 2008 8:36 pm    Post subject: Reply with quote

XavierMiller wrote:
fais un memtest86+, histoire de voir si la mémoire est en bon état. Vérifie aussi tes ventilateurs de CPU et d'alimentation...


Ayant déjà eu un pb de ce style, j'ai fait la chasse aux moutons ainsi qu'un brave test mémoire l'avant veille sans révéler d'erreurs...
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Fri Jun 27, 2008 9:58 am    Post subject: Reply with quote

sonofjah wrote:
je change de profile pour voir :

Code:

dagonland ~ # eselect profile list
Available profile symlink targets:
  [1]   default-linux/x86/2006.1
  [2]   default-linux/x86/no-nptl
  [3]   default-linux/x86/2006.1/desktop
  [4]   default-linux/x86/2007.0
  [5]   default-linux/x86/2007.0/desktop
  [6]   hardened/x86/2.6
  [7]   selinux/2007.0/x86
  [8]   selinux/2007.0/x86/hardened
  [9]   default/linux/x86/2008.0
  [10]  default/linux/x86/2008.0/desktop *
  [11]  default/linux/x86/2008.0/developer
  [12]  default/linux/x86/2008.0/no-nptl
  [13]  default/linux/x86/2008.0/server
  [14]  hardened/linux/x86


je fais un esync puis emerge -avtNuD world ?? 400 Mo à compiler wow !!!


plantage de nouveau dans la compilation de gtk+ grrr je ne poursuit pas la mise à jour, la matinée a été passé à faire un long test de surface des disques ( 2 * 18 Go UW + 1 34 Go UW sur une carte Adaptec SCSI Card 29160LP) mais sans malheur, je crois que je vais être obligé de tout réinstaller...f***k !!

heuuu... AU SECOURS !!!! :?


Last edited by sonofjah on Fri Jun 27, 2008 12:21 pm; edited 2 times in total
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Fri Jun 27, 2008 10:10 am    Post subject: Reply with quote

La libdl a peut-être un problème aussi (utilisée dans tout ce qui concerne le chargement dynamique de bibliothèques (plugins, modules externes, etc.)), c'est pas très normal qu'elle segfaulte comme ça.

Ça serait peut-être une bonne idée de réinstaller la glibc (fais peut-être un backup avant avec quickpkg).
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Fri Jun 27, 2008 12:20 pm    Post subject: Reply with quote

Desintegr wrote:
La libdl a peut-être un problème aussi (utilisée dans tout ce qui concerne le chargement dynamique de bibliothèques (plugins, modules externes, etc.)), c'est pas très normal qu'elle segfaulte comme ça.

Ça serait peut-être une bonne idée de réinstaller la glibc (fais peut-être un backup avant avec quickpkg).


quickpkg glibc...

emerge -av glibc... In progress... :mrgreen:

... Compile OK... je relance emerge -av gtk+ ... wait and see :oops:

... ça n'a pas durée longtemps... Splash !! :(

début du message d'erreur dans le log

Code:

(cd .libs && rm -f im-multipress.la && ln -s ../im-multipress.la im-multipress.la)
../../gtk/gtk-query-immodules-2.0 im-xim.la  im-am-et.la im-cedilla.la im-cyrillic-translit.la im-inuktitut.la im-ipa.la im-thai.la im-ti-er.la im-ti-et.la im-viqr.la im-multipress.la  > gtk.immodules
Cannot load module /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-xim.la: dynamic modules are not supported by this system
/var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-xim.la does not export GTK+ IM module API: dynamic modules are not supported by this system
Cannot load module /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-am-et.la: dynamic modules are not supported by this system
/var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-am-et.la does not export GTK+ IM module API: dynamic modules are not supported by this system
Cannot load module /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-cedilla.la: dynamic modules are not supported by this system


fin du message

Code:

/var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-multipress.la does not export GTK+ IM module API: dynamic modules are not supported by this system
make[3]: *** [gtk.immodules] Erreur 1
make[3]: quittant le répertoire « /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input »
make[2]: *** [all-recursive] Erreur 1
make[2]: quittant le répertoire « /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9 »
make: *** [all] Erreur 2
 *
 * ERROR: x11-libs/gtk+-2.12.9-r2 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2849:  Called die
 * The specific snippet of code:
 *       emake || die "compile failed"
 *  The die message:
 *   compile failed
 *
 * If you need support


I really need support :!: :!: :!:

et toujours 'segfault' dans dmesg
Back to top
View user's profile Send private message
razer
l33t
l33t


Joined: 08 Oct 2004
Posts: 893
Location: Paris - France

PostPosted: Fri Jun 27, 2008 4:40 pm    Post subject: Reply with quote

As tu plusieurs versions différentes de gcc installées sur ton système ?
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Fri Jun 27, 2008 5:17 pm    Post subject: Reply with quote

razer wrote:
As tu plusieurs versions différentes de gcc installées sur ton système ?


Bonsoir, il n'y a priori qu'une seule version de GCC installée :

Code:

dagonland ~ # gcc-config -l
 [1] i686-pc-linux-gnu-4.1.2 *
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Fri Jun 27, 2008 7:11 pm    Post subject: Reply with quote

Bonsoir,

En fait je ne pense pas que mon problème ne soit pas lié spécialement à GTK mais plutôt à une histoire de 'modules dynamiques' qui ne serait plus compatible. Je ne sais pas si mon raisonement est censé mais en épluchant le log de compilation de gtk, je me suis mis à recompiler les libs liées aux plantages.

En gros, les problèmes commencent ici :

Code:

 vi /var/log/portage/x11-libs\:gtk+-2.12.9-r2\:20080627-181516.log


(cd .libs && rm -f im-multipress.la && ln -s ../im-multipress.la im-multipress.la)
../../gtk/gtk-query-immodules-2.0 im-xim.la  im-am-et.la im-cedilla.la im-cyrillic-translit.la im-inuktitut.la im-ipa.la im-thai.la im-ti-er.la im-ti-et.la im-viqr.la im-multipress.la  > gtk.immodules
Cannot load module /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/work/gtk+-2.12.9/modules/input/im-xim.la: dynamic modules are not supported by this system


je recherche un peux plus haut la sequence 'im-xim' pour trouver :

Code:


/var/log/portage/x11-libs\:gtk+-2.12.9-r2\:20080627-181516.log


/bin/sh ../../libtool --mode=link i686-pc-linux-gnu-gcc  -O2 -march=athlon-xp -pipe -Wall   -o im-xim.la -rpath /usr/lib/gtk-2.0/2.10.0/immodules -rpath /usr/lib/gtk-2.0/2.10.0/immodules -avoid-version -module  gtkimcontextxim.lo imxim.lo ../../gdk-pixbuf/libgdk_pixbuf-2.0.la ../../gdk/libgdk-x11-2.0.la ../../gtk/libgtk-x11-2.0.la -lpangocairo-1.0 -lpango-1.0 -lX11 -lXcomposite -lXdamage -lXfixes -latk-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lcairo -ltiff -ljpeg -lpng12 -lm


je vois que les libs utilisées sont entre autre : libgtk libXfixes atk et pango
je lance donc les compils successive et lorsque pango termine, il donne :

Code:

>>> Completed installing pango-1.20.3 into /var/tmp/portage/x11-libs/pango-1.20.3/image/

ecompressdir: bzip2 -9 /usr/share/man
strip: i686-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/pango-querymodules
   usr/bin/pango-view
   usr/lib/libpangoxft-1.0.so.0.2002.1
   usr/lib/pango/1.6.0/modules/pango-khmer-fc.so
   usr/lib/pango/1.6.0/modules/pango-basic-x.so
   usr/lib/pango/1.6.0/modules/pango-thai-fc.so
   usr/lib/pango/1.6.0/modules/pango-arabic-fc.so
   usr/lib/pango/1.6.0/modules/pango-indic-fc.so
   usr/lib/pango/1.6.0/modules/pango-arabic-lang.so
   usr/lib/pango/1.6.0/modules/pango-hangul-fc.so
   usr/lib/pango/1.6.0/modules/pango-indic-lang.so
   usr/lib/pango/1.6.0/modules/pango-syriac-fc.so
   usr/lib/pango/1.6.0/modules/pango-basic-fc.so
   usr/lib/pango/1.6.0/modules/pango-hebrew-fc.so
   usr/lib/pango/1.6.0/modules/pango-tibetan-fc.so
   usr/lib/libpango-1.0.so.0.2002.1
   usr/lib/libpangocairo-1.0.so.0.2002.1
   usr/lib/libpangox-1.0.so.0.2002.1
   usr/lib/libpangoft2-1.0.so.0.2002.1
removing executable bit: usr/lib/libpango-1.0.la
removing executable bit: usr/lib/libpangocairo-1.0.la

^G
 ^[[33;01m*^[[0m QA Notice: Package has poor programming practices which may compile
 ^[[33;01m*^[[0m            fine but exhibit random runtime failures.
 ^[[33;01m*^[[0m fonts.c:925: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:926: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:927: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:928: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:929: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:181: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:183: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:185: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:187: warning: dereferencing type-punned pointer will break strict-aliasing rules
pangofc-fontmap.c:1327: warning: dereferencing type-punned pointer will break strict-aliasing rules
^G
 ^[[33;01m*^[[0m Please do not file a Gentoo bug and instead report the above QA
 ^[[33;01m*^[[0m issues directly to the upstream developers of this software.
 ^[[33;01m*^[[0m Homepage: http://www.pango.org/
 ^[[32;01m*^[[0m Generating modules listing...
Cannot load module /usr/lib/pango/1.6.0/modules/pango-khmer-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-khmer-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-basic-x.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-basic-x.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-thai-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-thai-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-arabic-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-arabic-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-indic-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-indic-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-arabic-lang.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-arabic-lang.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-hangul-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-hangul-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-indic-lang.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-indic-lang.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-syriac-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-syriac-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-basic-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-basic-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-hebrew-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-hebrew-fc.so does not export Pango module API
Cannot load module /usr/lib/pango/1.6.0/modules/pango-tibetan-fc.so: dynamic modules are not supported by this system
/usr/lib/pango/1.6.0/modules/pango-tibetan-fc.so does not export Pango module API


J'en viens à la conclusion que ce n'est pas GTK la cause du problème (mais là je me répète) car je ne sais pas où chercher... Je vais peut-être changer le titre du post :?: :!:

où aller...je ne sais où aller... (dixit : tiken jah Fakoly)
Back to top
View user's profile Send private message
sonofjah
n00b
n00b


Joined: 16 Feb 2007
Posts: 20

PostPosted: Fri Jun 27, 2008 9:30 pm    Post subject: Reply with quote

:!: :!: :!: YES :!: :!: :!:

Il me semble avoir trouvé la solution, apres avoir compiler dans l'ordre :

x11-libs/cairo
dev-python/pygobject
x11-libs/libXfixes
dev-libs/atk
sys-devel/libtool
sys-libs/glibc
dev-libs/glib
x11-libs/pango

j'obtiens à la fin de pango :

Code:


vi x11-libs:pango-1.20.3:20080627-204815.log

>>> Completed installing pango-1.20.3 into /var/tmp/portage/x11-libs/pango-1.20.3/image/

ecompressdir: bzip2 -9 /usr/share/man
strip: i686-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/pango-querymodules
   usr/bin/pango-view
   usr/lib/libpangoxft-1.0.so.0.2002.1
   usr/lib/pango/1.6.0/modules/pango-khmer-fc.so
   usr/lib/pango/1.6.0/modules/pango-basic-x.so
   usr/lib/pango/1.6.0/modules/pango-thai-fc.so
   usr/lib/pango/1.6.0/modules/pango-arabic-fc.so
   usr/lib/pango/1.6.0/modules/pango-indic-fc.so
   usr/lib/pango/1.6.0/modules/pango-arabic-lang.so
   usr/lib/pango/1.6.0/modules/pango-hangul-fc.so
   usr/lib/pango/1.6.0/modules/pango-indic-lang.so
   usr/lib/pango/1.6.0/modules/pango-syriac-fc.so
   usr/lib/pango/1.6.0/modules/pango-basic-fc.so
   usr/lib/pango/1.6.0/modules/pango-hebrew-fc.so
   usr/lib/pango/1.6.0/modules/pango-tibetan-fc.so
   usr/lib/libpango-1.0.so.0.2002.1
   usr/lib/libpangocairo-1.0.so.0.2002.1
   usr/lib/libpangox-1.0.so.0.2002.1
   usr/lib/libpangoft2-1.0.so.0.2002.1
removing executable bit: usr/lib/libpango-1.0.la
removing executable bit: usr/lib/libpangocairo-1.0.la
^G
 ^[[33;01m*^[[0m QA Notice: Package has poor programming practices which may compile
 ^[[33;01m*^[[0m            fine but exhibit random runtime failures.
 ^[[33;01m*^[[0m fonts.c:925: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:926: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:927: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:928: warning: dereferencing type-punned pointer will break strict-aliasing rules
fonts.c:929: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:181: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:183: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:185: warning: dereferencing type-punned pointer will break strict-aliasing rules
modules.c:187: warning: dereferencing type-punned pointer will break strict-aliasing rules
pangofc-fontmap.c:1327: warning: dereferencing type-punned pointer will break strict-aliasing rules
^G
 ^[[33;01m*^[[0m Please do not file a Gentoo bug and instead report the above QA
 ^[[33;01m*^[[0m issues directly to the upstream developers of this software.
 ^[[33;01m*^[[0m Homepage: http://www.pango.org/
 ^[[32;01m*^[[0m Generating modules listing...


En gros c'est cool plus de message avec l'erreur 'dynamic modules are not supported by this system'

et maintenant en route pour GTK et cette fois cette brave Gentoo va jusqu'au bout :lol:

Code:


vi x11-libs:gtk+-2.12.9-r2:20080627-205144.log

>>> Completed installing gtk+-2.12.9-r2 into /var/tmp/portage/x11-libs/gtk+-2.12.9-r2/image/

ecompressdir: bzip2 -9 /usr/share/man
strip: i686-pc-linux-gnu-strip --strip-unneeded -R .comment
   usr/bin/gdk-pixbuf-csource
   usr/bin/gdk-pixbuf-query-loaders
   usr/bin/gtk-query-immodules-2.0
   ............



Ainsi, je change l'intituler du topic et le considère comme résolu. \O/

Merci à tous :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum