Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4: dns resolving is extremely slow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Tue Jun 24, 2008 9:01 pm    Post subject: KDE 4: dns resolving is extremely slow Reply with quote

I've got a problem using KDE svn from the overlay: DNS resolving is extremely slow, usually I get timeouts, in fact it's absolutely unusable. KDE_DISABLE_IPV6=1 is set in env.d, the ipv6 use flag isn't set. Everything outside KDE works perfectly. Does anyone know that problem nad hopefully a solution as well?
Back to top
View user's profile Send private message
tgurr
Retired Dev
Retired Dev


Joined: 27 Jan 2004
Posts: 571
Location: germany

PostPosted: Wed Jun 25, 2008 8:13 am    Post subject: Reply with quote

Sounds much like KDE bug #162600. Especially if you happen to use a Fritz!Box router (which is very common in germany for private use) you're affected. One workaround is to install a local dns server/cache like pdns. Looking at the bug qt 4.4.1 will probably also contain a workaround for this issue.
Back to top
View user's profile Send private message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Wed Jun 25, 2008 5:39 pm    Post subject: Reply with quote

I don't use a Fritzbox, but it was that problem. Setting up a cache helped, thanks.
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 3253
Location: Gainesville, Florida

PostPosted: Sat Jun 28, 2008 2:58 pm    Post subject: Reply with quote

Is the correct syntax "KDE_DISABLE_IPV6=1" or "KDE_NO_IPV6 = 1"?

Or, do they both work? I've seen both referred to.
_________________
Main box- AsRock x370 Gaming K4
Ryzen 1700, 3.0GHz, 16GB GSkill Flare DDR4 3200mhz
Samsung SATA 1000GB, Radeon HD R7 350 2GB DDR5
Gentoo ~amd64 plasma, glibc-2.29-r5, gcc-9.2.0 kernel-5.2.10-gentoo USE=experimental
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum