Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ebuild for Ekee (LaTeX equation editor)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
urcindalo
Guru
Guru


Joined: 08 Feb 2005
Posts: 591
Location: Almeria, Spain

PostPosted: Thu Jun 26, 2008 7:56 am    Post subject: ebuild for Ekee (LaTeX equation editor) Reply with quote

Ekee is a clone of Mac OS X's "LaTeX Equation Editor" and "LaTeXiT".

Ekee produces images interactively from LaTeX expressions. Drag and drop in
several common formats (PNG, SVG, PDF, EPS) to other applications is supported.
Ekee can reopen the equations it has created in PNG format. It is free
software, released under the GPL.

Could anyone provide an ebuild for it?

When I try to exec the script the author provides I get this error:
Code:
$ ekee
/usr/local/bin/ekee:22:in `require': no such file to load -- Qt4 (LoadError)
        from /usr/local/bin/ekee:22


According to the author, the dependencies are:
Quote:
- ruby
- the Qt4 bindings for Ruby
- LaTeX (as provided by the Texlive base for instance)
- dvipng
- pstoedit
- epstopdf (may be provided by Texlive)
- xdg-utils


I have all of them installed in my system except the Qt4 bindings for Ruby. When I try to install qt4-qtruby-1.4.9-r3 I get the error in this bug report. However, I got PyQt4 installed.

Any help is greatly appreciated. Thanks in advance.
Back to top
View user's profile Send private message
yamakawa
Guru
Guru


Joined: 28 Jul 2003
Posts: 340

PostPosted: Sat Jul 05, 2008 2:33 pm    Post subject: Reply with quote

I managed to install the app and launch it with success. :)
Unfortunately, ebuild for the app has not been done.
There are a few things to successfully launch Ekee other than you mentioned.

Quote:
1. portage dependency as you mentioned, but additonal info:
dev-ruby/qt4-qtruby (1.4.10) -- need to drop x11-libs/qwt dependency (see the forum link below)
I've tested the latest 1.4.9-r3(~). Since it fails to emerge due to qwt related error,
I made up my own ebuild to use the very latest 1.4.10. With the workround, you could still use 1.4.9-r3.

2. might need some reemerge of:
x11-libs/qt-webkit (4.4.0)
x11-libs/qt-core (4.4.0)
not sure if these reemerges could fix problems or not.

3. Ekee script itself must be modifes at line 849 and 1787, "Config" to "QByteArray"
You can see more detailed error when you comment out Qt.debug_level at line 23.
This is why I found the solution.

You might also want to see below links:
https://bugs.gentoo.org/show_bug.cgi?id=224091 (see newer comments from #3)
http://rubyforge.org/forum/forum.php?thread_id=26531&forum_id=723


With these, I guess you can launch it at least locally.
Hope this helps! :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum