Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
XBMC Linux HOWTO
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
alphacube
n00b
n00b


Joined: 14 Jan 2007
Posts: 38

PostPosted: Tue Jul 01, 2008 7:44 pm    Post subject: XBMC Linux HOWTO Reply with quote

I'v put togeter a brief HOWTO for installing XBMC linux.
http://gentoo-wiki.com/HOWTO_XBMC_Linux

And theres a workaround for the
Floating point exception error

at least if you use the Intel HD Audio ALSA driver.

cheers :wink:
_________________
\\Alphacube
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Jul 01, 2008 7:56 pm    Post subject: Re: XBMC Linux HOWTO Reply with quote

alphacube wrote:
I'v put togeter a brief HOWTO for installing XBMC linux.
http://gentoo-wiki.com/HOWTO_XBMC_Linux

And theres a workaround for the
Floating point exception error

at least if you use the Intel HD Audio ALSA driver.

cheers :wink:


this works on non-XBox hardware, too, right ? :roll:

Cheers :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
alphacube
n00b
n00b


Joined: 14 Jan 2007
Posts: 38

PostPosted: Tue Jul 01, 2008 8:13 pm    Post subject: Reply with quote

Actually it won't work on Xbox hardware.
this is only for PC hardware.

all development is done on Ubuntu so Gentoo is'nt supported....well its still alpha so there is no actual support for end users at all.
I got it working really nice on two boxes today.

cheers
_________________
\\Alphacube
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Wed Jul 02, 2008 11:29 am    Post subject: Reply with quote

Hi,

There is an XBMC SVN ebuild available in Bugzilla which should simplify things. :D
Back to top
View user's profile Send private message
alphacube
n00b
n00b


Joined: 14 Jan 2007
Posts: 38

PostPosted: Wed Jul 02, 2008 2:52 pm    Post subject: Reply with quote

I saw that today. but it seems to enable halmount wich messes things up for me... don't know why yet...
but I'll try to rewrit the ebuild... Good learning :twisted:
_________________
\\Alphacube
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Wed Jul 02, 2008 3:12 pm    Post subject: Reply with quote

alphacube wrote:
I saw that today. but it seems to enable halmount wich messes things up for me

Is halmount enabled even when the hal use flag is disabled?
Back to top
View user's profile Send private message
alphacube
n00b
n00b


Joined: 14 Jan 2007
Posts: 38

PostPosted: Wed Jul 02, 2008 5:20 pm    Post subject: Reply with quote

Naa...my bad there...

but the ebuild did need a makeover.

Added som useflags to.
_________________
\\Alphacube
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Thu Jul 03, 2008 5:27 am    Post subject: Reply with quote

alphacube,

Could you update the Wiki so that it uses the ebuild instead of the manual build instructions?


Last edited by BT on Sun Jul 27, 2008 10:40 am; edited 1 time in total
Back to top
View user's profile Send private message
alphacube
n00b
n00b


Joined: 14 Jan 2007
Posts: 38

PostPosted: Thu Jul 03, 2008 7:33 am    Post subject: Reply with quote

Way ahead of you. section "7 Easy way" 8)
_________________
\\Alphacube
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Thu Jul 03, 2008 8:12 am    Post subject: Reply with quote

alphacube wrote:
Way ahead of you. section "7 Easy way" 8)

That was quick. :D
Back to top
View user's profile Send private message
alphacube
n00b
n00b


Joined: 14 Jan 2007
Posts: 38

PostPosted: Mon Jul 07, 2008 1:07 pm    Post subject: Reply with quote

Updated Ebuild https://bugs.gentoo.org/show_bug.cgi?id=198849
with information how to get a specific rev or the latest when reemerg.
_________________
\\Alphacube
Back to top
View user's profile Send private message
Gorgone
Tux's lil' helper
Tux's lil' helper


Joined: 10 Mar 2003
Posts: 100

PostPosted: Fri Jul 11, 2008 4:46 pm    Post subject: Reply with quote

is there a "working solution" for xbmc ?

the bug ebuild and the howto dont work for me ....
Back to top
View user's profile Send private message
doesntcount
n00b
n00b


Joined: 30 Sep 2007
Posts: 69
Location: Waterloo

PostPosted: Fri Aug 01, 2008 3:20 am    Post subject: Reply with quote

I tried digesting the ebuild from here (https://bugs.gentoo.org/attachment.cgi?id=161515) and was given this error:

# ebuild xbmc.ebuild digest
!!! media-video/xbmc does not follow correct package syntax.

This is my first shot at trying to use a 3rd party ebuild, so I'm pretty noobish, but I'm pretty keen on getting xbmc working. Any help would be great. Alternatively, if you need some help/info getting this going right until we have this in portage, I'd be up for help with that as well.
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Fri Aug 01, 2008 9:48 pm    Post subject: Reply with quote

doesntcount,

You need to make sure that the ebuild filename has a version specified i.e. xbmc-9999.ebuild


Last edited by BT on Wed Aug 20, 2008 6:22 am; edited 1 time in total
Back to top
View user's profile Send private message
doesntcount
n00b
n00b


Joined: 30 Sep 2007
Posts: 69
Location: Waterloo

PostPosted: Fri Aug 01, 2008 10:23 pm    Post subject: Reply with quote

That did it. Thanks! I'm officially installed (remotely from work) now to head home and see if it works.
Back to top
View user's profile Send private message
Lucipher
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2007
Posts: 78

PostPosted: Tue Aug 19, 2008 5:46 am    Post subject: Reply with quote

I got this error when I trried to compile with that ebuild:

Code:
Surface.cpp: In constructor 'Surface::CSurface::CSurface(int, int, bool, Surface::CSurface*, Surface::CSurface*, SDL_Surface*, bool, bool, bool, int)':
Surface.cpp:139: error: 'GLX_SAMPLE_BUFFERS' was not declared in this scope
make[1]: ** [Surface.o] Erro 1


Any help?
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Wed Aug 20, 2008 6:34 am    Post subject: Reply with quote

Lucipher,

The error your getting is most likely an issue with the specific SVN revision your trying to compile. You can wait for a new revision or try a different one by setting ESVN_REVISION in the ebuild to the revision you want. Please be aware that SVN can and will break often so getting compile failures is not uncommon.
Back to top
View user's profile Send private message
Lucipher
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2007
Posts: 78

PostPosted: Thu Aug 21, 2008 5:23 pm    Post subject: Reply with quote

BT wrote:
Lucipher,

The error your getting is most likely an issue with the specific SVN revision your trying to compile. You can wait for a new revision or try a different one by setting ESVN_REVISION in the ebuild to the revision you want. Please be aware that SVN can and will break often so getting compile failures is not uncommon.

Yep, I realized that!
Any chance to provide an ebuild for official/stable release?
Back to top
View user's profile Send private message
BT
Guru
Guru


Joined: 13 Jun 2004
Posts: 309

PostPosted: Fri Aug 22, 2008 1:19 am    Post subject: Reply with quote

Lucipher wrote:
Any chance to provide an ebuild for official/stable release?

Yes, when the XBMC team release a stable version.
Back to top
View user's profile Send private message
Lucipher
Tux's lil' helper
Tux's lil' helper


Joined: 11 Feb 2007
Posts: 78

PostPosted: Fri Aug 22, 2008 3:11 am    Post subject: Reply with quote

BT wrote:
Lucipher wrote:
Any chance to provide an ebuild for official/stable release?

Yes, when the XBMC team release a stable version.


I thought they released one, but it was for other platforms.
Back to top
View user's profile Send private message
iKiddo
Guru
Guru


Joined: 27 Jun 2002
Posts: 341
Location: Europe?

PostPosted: Sun Sep 21, 2008 3:42 pm    Post subject: Reply with quote

Lucipher wrote:
BT wrote:
Lucipher wrote:
Any chance to provide an ebuild for official/stable release?

Yes, when the XBMC team release a stable version.

I thought they released one, but it was for other platforms.


They recently released a beta, no stable yet.

Quote:
------- Comment #28 From BT 2008-09-19 12:45:39 0000 -------

Created an attachment (id=165834)
Beta 1 ebuild

Changes include:
- Added eautoreconf in src_unpack().
- ESVN_REPO_URI now points to the tagged beta 1 release.

I have successfully built the beta 1 release numerous times without any of the
reported build failures. It should be much more stable since it's a tagged
release, although the ebuild still uses Subversion since there are no tarballs.
I recommend that users no longer use the 9999 ebuild as SVN trunk breaks way
too often.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum