Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Official thread: "zenmm-sources" - Latest: 2.6.27-rc1-zenmm0
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 11, 12, 13  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Mon Jul 21, 2008 7:40 pm    Post subject: Reply with quote

cheater1034 wrote:
Reiser4 for zenrt patch
I would of pushed it, but for some reason i get permission denied.

Anyway, here's a working reiser4 diffed against zenrt, it's the latest r4 from mm, i tested it awhile back on 2.6.25.8-rt7, havent booted zenrt (i don't use RT for anything, it would just slow me down but i'd do testing)

http://omploader.org/vbWV1

just apply with patch -p1 -i


patch applies, compiles and works. thanks.
now i have to face the nvidia-drivers compilation problem.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Jul 21, 2008 8:55 pm    Post subject: Reply with quote

Lol, we need another thread about -zenrt now!

Reading http://www.nvnews.net/vbulletin/showthread.php?t=116514 you need another patch:

http://gimpel.ath.cx/files/nvidia-drivers-177.13-dot26-git.patch

It compiles, but I haven't booted that kernel yet. So no idea if it loads & works, or if it simply will burn out your GPU with a funky POOF!
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Mon Jul 21, 2008 9:10 pm    Post subject: Reply with quote

gimpel wrote:
Lol, we need another thread about -zenrt now!

Reading http://www.nvnews.net/vbulletin/showthread.php?t=116514 you need another patch:

http://gimpel.ath.cx/files/nvidia-drivers-177.13-dot26-git.patch

It compiles, but I haven't booted that kernel yet. So no idea if it loads & works, or if it simply will burn out your GPU with a funky POOF!


doesn't compile. nvidia-drivers-173.14.09
rivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c
/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c: In function ‘nv_alloc_file_private’:
/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c:1887: error: implicit declaration of function ‘__SEMAPHORE_INITIALIZER’
/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c:1887: error: invalid initializer
/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c: In function ‘nv_lock_init_locks’:
/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c:3808: error: invalid initializer
/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.c:3809: error: invalid initializer
make[3]: *** [/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv/nv.o] Error 1
make[2]: *** [_module_/var/tmp/portage/x11-drivers/nvidia-drivers-173.14.09/work/NVIDIA-Linux-x86-173.14.09-pkg0/usr/src/nv] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
_________________
this is a strange strange world.


Last edited by tranquilcool on Mon Jul 21, 2008 9:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Jul 21, 2008 9:11 pm    Post subject: Reply with quote

No idea, I'm using 177.13 (as patch name implies)

But it _HARD_ locks up anyway as soon as X starts up, so... it loads fine though.

EDIT: that patch was bogus. It's working now! (same URL) :)
Code:
┌--tom@sirius---[Mo Jul 21 23:21:06]---[~]
└» uname -a
Linux sirius 2.6.26-zenrt1 #1 SMP PREEMPT RT Mon Jul 21 22:21:36 CEST 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ AuthenticAMD GNU/Linux
┌--tom@sirius---[Mo Jul 21 23:25:22]---[~]
└» glxinfo |egrep '(rendering|OpenGL vendor)'
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation


Sweet!

Thanks for the Reiser4 patch. That's my first successfull -rt boot since .24 ;)

Let's see how it performs.. and if it runs stable.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Mon Jul 21, 2008 9:36 pm    Post subject: Reply with quote

gimpel wrote:
No idea, I'm using 177.13 (as patch name implies)

But it _HARD_ locks up anyway as soon as X starts up, so... it loads fine though.

EDIT: that patch was bogus. It's working now! (same URL) :)
Code:
┌--tom@sirius---[Mo Jul 21 23:21:06]---[~]
└» uname -a
Linux sirius 2.6.26-zenrt1 #1 SMP PREEMPT RT Mon Jul 21 22:21:36 CEST 2008 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ AuthenticAMD GNU/Linux
┌--tom@sirius---[Mo Jul 21 23:25:22]---[~]
└» glxinfo |egrep '(rendering|OpenGL vendor)'
direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation


Sweet!

Thanks for the Reiser4 patch. That's my first successfull -rt boot since .24 ;)

Let's see how it performs.. and if it runs stable.


patches clean. but no compilation.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Jul 21, 2008 9:43 pm    Post subject: Reply with quote

tranquilcool wrote:
patches clean. but no compilation.

Well for the old version you try to compile, you'll also need

/usr/portage/x11-drivers/nvidia-drivers/files/NVIDIA_kernel-173.14.05-2419292.diff

as mentioned in the above mentioned thread on nvnews forum.

Did you apply that one?
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Mon Jul 21, 2008 9:51 pm    Post subject: Reply with quote

gimpel wrote:
tranquilcool wrote:
patches clean. but no compilation.

Well for the old version you try to compile, you'll also need

/usr/portage/x11-drivers/nvidia-drivers/files/NVIDIA_kernel-173.14.05-2419292.diff

as mentioned in the above mentioned thread on nvnews forum.

Did you apply that one?


now compiles and installs.

applied your patch and this;

diff -ru usr/src/nv/nv-linux.h usr/src/nv.2512683/nv-linux.h
--- usr/src/nv/nv-linux.h 2008-06-05 00:13:45.000000000 -0700
+++ usr/src/nv.2512683/nv-linux.h 2008-06-24 09:47:50.292382526 -0700
@@ -684,12 +684,16 @@
#define nv_down(lock) down(&lock)
#define nv_up(lock) up(&lock)

+#if defined(CONFIG_PREEMPT_RT)
+#define NV_INIT_MUTEX(mutex) init_MUTEX(mutex)
+#else
#define NV_INIT_MUTEX(mutex) \
{ \
struct semaphore __mutex = \
__SEMAPHORE_INITIALIZER(*(mutex), 1); \
*(mutex) = __mutex; \
}
+#endif

thanks. now i'll reboot and see.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Jul 21, 2008 9:58 pm    Post subject: Reply with quote

I hope you re-downloaded my patch! :)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Mon Jul 21, 2008 10:04 pm    Post subject: Reply with quote

gimpel wrote:
I hope you re-downloaded my patch! :)


yes i did.
boots, loads and is perfect.

thanks gimpel!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Jul 22, 2008 12:06 am    Post subject: Reply with quote

Hrm, zenrt completely hardlocked here some minutes ago. System was doing pretty much nothing, just playing a movie.
zenmm3 hardlocked in a similar fashion, but after some days running.

Back on rock-solid -rc8-zenmm2 for now.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Jul 22, 2008 4:15 am    Post subject: Reply with quote

gimpel wrote:
Hrm, zenrt completely hardlocked here some minutes ago. System was doing pretty much nothing, just playing a movie.
zenmm3 hardlocked in a similar fashion, but after some days running.

Back on rock-solid -rc8-zenmm2 for now.


i've had 1 hardlock in -zenrt and that was after i rebooted from -zenmm into -zenrt, when i do a cold boot (from power off) into -zenrt I have no issues (so far)
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jul 22, 2008 5:32 am    Post subject: Reply with quote

zenrt hardlocks here 1, 2, 3, 4, many times.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Tue Jul 22, 2008 6:29 am    Post subject: Reply with quote

RT branch was reverted from master, and i reverted 1 lkml patch (i don't think it affected my hardlocks, but it seemed the only potential one that could)

Anyway, i've been running strong in X (1.5) / gnome for awhile now with no hardlocks and a clean dmesg, it seems finally rc8-zenmm is running good for me (no panics, oops, bug, or lock)

(and oss4 works for me too perfect)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Jul 22, 2008 8:28 am    Post subject: Reply with quote

rc8-zenmm3

always clean dmesg, deadline elevator, fast fast fast, no hardlocks so far.
oss-devel is perfect.
well now zenmm is on it's way to becoming the default kernel for me.
thanks guys!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
post-factum
n00b
n00b


Joined: 19 Aug 2007
Posts: 14
Location: /ukraine/novi sanzhary

PostPosted: Tue Jul 22, 2008 8:35 am    Post subject: Reply with quote

I've compiled 2.6.26-zenrt1 and got following in dmesg:
Code:

BUG: sleeping function called from invalid context sirq-rcu/1(26) at kernel/rtmutex.c:743
in_atomic():1 [00000002], irqs_disabled():1
Pid: 26, comm: sirq-rcu/1 Not tainted 2.6.26-zenrt1 #1
 [<c04fcb3f>] __rt_spin_lock+0x5f/0x70
 [<c01238f8>] update_curr_rt+0x98/0x1b0
 [<c0123b53>] dequeue_task_rt+0x13/0x50
 [<c011df84>] dequeue_task+0x74/0x90
 [<c011e007>] deactivate_task+0x17/0x20
 [<c04fa53f>] __schedule+0x35f/0x8e0
 [<c04faae6>] schedule+0x26/0xe0
 [<c04ffaaa>] add_preempt_count+0xa/0x90
 [<c012fd15>] ksoftirqd+0x205/0x290
 [<c012fb10>] ksoftirqd+0x0/0x290
 [<c013f919>] kthread+0x39/0x70
 [<c013f8e0>] kthread+0x0/0x70
 [<c0104ad7>] kernel_thread_helper+0x7/0x10
 =======================


Code:
BUG: sleeping function called from invalid context swapper(0) at kernel/rtmutex.c:743
in_atomic():1 [00000001], irqs_disabled():1
Pid: 0, comm: swapper Not tainted 2.6.26-zenrt1 #1
 [<c04fcb3f>] __rt_spin_lock+0x5f/0x70
 [<c014524d>] pm_qos_requirement+0xd/0x30
 [<c0413e4c>] menu_select+0x7c/0x90
 [<c0412c7b>] cpuidle_idle_call+0x5b/0xc0
 [<c0102cca>] cpu_idle+0x5a/0x100
 =======================


Code:
BUG: sleeping function called from invalid context IRQ-22(2278) at kernel/rtmutex.c:743
in_atomic():1 [00000002], irqs_disabled():1
Pid: 2278, comm: IRQ-22 Not tainted 2.6.26-zenrt1 #1
 [<c04fcb3f>] __rt_spin_lock+0x5f/0x70
 [<c01238f8>] update_curr_rt+0x98/0x1b0
 [<c0123b53>] dequeue_task_rt+0x13/0x50
 [<c011df84>] dequeue_task+0x74/0x90
 [<c011e007>] deactivate_task+0x17/0x20
 [<c04fa53f>] __schedule+0x35f/0x8e0
 [<f886e392>] uhci_irq+0x82/0x170 [uhci_hcd]
 [<f90f4011>] ehci_irq+0xf1/0x199 [ehci_hcd]
 [<c03da0a3>] usb_hcd_irq+0x23/0x60
 [<c015e61c>] handle_IRQ_event+0x4c/0xd0
 [<c04faae6>] schedule+0x26/0xe0
 [<c01169e6>] unmask_IO_APIC_irq+0x26/0x40
 [<c015ebe9>] do_irqd+0x179/0x2b0
 [<c015ea70>] do_irqd+0x0/0x2b0
 [<c013f919>] kthread+0x39/0x70
 [<c013f8e0>] kthread+0x0/0x70
 [<c0104ad7>] kernel_thread_helper+0x7/0x10
 =======================


And this happens many times:

Code:
post-factum@eternity:~$ dmesg | grep BUG: | wc -l
366


so, wtf?
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jul 22, 2008 12:43 pm    Post subject: Reply with quote

I just pulled this AM and saw changws in -zenrt & -zenmm. Will compile later and test but so far rc8-zenmm2 is #1, -zenmm3, #2 for me.
What I really need to do is sort all the .configs I have from testing. If I couldn't pull the running config from -zenmm2 I wod be lost.
Back to top
View user's profile Send private message
FallenWizard
n00b
n00b


Joined: 04 Sep 2007
Posts: 51
Location: Vienna / Austria

PostPosted: Tue Jul 22, 2008 12:59 pm    Post subject: Reply with quote

cheater1034 wrote:
RT branch was reverted from master, and i reverted 1 lkml patch (i don't think it affected my hardlocks, but it seemed the only potential one that could)

Anyway, i've been running strong in X (1.5) / gnome for awhile now with no hardlocks and a clean dmesg, it seems finally rc8-zenmm is running good for me (no panics, oops, bug, or lock)

(and oss4 works for me too perfect)


Yes, the hardlocks are gone, zenmm is running well again :D
Back to top
View user's profile Send private message
Strayer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2003
Posts: 75
Location: Germany

PostPosted: Tue Jul 22, 2008 1:33 pm    Post subject: Reply with quote

I can't compile nvidia-drivers-177.13 with the latest zenmm (2.6.26-rc8-zenmm3) from git.

Using the zen-overlay fixed the first error... now I get this one:
http://strayer.pastebin.org/55530

None of the patches above seem to work... any help? :(
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Jul 22, 2008 1:37 pm    Post subject: Reply with quote

Strayer, edit the ebuild so it looks like
Code:
    cd ${S}/usr/src/nv
    epatch "${FILESDIR}/mm-fix.patch"
    sed -i -e 's:return kill_proc:return kill_pid:g' os-interface.c || die


Do not apply above patches! They are for -rt and .26-git. Not needed for -rc8-zenmm3
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Strayer
Tux's lil' helper
Tux's lil' helper


Joined: 11 Nov 2003
Posts: 75
Location: Germany

PostPosted: Tue Jul 22, 2008 1:42 pm    Post subject: Reply with quote

Removed the patches and added that line... worked!

Thanks! :)
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Jul 22, 2008 1:57 pm    Post subject: Reply with quote

One more regarding that ebuild...

@ overlay maintainers:

May I suggest conditional patching, means applying -mm patch _only_ if the kernel is -zenmm?
linux-info's KV_EXTRA fails on -rc's, so we need to grep it -> proposed patch for the ebuild:
http://gimpel.ath.cx/files/ebuild.diff
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
klixon
n00b
n00b


Joined: 14 Feb 2006
Posts: 39
Location: Holland

PostPosted: Tue Jul 22, 2008 2:37 pm    Post subject: Reply with quote

Where does one get that mm-fix.patch when one does not run gentoo? Can i download it from some place?
_________________
Stand back, intruder, or I'll blast you out of space. I am Klixon and I don't want any dealings with you human lifeforms... I'm a cyborg!
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Tue Jul 22, 2008 3:17 pm    Post subject: Reply with quote

klixon wrote:
Where does one get that mm-fix.patch when one does not run gentoo? Can i download it from some place?

Here ya go:
http://gentoo-overlays.zugaina.org/zen-overlay/portage/x11-drivers/nvidia-drivers/files/mm-fix.patch
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
klixon
n00b
n00b


Joined: 14 Feb 2006
Posts: 39
Location: Holland

PostPosted: Tue Jul 22, 2008 4:04 pm    Post subject: Reply with quote

Awesomeness! Finally got it running!
_________________
Stand back, intruder, or I'll blast you out of space. I am Klixon and I don't want any dealings with you human lifeforms... I'm a cyborg!
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Tue Jul 22, 2008 4:16 pm    Post subject: Reply with quote

Looks like I have a fairly stable -zenmm3 running right now. I am emerging php, compiling -zenrt kernel, playing amarok, using vlc for an .avi, running dep -w, have Thunderbird checking mail and firefox browsing and not a hardlock yet and dmesg is clean.

When -zenrt is finished I will report back.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 7, 8, 9 ... 11, 12, 13  Next
Page 8 of 13

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum