Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Java with Opera 9.50 on amd64
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
friesia
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 200

PostPosted: Fri Jul 04, 2008 8:07 am    Post subject: Java with Opera 9.50 on amd64 Reply with quote

I've noticed this trouble in betas, and it still remains in the release.
I think it's probably Blackdown JDK's fault. If I set Java directory to /opt/blackdown-jdk-1.4.2.03/jre/lib/amd64/, Opera accepts that, but fails on first Java applet it sees (causes emergency exit).
As I investigated the internet, I can't use Java with 64-bit Firefox and Konqueror as well.
Do you have any solution to this?
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Jul 04, 2008 8:32 am    Post subject: Reply with quote

Install icedtea from java-overlay, with USE="nsplugin" ;)
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
friesia
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 200

PostPosted: Sat Jul 05, 2008 7:10 am    Post subject: Reply with quote

I did as gimpel told, but it seems nspluginwrapper wouldn't accept the library:

Code:
 * Auto installing 32bit plugins...
*** NSPlugin Viewer  *** ERROR: /usr/lib/nsbrowser/plugins/javaplugin.so: wrong ELF class: ELFCLASS64
*** NSPlugin Viewer  *** ERROR: /usr/lib64/nsbrowser/plugins/javaplugin.so: wrong ELF class: ELFCLASS64
>>> Original instance of package unmerged safely.
 * Auto installing 32bit plugins...
*** NSPlugin Viewer  *** ERROR: /usr/lib/nsbrowser/plugins/javaplugin.so: wrong ELF class: ELFCLASS64
*** NSPlugin Viewer  *** ERROR: /usr/lib64/nsbrowser/plugins/javaplugin.so: wrong ELF class: ELFCLASS64


It seems icedtea is 64-bit, so why nsplugin?
Setting Java path in Opera to /usr/lib/icedtea6-1.2/jre/lib/amd64/ wouldn't enable Java as well (the directory is told to be valid, same thing with Sun JDK).
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sat Jul 05, 2008 7:13 am    Post subject: Reply with quote

friesia wrote:
It seems icedtea is 64-bit, so why nsplugin?

You now have a 64bit java browser plugin. Wasn't that what you actually wanted?

My Opera 9.50 does find it. And it sort of works but it's horribly slow and sluggish.
Works like a charme in FF3 though.

Code:
└» sudo eselect java-nsplugin list
Available 32-bit Java browser plugins
Available 64-bit Java browser plugins
  [1]   icedtea-6  current

_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
friesia
Apprentice
Apprentice


Joined: 23 Mar 2007
Posts: 200

PostPosted: Sat Jul 05, 2008 8:39 am    Post subject: Reply with quote

Works for me in FF too.
Could you tell me the plugin path for Opera please? Is it /usr/lib/icedtea6-1.2/jre/lib/amd64/gcjwebplugin.so?
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Sat Jul 05, 2008 8:47 am    Post subject: Reply with quote

/usr/lib/icedtea6-1.2/jre/lib/amd64, yes.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum