Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Open Office wont compile [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
hawk__0
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2008
Posts: 76

PostPosted: Sat Jul 05, 2008 7:38 pm    Post subject: Open Office wont compile [SOLVED] Reply with quote

I'm trying to install the new open office, and:
Code:
 *
 *
 * ERROR: app-office/openoffice-2.4.1 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   openoffice-2.4.1.ebuild, line  210:  Called built_with_use 'pkg_setup' 'pkg_setup'
 *             eutils.eclass, line 1729:  Called die
 * The specific snippet of code:
 *                  die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   dev-lang/python-2.4.4-r9 does not actually support the threads USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-2.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-2.4.1/temp/die.env'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="." JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

 * Messages for package app-office/openoffice-2.4.1:

 *
 * ERROR: app-office/openoffice-2.4.1 failed.
 * Call stack:
 *                 ebuild.sh, line   49:  Called pkg_setup
 *   openoffice-2.4.1.ebuild, line  210:  Called built_with_use 'pkg_setup' 'pkg_setup'
 *             eutils.eclass, line 1729:  Called die
 * The specific snippet of code:
 *                  die)   die "$PKG does not actually support the $1 USE flag!";;
 *  The die message:
 *   dev-lang/python-2.4.4-r9 does not actually support the threads USE flag!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-office/openoffice-2.4.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/openoffice-2.4.1/temp/die.env'.
 *


I've tried messing with my use flags and it doesn't seem to matter what I do I always get this. How can I resolve this problem?


Last edited by hawk__0 on Sun Jul 06, 2008 1:10 am; edited 1 time in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43571
Location: 56N 3W

PostPosted: Sat Jul 05, 2008 8:29 pm    Post subject: Reply with quote

hawk__0,

The key bit is
Code:
dev-lang/python-2.4.4-r9 does not actually support the threads USE flag


Open /etc/portage/package.use and add one line
Code:
dev-lang/python -threads
to turn off threading for python.
Code:
emerge -1 python
to rebuild it.

Now try OpenOffice again
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
hawk__0
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2008
Posts: 76

PostPosted: Sat Jul 05, 2008 9:09 pm    Post subject: Reply with quote

Thank for the help, but I ran this:
Code:
emerge -1 python && USE="en_US" emerge openoffice

and then got the same error :(

python compiled too, by the way.


EDIT:
fixed, it NEEDED threads support in python, so i recompiled it with threads support so it works now :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum