Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Webmin update. How to update webmin. Thx to slack
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Pedro84
n00b
n00b


Joined: 07 Jul 2008
Posts: 9

PostPosted: Mon Jul 07, 2008 2:13 pm    Post subject: [SOLVED] Webmin update. How to update webmin. Thx to slack Reply with quote

Hello,

First of all, I'd like to say thank you for all Gentoo developers, contributors and supporters for fantastic operating system!


I got question about updating one software. I'm talking about Webmin. When I use
Code:
emerge --update webmin

the newest version in repesitory is 1.400.

I'd like to have version 1.420 on my server and got question. What should I to do to have it?

Should I download sources, compile them and install free installation?

Pedro


Last edited by Pedro84 on Mon Jul 07, 2008 4:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Mon Jul 07, 2008 2:18 pm    Post subject: Re: Question about updating software Reply with quote

Pedro84 wrote:
Hello,

First of all, I'd like to say thank you for all Gentoo developers, contributors and supporters for fantastic operating system!


I got question about updating one software. I'm talking about Webmin. When I use
Code:
emerge --update webmin

the newest version in repesitory is 1.400.

I'd like to have version 1.420 on my server and got question. What should I to do to have it?

Should I download sources, compile them and install free installation?

Pedro


EDIT : Scrap what I wrote, there is already a version bump in bugzilla at 219254


slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
Pedro84
n00b
n00b


Joined: 07 Jul 2008
Posts: 9

PostPosted: Mon Jul 07, 2008 2:26 pm    Post subject: Reply with quote

Thanks for fast reply slack.

After doing all steps from your post, after emerge -a webmin I got error:

Code:

 *
 *   /usr/local/portage/app-admin/webmin/files/webmin-1.270-ldap-useradmin.patch
 *   ( webmin-1.270-ldap-useradmin.patch )
 *
 * ERROR: app-admin/webmin-1.420 failed.
 * Call stack:
 *             ebuild.sh, line 1701:  Called dyn_unpack
 *             ebuild.sh, line  817:  Called qa_call 'src_unpack'
 *             ebuild.sh, line   44:  Called src_unpack
 *   webmin-1.420.ebuild, line   43:  Called epatch '/usr/local/portage/app-admin/webmin/files/webmin-1.270-ldap-useradmin.patch'
 *         eutils.eclass, line  181:  Called die
 * The specific snippet of code:
 *                      die "Cannot find \$EPATCH_SOURCE!"
 *  The die message:
 *   Cannot find $EPATCH_SOURCE!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-admin/webmin-1.420/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/portage/'


Sorry for my ignorance but it's my first time with gentoo :)
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Mon Jul 07, 2008 2:55 pm    Post subject: Reply with quote

Not a problem Pedro84.

Apologies for editing things, should have looked for a bug first.

Anyway, this means that the build can't find the associated patches that need to be applied to the source code and are listed in the the whole procedure using the reported bug from bugzilla. The following should get you there (although some of the commands are redundant as you will have already done them)...

Code:

# mkdir /usr/local/portage/app-admin/webmin/files -p
# cd /usr/local/portage/app-admin/webmin/files
# wget http://bugs.gentoo.org/attachment.cgi?id=150923 -O webmin-1.420-ldap-useradmin.patch
# wget http://bugs.gentoo.org/attachment.cgi?id=150924 -O virtual-server-3.56-nocgibin.patch
# wget http://bugs.gentoo.org/attachment.cgi?id=150921 -O webmin-1.420.patch


You now need to edit the ebuild and change the second line to the version you want, in this case 1.420 instead of 1.410 as it currently stands in the patch, you can do this using nano or whatever editor your happy with (e.g. nano /usr/local/portage/app-admin/webmin/files/webmin-1.410.patch then make the change, save and exit (Ctrl + O to save, answering 'Yes', and then Ctrl + X to exit).

Now apply the patch...

Code:

patch -p0 < webmin-1.420.patch


....and this should leave you with a the file /usr/local/portage/app-admin/webmin/webmin-1.420.ebuild

You now need to digest this, make sure the overlay is in your /etc/make.conf (if you've not done so already) and then emerge...

Code:

# ebuild /usr/local/portage/app-admin/webmin/webmin-1.420.ebuild digest
# echo 'PORTDIR_OVERLAY=/usr/local/portage' >> /etc/make.conf
# emerge -av webmin


slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
Pedro84
n00b
n00b


Joined: 07 Jul 2008
Posts: 9

PostPosted: Mon Jul 07, 2008 3:08 pm    Post subject: Reply with quote

Done exactly what you post. Getting:

Code:
]

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/app-admin/webmin/files/virtual-server-3.23-nocgibin.patch
 *   ( virtual-server-3.23-nocgibin.patch )

 *
 * ERROR: app-admin/webmin-1.420 failed.
 * Call stack:
 *             ebuild.sh, line 1701:  Called dyn_unpack
 *             ebuild.sh, line  817:  Called qa_call 'src_unpack'
 *             ebuild.sh, line   44:  Called src_unpack
 *   webmin-1.420.ebuild, line   49:  Called epatch '/usr/local/portage/app-admin/webmin/files/virtual-server-3.23-nocgibin.patch'
 *         eutils.eclass, line  181:  Called die
 * The specific snippet of code:
 *                      die "Cannot find \$EPATCH_SOURCE!"
 *  The die message:
 *   Cannot find $EPATCH_SOURCE!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-admin/webmin-1.420/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 *

 * Messages for package app-admin/webmin-1.420:

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /usr/local/portage/app-admin/webmin/files/virtual-server-3.23-nocgibin.patch
 *   ( virtual-server-3.23-nocgibin.patch )
 *
 * ERROR: app-admin/webmin-1.420 failed.
 * Call stack:
 *             ebuild.sh, line 1701:  Called dyn_unpack
 *             ebuild.sh, line  817:  Called qa_call 'src_unpack'
 *             ebuild.sh, line   44:  Called src_unpack
 *   webmin-1.420.ebuild, line   49:  Called epatch '/usr/local/portage/app-admin/webmin/files/virtual-server-3.23-nocgibin.patch'
 *         eutils.eclass, line  181:  Called die
 * The specific snippet of code:
 *                      die "Cannot find \$EPATCH_SOURCE!"
 *  The die message:
 *   Cannot find $EPATCH_SOURCE!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-admin/webmin-1.420/temp/build.log'.
 * This ebuild is from an overlay: '/usr/local/portage/'
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Mon Jul 07, 2008 3:12 pm    Post subject: Reply with quote

The answer is hidden in the output your posting :wink:

I forgot to advise that there are other patches that you need to copy over, sorry about that. This is clear from the line...

Quote:

Code:

 *   /usr/local/portage/app-admin/webmin/files/virtual-server-3.23-nocgibin.patch




Thus simply copy over all other patches from the main portage tree with...

Code:

cp /usr/portage/app-admin/webmin/files/*.patch /usr/local/portage/app-admin/webmin/files/.


..and that should work. Note however the comments on the bug, that this hasn't actually worked, so you may find that after all this your still stuck with the current version in portage anyway, but it would be worthwhile adding details of any problems to the bug if you get any, and then the devs can work on resolving them.

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
Pedro84
n00b
n00b


Joined: 07 Jul 2008
Posts: 9

PostPosted: Mon Jul 07, 2008 4:19 pm    Post subject: Reply with quote

Thanks slack! Helped! Got 1.420 installed:)

All the time I used an African word meaning "Gentoo is too hard for me" :D
Back to top
View user's profile Send private message
slackline
Veteran
Veteran


Joined: 01 Apr 2005
Posts: 1422
Location: /uk/sheffield

PostPosted: Mon Jul 07, 2008 4:36 pm    Post subject: Reply with quote

Cool, glad you got it sorted.

If you could help other forum users by editing your first post and adding [SOLVED] to the subject line then they'll know its a useful thread if they're searching for solutions to similar problems.

Oh, and welcome to the world of Gentoo, hope you like it and stick around :D

slack
_________________
"Science is what we understand well enough to explain to a computer.  Art is everything else we do." - Donald Knuth
Back to top
View user's profile Send private message
Pedro84
n00b
n00b


Joined: 07 Jul 2008
Posts: 9

PostPosted: Mon Jul 07, 2008 4:39 pm    Post subject: Reply with quote

slack---line wrote:
Cool, glad you got it sorted.

If you could help other forum users by editing your first post and adding [SOLVED] to the subject line then they'll know its a useful thread if they're searching for solutions to similar problems.

Oh, and welcome to the world of Gentoo, hope you like it and stick around :D

slack


Done:) Also renamed it a bit cause I named it wrong way previously:)

Wanted to install Gentoo years ago, but now did it:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum