Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gcc-4.3.1[-r1] using itself to compile [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dR0PS
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2005
Posts: 116
Location: DE/Hamburg

PostPosted: Fri Jul 11, 2008 6:05 pm    Post subject: gcc-4.3.1[-r1] using itself to compile [solved] Reply with quote

Hi folks

i get always compile error when compiling gcc-4.3.1 or gcc-4.3.1-r1 when using gcc-4.3.1.
Is this normal behavior (bug) or is it possible to do somehow?

Code:
if [ x"-fpic" != x ]; then \
          /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/build/./prev-gcc/xgcc -B/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/build/./prev-gcc/ -B/usr/i686-pc-linux-gnu/bin/ -c -DHAVE_CONFIG_H -march=native -pipe -fprofile-use -I. -I/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libiberty/../include  -W -Wall -Wwrite-strings -Wc++-compat -Wstrict-prototypes -pedantic  -fpic /var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libiberty/splay-tree.c -o pic/splay-tree.o; \
        else true; fi
/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libiberty/splay-tree.c: In function ‘splay_tree_delete_helper’:
/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/gcc-4.3.1/libiberty/splay-tree.c:107: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://bugs.gentoo.org/> for instructions.
make[3]: *** [splay-tree.o] Error 1
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/build/libiberty'
make[2]: *** [all-stagefeedback-libiberty] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/build'
make[1]: *** [stagefeedback-bubble] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.3.1-r1/work/build'
make: *** [profiledbootstrap] Error 2
 *
 * ERROR: sys-devel/gcc-4.3.1-r1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 4582:  Called toolchain_src_compile
 *             environment, line 5097:  Called gcc_src_compile
 *             environment, line 2946:  Called gcc_do_make
 *             environment, line 2776:  Called die
 * The specific snippet of code:
 *       emake LDFLAGS="${LDFLAGS}" STAGE1_CFLAGS="${STAGE1_CFLAGS}" LIBPATH="${LIBPATH}" BOOT_CFLAGS="${BOOT_CFLAGS}" ${GCC_MAKE_TARGET} || die "emake failed with ${GCC_MAKE_TARGET}";
 *  The die message:
 *   emake failed with profiledbootstrap
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.3.1-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.3.1-r1/temp/environment'.
 *
Code:
gentoo ~ # emerge --info
Portage 2.2_rc1 (default-linux/x86/2007.0/desktop, gcc-4.3.1, glibc-2.8_p20080602-r0, 2.6.25-zen2 i686)
=================================================================
System uname: Linux-2.6.25-zen2-i686-AMD_Athlon-tm-_XP_3200+-with-glibc2.0
Timestamp of tree: Fri, 11 Jul 2008 04:46:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.5.2-r5
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.25-r4
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/bind /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=native -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages metadata-transfer parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS=""
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/custom-kernels /usr/portage/local/layman/desktop-effects /usr/local/portage"
SYNC="rsync://rsync.gentoo.stealer.net/gentoo-portage"
USE="3dnow 3dnowext X a52 aac aalib accessibility acl acpi additions alsa amr amuled apache2 apm asf authdaemon automount avi bash-completion berkdb bidi bitmap-fonts bluetooth browserplugin buttons bzip2 cairo caps cdda cddb cdio cdparanoia cdr cli cpdflib cpudetection cracklib crypt ctype cups curl daap dba dbus dcc dedicated dga dhcp dio directfb diskio divx dri dts dv dvb dvd dvdr dvdread dynamicplugin eds emboss encode esd etcproposals evo examples exif extras fam fbcondecor ffmpeg fftw filter_default flac flash fontconfig foomaticdb fortran fpx freetype ftp fuse gd gdbm gdm gecko-sdk gif glitz gmedia gnome gpm gs gstreamer gtk gtk2 hal hddtemp hdri http httpd iconv imagemagick imap imlib imlib2 inline innodb iproute2 irmc isdnlog java javascript jbig jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kdgraphics kerberos ldap ldbm libcaca libg++ libwww live lm_sensors logitech-mouse lua lzo mad maildir matroska mhash midi mikmod mmbox mmx mng motif mp3 mp4 mpd mpeg mpeg2dec mudflap musepack musicbrainz mysql nagios-dns nagios-game nagios-ntp nagios-ping nagios-ssh nas ncurses net netboot network newspr nls nptl nptlonly nsplugin nvidia ogg oggvorbis openexr opengl openmp optimize pam pam-mysql passwordsave pch pcre pdf pdflib pear perl pertty php php5 png posix ppds pppd python pyzor qt qt-copy qt3 qt3support qt4 quicktime razor readline real realmedia reflection remote remote-gui rrdtool rtsp samba sasl scanner screen sdl session shout skins slp snmp sockets socks5 speex spell spl sse ssl stats stream svg svga tcl tcltk tcpd theora threads tiff tk tools truetype truetype-fonts type1-fonts unicode urandom usb userlocales utempter v4l v4l2 vcd vda vidcap videos visualization vlm vorbis webdav win32codecs wmf wmp wxwindows x264 x86 xcb xine xinerama xml xml2 xorg xosd xpm xulrunner xv xvid xvimlib zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1       emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m       maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="nvidia v4l"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Maybe someone could help me out?
I've already heard something about splay-tree.c errors, but didn't find a solution, yet?
Is there a way to keep the "toolchain" completely uptodate / insane ;)

Thanks in advance, dR0PS
_________________

~x86 gentoo / zen-sources 2.6.36-zen1


Last edited by dR0PS on Wed Jul 16, 2008 5:44 am; edited 2 times in total
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43012
Location: 56N 3W

PostPosted: Fri Jul 11, 2008 6:51 pm    Post subject: Reply with quote

dR0PS,

If you repeat the emerge, do you get exactly the same error in the same place ?
If not, you probably have a hardware problem, possibly overheating.

Code:
CFLAGS="-march=native -fomit-frame-pointer -pipe"
You don't have an -O setting in there. -O2 is safe.
I see you use
Code:
dev-util/ccache:     2.4-r7.

Flushing the cache may help.

gcc has a strange compile process. First, it uses your selected compiler to compile a bootstrap compiler. This is gcc for C only.
Now it uses this bootstrapped compiler to compile the gcc that will be installed, including the C part. This ensures the gcc is always compiled with itself.

Its not clear from your post if the bootstrap phase completed or not
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
dR0PS
Tux's lil' helper
Tux's lil' helper


Joined: 27 Feb 2005
Posts: 116
Location: DE/Hamburg

PostPosted: Wed Jul 16, 2008 5:43 am    Post subject: [clsd] Reply with quote

Hi Neddy

sorry for the delay. -O2 got lost when changing to -march=native.
I changed it back to -O2 -march=native and it didn't work in the first try either.

I waited some days and now it works. Since this day some packages came into portage dunno if
any of these was the clue.

Thanks for help.

dR0PS
_________________

~x86 gentoo / zen-sources 2.6.36-zen1
Back to top
View user's profile Send private message
Peha
n00b
n00b


Joined: 07 Aug 2002
Posts: 37

PostPosted: Mon Jul 21, 2008 1:41 pm    Post subject: Reply with quote

Aw man, I have the same problem! Did you really not change anything before the compilation succeeded?

Regards,
Peha
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum