Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
zen-overlay alsa-plugins is broken
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
yngwin
Retired Dev
Retired Dev


Joined: 19 Dec 2002
Posts: 4572
Location: Suzhou, China

PostPosted: Sat Jul 12, 2008 11:24 pm    Post subject: zen-overlay alsa-plugins is broken Reply with quote

I saw a new alsa 1.0.17_rc2 version in zen overlay and decided to try it. The alsa-plugins ebuild though fails because it can't find an ffmpeg header, even though I specified USE=-ffmpeg. The ffmpeg header locations have changed in the ~arch version, so you need to patch your ebuild to work with these, as well as disable features that need ffmpeg when USE=-ffmpeg is set.
_________________
"Those who deny freedom to others deserve it not for themselves." - Abraham Lincoln
Free Culture | Defective by Design | EFF
Back to top
View user's profile Send private message
CooSee
Guru
Guru


Joined: 20 Nov 2004
Posts: 458
Location: Earth

PostPosted: Sat Jul 12, 2008 11:38 pm    Post subject: Re: zen-overlay alsa-plugins is broken Reply with quote

yngwin wrote:
I saw a new alsa 1.0.17_rc2 version in zen overlay and decided to try it. The alsa-plugins ebuild though fails because it can't find an ffmpeg header, even though I specified USE=-ffmpeg. The ffmpeg header locations have changed in the ~arch version, so you need to patch your ebuild to work with these, as well as disable features that need ffmpeg when USE=-ffmpeg is set.


worked for me :roll: :!:

Code:
[ebuild   R   ] media-libs/alsa-lib-1.0.17_rc2  USE="midi -alisp -debug -doc" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" 0 kB [1]
[ebuild   R   ] media-video/ffmpeg-20089999  USE="a52 aac ipv6 mmx mp3 sdl swscaler theora threads truetype vorbis xvid zlib (-altivec) -amrnb -amrwb -debug-doc -hardcoded-tables -ieee1394 -imlib -network -oss -schroedinger -test -v4l -x264" 0 kB [2]
[ebuild   R   ] media-sound/alsa-utils-1.0.17_rc2  USE="midi nls" 0 kB [1]
[ebuild   R   ] media-sound/alsa-tools-1.0.17_rc1  USE="gtk midi -fltk" ALSA_CARDS="emu10k1 -darla20 -darla24 -echo3g -emu10k1x -gina20 -gina24 -hdsp -hdspm-ice1712 -indigo -indigoio -layla20 -layla24 -mia -mixart -mona -pcxhr -rme32 -rme96 -sb16 -sbawe -sscape -usb-usx2y -vx222" 0 kB [1]
[ebuild   R   ] media-plugins/alsa-plugins-1.0.17_rc2  USE="ffmpeg jack -debug -libsamplerate -pulseaudio -speex" 0 kB [1]


CooSee ' Ya
_________________
beQuiet! Silent Base 800 Black - MSI C236A - Xeon E3-1245v5 - 32GB RAM Kingston - Sapphire Nitro+ Radeon RX590 8G - Samsung PM961 M.2 128GB - Samsung 840 EVO 120GB - Creative Sound Blaster RX PCIe - Logitech Z623 2.1 - G110 Keyboard - Mouse G400
Back to top
View user's profile Send private message
Diskmaster
n00b
n00b


Joined: 13 Jul 2008
Posts: 23

PostPosted: Sun Jul 13, 2008 11:45 am    Post subject: Re: zen-overlay alsa-plugins is broken Reply with quote

yngwin wrote:
I saw a new alsa 1.0.17_rc2 version in zen overlay and decided to try it. The alsa-plugins ebuild though fails because it can't find an ffmpeg header, even though I specified USE=-ffmpeg. The ffmpeg header locations have changed in the ~arch version, so you need to patch your ebuild to work with these, as well as disable features that need ffmpeg when USE=-ffmpeg is set.


Apparently I somehow screwed up when I re-diff'd the configure patch. I'll play with it some more after work.
_________________
Linux polished-diamond 3.0.9-00003-g3c676b1 x86_64 Intel(R) Core(TM) i7 CPU 950 @ 3.07GHz GenuineIntel GNU/Linux
Something witty goes here.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum