Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED!] Eclipse 3.4: Cannot launch the update UI.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
willie_wang
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2008
Posts: 87
Location: Edinburgh, Scotland

PostPosted: Wed Jul 16, 2008 12:23 pm    Post subject: [SOLVED!] Eclipse 3.4: Cannot launch the update UI. Reply with quote

Hi! I installed the latest Eclipse 3.4 from the java overlay. And now whenever I try to update the software, or add new plugins, I can't.

I get the message, "Cannot launch the update UI. This installation has not been configured properly for Software Updates." I don't know what to do about this as this problem makes Eclipse virtually unusable.

Any help please? ~ww


Last edited by willie_wang on Fri Jul 18, 2008 1:07 am; edited 1 time in total
Back to top
View user's profile Send private message
Maliwik
Apprentice
Apprentice


Joined: 14 Apr 2008
Posts: 252
Location: Wisconsin, U.S. of A.

PostPosted: Wed Jul 16, 2008 2:43 pm    Post subject: Reply with quote

You have to be running Eclipse as root to be able to update it since it's an actual program update rather than profile update.
_________________
freelight wrote:
I have a severe case of procrastinitis.
Back to top
View user's profile Send private message
willie_wang
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2008
Posts: 87
Location: Edinburgh, Scotland

PostPosted: Wed Jul 16, 2008 3:23 pm    Post subject: Reply with quote

Maliwik wrote:
You have to be running Eclipse as root to be able to update it since it's an actual program update rather than profile update.


Code:
# eclipse-3.4
Do not run eclipse as root user! Exitting ...


It says I can't run eclipse as root.
Back to top
View user's profile Send private message
willie_wang
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2008
Posts: 87
Location: Edinburgh, Scotland

PostPosted: Wed Jul 16, 2008 4:05 pm    Post subject: Reply with quote

Ok, with a little more research, the problem seems to be related to the new update manager that Eclipse 3.4 has - namely, Equinox p2. http://wiki.eclipse.org/Equinox_p2_Getting_Started Here's some more info http://dev.eclipse.org/mhonarc/lists/linux-distros-dev/msg00345.html.

Unfortunately, I'm pretty sure the new update UI isn't installed with the 3.4 ebuild in the java overlay. I'm trying to do it manually now, but I'm new with Eclipse, so I'm not entirely sure how to do this. I'm trying to work out what's going on in the Admin UI to see if I can install the new Update UI from this interface, although it's very confusing - see http://wiki.eclipse.org/Equinox_p2_Getting_Started_Admin_UI.

Has anyone managed to get the Software Updates in 3.4 working yet? Or can someone tell me how? Thanks for the response so far. Any help is greatly appreciated ~ww
Back to top
View user's profile Send private message
willie_wang
Tux's lil' helper
Tux's lil' helper


Joined: 02 Apr 2008
Posts: 87
Location: Edinburgh, Scotland

PostPosted: Wed Jul 16, 2008 4:44 pm    Post subject: Reply with quote

Buggrit. Found a solution. To enable the classic install interface, go to: Window, Preferences, General, Capabilities, Classic Update.
Back to top
View user's profile Send private message
pathfinder
l33t
l33t


Joined: 19 Jan 2006
Posts: 731
Location: Barcelona, Spain

PostPosted: Fri Oct 03, 2008 1:26 pm    Post subject: Reply with quote

Then Help > Software Updates ... > Find and Install > Add Remote Location > http://download.eclipse.org/technology/photran/updates/eclipse3.4cdt5.0

and you're done for the Fortran IDE Photran.
_________________
Cuando un tonto coge un camino, el camino se acaba, pero el tonto sigue
Back to top
View user's profile Send private message
rendier
n00b
n00b


Joined: 15 Nov 2005
Posts: 4

PostPosted: Sat Dec 06, 2008 8:31 pm    Post subject: Reply with quote

willie_wang wrote:
Buggrit. Found a solution. To enable the classic install interface, go to: Window, Preferences, General, Capabilities, Classic Update.


thank you so much for sharing this info!

same problem, same solution :-)
Back to top
View user's profile Send private message
lord_ph
Tux's lil' helper
Tux's lil' helper


Joined: 18 Nov 2003
Posts: 97
Location: Portland,OR

PostPosted: Tue Jan 06, 2009 4:29 am    Post subject: Reply with quote

Yes, thank you for sharing this info. Helped me out in a pinch. :)
Back to top
View user's profile Send private message
xitrium
n00b
n00b


Joined: 26 Feb 2004
Posts: 16

PostPosted: Fri Feb 13, 2009 1:17 pm    Post subject: Reply with quote

It seems like this is only partially solved... Why doesn't the new eclipse update manager work in Gentoo?
Back to top
View user's profile Send private message
Shockwaver
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2005
Posts: 123

PostPosted: Mon Apr 27, 2009 9:08 pm    Post subject: Reply with quote

When I try to update the eclipse platform (e.g. to the 3.4.2) from the update manager i get permission denied when installing: of course the available installation is in /usr/lib/eclipse-3.4 and exactly there i can only install the update.
What can i do?
Back to top
View user's profile Send private message
muhsinzubeir
l33t
l33t


Joined: 29 Sep 2007
Posts: 948
Location: /home/muhsin

PostPosted: Fri May 08, 2009 2:28 pm    Post subject: Reply with quote

Shockwaver wrote:
When I try to update the eclipse platform (e.g. to the 3.4.2) from the update manager i get permission denied when installing: of course the available installation is in /usr/lib/eclipse-3.4 and exactly there i can only install the update.
What can i do?


updates are being installed on ~/.eclipse
id recommend to check permissions if user can write

cheers
_________________
~x86
p5k-se
Intel Core 2 Duo
Nvidia GT200
http://www.zanbytes.com
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Wed May 27, 2009 9:20 am    Post subject: Reply with quote

muhsinzubeir wrote:
updates are being installed on ~/.eclipse
Unfortunately, Ganymede updates are installed in /usr/lib/eclipse-3.4/features. Everything else is installed in ~/.eclipse :-(
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
cst
Apprentice
Apprentice


Joined: 24 Feb 2008
Posts: 203
Location: /proc

PostPosted: Thu Jun 04, 2009 9:39 am    Post subject: Reply with quote

Yes the updates are installed in ~/.eclipse and they dont work from there (atleast php didnt) but I copied them to /usr/lib/eclipse and they work. I still have problems getting eclipse to work with lampp though:(
_________________
i7 3930K @ 4GHz
MSI X79A-GD45 (8D)
32GB 1600 MHz DDR3 Samsung
Samsung 840 PRO, 2xSamsung HD502HJ in RAID 1
MSI GTX 980Ti
latest gentoo-sources on x86_64 Fluxbox (amd64)

best render farm: www.GarageFarm.NET
Back to top
View user's profile Send private message
tekknokrat
Apprentice
Apprentice


Joined: 17 Apr 2005
Posts: 278
Location: Magdeburg

PostPosted: Mon Jun 22, 2009 3:14 pm    Post subject: Reply with quote

I am getting this error message when installing phpeclipse via update site the classic way:

Code:
Current configuration contains errors that are not corrected by the requested operation and more errors would be introduced. See details for more information.
  ----- Current configuration problems -----
    Error creating feature "file:/usr/lib64/eclipse-3.4/features/org.eclipse.jdt_3.4.1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97/". [XML document structures must start and end within the same entity.]
    XML document structures must start and end within the same entity.
  ----- Configuration problems after the operation -----
    Error creating feature "file:/usr/lib64/eclipse-3.4/features/org.eclipse.jdt_3.4.1.r341_v20080709-0800-7o7tEAfEF_U5qyUgrb2HAp539P97/". [XML document structures must start and end within the same entity.]
    XML document structures must start and end within the same entity.


Is there a way to change the path before installing. I know on installation screen there's a way too change destination path.
_________________
Optimism is solely an absence of information. / Optimismus ist nur ein Mangel an Information.
(Arthur Schopenhauer)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum