Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
paludis - package is blocking
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
newc0mer
n00b
n00b


Joined: 18 Mar 2008
Posts: 45

PostPosted: Fri Jul 18, 2008 7:39 am    Post subject: paludis - package is blocking Reply with quote

Hi

I attempted a sys update and the pacakge ant-tasks is blocked by ant-core:
Code:
# paludis -i world
Building target list...
Building dependency list...

These packages will be installed:

* dev-java/ant-tasks::installed [! blocking]
    Reasons: dev-java/ant-core-1.7.0-r1:0::installed
* perl-core/Storable [U 2.16 -> 2.18]
    173.61 kBytes to download
* virtual/perl-Storable [U 2.16 -> 2.18]
* dev-perl/IO-Socket-SSL [U 1.12 -> 1.13]
    51.30 kBytes to download
* dev-perl/Compress-Raw-Zlib [U 2.005 -> 2.011]
    202.97 kBytes to download
* dev-perl/IO-Compress-Base [U 2.005 -> 2.011]
    92.36 kBytes to download
* dev-perl/IO-Compress-Zlib [U 2.005 -> 2.011]
    137.41 kBytes to download
* dev-perl/Compress-Zlib [U 2.005 -> 2.011]
    62.63 kBytes to download
* dev-perl/IO-Zlib [U 1.07 -> 1.09]
    9.86 kBytes to download
* dev-perl/ExtUtils-CBuilder [U 0.19 -> 0.23]
    20.36 kBytes to download
* dev-perl/extutils-parsexs [U 2.18 -> 2.19]
    24.62 kBytes to download
* dev-perl/DateManip [U 5.44 -> 5.54]
    177.58 kBytes to download
* perl-core/libnet [U 1.21 -> 1.22]
    -sasl
    66.25 kBytes to download
* virtual/perl-libnet [U 1.21 -> 1.22]
* dev-perl/HTML-Tagset [U 3.10 -> 3.20]
    7.96 kBytes to download
* dev-java/sun-jre-bin :1.6 [U 1.6.0.06 -> 1.6.0.07] <world>
    X alsa -nsplugin -odbc
* net-proxy/tsocks [U 1.8_beta5-r2 -> 1.8_beta5-r3]
    tordns
    101.55 kBytes to download

Total: 16 packages (16 upgrades), 1.10 MBytes to download, 1 error

* Cannot continue with install due to the errors indicated above

 * No unread news items found

 * Searching for configuration files requiring action...
 * No configuration file updates required


But I don't know why this block is, because:
Code:
vim ant-core/ant-core-1.7.0-r1.ebuild:
.
.
# 1.7.0 instead of $PV in blocks is intentional, >1.7.0 upgrades should
# be block free (but these fixed blocks should stay there for users upgrading
# from <1.7.0 of course)
RDEPEND=">=virtual/jdk-1.4
    !<dev-java/ant-tasks-1.7.0
    !<dev-java/ant-1.7.0
    !dev-java/ant-optional"
DEPEND="${RDEPEND}
    source? ( app-arch/zip )"
.
.


Can anyone help me solving this problem?

Additionally, I want to update my packages without ant-tasks, but how? I'd like to do somethink like --resume --skipfirst or so...

ty
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 250
Location: Ukraine

PostPosted: Fri Jul 18, 2008 3:23 pm    Post subject: Reply with quote

Seems like ant-tasks already contains some functionality of ant-core.
Try to uninstall ant-core
Back to top
View user's profile Send private message
newc0mer
n00b
n00b


Joined: 18 Mar 2008
Posts: 45

PostPosted: Sun Jul 20, 2008 1:07 pm    Post subject: Reply with quote

There are too much packages depending on ant-core (38 package) and I need them, can't uninstall them.

Is there no way to get around this problem?
Back to top
View user's profile Send private message
MageSlayer
Apprentice
Apprentice


Joined: 26 Jul 2007
Posts: 250
Location: Ukraine

PostPosted: Wed Jul 23, 2008 8:11 am    Post subject: Reply with quote

See unsafe uninstall and reconcilio
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum