Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cannot emerge compiz-fusion
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
exif
n00b
n00b


Joined: 07 Jul 2008
Posts: 57
Location: Waterloo, ON, Canada

PostPosted: Mon Aug 04, 2008 5:26 pm    Post subject: Cannot emerge compiz-fusion Reply with quote

Using the desktop-effects overlay, following this wiki page, when I try to emerge compiz-fusion I get the following error:

Code:
Calculating dependencies -
!!! All ebuilds that could satisfy "~x11-plugins/compiz-fusion-plugins-main-0.7.6" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-plugins/compiz-fusion-plugins-main-0.7.6 (masked by: EAPI 2_pre1, invalid: SLOT is undefined)

The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-wm/compiz-fusion-0.7.6" [ebuild])
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Aug 04, 2008 5:57 pm    Post subject: Reply with quote

Try syncing the overlay. Looking at the ebuild, SLOT _is_ defined and all should be fine.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
exif
n00b
n00b


Joined: 07 Jul 2008
Posts: 57
Location: Waterloo, ON, Canada

PostPosted: Mon Aug 04, 2008 6:09 pm    Post subject: Reply with quote

I've tried:

Code:
emerge --sync && layman -S && emerge -av compiz-fusion


and the same error happens.

Is it possible that I haven't set up the overlay correctly? I followed the official docs and succesfully emerged compiz before running into this issue.
Back to top
View user's profile Send private message
exif
n00b
n00b


Joined: 07 Jul 2008
Posts: 57
Location: Waterloo, ON, Canada

PostPosted: Mon Aug 04, 2008 8:15 pm    Post subject: Reply with quote

I decided to try the GIT latest instead. It's compiling now.
Back to top
View user's profile Send private message
tarpman
Veteran
Veteran


Joined: 04 Nov 2004
Posts: 1083
Location: Victoria, BC, Canada

PostPosted: Tue Aug 05, 2008 2:43 am    Post subject: Re: Cannot emerge compiz-fusion Reply with quote

exif wrote:
Code:
The current version of portage supports EAPI '1'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.

Update your portage.
_________________
Saving the world, one kilobyte at a time.
Back to top
View user's profile Send private message
exif
n00b
n00b


Joined: 07 Jul 2008
Posts: 57
Location: Waterloo, ON, Canada

PostPosted: Tue Aug 05, 2008 3:10 am    Post subject: Reply with quote

My portage was updated as much as it could without having to unmask ~amd64.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum