Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Carte son] Creative ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Ulrar
n00b
n00b


Joined: 25 May 2006
Posts: 74

PostPosted: Fri Aug 08, 2008 10:09 pm    Post subject: [Carte son] Creative ? Reply with quote

Bonjour,

J'ai recement achetter tout un tas de nouveaux materiel pour mon PC, et avec ma nouvelle carte mere, j'ai eu une carte son, puisque la carte mere ne possede pas de chipset.

J'ai reinstaller gentoo cet aprem, mais entre different problme (nouveau materiel, nouveau probleme ^^), ma carte son n'est pas detectée par alsaconf.
Par contre, ma carte TV, sans probleme, mais c'est pas une carte son -_-'.

Bref, ma carte son vu par lspci :

0c:00.0 Audio device: Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG

et, vu par everest sous windows :

Creative SB X-Fi Xtreme HD Audio Controller

Apres quelques recherche, j'ai vu qu'elle n'etait pas gerer sous linux.
J'ai aussi entendu parler d'un driver en beta, je l'ai chercher, telecharger, et finnallement, il ne gere pas cette carte.

Au final, il semblerai que cette carte ne soit pas gerer parce qu'elle est en PCI-E , et que alsa ne verifie pas les ports PCI-E , parce que je cite, seulement deux carte son existe en PCI-E , celle ci et une asus.

Je sais pas si c'est vrai, mais ça m'embette beaucoup, parce que sans son, je peux dificlement me servir de linux (j'aime pas le silence moi).
Je dois quand meme pas etre le seul a avoir cette carte ?
y a quand meme bien quelqu'un qui a reussi a faire fonctionné cette carte ?
elle gere le 5.1, j'aimerai bien avoir au moin du 2.0 ...

Ah, et j'ai lu que les specifications de la carte avaient été difusée en mars, et que la prochaine version d'alsa devrait etre compatible.
Une idée de quand elle sortira cette prochaine version ?
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Mon Aug 11, 2008 5:29 pm    Post subject: Reply with quote

Euh, nan, il ne faut pas accuser Alsa et le PCIe, mais Creative, hein. Ya pas de driver ALSA, yen a pas, un point c'est tout, c'est pas la faute à ALSA qui n'irait pas scanner le port qui va bien. :)
Un ami à moi a une XFI (quelle idée aussi), et le seul driver dispo (en beta, ... ) il est pour OSS, et non ALSA. Ca "marche". Pas le micro, mais pour lire des videos et de la zik, ça passe.

Creative, c'est de la m....
Sauf les "vieilles" pre-XFI sous Linux, c'est à dire tant qu'on peut se passer d'un driver écrit par les devs incompétents de Creative. (je vous laisse essayer d'installer une Audigy sous un XP Ouinouin 64bits avec +3Go de RAM, c'est rigolo, les adresses mémoires étant en dur, vous allez écouter du binaire, c'est hype).
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Mon Aug 11, 2008 6:47 pm    Post subject: Reply with quote

Pour continuer ce que dit EL_goretto : http://manuals.opensound.com/devlists/Linux.html tu as bien un driver pour ta carte en beta.

Pour installer OSSv4 il suffit de rajouter l'overlay oss-overlay via layman par exemple.
En ce qui concerne la partie support, il faut juste laisser le support pour le son, mais pas besoin de mettre quoi que ce soit dans ALSA ni OSS.
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Mon Aug 11, 2008 7:51 pm    Post subject: Reply with quote

Marrant que je vois ce topic maintenant car je viens de recompiler mon noyau pour repasser sur mon chipset intégré VIA AC97.
J'avais acheté une audigy y a quelques mois mais le chipset c'est "audigy LS" et le driver est tout caca, ça sort du son et c'est tout... et je ne pouvais plus utiliser Traverso.
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Oupsman
Veteran
Veteran


Joined: 19 Jul 2004
Posts: 1042

PostPosted: Tue Aug 12, 2008 1:36 pm    Post subject: Reply with quote

Temet wrote:
Marrant que je vois ce topic maintenant car je viens de recompiler mon noyau pour repasser sur mon chipset intégré VIA AC97.
J'avais acheté une audigy y a quelques mois mais le chipset c'est "audigy LS" et le driver est tout caca, ça sort du son et c'est tout... et je ne pouvais plus utiliser Traverso.


Bon déjà il sort du son. C'est déjà pas mal ...
_________________
--
L'idéal de nouveauté semble avoir remplacé l'idéal de progrès. C'est bien triste.

----
Unix philosophy: "Do one thing and do it well."
systemd: "Try to do everything and do it wrong."
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Tue Aug 12, 2008 2:22 pm    Post subject: Reply with quote

Ouais, mais je ne pouvais plus utiliser traverso... il est pas mal ce petit truc pour le profane quand même ;)
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum