Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[APR] Digest verification failed (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
legabier
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 231

PostPosted: Mon Aug 11, 2008 12:50 am    Post subject: [APR] Digest verification failed (résolu) Reply with quote

Bonjour,

J'ai fait un emerge --sync
Ensuite emerge -a world, il y avait ceci à faire:
Code:
[ebuild     U ] dev-libs/apr-1.3.2 [1.2.11]
[ebuild     U ] sys-fs/udev-124-r1 [119]
[ebuild     U ] dev-python/twisted-8.1.0 [2.4.0]
[ebuild     U ] dev-libs/libxml2-2.6.32 [2.6.31]
[ebuild     U ] dev-libs/apr-util-1.3.2 [1.2.10] USE="-freetds% -odbc%"


Ça n'a pas été bien loin, juste après le dépaquetage du premier paquet, apr-1.3.2, j'avais ceci:
Code:
>>> Emerging (1 of 5) dev-libs/apr-1.3.2 to /
>>> Resuming download...
>>> Downloading 'rsync://mirrors.tera-byte.com/gentoo/distfiles/apr-1.3.2.tar.gz'
rsync://mirrors.tera-byte.com/gentoo/distfiles/apr-1.3.2.tar.gz: Schème non supporté.
>>> Resuming download...
>>> Downloading 'http://adelie.polymtl.ca/distfiles/apr-1.3.2.tar.gz'
--2008-08-10 20:37:09--  http://adelie.polymtl.ca/distfiles/apr-1.3.2.tar.gz
Résolution de adelie.polymtl.ca... 132.207.4.160
Connexion vers adelie.polymtl.ca|132.207.4.160|:80...connecté.
requête HTTP transmise, en attente de la réponse...404 Not Found
2008-08-10 20:37:09 ERREUR 404: Not Found.

>>> Resuming download...
>>> Downloading 'ftp://gentoo.arcticnetwork.ca/pub/gentoo/distfiles/apr-1.3.2.tar.gz'
--2008-08-10 20:37:09--  ftp://gentoo.arcticnetwork.ca/pub/gentoo/distfiles/apr-1.3.2.tar.gz
           => `/usr/portage/distfiles/apr-1.3.2.tar.gz'
Résolution de gentoo.arcticnetwork.ca... 206.75.218.53
Connexion vers gentoo.arcticnetwork.ca|206.75.218.53|:21...connecté.
Ouverture de session en anonymous...Session établie!
==> SYST ... complété.    ==> PWD ... complété.
==> TYPE I ... complété.  ==> CWD /pub/gentoo/distfiles ... complété.
==> SIZE apr-1.3.2.tar.gz ... 1158861
==> PASV ... complété.    ==> REST 2080 ... complété.
==> RETR apr-1.3.2.tar.gz ... complété.
Longueur: 1158861 (1,1M), 1156781 (1,1M) restant

100%[====================================================================================================>] 1158861     7,33K/s   in 3m 3s

2008-08-10 20:40:16 (6,17 KB/s) - « /usr/portage/distfiles/apr-1.3.2.tar.gz » sauvegardé [1158861]

 * checking ebuild checksums ;-) ...                                                                                                    [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                   [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                  [ ok ]
 * checking apr-1.3.2.tar.gz ;-) ...                                                                                                    [ !! ]

!!! Digest verification failed:
!!! /usr/portage/distfiles/apr-1.3.2.tar.gz
!!! Reason: Failed on RMD160 verification
!!! Got: 40283d2477b2920196df4032cb1fef443fd66bb0
!!! Expected: 5606e1d53c7b5fa1214099515c8a746144e0cb7c


Une solution? Attendre quelques jours et refaire un emerge --sync?

Merci !
_________________
Néophyte ou novice, telle est la question...


Last edited by legabier on Mon Aug 11, 2008 3:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Aug 11, 2008 8:40 am    Post subject: Reply with quote

Bonjour,

tu peux tenter de supprimer le fichier afin de verifier qu'il n'y a pas eu d'erreur au transfert (a une epoque portage ne le faisait pas tout seul mais ca a peut etre change)
Code:
su -
rm /usr/portage/apr-1.3.2.tar.gz
emerge ...


Si ca ne marche pas, essaie de resynchroniser ton arbre (voir commencer par synchroniser avant de retenter emerge -a world).
Back to top
View user's profile Send private message
legabier
Apprentice
Apprentice


Joined: 30 Aug 2004
Posts: 231

PostPosted: Mon Aug 11, 2008 3:48 pm    Post subject: Reply with quote

Il n'était pas exactement là, mais oui, en l'effaçant et retéléchargeant, ça a fonctionné.

Merci
_________________
Néophyte ou novice, telle est la question...
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 501

PostPosted: Mon Aug 11, 2008 4:33 pm    Post subject: Reply with quote

legabier wrote:
Il n'était pas exactement là, mais oui, en l'effaçant et retéléchargeant, ça a fonctionné.

Merci


Aitant pour moi, l fallait évidement lire:
Code:
rm /usr/portage/distfiles/apr...
(par ailleurs, son nom est correctement indiqué en bas du log)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum