Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
autounmask not work
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
DarkMind
Guru
Guru


Joined: 18 Dec 2003
Posts: 525
Location: Santiago, Chile

PostPosted: Thu Aug 14, 2008 11:34 pm    Post subject: autounmask not work Reply with quote

autounmask kde-base/kde-meta-4.1.0

* Unmasking kde-base/kde-meta-4.1.0 and its dependencies.. this might take a while..

* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords
* Added '=kde-base/kde-meta-4.1.0 ~' to /etc/portage/package.keywords

and in /etc/portage/package.keyword says:

kde-base/kde-meta-4.1.0 ~
kde-base/kde-meta-4.1.0 ~
kde-base/kde-meta-4.1.0 ~
kde-base/kde-meta-4.1.0 ~


etc etc...

why not work?
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Fri Aug 15, 2008 7:57 am    Post subject: Reply with quote

Dunno man it started doing that months ago here, and couldn't seem to get a fix for it, so we added the functionality to update instead of calling autounmask. You might find that easier to work with (implementing it internally means one less call of the resolver to check if all deps have been unmasked.)
Back to top
View user's profile Send private message
drescherjm
Advocate
Advocate


Joined: 05 Jun 2004
Posts: 2779
Location: Pittsburgh, PA, USA

PostPosted: Tue Aug 19, 2008 8:45 pm    Post subject: Reply with quote

Upgrading PortageXS to PortageXS-0.02.08 fixes the problem:

https://bugs.gentoo.org/show_bug.cgi?id=216484
_________________
John

My gentoo overlay
Instructons for overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum