Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem emerging KDE 4.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
tskuzzy
n00b
n00b


Joined: 13 Aug 2008
Posts: 70

PostPosted: Sat Aug 16, 2008 12:09 am    Post subject: Problem emerging KDE 4.1 Reply with quote

Ok, the emerge goes fine until it tries to emerge kdepimlibs:
Code:
[ 56%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o
Linking CXX shared library ../lib/libsyndication.so
[ 56%] Built target syndication
make: *** [all] Error 2
 *
 * ERROR: kde-base/kdepimlibs-4.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2627:  Called kde4overlay-base_src_compile
 *             environment, line 1962:  Called kde4overlay-base_src_make
 *             environment, line 1995:  Called cmake-utils_src_make
 *             environment, line  654:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdepimlibs-4.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdepimlibs-4.1.0/temp/environment'.
 *

 * GNU info directory index is up-to-date.


emerge --info
Code:
# emerge --info
Portage 2.2_rc8 (default/linux/amd64/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.24-19-generic x86_64)
=================================================================
System uname: Linux-2.6.24-19-generic-x86_64-with-glibc2.2.5
Timestamp of tree: Fri, 15 Aug 2008 22:15:01 +0000
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.4.4-r13, 2.5.2-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=nocona -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distcc distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/kdesvn-portage /usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="X aac acl acpi aim alsa amarok amd64 arts bash-completion berkdb branding bzip2 cairo cdr cjk cli cracklib crypt cups cvs dbus djvu dri dvd dvdr dvdread eds emboss encode esd evo examples fam ffmpeg firefox flac fortran ftp gdbm gif gimp gphoto2 gpm graphviz gstreamer gtk hal htmlhandbook iconv imagemagick immqt-bc ipv6 isdnlog jabber jack java java6 jpeg jpeg2k kde kerberos latex ldap libnotify mad midi mikmod mime mmx mp3 mpeg mudflap multilib ncurses nls nptl nptlonly nsplugin ogg ogs opengl openmp oss pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime raw readline reflection ruby samba scanner sdl session spell spl sse sse2 ssl startup-notification subversion svg symlink sysfs tcpd threads tiff truetype unicode usb vim-syntax vnc vorbis wmf xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Ideas/suggestions?
Back to top
View user's profile Send private message
timeBandit
Bodhisattva
Bodhisattva


Joined: 31 Dec 2004
Posts: 2674
Location: here, there or in transit

PostPosted: Sat Aug 16, 2008 12:42 am    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.
_________________
Plants are pithy, brooks tend to babble--I'm content to lie between them.
Super-short f.g.o checklist: Search first, strip comments, mark solved, help others.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sat Aug 16, 2008 12:56 am    Post subject: Reply with quote

You haven't given us the full picture. The actual error that caused it is a number of lines back. Try to find where the error is and post that.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
tskuzzy
n00b
n00b


Joined: 13 Aug 2008
Posts: 70

PostPosted: Sat Aug 16, 2008 2:06 am    Post subject: Reply with quote

Hm, there doesn't seem to be more lines of the error
Code:
-snip-
[ 56%] Building CXX object syndication/CMakeFiles/syndication.dir/category.o
[ 56%] Building CXX object syndication/CMakeFiles/syndication.dir/image.o
[ 56%] Building CXX object syndication/CMakeFiles/syndication.dir/tools.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/person.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/personimpl.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/loader.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/global.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/dataretriever.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/specificitemvisitor.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/specificitem.o
[ 57%] Building CXX object syndication/CMakeFiles/syndication.dir/specificdocument.o
[ 59%] Building CXX object syndication/CMakeFiles/syndication.dir/abstractparser.o
[ 59%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o
Linking CXX shared library ../lib/libsyndication.so
[ 59%] Built target syndication
make: *** [all] Error 2
 *
 * ERROR: kde-base/kdepimlibs-4.1.0 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2627:  Called kde4overlay-base_src_compile
 *             environment, line 1962:  Called kde4overlay-base_src_make
 *             environment, line 1995:  Called cmake-utils_src_make
 *             environment, line  654:  Called die
 * The specific snippet of code:
 *           emake "$@" || die "Make failed!";
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdepimlibs-4.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/kde-base/kdepimlibs-4.1.0/temp/environment'.
 *
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Aug 16, 2008 2:11 am    Post subject: Reply with quote

Hi, first can you update your python installation ?

Code:

dev-lang/python:     2.4.4-r13, 2.5.2-r6


You need to use the 2.5.2-r6 version.

Also, can you post your /etc/portage/package.keywords and /etc/portage/package.unmask
Back to top
View user's profile Send private message
tskuzzy
n00b
n00b


Joined: 13 Aug 2008
Posts: 70

PostPosted: Sat Aug 16, 2008 2:18 am    Post subject: Reply with quote

Yes, I have python 2.5.2-r6 installed
I used the unofficial KDE4 overlay, so my /etc/portage/package.* is a whole lotta files

ls -rl /etc/portage/package.*
Code:
# ls -rl /etc/portage/package.*
/etc/portage/package.use:
total 0

/etc/portage/package.unmask:
total 4
lrwxrwxrwx 1 root root 78 Aug 14 21:36 kdesvn -> /usr/portage/local/layman/kdesvn-portage/Documentation/portage/package.unmask/

/etc/portage/package.mask:
total 0

/etc/portage/package.keywords:
total 20
-rw-r--r-- 1 root root  409 Aug 14 08:54 startdict
-rw-r--r-- 1 root root   58 Aug 14 08:54 portage
-rw-r--r-- 1 root root  104 Aug 15 15:29 monolithic
drwxr-xr-x 2 root root 4096 Aug 15 11:54 kdesvn
-rw-r--r-- 1 root root   73 Aug 14 08:57 firefox


cat /etc/portage/package.unmask/kdesvn/*
Code:
# cat /etc/portage/package.unmask/kdesvn/*
# This file contains basic dependencies for KDE4

=dev-libs/soprano-2.1
=kde-base/automoc-0.9.84
=app-office/akonadi-server-1.0.0
kde-base/kdelibs:4.1
kde-base/kdepimlibs:4.1
=media-sound/phonon-4.2.0
kde-base/kde-l10n:4.1
net-wireless/kdebluetooth4:4.1
net-p2p/ktorrent:4.1
=net-libs/decibel-9999
=net-voip/tapioca-9999
kde-base/kde-meta:4.1
kde-base/kdeartwork-meta:4.1
kde-base/kdebase-meta:4.1
kde-base/kdeedu-meta:4.1
kde-base/kdegames-meta:4.1
kde-base/kdegraphics-meta:4.1
kde-base/kdemultimedia-meta:4.1
kde-base/kdenetwork-meta:4.1
kde-base/kdepim-meta:4.1
kde-base/kdeplasmoids:4.1
kde-base/kdesdk-meta:4.1
kde-base/kdetoys-meta:4.1
kde-base/kdeutils-meta:4.1
kde-base/kdevplatform:4.1
kde-base/kdeadmin-meta:4.1
kde-base/kcron:4.1
kde-base/kdeadmin-strigi-analyzer:4.1
kde-base/knetworkconf:4.1
kde-base/kuser:4.1
kde-base/ksystemlog:4.1
# This file contains everything in kdeartwork

kde-base/kdeartwork-colorschemes:4.1
kde-base/kdeartwork-emoticons:4.1
kde-base/kdeartwork-icewm-themes:4.1
kde-base/kdeartwork-iconthemes:4.1
kde-base/kdeartwork-kscreensaver:4.1
kde-base/kdeartwork-kworldclock:4.1
kde-base/kdeartwork-sounds:4.1
kde-base/kdeartwork-styles:4.1
kde-base/kdeartwork-wallpapers:4.1
# This file contains everything in kdebase

# Include the dependencies
#kde-deps-scm

>=kde-base/qimageblitz-0.0.4

# This is kdebase
kde-base/dolphin:4.1
kde-base/drkonqi:4.1
kde-base/kappfinder:4.1
kde-base/kcheckpass:4.1
kde-base/kcminit:4.1
kde-base/kcmshell:4.1
kde-base/kcontrol:4.1
kde-base/kde-menu:4.1
kde-base/kde-menu-icons:4.1
kde-base/kde-wallpapers:4.1
kde-base/kdebase-data:4.1
kde-base/kdebase-kioslaves:4.1
kde-base/kdebase-startkde:4.1
kde-base/kdebugdialog:4.1
kde-base/kdepasswd:4.1
kde-base/kdesu:4.1
kde-base/kdialog:4.1
kde-base/kdm:4.1
kde-base/keditbookmarks:4.1
kde-base/kfile:4.1
kde-base/kfind:4.1
kde-base/khelpcenter:4.1
kde-base/khotkeys:4.1
kde-base/kiconfinder:4.1
kde-base/kinfocenter:4.1
kde-base/kioclient:4.1
kde-base/klipper:4.1
kde-base/kmenuedit:4.1
kde-base/kmimetypefinder:4.1
kde-base/kmilo:4.1
kde-base/knetattach:4.1
kde-base/knewstuff:4.1
kde-base/knotify:4.1
kde-base/konqueror:4.1
kde-base/konsole:4.1
kde-base/kpasswdserver:4.1
kde-base/kquitapp:4.1
kde-base/kreadconfig:4.1
kde-base/krunner:4.1
kde-base/kscreensaver:4.1
kde-base/ksmserver:4.1
kde-base/ksplash:4.1
kde-base/kstart:4.1
kde-base/kstartupconfig:4.1
kde-base/kstyles:4.1
kde-base/ksysguard:4.1
kde-base/ksystraycmd:4.1
kde-base/ktimezoned:4.1
kde-base/ktraderclient:4.1
kde-base/ktnef:4.1
kde-base/kuiserver:4.1
kde-base/kurifilter-plugins:4.1
kde-base/kwin:4.1
kde-base/kwrite:4.1
kde-base/libkonq:4.1
kde-base/libkworkspace:4.1
kde-base/libplasma:4.1
kde-base/libtaskmanager:4.1
kde-base/nepomuk:4.1
kde-base/nsplugins:4.1
kde-base/phonon-xine:4.1
kde-base/plasma:4.1
kde-base/plasma-apps:4.1
kde-base/plasma-workspace:4.1
kde-base/renamedlg-plugins:4.1
kde-base/solid:4.1
kde-base/solid-hardware:4.1
kde-base/soliduiserver:4.1
kde-base/systemsettings:4.1
# This file contains everything in kdeedu

kde-base/blinken:4.1
kde-base/kalgebra:4.1
kde-base/kalzium:4.1
kde-base/kanagram:4.1
kde-base/kbruch:4.1
kde-base/kgeography:4.1
kde-base/khangman:4.1
kde-base/kig:4.1
kde-base/kiten:4.1
kde-base/klettres:4.1
kde-base/kmplot:4.1
kde-base/kpercentage:4.1
kde-base/kstars:4.1
kde-base/ktouch:4.1
kde-base/kturtle:4.1
kde-base/kwordquiz:4.1
kde-base/libkdeedu:4.1
kde-base/marble:4.1
kde-base/parley:4.1
kde-base/step:4.1

# This file contains everything in kdegames
kde-base/bovo:4.1
kde-base/katomic:4.1
kde-base/kbattleship:4.1
kde-base/kblackbox:4.1
kde-base/kblocks:4.1
kde-base/kbounce:4.1
kde-base/kbreakout:4.1
kde-base/kdiamond:4.1
kde-base/kfourinline:4.1
kde-base/kgoldrunner:4.1
kde-base/kiriki:4.1
kde-base/kjumpingcube:4.1
kde-base/klines:4.1
kde-base/kmahjongg:4.1
kde-base/kmines:4.1
kde-base/knetwalk:4.1
kde-base/kolf:4.1
kde-base/kollision:4.1
kde-base/konquest:4.1
kde-base/kpat:4.1
kde-base/kreversi:4.1
kde-base/ksame:4.1
kde-base/kshisen:4.1
kde-base/ksirk:4.1
kde-base/kspaceduel:4.1
kde-base/ksquares:4.1
kde-base/ksudoku:4.1
kde-base/ktuberling:4.1
kde-base/kubrick:4.1
kde-base/libkdegames:4.1
kde-base/libkmahjongg:4.1
kde-base/lskat:4.1
# This file contains everything in kdegraphics

kde-base/gwenview:4.1
kde-base/kamera:4.1
kde-base/kcolorchooser:4.1
kde-base/kgamma:4.1
kde-base/kolourpaint:4.1
kde-base/kruler:4.1
kde-base/ksnapshot:4.1
kde-base/libksane:4.1
kde-base/okular:4.1
kde-base/svgpart:4.1
kde-base/libkexiv2:4.1
kde-base/libkdcraw:4.1
kde-base/libkipi:4.1
kde-base/kdegraphics-strigi-analyzer:4.1

# This file contains everything in kdemultimedia


kde-base/dragonplayer:4.1
kde-base/juk:4.1
kde-base/kdemultimedia-kioslaves:4.1
kde-base/kmix:4.1
kde-base/kscd:4.1
kde-base/libkcddb:4.1
kde-base/libkcompactdisc:4.1
# This file contains everything in kdenetwork

kde-base/kdenetwork-filesharing:4.1
kde-base/kdnssd:4.1
kde-base/kget:4.1
kde-base/knewsticker:4.1
kde-base/kopete:4.1
kde-base/kppp:4.1
kde-base/krdc:4.1
kde-base/krfb:4.1
# This file contains everything in kdepim (not yet complete)

kde-base/akonadi:4.1
kde-base/akregator:4.1
kde-base/kaddressbook:4.1
kde-base/kalarm:4.1
kde-base/kdemaildir:4.1
kde-base/kdepim-kresources:4.1
kde-base/kdepim-strigi-analyzer:4.1
kde-base/kdepim-wizards:4.1
kde-base/kfeed:4.1
kde-base/kitchensync:4.1
kde-base/kjots:4.1
kde-base/kleopatra:4.1
kde-base/kmail:4.1
kde-base/kmailcvt:4.1
kde-base/kmobiletools:4.1
kde-base/knode:4.1
kde-base/knotes:4.1
kde-base/kode:4.1
kde-base/kontact:4.1
kde-base/kontactinterfaces:4.1
kde-base/korganizer:4.1
#kde-base/korn:4.1 doesn't build
kde-base/kpilot:4.1
kde-base/ktimetracker:4.1
#?: kde-base/ktnef:4.1
kde-base/libkdepim:4.1
kde-base/libkholidays:4.1
kde-base/libkleo:4.1
kde-base/libkpgp:4.1
kde-base/libksieve:4.1
kde-base/mimelib:4.1
# This file contains everything in kdesdk (not yet complete)

kde-base/cervisia:4.1
kde-base/kdeaccounts-plugin:4.1
kde-base/kapptemplate:4.1
kde-base/kate:4.1
#?: kde-base/kbabel:4.1
kde-base/kbugbuster:4.1
kde-base/kcachegrind:4.1
kde-base/kdesdk-kioslaves:4.1
kde-base/kdesdk-misc:4.1
kde-base/kdesdk-scripts:4.1
#?: kde-base/kmtrace:4.1
kde-base/kompare:4.1
#?: kde-base/kspy:4.1
kde-base/kstartperf:4.1
kde-base/kdesdk-strigi-analyzer:4.1
kde-base/kuiviewer:4.1
kde-base/lokalize:4.1
#?: kde-base/poxml:4.1
kde-base/umbrello:4.1
# This file contains everything in kdetoys

kde-base/amor:4.1
kde-base/kteatime:4.1
kde-base/ktux:4.1
kde-base/kweather:4.1
kde-base/kworldclock:4.1
# This file contains everything in kdeutils

kde-base/ark:4.1
kde-base/kcalc:4.1
kde-base/kcharselect:4.1
kde-base/kdessh:4.1
kde-base/kdf:4.1
kde-base/kfloppy:4.1
kde-base/kgpg:4.1
kde-base/kdessh:4.1
kde-base/ktimer:4.1
kde-base/kwallet:4.1
kde-base/okteta:4.1
kde-base/superkaramba:4.1
kde-base/sweeper:4.1
# Ingmar Vanhassel <ingmar@gentoo.org> (10 Mar 2008)
# Masked for testing, various dependencies still need to be updated...
# Note that this version of Qt4 makes KDE 4.0.x roughly unusable.
=x11-libs/qt-4.4*
=x11-libs/qt-assistant-4.4*
=x11-libs/qt-core-4.4*
=x11-libs/qt-gui-4.4*
=x11-libs/qt-script-4.4*
=x11-libs/qt-test-4.4*
=x11-libs/qt-svg-4.4*
=x11-libs/qt-webkit-4.4*
=x11-libs/qt-phonon-4.4*
=x11-libs/qt-qt3support-4.4*
=x11-libs/qt-dbus-4.4*
=x11-libs/qt-opengl-4.4*
=x11-libs/qt-sql-4.4*
=x11-libs/qt-xmlpatterns-4.4*
=x11-libs/qt-demo-4.4*
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Sat Aug 16, 2008 2:24 am    Post subject: Reply with quote

tskuzzy wrote:
Yes, I have python 2.5.2-r6 installed


I know, but you need to enable it :)

Just read this thread : https://forums.gentoo.org/viewtopic-t-702480-highlight-python.html
Back to top
View user's profile Send private message
gionnico
Apprentice
Apprentice


Joined: 29 Jun 2007
Posts: 192
Location: Italy

PostPosted: Sat Aug 16, 2008 12:16 pm    Post subject: Same problem here Reply with quote

kdepimlibs-4.1.0

the error
Code:

[ 32%] Building CXX object akonadi/CMakeFiles/akonadi-kde.dir/controladaptor.o
/var/tmp/portage/kde-base/kdepimlibs-4.1.0/work/kdepimlibs_build/akonadi/controladaptor.cpp: In member function ‘void ControlAdaptor::reconfigure()’:
/var/tmp/portage/kde-base/kdepimlibs-4.1.0/work/kdepimlibs_build/akonadi/controladaptor.cpp:57: error: ‘class Akonadi::AgentBase’ has no member named ‘reconfigure’
make[2]: *** [akonadi/CMakeFiles/akonadi-kde.dir/controladaptor.o] Error 1
make[1]: *** [akonadi/CMakeFiles/akonadi-kde.dir/all] Error 2
make: *** [all] Error 2


emerge --info
Code:

Portage 2.2_rc8 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.25-gentoo-r7 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r7-i686-Intel-R-_Pentium-R-_4_CPU_2.53GHz-with-glibc2.0
Timestamp of tree: Thu, 14 Aug 2008 20:19:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p33
dev-lang/python:     2.5.2-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r2
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.1/env /usr/kde/4.1/share/config /usr/kde/4.1/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-Os -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://trumpetti.atm.tut.fi/gentoo/"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="it"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/kdesvn-portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl acpi alsa berkdb branding bzip2 cairo cdr cli cracklib crypt curl dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox gdbm gif gpm gstreamer hal iconv isdnlog jpeg kde kerberos libnotify mad midi mikmod mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3support qt4 quicktime readline reflection sdl session spell spl ssl startup-notification subversion svg sysfs tcpd tiff truetype unicode usb vorbis win32codecs x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


unmask / keywords
Code:

unmask
Link to:
/usr/portage/local/layman/kdesvn-portage/Documentation/portage/package.unmask

keywords
Link to:
/usr/portage/local/layman/kdesvn-portage/Documentation/portage/package.keywords/*.keywords

Also:
cat kde-4.1.keywords
=net-voip/tapioca-qt-9999 **
=net-libs/telepathy-qt-9999 **

dev-libs/rasqal ~x86
dev-cpp/clucene ~x86
dev-libs/redland ~x86
dev-util/cmake ~x86
app-misc/strigi ~x86
app-crypt/qca ~x86
app-text/libspectre ~x86
x11-apps/xinit ~x86
media-libs/raptor ~x86


PS: I also had also python 2.4 and followed the procedure you posted, but nothing changed.
Back to top
View user's profile Send private message
tskuzzy
n00b
n00b


Joined: 13 Aug 2008
Posts: 70

PostPosted: Sun Aug 17, 2008 2:45 am    Post subject: Reply with quote

Ok, I enabled python 2.5.2-r6, but I still get the same error:
Code:
Linking CXX shared library ../lib/libsyndication.so
[ 59%] Built target syndication
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Sun Aug 17, 2008 7:49 pm    Post subject: Reply with quote

now that you've enabled it, run python-updater to get all your python libraries up to date.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
tskuzzy
n00b
n00b


Joined: 13 Aug 2008
Posts: 70

PostPosted: Sun Aug 17, 2008 10:30 pm    Post subject: Reply with quote

loftwyr wrote:
now that you've enabled it, run python-updater to get all your python libraries up to date.

Didn't solve the problem :(
Any other ideas?
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Sun Aug 24, 2008 9:30 pm    Post subject: Reply with quote

have you got this solved? I have exactly the same problem on a amd64 setup. Python is the one specified above and python-updater needs to do nothing.

Code:
[ 63%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o                                                                         
Linking CXX shared library ../lib/libsyndication.so                             
[ 63%] Built target syndication                                                 
make: *** [all] Error 2                                                         
 *                                                                             
 * ERROR: kde-base/kdepimlibs-4.1.0 failed.                                     
 * Call stack:                                                                 
 *               ebuild.sh, line   49:  Called src_compile                     
 *             environment, line 2666:  Called kde4overlay-base_src_compile     
 *             environment, line 1995:  Called kde4overlay-base_src_make       
 *             environment, line 2028:  Called cmake-utils_src_make             
 *             environment, line  687:  Called die                             
 * The specific snippet of code:                                               
 *           emake "$@" || die "Make failed!";                                 
 *  The die message
Back to top
View user's profile Send private message
gionnico
Apprentice
Apprentice


Joined: 29 Jun 2007
Posts: 192
Location: Italy

PostPosted: Mon Aug 25, 2008 4:09 pm    Post subject: Reply with quote

regomodo wrote:
have you got this solved? I have exactly the same problem on a amd64 setup. Python is the one specified above and python-updater needs to do nothing.

Code:
[ 63%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o                                                                         
Linking CXX shared library ../lib/libsyndication.so                             
[ 63%] Built target syndication                                                 
make: *** [all] Error 2                                                         
 *                                                                             
 * ERROR: kde-base/kdepimlibs-4.1.0 failed.                                     
 * Call stack:                                                                 
 *               ebuild.sh, line   49:  Called src_compile                     
 *             environment, line 2666:  Called kde4overlay-base_src_compile     
 *             environment, line 1995:  Called kde4overlay-base_src_make       
 *             environment, line 2028:  Called cmake-utils_src_make             
 *             environment, line  687:  Called die                             
 * The specific snippet of code:                                               
 *           emake "$@" || die "Make failed!";                                 
 *  The die message


As said, the error is not there, there must be something else.
Back to top
View user's profile Send private message
regomodo
Guru
Guru


Joined: 25 Mar 2008
Posts: 445

PostPosted: Mon Aug 25, 2008 9:19 pm    Post subject: Reply with quote

gionnico wrote:

As said, the error is not there, there must be something else.


I've searched and searched and given up. Using kde-svn packages now.
Back to top
View user's profile Send private message
rdcalle
n00b
n00b


Joined: 03 Feb 2004
Posts: 5

PostPosted: Wed Aug 27, 2008 10:46 am    Post subject: Fixed Reply with quote

layman -S
reemerge kdepimlibs:4.1
Back to top
View user's profile Send private message
My_World
Guru
Guru


Joined: 01 Sep 2003
Posts: 339
Location: Kalahari Desert

PostPosted: Fri Sep 05, 2008 8:18 am    Post subject: Reply with quote

Quote:

As of kdelibs-4.0.1, the pcre USE flag in Gentoo has been removed. It is now required that kdelibs be built against libpcre, thereby defeating my "fix". Something needs to be done, probably to CMake, to get everything to work again. Until then, it is back to gnome for me.


Quote:

A new "solution" that seems to work: move the files libpcre.a and libpcre.la from /usr/lib/ to some other directory not in the $LD_LIBRARY_PATH (like /root/). Build works because cmake can't find the static version of libpcre, so it is forced to link dynamically. This is clearly a problem with cmake, but I'm wondering if I even need the static versions of these libraries...


http://bugs.kde.org/show_bug.cgi?id=156895
_________________
"Ubuntu" - an African word meaning "Gentoo is too hard for me".
Back to top
View user's profile Send private message
tskuzzy
n00b
n00b


Joined: 13 Aug 2008
Posts: 70

PostPosted: Fri Sep 05, 2008 6:33 pm    Post subject: Reply with quote

regomodo wrote:
have you got this solved? I have exactly the same problem on a amd64 setup. Python is the one specified above and python-updater needs to do nothing.

Code:
[ 63%] Building CXX object syndication/CMakeFiles/syndication.dir/syndication_automoc.o                                                                         
Linking CXX shared library ../lib/libsyndication.so                             
[ 63%] Built target syndication                                                 
make: *** [all] Error 2                                                         
 *                                                                             
 * ERROR: kde-base/kdepimlibs-4.1.0 failed.                                     
 * Call stack:                                                                 
 *               ebuild.sh, line   49:  Called src_compile                     
 *             environment, line 2666:  Called kde4overlay-base_src_compile     
 *             environment, line 1995:  Called kde4overlay-base_src_make       
 *             environment, line 2028:  Called cmake-utils_src_make             
 *             environment, line  687:  Called die                             
 * The specific snippet of code:                                               
 *           emake "$@" || die "Make failed!";                                 
 *  The die message

Yeah, I solved it. I just deleted the overlay and updated it to a new one and it worked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum