Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Official thread: "zen-sources" - Part V
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 20, 21, 22, 23  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Dec 20, 2008 10:32 am    Post subject: Reply with quote

Code:

  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
  SYMLINK include/asm -> include/asm-x86
  CALL    scripts/checksyscalls.sh
  CHK     include/linux/compile.h
/usr/src/zen-git-sources/drivers/net/wireless/madwifi/ath_rate/amrr/Makefile:49: drivers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc: No such file or directory
make[5]: *** No rule to make target `drivers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc'.  Stop.
make[4]: *** [drivers/net/wireless/madwifi/ath_rate/amrr] Error 2
make[3]: *** [drivers/net/wireless/madwifi] Error 2
make[2]: *** [drivers/net/wireless] Error 2
make[1]: *** [drivers/net] Error 2
make: *** [drivers] Error 2

_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
ponciarello
Apprentice
Apprentice


Joined: 22 Jul 2008
Posts: 223
Location: beach of slack

PostPosted: Sat Dec 20, 2008 1:18 pm    Post subject: Reply with quote

ponciarello wrote:
Code:
vers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc: No such file or directory
make[6]: *** No rule to make target `drivers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc'.  Stop.
make[5]: *** [drivers/net/wireless/madwifi/ath_rate/amrr] Error 2
make[4]: *** [drivers/net/wireless/madwifi] Error 2
make[3]: *** [drivers/net/wireless] Error 2
make[2]: *** [drivers/net] Error 2
make[1]: *** [_clean_drivers] Error 2
make[1]: Leaving directory `/usr/src/zen-sources'
make: *** [minimal_clean] Error 2


solved that with
Code:
touch drivers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc


eight messages ago :D
_________________
look for monty python channel on youtube :D
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Dec 20, 2008 6:32 pm    Post subject: Reply with quote

ponciarello wrote:
ponciarello wrote:
Code:
vers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc: No such file or directory
make[6]: *** No rule to make target `drivers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc'.  Stop.
make[5]: *** [drivers/net/wireless/madwifi/ath_rate/amrr] Error 2
make[4]: *** [drivers/net/wireless/madwifi] Error 2
make[3]: *** [drivers/net/wireless] Error 2
make[2]: *** [drivers/net] Error 2
make[1]: *** [_clean_drivers] Error 2
make[1]: Leaving directory `/usr/src/zen-sources'
make: *** [minimal_clean] Error 2


solved that with
Code:
touch drivers/net/wireless/madwifi/ath_rate/amrr/../../Makefile.inc


eight messages ago :D


Hehe I just used another algorithm :)
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Sun Dec 21, 2008 4:52 pm    Post subject: Reply with quote

JoKo wrote:
Hi,

Where to find the latest patch?

e.g. http://zen-sources.org/kernels/2.6.28-rc3-zen2.patch.lzma is not working.

Here too:
Quote:

>>> Emerging (1 of 1) sys-kernel/zen-sources-2.6.28_rc3-r2 to /
>>> Resuming download...
>>> Downloading 'http://distfiles.gentoo.org/distfiles/2.6.28-rc3-zen2.patch.lzma'
--2008-12-21 17:49:41-- http://distfiles.gentoo.org/distfiles/2.6.28-rc3-zen2.patch.lzma
Resolving distfiles.gentoo.org... 216.165.129.135, 156.56.247.195, 140.211.166.134, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2008-12-21 17:49:41 ERROR 404: Not Found.

>>> Resuming download...
>>> Downloading 'http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/2.6.28-rc3-zen2.patch.lzma'
--2008-12-21 17:49:41-- http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/2.6.28-rc3-zen2.patch.lzma
Resolving distro.ibiblio.org... 152.46.7.109
Connecting to distro.ibiblio.org|152.46.7.109|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2008-12-21 17:49:43 ERROR 404: Not Found.

>>> Resuming download...
>>> Downloading 'http://zen-sources.org/kernels/2.6.28-rc3-zen2.patch.lzma'
--2008-12-21 17:49:43-- http://zen-sources.org/kernels/2.6.28-rc3-zen2.patch.lzma
Resolving zen-sources.org... 134.155.50.250
Connecting to zen-sources.org|134.155.50.250|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: unspecified [text/html]
Saving to: `/usr/portage/distfiles/2.6.28-rc3-zen2.patch.lzma'

100%[=================================================================================================================>] 29,207 102K/s in 0.3s

2008-12-21 17:49:44 (102 KB/s) - `/usr/portage/distfiles/2.6.28-rc3-zen2.patch.lzma' saved [29207]

('Filesize does not match recorded size', 29207L, 6573453)
!!! Fetched file: 2.6.28-rc3-zen2.patch.lzma VERIFY FAILED!
!!! Reason: Filesize does not match recorded size
!!! Got: 29207
!!! Expected: 6573453

_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 468

PostPosted: Tue Dec 23, 2008 12:00 am    Post subject: Reply with quote

Website (and git) still down for me too.In the mean time, does anybody have a broken out reiser4 patch from zen-sources? I want to use 2.6.28-rc9 vanilla but I can't because the mm reiser4 patch (and the 2.6.27 patch) doesn't work with 2.6.28.
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Tue Dec 23, 2008 12:03 am    Post subject: Reply with quote

darklegion wrote:
Website (and git) still down for me too.In the mean time, does anybody have a broken out reiser4 patch from zen-sources? I want to use 2.6.28-rc9 vanilla but I can't because the mm reiser4 patch (and the 2.6.27 patch) doesn't work with 2.6.28.


Website is up and running: http://git.zen-sources.org/
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Tue Dec 23, 2008 12:43 am    Post subject: Reply with quote

darklegion wrote:
Website (and git) still down for me too.In the mean time, does anybody have a broken out reiser4 patch from zen-sources? I want to use 2.6.28-rc9 vanilla but I can't because the mm reiser4 patch (and the 2.6.27 patch) doesn't work with 2.6.28.


why don't you guys just RTFI (instruction ;) ) ? https://forums.gentoo.org/viewtopic-p-5185885.html#5185885

i've updated it some days ago and it still works :?
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
darklegion
Guru
Guru


Joined: 14 Nov 2004
Posts: 468

PostPosted: Tue Dec 23, 2008 1:56 am    Post subject: Reply with quote

Yeah, that's the one I was using kerneloftruth.It was only down for a day or so, but it was down :) Good to see it's back up again.
Back to top
View user's profile Send private message
massimo
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1226

PostPosted: Tue Dec 23, 2008 6:55 am    Post subject: Reply with quote

Installing the latest version from the overlay does definitely not work.
_________________
Hello 911? How are you?
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1160

PostPosted: Tue Dec 23, 2008 7:35 am    Post subject: Reply with quote

*** Unable to determine the target kernel version. ***

error with nvidia-drivers.

EDIT: it's an error with the nvidia-drivers-173.14.12-r2 ebuild from the zen-overlay.
so it's nvidia ebuild related.
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
rmh3093
Advocate
Advocate


Joined: 06 Aug 2003
Posts: 2138
Location: Albany, NY

PostPosted: Tue Dec 23, 2008 9:32 pm    Post subject: Reply with quote

kernelOfTruth wrote:
darklegion wrote:
Website (and git) still down for me too.In the mean time, does anybody have a broken out reiser4 patch from zen-sources? I want to use 2.6.28-rc9 vanilla but I can't because the mm reiser4 patch (and the 2.6.27 patch) doesn't work with 2.6.28.


why don't you guys just RTFI (instruction ;) ) ? https://forums.gentoo.org/viewtopic-p-5185885.html#5185885

i've updated it some days ago and it still works :?


would you mind moving some or all this to the website somewhere, there in an install guide section that could use good "generic" git instructions and then some basic distro related (for gentoo that would be layman and ebuild info) info
_________________
Do not meddle in the affairs of wizards, for they are subtle and quick to anger.
Back to top
View user's profile Send private message
Strowi
l33t
l33t


Joined: 19 Aug 2003
Posts: 655
Location: Bonn

PostPosted: Thu Dec 25, 2008 1:16 pm    Post subject: Reply with quote

hi,

just noticed tp_smapi has been removed in git, does anyone know why?
Also i noticed: ide_piix does not work anymore on thinkpad x31, instead ata_piix should be used. If anyone wonders why new kernel is not bootable.
_________________
--
Linux & such ...
http://blog.hasnoname.de
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2843

PostPosted: Thu Dec 25, 2008 10:10 pm    Post subject: Reply with quote

Where is gone zen.git in git.zen-sources.org?
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
FallenWizard
n00b
n00b


Joined: 04 Sep 2007
Posts: 51
Location: Vienna / Austria

PostPosted: Fri Dec 26, 2008 11:18 pm    Post subject: Reply with quote

SlashBeast wrote:
Where is gone zen.git in git.zen-sources.org?


Quote from IRC:

Quote:

<rmh3093> ocin: because people bitch that the they cant tell what in a zen kernel
<rmh3093> and they want an up2date website
<rmh3093> and i agree
<rmh3093> we need a better webpresense
<rmh3093> so until the website is to my satisfaction
<rmh3093> there will be no kernel
<rmh3093> so people should start working on the website
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Dec 26, 2008 11:49 pm    Post subject: Reply with quote

rmh3093 wrote:
kernelOfTruth wrote:
darklegion wrote:
Website (and git) still down for me too.In the mean time, does anybody have a broken out reiser4 patch from zen-sources? I want to use 2.6.28-rc9 vanilla but I can't because the mm reiser4 patch (and the 2.6.27 patch) doesn't work with 2.6.28.


why don't you guys just RTFI (instruction ;) ) ? https://forums.gentoo.org/viewtopic-p-5185885.html#5185885

i've updated it some days ago and it still works :?


would you mind moving some or all this to the website somewhere, there in an install guide section that could use good "generic" git instructions and then some basic distro related (for gentoo that would be layman and ebuild info) info


done in some way - it still needs some corrections (BBCode -> HTML-Code) but at the least the people can't bitch around about lacking installation instruction now :P

Quote:
<rmh3093> we need a better webpresense
<rmh3093> so until the website is to my satisfaction
<rmh3093> there will be no kernel
<rmh3093> so people should start working on the website


is the zen-sources repo being removed the result of that discussion / announcement ? :o
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
prestige
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2005
Posts: 95

PostPosted: Fri Dec 26, 2008 11:54 pm    Post subject: Reply with quote

Well... putting zen website with higher priority than the zen sources itself does not make any sense to me. The most important thing to me as a zen-sources user is the git repository and the zen-sources itself and not the website! We need a good quality up do date sources and not a fancy website (refer to kernel.org for example). Please resolve the internal team issues people (I presume you are experienced such).

2.6.28-rc9-zen1 works very well.
_________________
zen-sources - whole new world discovered
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Sat Dec 27, 2008 12:58 am    Post subject: Reply with quote

prestige wrote:
Well... putting zen website with higher priority than the zen sources itself does not make any sense to me. The most important thing to me as a zen-sources user is the git repository and the zen-sources itself and not the website! We need a good quality up do date sources and not a fancy website (refer to kernel.org for example). Please resolve the internal team issues people (I presume you are experienced such).

2.6.28-rc9-zen1 works very well.

I'm not really used to this linux world, but I'm afraid that it can have a bad end. Its sad 'cause those guys are doing a great job here.
BTW, where can I get 2.6.28-rc9?? My last version is rc8 =S
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 188

PostPosted: Sat Dec 27, 2008 4:23 am    Post subject: Reply with quote

prestige wrote:
Well... putting zen website with higher priority than the zen sources itself does not make any sense to me. The most important thing to me as a zen-sources user is the git repository and the zen-sources itself and not the website! We need a good quality up do date sources and not a fancy website (refer to kernel.org for example). Please resolve the internal team issues people (I presume you are experienced such).

2.6.28-rc9-zen1 works very well.


I can't tell how much I agree! I would like to ask for proper patches, not for any web-presence.

Guys, as I told you already: you messed zen-sources. I really miss Waninkokos kamikaze-sources! He has a much better feeling what's needed and what not.

Nevertheless: 2.6.28-rc9-zen1 works well and is much better then nothing. Have I to fork and set up a own overlay with ebuilds now?

Regards!
Back to top
View user's profile Send private message
mbar
Veteran
Veteran


Joined: 19 Jan 2005
Posts: 1981
Location: Poland

PostPosted: Sat Dec 27, 2008 1:41 pm    Post subject: Reply with quote

are wrote:
Nevertheless: 2.6.28-rc9-zen1 works well and is much better then nothing. Have I to fork and set up a own overlay with ebuilds now?

Regards!


Yes please!!! Because I fvcking hate live/git ebuilds, I like my kernel with a single file patch. And I mean it :)
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sat Dec 27, 2008 5:47 pm    Post subject: Reply with quote

I don't understand it either. Updating the website to a minimum takes no time... Furthermore they changed things that much last two months, its just annoying.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
mieszkoslusarczyk
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2008
Posts: 92
Location: Kraków/Poland

PostPosted: Sat Dec 27, 2008 7:39 pm    Post subject: Reply with quote

Code:
* Digest verification failed:
 * /usr/portage/local/layman/THE/x11-base/xorg-server/xorg-server-9999.ebuild
 * Reason: Filesize does not match recorded size
 * Got: 14170
 * Expected: 14208
Back to top
View user's profile Send private message
kowal
n00b
n00b


Joined: 23 Apr 2003
Posts: 40

PostPosted: Sat Dec 27, 2008 11:35 pm    Post subject: obtaining zen-sources Reply with quote

Anyone else getting "fatal: The remote end hung up unexpectedly" when cloning zen-sources as outlined on the first page of this thread?
Solution: change repository location to git://repo.or.cz/linux-2.6/zen-sources.git
Back to top
View user's profile Send private message
SlashBeast
Moderator
Moderator


Joined: 23 May 2006
Posts: 2843

PostPosted: Sun Dec 28, 2008 12:00 am    Post subject: Reply with quote

FallenWizard wrote:
Quote:

<rmh3093> ocin: because people bitch that the they cant tell what in a zen kernel
<rmh3093> and they want an up2date website
<rmh3093> and i agree
<rmh3093> we need a better webpresense
<rmh3093> so until the website is to my satisfaction
<rmh3093> there will be no kernel
<rmh3093> so people should start working on the website


ROTFL'n'LOL... no website == no kernel? Funny.

mbar wrote:
are wrote:
Nevertheless: 2.6.28-rc9-zen1 works well and is much better then nothing. Have I to fork and set up a own overlay with ebuilds now?

Regards!


Yes please!!! Because I fvcking hate live/git ebuilds, I like my kernel with a single file patch. And I mean it :)

+1
_________________
BitBucket -- better-initramfs
Back to top
View user's profile Send private message
ponciarello
Apprentice
Apprentice


Joined: 22 Jul 2008
Posts: 223
Location: beach of slack

PostPosted: Sun Dec 28, 2008 8:35 am    Post subject: Reply with quote

SlashBeast wrote:
ROTFL'n'LOL

+1 lol :lol:

in the meantime (like Helmet sung), if someone needs latest version released, 2.6.28-rc9-zen1 (apply to 2.6.28-rc9), I've diffed the patch, it's here. :)
_________________
look for monty python channel on youtube :D
Back to top
View user's profile Send private message
are
Apprentice
Apprentice


Joined: 03 Jan 2006
Posts: 188

PostPosted: Sun Dec 28, 2008 11:45 am    Post subject: Reply with quote

In order to give the zen-guys enough time to discuss their website issue:

I've raised kamikaze-sources-2.6.28_rc9-r1.ebuild from death.

disclaimer: it's just the work of the zen-guys plus some organization. I take no credits as all parts are shameless stolen...

special note: unfortunately the kernel-2.eclass does not support lzma so far and I have to use bz2. will send a patched kernel-2.eclass to the developpers soon.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 20, 21, 22, 23  Next
Page 21 of 23

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum