Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Official thread: "zen-sources" - Part V
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 13, 14, 15 ... 21, 22, 23  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lmmsci
Apprentice
Apprentice


Joined: 20 May 2006
Posts: 190

PostPosted: Sun Oct 26, 2008 6:06 pm    Post subject: Reply with quote

Also thanks. Works perfectly for me :D
Back to top
View user's profile Send private message
Holysword
l33t
l33t


Joined: 19 Nov 2006
Posts: 946
Location: Greece

PostPosted: Sun Oct 26, 2008 10:15 pm    Post subject: Reply with quote

There is an issue with gspca and 2.6.27 kernels too... its pretty common, to happen

Code:
kuroiryu ~ # v4l-conf -c /dev/v4l/video0
v4l-conf: using X11 display :0.0
WARNING: v4l-conf is compiled without DGA support.
mode: 1440x900, depth=24, bpp=32, bpl=5760, base=unknown
/dev/v4l/video0 [v4l2]: no overlay support
kuroiryu ~ #


I could found a ton of people with this problem in google, some of them with workaround (none worked for me...) and some without answear...
The package libv4l still masked as ~amd64, I keyworded it but still not working for me... the very same anoying error: "no overlay support"

Any clue of a patch or something else to fix it??
_________________
"Nolite arbitrari quia venerim mittere pacem in terram non veni pacem mittere sed gladium" (Yeshua Ha Mashiach)
Back to top
View user's profile Send private message
prestige
Tux's lil' helper
Tux's lil' helper


Joined: 24 Sep 2005
Posts: 95

PostPosted: Tue Oct 28, 2008 8:51 am    Post subject: Reply with quote

Hmm... the v2.6.27-zen3-hotfix1 tag exists on the site, but there is no such tag when you type "git tag -l". Why is that?
_________________
zen-sources - whole new world discovered
Back to top
View user's profile Send private message
loeb-it
n00b
n00b


Joined: 15 May 2007
Posts: 37

PostPosted: Wed Oct 29, 2008 10:23 pm    Post subject: Reply with quote

prestige wrote:
loeb-it wrote:

My configuration is very similar. Major difference is that I only use TKIP. Do you experience speed issues? When I transfer large files using iwl3945 driver, the speed (measured by scp) drops to less than 100 Kb/s after some time. With the ipw-driver I get around 2.5 to 2.7 MB/s. Thats the reason why I use ipw3945 with 2.6.27-zen2. I also had the same proplems with the iwl-driver in 2.6.25 and 2.6.26 but never found out the reason...
I found some reports on this in the web, but no solution. It seems that only a minority of people is experiencing this problem since I counted only 6 downloads of the patch until now. Or ... the large majority isn' t recognizing the speed loss (which I cannot believe...).
...


I have not experienced the speed issues you mentioned, but if I have to be honest I have never tested the speed with scp/sftp. I am transferring files via NFS and the speed is quite the same with iwl and ipw - something around 1.8-2.2MB/s. I am not sure where is the bottleneck - the used wifi module, the used firmware (dd-wrt) or it is some configuration issue. I will do some tests with scp/sftp during the weekend and share the results.


It will be really nice to see the results when they are ready. I have the newest ucode file for the ipw card.
Firmware on the Linksys router is:

Firmware Version: v4.71.1, Hyperwrt 2.1b1 + Thibor15c

Well, but I'd say the router firmware schould not be the problem, since the 3945 is the only device having problems and it just works with the ipw driver...
_________________
The box said 'Windows 2000 Server or better', so I installed Gentoo

Linux galadriel 4.12.12-gentoo #4 SMP PREEMPT Fri Nov 3 00:09:29 CET 2017 x86_64 Intel(R) Core(TM) i7-2860QM CPU @ 2.50GHz GenuineIntel GNU/Linux

Visit www.mygnu.de
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Wed Oct 29, 2008 10:31 pm    Post subject: Reply with quote

prestige wrote:
Hmm... the v2.6.27-zen3-hotfix1 tag exists on the site, but there is no such tag when you type "git tag -l". Why is that?


Yes I experienced the same...

Anyone can help?
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Oct 29, 2008 10:33 pm    Post subject: Reply with quote

prestige wrote:
My wifi configuration is very simple. I use wifi only at home.

My /etc/wpa_supplicant/wpa_supplicant.conf:

Code:

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel
fast_reauth=1

network={
    ssid="myssid"
    scan_ssid=1
    proto=WPA2
    key_mgmt=WPA-PSK
    pairwise=CCMP TKIP
    group=CCMP TKIP
    psk="mysupersecretpassword"
}


My /etc/conf.d/net:
Code:

modules_wlan0=( "wpa_supplicant" "dhclient" )
wpa_supplicant_wlan0="-Dwext"
config_wlan0=( "dhcp" )
dhcpcd_wlan0="-N"
dhcp_wlan0="nodns nontp nonis"
wpa_timeout_wlan0=60


Maybe you will need this also:
Code:

# cd /etc/init.d
# ln -s net.lo net.wlan0


I am starting the wlan with "modprobe iwl3945". Loading the module automatically starts wpa_supplicant (not sure how exactly. If someone knows please share.). After a few seconds the network gets associated and the IP address is obtained.

Hope this helps and sorry for the offtopic.


thanks, prestige,

I'll try this out ASAP my new system is ready to use (currently using buntu on my laptop since wireless at university + use is a MUST)

++

sorry for the offtopic, I don't hope this kernel-related but will triple-check my config whether anything's missing
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Wed Oct 29, 2008 11:17 pm    Post subject: Reply with quote

is there a switch to continue getting the 2.6.27* kernels only instead of the 2.6.28-rc*s ?

e.g. "checking out" the 2.6.27 sub-branch or something like that

many thanks in advance :)
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Wed Oct 29, 2008 11:57 pm    Post subject: Reply with quote

kernelOfTruth wrote:
is there a switch to continue getting the 2.6.27* kernels only instead of the 2.6.28-rc*s ?

e.g. "checking out" the 2.6.27 sub-branch or something like that

many thanks in advance :)



git checkout v2.6.26-zen3
git checkout -b v2.6.26-zen3
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Oct 30, 2008 1:50 am    Post subject: Reply with quote

tranquilcool wrote:
kernelOfTruth wrote:
is there a switch to continue getting the 2.6.27* kernels only instead of the 2.6.28-rc*s ?

e.g. "checking out" the 2.6.27 sub-branch or something like that

many thanks in advance :)



git checkout v2.6.26-zen3
git checkout -b v2.6.26-zen3


thanks, the latter probably does the job,

I'll give that a try,

concerning my wireless problem - I might have found the culprit:

Quote:
[ ] Wireless extensions sysfs files


Quote:
CONFIG_WIRELESS_EXT_SYSFS: │
│ │
│ This option enables the deprecated wireless statistics │
│ files in /sys/class/net/*/wireless/. The same information │
│ is available via the ioctls as well. │
│ │
│ Say Y if you have programs using it, like old versions of │
│ hal.

_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
termite
Guru
Guru


Joined: 06 May 2007
Posts: 466

PostPosted: Thu Oct 30, 2008 11:28 am    Post subject: Reply with quote

emerging zen-sources-2.6.27-r31 installs the sources in /usr/src/linux-2.6.27, instead of /usr/src/linux-2.6.27-zen31. Please fix this :)
Back to top
View user's profile Send private message
manwe_
l33t
l33t


Joined: 01 Feb 2006
Posts: 621
Location: Kraków/Cracow, Poland

PostPosted: Thu Oct 30, 2008 11:50 am    Post subject: Reply with quote

[never mind, works after upgrade to -zen31]

Last edited by manwe_ on Thu Oct 30, 2008 12:47 pm; edited 2 times in total
Back to top
View user's profile Send private message
Mr. Tao
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2007
Posts: 147

PostPosted: Thu Oct 30, 2008 11:52 am    Post subject: Asus_laptop Reply with quote

manwe_ wrote:
Asus acpi doesn't work in 2.6.26-r21.
The same applies to recent 2.6.28-rc2 Exherbo must Die!. Although it worked nicely with previous 2.6.27.
Back to top
View user's profile Send private message
mroconnor
Guru
Guru


Joined: 24 Feb 2006
Posts: 402
Location: USA

PostPosted: Thu Oct 30, 2008 1:00 pm    Post subject: Reply with quote

I'm having a lot of issues w/ 2.6.28-x on my thinkpad. I keep bollovking around w/ the config but haven't gotten it working. Looks like I need to spend some time @ lkml.org today. ;)
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Thu Oct 30, 2008 2:38 pm    Post subject: Reply with quote

termite wrote:
emerging zen-sources-2.6.27-r31 installs the sources in /usr/src/linux-2.6.27, instead of /usr/src/linux-2.6.27-zen31. Please fix this :)



same here. upgrade doesn't solve it.
should be fixed. thanks!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Thu Oct 30, 2008 3:04 pm    Post subject: Reply with quote

Quote:
make
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
scripts/Makefile.build:60: scripts/Makefile.host: No such file or directory
make[2]: *** No rule to make target `scripts/Makefile.host'. Stop.
make[1]: *** [scripts_basic] Error 2
make: *** No rule to make target `include/config/auto.conf', needed by `include/config/kernel.release'. Stop.


now what is this ?

I'm pretty sure the hardened toolchain isn't the cause

any ideas?

many thanks in advance
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Spaulding
Apprentice
Apprentice


Joined: 16 Apr 2006
Posts: 159
Location: /dev/vagina

PostPosted: Thu Oct 30, 2008 3:16 pm    Post subject: Reply with quote

Code:
  LD      .tmp_vmlinux1
block/built-in.o: In function `vr_dispatch_requests':
vr-iosched.c:(.text+0xe90d): undefined reference to `__udivdi3'
vr-iosched.c:(.text+0xe923): undefined reference to `__udivdi3'
make: *** [.tmp_vmlinux1] Błąd 1


after compile without vr-iosched i have this
Code:

radeonfb 0000:01:00.0: PCI INT A -> Link[LNKE] -> GSI 11
                    (level, low) -> IRQ 11
radeonfb 0000:01:00.0: BAR 0: can't reserve mem region
                    [0xd0000000-0xd7ffffff]
radeonfb (0000:01:00.0): cannot request region 0.
and i have only 120FPS in glxgears 8O plz fix that
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6108
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Fri Oct 31, 2008 12:18 am    Post subject: Reply with quote

kernelOfTruth wrote:
Quote:
make
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
/bin/sh: /usr/src/linux-2.6.27-zen3/scripts/gcc-x86_64-has-stack-protector.sh: No such file or directory
scripts/Makefile.build:60: scripts/Makefile.host: No such file or directory
make[2]: *** No rule to make target `scripts/Makefile.host'. Stop.
make[1]: *** [scripts_basic] Error 2
make: *** No rule to make target `include/config/auto.conf', needed by `include/config/kernel.release'. Stop.


now what is this ?

I'm pretty sure the hardened toolchain isn't the cause

any ideas?

many thanks in advance


the answer:

it was a local repo problem,

re-cloning (via linus' repo as reference) fixed it
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
cheater1034
Veteran
Veteran


Joined: 09 Sep 2004
Posts: 1558

PostPosted: Fri Oct 31, 2008 12:28 am    Post subject: Reply with quote

prestige wrote:
Hmm... the v2.6.27-zen3-hotfix1 tag exists on the site, but there is no such tag when you type "git tag -l". Why is that?

You need to git fetch before you git tag -l. The tag is there and has been pushed when i made it

scp or evilroot wrote:
Code:
  LD      .tmp_vmlinux1
block/built-in.o: In function `vr_dispatch_requests':
vr-iosched.c:(.text+0xe90d): undefined reference to `__udivdi3'
vr-iosched.c:(.text+0xe923): undefined reference to `__udivdi3'
make: *** [.tmp_vmlinux1] Błąd 1


after compile without vr-iosched i have this
Code:

radeonfb 0000:01:00.0: PCI INT A -> Link[LNKE] -> GSI 11
                    (level, low) -> IRQ 11
radeonfb 0000:01:00.0: BAR 0: can't reserve mem region
                    [0xd0000000-0xd7ffffff]
radeonfb (0000:01:00.0): cannot request region 0.
and i have only 120FPS in glxgears 8O plz fix that


vr-iosched has nothing to do with your problem. If you're using the latest development zen keep pulling. We pull from linus git regularly and problems are expected at this stage in development.

Also, the __udivdi3 problem with vr-iosched.c may be a problem somewhere in vr-iosched.c. This problem occurs in 32-bit situations with ubuntu's libc. So, i assume i'm right and you are on ubuntu there is nothing i can do for your problem since the problem rests in the ubuntu libc (which should define __udivdi3).

So, either you are missing a distro package, or ubuntu's libc doesn't define __udivdi3 which it should (I'm assuming that you are missing a package under your distribution, this is not a zen problem)

glxgears is a louzy test

radeonfb is a drm problem? compile your kernel without it unless you need it (drm is something new in 2.6.28-zen, so if you used older zens don't use drm and see if it resolves) --> i'm aware of drm's problems ;)

termite wrote:
emerging zen-sources-2.6.27-r31 installs the sources in /usr/src/linux-2.6.27, instead of /usr/src/linux-2.6.27-zen31. Please fix this :)


I knew the problem last night i just didn't have time to fix it. Fixed now though ;)
_________________
IRC!: #zen-sources on irc.rizon.net
zen-kernel.org
--
Lost in android development land.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Fri Oct 31, 2008 4:15 am    Post subject: Reply with quote

cheater1034 wrote:
prestige wrote:
Hmm... the v2.6.27-zen3-hotfix1 tag exists on the site, but there is no such tag when you type "git tag -l". Why is that?

You need to git fetch before you git tag -l. The tag is there and has been pushed when i made it

scp or evilroot wrote:
Code:
  LD      .tmp_vmlinux1
block/built-in.o: In function `vr_dispatch_requests':
vr-iosched.c:(.text+0xe90d): undefined reference to `__udivdi3'
vr-iosched.c:(.text+0xe923): undefined reference to `__udivdi3'
make: *** [.tmp_vmlinux1] Błąd 1


after compile without vr-iosched i have this
Code:

radeonfb 0000:01:00.0: PCI INT A -> Link[LNKE] -> GSI 11
                    (level, low) -> IRQ 11
radeonfb 0000:01:00.0: BAR 0: can't reserve mem region
                    [0xd0000000-0xd7ffffff]
radeonfb (0000:01:00.0): cannot request region 0.
and i have only 120FPS in glxgears 8O plz fix that


vr-iosched has nothing to do with your problem. If you're using the latest development zen keep pulling. We pull from linus git regularly and problems are expected at this stage in development.

Also, the __udivdi3 problem with vr-iosched.c may be a problem somewhere in vr-iosched.c. This problem occurs in 32-bit situations with ubuntu's libc. So, i assume i'm right and you are on ubuntu there is nothing i can do for your problem since the problem rests in the ubuntu libc (which should define __udivdi3).

So, either you are missing a distro package, or ubuntu's libc doesn't define __udivdi3 which it should (I'm assuming that you are missing a package under your distribution, this is not a zen problem)

glxgears is a louzy test

radeonfb is a drm problem? compile your kernel without it unless you need it (drm is something new in 2.6.28-zen, so if you used older zens don't use drm and see if it resolves) --> i'm aware of drm's problems ;)

termite wrote:
emerging zen-sources-2.6.27-r31 installs the sources in /usr/src/linux-2.6.27, instead of /usr/src/linux-2.6.27-zen31. Please fix this :)


I knew the problem last night i just didn't have time to fix it. Fixed now though ;)



emerging zen-sources-2.6.27-r31 still installs the sources in /usr/src/linux-2.6.27
not fixed.

errors latest git pull;

CC fs/reiser4/page_cache.o
fs/reiser4/page_cache.c:565: error: unknown field ‘prepare_write’ specified in initializer
fs/reiser4/page_cache.c:566: error: unknown field ‘commit_write’ specified in initializer
make[2]: *** [fs/reiser4/page_cache.o] Error 1
make[1]: *** [fs/reiser4] Error 2
make: *** [fs] Error 2
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
termite
Guru
Guru


Joined: 06 May 2007
Posts: 466

PostPosted: Fri Oct 31, 2008 11:55 am    Post subject: Reply with quote

unemerging and reemerging put it in the right place here.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Fri Oct 31, 2008 2:19 pm    Post subject: Reply with quote

termite wrote:
unemerging and reemerging put it in the right place here.


solved.
thanks!
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
tranquilcool
Veteran
Veteran


Joined: 25 Mar 2005
Posts: 1159

PostPosted: Sat Nov 01, 2008 6:59 am    Post subject: Reply with quote

some more debug latest git pull;


CC arch/x86/kernel/cpu/powerflags.o
CC arch/x86/kernel/cpu/common.o
arch/x86/kernel/cpu/common.c: In function ‘early_identify_cpu’:
arch/x86/kernel/cpu/common.c:554: error: ‘boot_cpu_id’ undeclared (first use in this function)
arch/x86/kernel/cpu/common.c:554: error: (Each undeclared identifier is reported only once
arch/x86/kernel/cpu/common.c:554: error: for each function it appears in.)
arch/x86/kernel/cpu/common.c: In function ‘cpu_init’:
arch/x86/kernel/cpu/common.c:1141: error: ‘boot_cpu_id’ undeclared (first use in this function)
make[2]: *** [arch/x86/kernel/cpu/common.o] Error 1
make[1]: *** [arch/x86/kernel/cpu] Error 2
make: *** [arch/x86/kernel] Error 2
_________________
this is a strange strange world.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sat Nov 01, 2008 7:07 am    Post subject: Reply with quote

hi. I am having problems for emerging nvidia-drivers-177.80, since zen-sources-2.6.28-rc2-zen. error is:
Code:

 * Preparing nvidia module
If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.

*** Unable to determine the target kernel version. ***

make: *** [select_makefile] Error 1
 *
 * ERROR: x11-drivers/nvidia-drivers-177.80 failed.
 * Call stack:
 * ebuild.sh, line   49:  Called src_compile
 * environment, line 3930:  Called linux-mod_src_compile
 * environment, line 2826:  Called die
 * The specific snippet of code:
 * eval "emake HOSTCC="$(tc-getBUILD_CC)"                   CROSS_COMPILE=${CHOST}-                   LDFLAGS="$(get_abi_LDFLAGS)"          ${BUILD_FIXES}                   ${BUILD_PARAMS}             ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
 * The die message:
 * Unable to emake HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS=  IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux       SYSOUT=/usr/src/linux HOST_CC=x86_64-pc-linux-gnu-gcc clean module
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/log/portage/x11-drivers:nvidia-drivers-177.80:20081101-063648.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/nvidia-drivers-177.80/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/overlays/zen-overlay/'

Any idea? I use ~amd64 arch.

Edit : After applying the patch at nV News Forum, it emerged fine.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
seqizz
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jan 2008
Posts: 103

PostPosted: Sat Nov 01, 2008 9:53 am    Post subject: Reply with quote

tranquilcool wrote:
some more debug latest git pull;


CC arch/x86/kernel/cpu/powerflags.o
CC arch/x86/kernel/cpu/common.o
arch/x86/kernel/cpu/common.c: In function ‘early_identify_cpu’:
arch/x86/kernel/cpu/common.c:554: error: ‘boot_cpu_id’ undeclared (first use in this function)
arch/x86/kernel/cpu/common.c:554: error: (Each undeclared identifier is reported only once
arch/x86/kernel/cpu/common.c:554: error: for each function it appears in.)
arch/x86/kernel/cpu/common.c: In function ‘cpu_init’:
arch/x86/kernel/cpu/common.c:1141: error: ‘boot_cpu_id’ undeclared (first use in this function)
make[2]: *** [arch/x86/kernel/cpu/common.o] Error 1
make[1]: *** [arch/x86/kernel/cpu] Error 2
make: *** [arch/x86/kernel] Error 2


yes, same error, i've created a new config file but not fixed..
_________________
what about an answer here?
Back to top
View user's profile Send private message
a.b.
Apprentice
Apprentice


Joined: 23 Mar 2008
Posts: 218
Location: Anus Mundi, Germany

PostPosted: Sat Nov 01, 2008 10:45 am    Post subject: Reply with quote

2.6.27-zen3 (plus ext4 patches) doesn't react to changes in /sys/kernel/zen/system_layout:
Code:
 # cat system_layout
server file-server gaming [desktop] ll-desktop custom
zen # echo gaming > system_layout
zen # cat system_layout
server file-server gaming [desktop] ll-desktop custom
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 13, 14, 15 ... 21, 22, 23  Next
Page 14 of 23

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum