Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[python] mise à jour et problemes...[resolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Mon Aug 18, 2008 7:36 pm    Post subject: [python] mise à jour et problemes...[resolu] Reply with quote

Bonjour,
Freevo est installé sur mon PC depuis 2 bon mois et j'en apprend l'utilisation.
En voulant le lancer voilà le message qui m'est retourné :
Code:
ben@ataualpa /usr/lib $ freevo -fs
can't find python version with installed freevo

Sous /usr/lib/ j'ai deux répertoires relatif à Python :
python2.4 et python2.5.
Sous python2.4/site-packages je retrouve le dossier freevo ce qui n'est pas le cas sous python2.5/site-packages.

Je déduis donc qu'une de mes mises à jour de mon système concernait python et que depuis freevo ne se lance plus car il se lançait avec la 2.4 et non la 2.5.

Quelle est la méthode la plus propre pour corriger tout ça :
Une copie du dossier freevo de 2.4 vers 2.5 suffit-il ou faut-il autre chose ? Qu'en est-il des fichiers de config dans ce cas ?
Y a t-il une méthode pour ne pas oublier ce détail à la prochaine mise à jour de python ?

Merci pour votre aide !


Last edited by BENJI on Thu Aug 21, 2008 10:24 am; edited 1 time in total
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 227
Location: Devant l'écran

PostPosted: Mon Aug 18, 2008 8:13 pm    Post subject: Reply with quote

Salut

Je n'utilise pas freevo ,je ne sais pas si mon aide te sera d'un grand secours !!

Par contre sur mon système je dispose de 2 versions de dev-lang/python ,la 2.4.4-r14 et 2.5.2-r7 (en ~) , car ce sont 2 slots différents.

As tu tenter un python-updater ?
Lors d'une mise à jour de dev-lang/python , à la fin tu as message te conseillant d'utiliser python-updater ,selon la version de python que tu souhaites que ton système utilise.

Cela vaut donc la peine d'essayer.En espérant que mon post puisse t'aider!
_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Mon Aug 18, 2008 8:37 pm    Post subject: Reply with quote

HazeC5 wrote:
Salut

Je n'utilise pas freevo ,je ne sais pas si mon aide te sera d'un grand secours !!

Par contre sur mon système je dispose de 2 versions de dev-lang/python ,la 2.4.4-r14 et 2.5.2-r7 (en ~) , car ce sont 2 slots différents.

As tu tenter un python-updater ?
Lors d'une mise à jour de dev-lang/python , à la fin tu as message te conseillant d'utiliser python-updater ,selon la version de python que tu souhaites que ton système utilise.

Cela vaut donc la peine d'essayer.En espérant que mon post puisse t'aider!


+1
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Aug 19, 2008 6:50 am    Post subject: Reply with quote

Merci pour l'info.
J'ai lancé python-updater une première fois qui m'a donné ce message d'erreur:
Code:
......
 *   Adding to list: =dev-java/java-config-2.1.6
 *   Adding to list: =app-pda/libopensync-0.22
 *   Adding to list: =net-zope/zopeinterface-3.0.1
 *   Adding to list: =media-tv/freevo-1.7.6.1

These are the packages that would be merged, in order:

Calculating dependencies |
!!! All ebuilds that could satisfy "=dev-python/compizconfig-python-0.6.0.1" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-python/compizconfig-python-0.6.0.1 (masked by: ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.

J'ai donc commenté dans mon fichier package.keywords tout ce qui concernait compiz.
Ce n'est pas un problème car je ne l'utilise pas sur ma machine c'était juste un essai sans succès.
J'ai donc relancé à la suite python-updater.
Mais de nouveau le même message d'erreur.
Que faut-il faire ?
Code:
cat /etc/portage/package.keywords
#dev-python/compizconfig-python
#x11-apps/ccsm
#x11-libs/libcompizconfig
media-tv/freevo
kde-misc/ksystemlog
app-emulation/qemu ~x86
app-emulation/qemu-softmmu ~x86
app-emulation/qemu-user ~x86
app-emulation/kqemu ~x86
sys-devel/gcc ~x86
app-cdr/k9copy ~x86
media-video/ffmpeg ~x86
media-video/transcode ~x86
media-video/vlc ~x86
media-plugins/live ~x86
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3087
Location: Paris

PostPosted: Tue Aug 19, 2008 7:49 am    Post subject: Reply with quote

Et bien enlève le paquet "dev-python/compizconfig-python" de ton système, par exemple :)
Ou bien toute dépendance de compiz qui nécessite cet ebuild précis.
_________________
-Gentoo hardened [EoL]: µ-serv Gen8 G1610T, 8Go ECC ; NF9D-2700, 4Go
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go ; FreeNAS: µ-serv N40L, 8Go ECC
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Aug 19, 2008 9:28 am    Post subject: Reply with quote

J'ai fini par faire un emerge --depclean puisque le paquet compiz n'était plus installé sur mon système.
Ça en avait bien besoin !
Un redev-rebuild est en cours.
Dès qu'il sera fini je devrai pouvoir lancer python-updater pour pouvoir de nouveau réutiliser freevo.

J'ai une petite question pour ma culture générale.
Dans mon fichier /etc/portage/package.keywords j'ai des lignes avec des paquets suivis par ~x86 et d'autres sans !
Ne devrait-il pas n'y avoir que des lignes avec ~x86 ?
Code:
media-tv/freevo
kde-misc/ksystemlog
app-emulation/qemu ~x86
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Aug 19, 2008 9:41 am    Post subject: Reply with quote

:cry:
Voilà c'est bien fait pour moi j'ai parlé trop vite et le revdep-rebuild vient de se plaindre... j'ai un nouveau problème.
Le depclean d'avant à l'air d'y avoir été un peu fort !
Voilà le message :
Code:
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/alsa-lib-1.0.16/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/alsa-lib-1.0.16/temp/environment'.
 *

revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*

Le problème viendrait de alsa-lib c'est ça ?
Je fais quoi maintenant je suis même pas certain que mon problème vienne de alsa !
:(
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Tue Aug 19, 2008 10:48 am    Post subject: Reply with quote

L'erreur sur alsa-libs est un peu plus haut dans la sortie de revdep-rebuild...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Aug 19, 2008 11:47 am    Post subject: Reply with quote

Je viens de lancer un
Code:
emerge -1av alsa-lib
et voici le message d'erreur plus conséquent :
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] media-libs/alsa-lib-1.0.16  USE="midi -alisp -debug -doc" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) media-libs/alsa-lib-1.0.16 to /
 * alsa-lib-1.0.16.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...                                       [ ok ]
 * checking ebuild checksums ;-) ...                                                             [ ok ]
 * checking auxfile checksums ;-) ...                                                            [ ok ]
 * checking miscfile checksums ;-) ...                                                           [ ok ]
 * checking alsa-lib-1.0.16.tar.bz2 ;-) ...                                                      [ ok ]
>>> Unpacking source...
>>> Unpacking alsa-lib-1.0.16.tar.bz2 to /var/tmp/portage/media-libs/alsa-lib-1.0.16/work
 * Running elibtoolize in: alsa-lib-1.0.16
 *   Applying install-sh-1.5.4.patch ...
 *   Applying portage-1.5.10.patch ...
 *   Applying max_cmd_len-1.5.20.patch ...
 *   Applying sed-1.5.6.patch ...
 * Removing useless C++ checks ...                                                               [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/media-libs/alsa-lib-1.0.16/work/alsa-lib-1.0.16 ...
 * econf: updating alsa-lib-1.0.16/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating alsa-lib-1.0.16/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-static --enable-shared --disable-resmgr --without-debug --disable-alisp --enable-instr --enable-seq --enable-aload --with-pcm-plugins=adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol --disable-dependency-tracking --build=i686-pc-linux-gnu
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking target system type... i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking for C compiler default output file name... configure: error: C compiler cannot create executables
See `config.log' for more details.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/media-libs/alsa-lib-1.0.16/work/alsa-lib-1.0.16/config.log
 *
 * ERROR: media-libs/alsa-lib-1.0.16 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2531:  Called econf 'src_compile' 'src_compile' '--enable-static' '--enable-shared' '--disable-resmgr' '--without-debug' '--disable-alisp' '--enable-instr' '--enable-seq' '--enable-aload'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/alsa-lib-1.0.16/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/alsa-lib-1.0.16/temp/environment'.
 *

 * Messages for package media-libs/alsa-lib-1.0.16:

 *
 * ERROR: media-libs/alsa-lib-1.0.16 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_compile
 *             environment, line 2531:  Called econf 'src_compile' 'src_compile' '--enable-static' '--enable-shared' '--disable-resmgr' '--without-debug' '--disable-alisp' '--enable-instr' '--enable-seq' '--enable-aload'
 *               ebuild.sh, line  513:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *  The die message:
 *   econf failed
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/media-libs/alsa-lib-1.0.16/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-libs/alsa-lib-1.0.16/temp/environment'.
 *
Une erreur de compilation sûrement mais à cause de quoi ????
mon précédent emerge --depclean a dû effacer un paquet dont alsa-lib a besoin. Lequel j'en sais rien ?
Comment connaître la liste de ce qui a été désinstallé par le depclean ?
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Tue Aug 19, 2008 12:34 pm    Post subject: Reply with quote

Que donne (en root):
Code:
gcc-config -l


En particulier, est ce que ça matche avec la dernière version installée (ou au minimum une version installée)

PS: si tu as eix: eix -s gcc devrait te répondre ...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Aug 19, 2008 1:19 pm    Post subject: Reply with quote

Justement j'allais poster sur ce sujet car le malaise vient de gcc
Code:
ataualpa ben # gcc-config -L
 * gcc-config: Active gcc profile is invalid!
 [1] i686-pc-linux-gnu-3.3.6
 [2] i686-pc-linux-gnu-4.3.1

J'ai deux version de gcc. Je ne sais plus pour quel paquet j'avais du revenir sur une ancienne version de gcc pour le compiler mais j'avais remis tout en ordre après
alors pourquoi "gcc profile is invalid" ?

de mémoire il faut la version 4.3.1 de sélectionnée.

J'ai donc été dans les log de emerge pour savoir ce que mon précédent depclean avait effacé (et regardez ce que l'on trouve à la fin ! ! ! !):
Code:
1219136256: Started emerge on: Aug 19, 2008 10:57:36
1219136256:  *** emerge  depclean
1219136256:  >>> depclean
1219136265: === Unmerging... (dev-python/python-fchksum-1.7.1)
1219136268:  >>> unmerge success: dev-python/python-fchksum-1.7.1
1219136268: === Unmerging... (app-crypt/hashalot-0.3-r2)
1219136270:  >>> unmerge success: app-crypt/hashalot-0.3-r2
1219136270: === Unmerging... (dev-python/pyrex-0.9.4.1)
1219136274:  >>> unmerge success: dev-python/pyrex-0.9.4.1
1219136274: === Unmerging... (net-libs/libnet-1.1.2.1-r1)
1219136286:  >>> unmerge success: net-libs/libnet-1.1.2.1-r1
1219136286: === Unmerging... (gnome-base/gconf-2.20.1-r1)
1219136291:  >>> unmerge success: gnome-base/gconf-2.20.1-r1
1219136291: === Unmerging... (net-print/foomatic-filters-ppds-20070501)
1219136340:  >>> unmerge success: net-print/foomatic-filters-ppds-20070501
1219136340: === Unmerging... (dev-lang/python-2.4.4-r13)
1219136347:  >>> unmerge success: dev-lang/python-2.4.4-r13
1219136347: === Unmerging... (x11-libs/libcompizconfig-0.6.0)
1219136349:  >>> unmerge success: x11-libs/libcompizconfig-0.6.0
1219136349: === Unmerging... (dev-libs/libIDL-0.8.10)
1219136352:  >>> unmerge success: dev-libs/libIDL-0.8.10
1219136352: === Unmerging... (sys-libs/pwdb-0.62)
1219136356:  >>> unmerge success: sys-libs/pwdb-0.62
1219136356: === Unmerging... (sys-libs/db-4.3.29-r2)
1219136359:  >>> unmerge success: sys-libs/db-4.3.29-r2
1219136359: === Unmerging... (sys-libs/db-4.2.52_p4-r2)
1219136363:  >>> unmerge success: sys-libs/db-4.2.52_p4-r2
1219136363: === Unmerging... (dev-python/pycrypto-2.0.1-r6)
1219136368:  >>> unmerge success: dev-python/pycrypto-2.0.1-r6
1219136368: === Unmerging... (dev-libs/libol-0.3.18)
1219136370:  >>> unmerge success: dev-libs/libol-0.3.18
1219136370: === Unmerging... (sys-devel/automake-1.6.3)
1219136373:  >>> unmerge success: sys-devel/automake-1.6.3
1219136373: === Unmerging... (sys-devel/automake-1.4_p6)
1219136375:  >>> unmerge success: sys-devel/automake-1.4_p6
1219136375: === Unmerging... (dev-python/compizconfig-python-0.6.0.1)
1219136377:  >>> unmerge success: dev-python/compizconfig-python-0.6.0.1
1219136377: === Unmerging... (sys-apps/hdparm-8.6)
1219136379:  >>> unmerge success: sys-apps/hdparm-8.6
1219136379: === Unmerging... (net-nds/openldap-2.3.24-r1)
1219136383:  >>> unmerge success: net-nds/openldap-2.3.24-r1
1219136383: === Unmerging... (dev-libs/lzo-2.02-r1)
1219136385:  >>> unmerge success: dev-libs/lzo-2.02-r1
1219136385: === Unmerging... (gnome-base/orbit-2.14.12)
1219136388:  >>> unmerge success: gnome-base/orbit-2.14.12
1219136388: === Unmerging... (x11-libs/libwnck-2.20.3)
1219136392:  >>> unmerge success: x11-libs/libwnck-2.20.3
1219136392: === Unmerging... (sys-kernel/gentoo-sources-2.6.24-r3)
1219136422:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.24-r3
1219136422: === Unmerging... (sys-kernel/gentoo-sources-2.6.24-r4)
1219136450:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.24-r4
1219136450: === Unmerging... (sys-kernel/gentoo-sources-2.6.24-r8)
1219136477:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.24-r8
1219136477: === Unmerging... (sys-kernel/gentoo-sources-2.6.23-r6)
1219136506:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.23-r6
1219136506: === Unmerging... (sys-kernel/gentoo-sources-2.6.23-r9)
1219136534:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.23-r9
1219136534: === Unmerging... (sys-kernel/gentoo-sources-2.6.23-r8)
1219136560:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.23-r8
1219136560: === Unmerging... (sys-kernel/gentoo-sources-2.6.25-r6)
1219136590:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.25-r6
1219136590: === Unmerging... (sys-kernel/gentoo-sources-2.6.20-r6)
1219136618:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.20-r6
1219136618: === Unmerging... (sys-kernel/gentoo-sources-2.6.20-r7)
1219136641:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.20-r7
1219136641: === Unmerging... (sys-kernel/gentoo-sources-2.6.20-r8)
1219136666:  >>> unmerge success: sys-kernel/gentoo-sources-2.6.20-r8
1219136666: === Unmerging... (net-print/foomatic-filters-3.0.20060720)
1219136669:  >>> unmerge success: net-print/foomatic-filters-3.0.20060720
1219136669: === Unmerging... (net-print/foomatic-db-ppds-3.0.20060720)
1219136672:  >>> unmerge success: net-print/foomatic-db-ppds-3.0.20060720
1219136672: === Unmerging... (x11-libs/wxGTK-2.6.4.0-r3)
1219136676:  >>> unmerge success: x11-libs/wxGTK-2.6.4.0-r3
1219136676: === Unmerging... (media-libs/glitz-0.5.6)
1219136678:  >>> unmerge success: media-libs/glitz-0.5.6
1219136678: === Unmerging... (x11-libs/startup-notification-0.9)
1219136680:  >>> unmerge success: x11-libs/startup-notification-0.9
1219136680: === Unmerging... (sys-devel/gcc-4.1.2)
1219136680: === Unmerging... (sys-devel/gcc-4.1.2)
1219136690:  >>> unmerge success: sys-devel/gcc-4.1.2
1219136690:  *** exiting successfully.
1219136701:  *** terminating.


On dirait que le depclean m'a effacé gcc ce que j'ai pu confirmé par
Code:
ataualpa ben # emerge -s sys-devel/gcc
Searching...
[ Results for search key : sys-devel/gcc ]
[ Applications found : 0 ]


C'est qu'en même surprenant ! D'autant plus que gcc-config me propose des versions encore différentes (3.3.6 et 4.3.1)!
Un peu avant d'avoir tous ces problèmes j'avais migré vers un profile 2008 (j'étais encore en 2006 tout en croyant être en 2007) peut-il y avoir un lien !

Maintenant comment je remets tout ça en ordre ?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Aug 19, 2008 2:15 pm    Post subject: Reply with quote

et après un
Code:
gcc-config i686-pc-linux-gnu-4.3.1
ça donne quoi ?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Tue Aug 19, 2008 2:32 pm    Post subject: Reply with quote

Code:
ataualpa ben # gcc-config i686-pc-linux-gnu-4.3.1
 * Switching native-compiler to i686-pc-linux-gnu-4.3.1 ...

 * Your gcc has a bug with GCC_SPECS.
 * Please re-emerge gcc.
 * http://bugs.gentoo.org/68395

>>> Regenerating /etc/ld.so.cache...                                                             [ ok ]

 * If you intend to use the gcc from the new profile in an already
 * running shell, please remember to do:

 *   # source /etc/profile

:(
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 490

PostPosted: Tue Aug 19, 2008 3:02 pm    Post subject: Reply with quote

Comme indiqué,
Code:
pleqse reemerge gcc
donc
Code:
emerge -1 gcc
Back to top
View user's profile Send private message
gglaboussole
l33t
l33t


Joined: 17 May 2005
Posts: 641
Location: Monbalen (47),France

PostPosted: Tue Aug 19, 2008 5:01 pm    Post subject: Reply with quote

Rien à voir avec les tous derniers messages de ton post car tu as l'aide qu'il faut mais j'en reviens à python..
T'aurais pas du faire le depclean avant python updater !
En effet il y a de fortes chances que tu aies viré python 2.4 (je t'avoues d'ailleurs que je me suis aperçu que j'avais le 2.5 sur mon système en executant un emerge -pv --depclean...j'avais pas vu passer la maj tellement j'en avais... :lol: ) donc tu ne pourras pas executer python updater car il ne vera pas la présence de l'ancien...(enfin je pense mais j'en suis quasi sûr)
Si tel est le cas : emerge --oneshot =dev-lang/python-2.4.4-r14 puis python-updater puis re emerge --depclean...
Bon courage
_________________
On m'a dit que la terre tourne, alors j'attends que ma maison passe par ici...
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed Aug 20, 2008 8:20 am    Post subject: Reply with quote

Bon tu as raison python-updater n'a rien donné j'ai donc relancer un emerge --oneshot =dev-lang/python-2.4.4-r14.
J'ai fait une autre boullette :lol:
J'avais anticipé la réponse et j'ai fait un emerge -av gcc au lieu d'un emerge -1 gcc.
Du coup gcc fait partie de mon world.
Comment on corrige ça ? En supprimant une ligne dans /var/lib/portage/world ?
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Wed Aug 20, 2008 8:34 am    Post subject: Reply with quote

Ouais tu le supprimes comme ça, mais au pire c'est pas bien grave.
Je ne suis pas sur que ce bug impose un reemerge. M'enfin, trop tard. ça donne quoi maintenant que tu as fait gcc-config ?
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed Aug 20, 2008 10:35 am    Post subject: Reply with quote

gcc-config OK
python-updater est en cours et une trentaines de paquets sont en cours de compilation tel que
dev-python/pygobject
net-analyzer/rrdtool
dev-python/pygame
dev-python/PyQt4
media-libs/alsa-lib
dev-util/subversion
...
je vous tiens au jus
Back to top
View user's profile Send private message
BENJI
Guru
Guru


Joined: 10 Sep 2003
Posts: 543

PostPosted: Wed Aug 20, 2008 11:54 am    Post subject: Reply with quote

Je ne suis pas en face de ma machine (ssh), mais tout semble revenu à la normal !
J'attends un peu avant de tagger mon post en résolu !

Merci pour l'aide !
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum