Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kde 4 : dual head not working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
fuzzythebear
Guru
Guru


Joined: 28 Nov 2004
Posts: 317

PostPosted: Thu Aug 21, 2008 10:19 pm    Post subject: kde 4 : dual head not working Reply with quote

im on kde 4 trying to get dual head to work : no go , it works as is on kde 3.5.9 but kde 4 dosent even know there's a second screen . it shows just one screen in the configure desktop window.
anyone knows what's going on ? do i need special use flags apart from xinerama which i already have in the make.conf ?
Any help will be greatly appreciated :)

Thanks

Fuzzy
_________________
There's this once i thought i had made a mistake .. but i was wrong :|
Back to top
View user's profile Send private message
fuzzythebear
Guru
Guru


Joined: 28 Nov 2004
Posts: 317

PostPosted: Wed Oct 08, 2008 9:37 am    Post subject: follow up Reply with quote

Installed kde 4.1.2 and fired it last evening.Works nicely .. but still no dual head .
dosent show in config utilities either.
Basically dual head works for gnome and kde 3.5.* but not 4.*
What's going on here ?

this is the xorg.conf

Section "ServerLayout"

Identifier "Main Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
Screen 1 "aticonfig-Screen[1]" LeftOf "aticonfig-Screen[0]"
Option "DualHead" "true"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "Files"

RgbPath "/usr/share/X11/rgb"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi"
EndSection

Section "Module"

Load "dbe"
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "type1"
Load "freetype"

EndSection


Section "InputDevice"

Identifier "Keyboard1"
Driver "keyboard"
Option "AutoRepeat" "500 15"

EndSection

Section "InputDevice"

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "Auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"

EndSection

Section "Monitor"

Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
HorizSync 50 - 120
VertRefresh 30 - 54

EndSection

Section "Monitor"

Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
HorizSync 30 - 70
VertRefresh 50 - 120


EndSection

Section "Device"

Identifier "aticonfig-Device[0]"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 0

EndSection

Section "Device"

Identifier "aticonfig-Device[1]"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1

EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Modes "1280x1024"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "dri"
Mode 0666
EndSection


ideas ?
_________________
There's this once i thought i had made a mistake .. but i was wrong :|
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 354
Location: Belgium

PostPosted: Tue Oct 14, 2008 7:07 am    Post subject: Reply with quote

I'm having the same issue. The second X works [ I do see the mouse going there ]. However I dont see any output...
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
OPelerin
Guru
Guru


Joined: 17 Jul 2004
Posts: 354
Location: Belgium

PostPosted: Tue Oct 21, 2008 11:19 am    Post subject: Reply with quote

As workaround I'm using now the radeonhd opensource drivers. Then I can bring the second screen by using xrandr commands
_________________
Olivier PELERIN
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum