Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
openssl - 386 option
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
krotuss
Apprentice
Apprentice


Joined: 01 Aug 2008
Posts: 157

PostPosted: Sat Aug 23, 2008 12:52 pm    Post subject: openssl - 386 option Reply with quote

According to INSTALL file, openssl provides "386" configure option to generate 386 compatible code (otherwise 486+ code is generated which will cause SIGILL on 80386 CPU).
Code:
386             Use the 80386 instruction set only (the default x86 code is
                more efficient, but requires at least a 486). Note: Use
                compiler flags for any other CPU specific configuration,
                e.g. "-m32" to build x86 code on an x64 system.


I think so it would be great to be able to enable this option either manually by USE flag or have it automatically enabled by portage for example based on -march value in CFLAGS, but till now I have not found appropriate USE flag or other way how to enable this (is there any?).
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43562
Location: 56N 3W

PostPosted: Sat Aug 23, 2008 1:36 pm    Post subject: Reply with quote

Moved from Portage & Programming to Unsupported Software.

i386 as a CHOST is no longer supported. glibc >=2.3 will not build with a i386 CHOST, so you have bigger problems than just this.
If you want something for an embedded system, look at dropbear.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum