Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
open-vm-tools not working? [Partially Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Mon Aug 25, 2008 9:06 pm    Post subject: open-vm-tools not working? [Partially Solved] Reply with quote

I'm using a Windows XP SP2 based PC as host running VMware Workstation 6.0.3.

I've installed Gentoo 2008.0 as a guest.

I've done the following commands:
Code:
emerge open-vm-tools
rc-update add vmware-tools default


ps -ef | grep vmware shows:
Code:
root     15541     1  0 16:27 ?        00:00:02 /usr/sbin/vmware-guestd --background /var/run/vmware-guestd.pid

I don't get a message asking if I want to install vmware tools when I power on this virtual machine. However, I can't move my mouse freely between the guest and the host and I have no visibility of shared folders.

Can someone suggest some things I can try to correct this problem?

The following information might also be helpful:
Code:
linuxbase ~ # emerge --info
Portage 2.2_rc8 (default/linux/x86/2008.0/desktop, gcc-4.1.2, glibc-2.8_p20080602-r0, 2.6.25-gentoo-r6 i686)
=================================================================
System uname: Linux-2.6.25-gentoo-r6-i686-Intel-R-_Pentium-R-_D_CPU_2.80GHz-with-glibc2.0
Timestamp of tree: Mon, 25 Aug 2008 17:04:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 1.3.7, 2.1.6-r1
dev-lang/python:     2.4.4-r13, 2.5.2-r7
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5
sys-apps/sandbox:    1.2.18.1-r3
sys-devel/autoconf:  2.13, 2.62-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1-r1
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   2.2.4
virtual/os-headers:  2.6.26
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks parallel-fetch preserve-libs sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="C"
LDFLAGS="-Wl,-O1"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="7zip X acl acpi alsa berkdb bluetooth branding bzip2 cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo exif fam firefox fortran gdbm gif gpm gstreamer gtk hal iconv ipv6 isdnlog java jpeg kerberos ldap libnotify mad midi mikmod mmx mng mp3 mp4 mpeg mudflap mysql ncurses nls nptl nptlonly ogg opengl openmp pam pcre pdf perl png ppds pppd python qt3 qt3support qt4 quicktime readline reflection sasl sdl session spell spl sse ssl startup-notification svg sysfs tcpd tiff truetype unicode usb vorbis win32codecs wmf x86 xml xorg xv zlib" ALSA_CARDS="ens1371" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="vmmouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="vmware"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Edit: Patially solved for shared folder function. See my reply below.
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
dufeu
l33t
l33t


Joined: 30 Aug 2002
Posts: 896
Location: US-FL-EST

PostPosted: Tue Aug 26, 2008 2:04 pm    Post subject: Solved for Shared Folder Function Reply with quote

1) Edit the properties of the guest VM to enable and select a shared folder.

On the guest side:

2) Install open-vm-tools as per instructions for your distribution. The ebuild used in Gentoo seems to work fine for Gentoo users.

3) You need to be root to perform these next tasks. Open a terminal session. Either "su -" to become root or use "sudo". I prefer to become root because there are several commands you need to execute. You'll need to confirm to the security configuration for you installation. As root then: If it doesn't already exist, create the mount point that the shared folders function will use. "mkdir /mnt/hgfs"

4) On gentoo, the open-vm-tools does NOT currently set up the /etc/init.d/vmware-tools script to automatically load the vmhgfs kernal driver. This is the driver required for the shared folder function to work. As root then: "modprobe vmhgfs". You should receive no error messages. If you do, you need to check that open-vm-tools compiled properly.

5) Mount the shared folder. This is done by executing the command: "mount -t vmhgfs .host:/ /mnt/hgfs"

You should now have visibility and access to all shared folders configured for that guest VM.

I haven't yet looked into setting things up so that shared folders starts at boot time. Advice would be appreciated. I'm hoping that I can add something to /etc/conf.d/vmware-tools to do this. Anyone know how?
_________________
People whom think M$ is mediocre, don't know the half of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum